Home Forums SYSTEM SOA AT 40 GBPS

SOA AT 40 GBPS

Profile Photo
(joined September 2014)
Participant

HELLO ALL.I HAVE DESIGNED AN XOR GATE WHICH IS WORKING FINE AT 10 GBPS.I WANT MY LOGIC TO WORK AT 40GBPS.BUT WHEN I CHANGE THE DATA RATE TO 40GBPPS OUTPUT IS NOT CORRECT.I WANT TO KNOW:
A)BY CHANGING THE PARAMETERS OF SOA CAN WE MAKE IT TO WORK AT DATA RATE OF 40GBPS?
B)IF YES THEN WHICH PAPAMETERS REQUIRE CHANGES.
C)IS THERE ANY RELATION WITH PULSE WIDTH WITH DATA RATE?

XOR GATE FILE ATTACHED

Attachments:

Responses (1):

    • #14976
      Profile Photo
      vipul
      Participant

      HELLO ALL.I HAVE DESIGNED AN XOR GATE WHICH IS WORKING FINE AT 10 GBPS.I WANT MY LOGIC TO WORK AT 40GBPS.BUT WHEN I CHANGE THE DATA RATE TO 40GBPPS OUTPUT IS NOT CORRECT.I WANT TO KNOW:
      A)BY CHANGING THE PARAMETERS OF SOA CAN WE MAKE IT TO WORK AT DATA RATE OF 40GBPS?
      B)IF YES THEN WHICH PAPAMETERS REQUIRE CHANGES.
      C)IS THERE ANY RELATION WITH PULSE WIDTH WITH DATA RATE?

      XOR GATE FILE ATTACHED

      Attachments:
    • #15018
      Profile Photo
      Damian Marek
      Participant

      Hi Vipul,

      The problems I found (and fixed!) were actually related to filter center frequencies, bandwidths and making sure each component has the correct bit rate parameter.

      For example, you changed the User Defined Bit Sequence Generators to a manual value of 10 GHz, so changing the global parameter Bit rate did not change the speed. Generally it is a better idea to keep all the components scripted to the global value of “Bit rate” which will make sure each component is updated automatically with the correct bit rate.

      Furthermore, the WDM Mux need to be updated with a new channel bandwidth of 40 GHz other wise the signal will not be transmitted properly. This is also the case for the Gaussian Optical Filter at the receiver. Center frequency should be changed to 1540 nm and bandwidth set to 40 GHz.

      I made the changes to the project file attached.

      Cheers!

Login You must be logged in to reply to this topic.