Home Forums SYSTEM MATLAB- Optisystem co-simulation error

MATLAB- Optisystem co-simulation error

(joined August 2020)
Participant

I am doing a project which requires to use the matlab component block in the optisystem design. I tried to follow every instruction to get a successful result but each time I run the system it shows- ‘CIDF error in calculating matlab component’. I even tried the simplest ‘matlab binary switch’ program still the error shows up. Could anyone please help me in solving the problem? :(((
TIA.

Responses (11):

    • #68156

      I am doing a project which requires to use the matlab component block in the optisystem design. I tried to follow every instruction to get a successful result but each time I run the system it shows- ‘CIDF error in calculating matlab component’. I even tried the simplest ‘matlab binary switch’ program still the error shows up. Could anyone please help me in solving the problem? :(((
      TIA.

    • #68201
      Profile Photo
      Ahmad Atieh
      Moderator

      Dear Adree,
      Did you try to run the examples in OptiSystem Example Library located at the following link?
      Which version of OptiSystem are you using?
      C:\Users\USER NAME\Documents\OptiSystem 17.1 Samples\Software interworking\MATLAB co-simulation

      Regards,
      Ahmad

      • #68203

        Thanks a lot sir for the reply. I am using optisystem version 7 as my evaluation period for version 17 was over. I tried to run the co-simulation samples give in version 7 but every time I run the system, here says matlab engine could not be loaded. My matlab version is R2020a and is in F:/ drive while the optisystem is installed in C:/ drive. I can’t understand where I am doing wrong.

    • #68204
      Profile Photo
      Ahmad Atieh
      Moderator

      Unfortunately, we don’t support version 7 as it is hacked. So, we can’t tell what is the problem.

    • #68205

      Sir how can I buy optisystem version 17?

    • #68206
      Profile Photo
      Sawyer Ge
      Moderator

      Hello Adree,

      Thanks for your interest in our OptiSystem.

      Please send your request as well as your full contact information to sawyer.ge@optiwave.com

      Thanks.

      Sawyer

    • #68254
      Profile Photo
      Ahmad Atieh
      Moderator

      Yes it should work.
      Regards,
      Ahmad

      • #68257

        Sir do I need to have matlab installed in the C drive? Won’t it work if I keep this in other drives? Cause I have my matlab installed in F drive.. but the mentioned problem is still showing up even after using optisystem 13.
        I have done everything as mentioned in this video-

        but no luck.

    • #68262
      Profile Photo
      Ahmad Atieh
      Moderator

      Hello Adree,
      You need to make sure that the file path of the Matlab code is properly used in the component, or you need to have the Matlab code in the same place the OptiSystem project file is located.
      You may read the datasheet for more information.

      Do you know if your university will acquire OptiSystem software?
      What is the name of your institution?

      Regards,
      Ahmad

    • #68272

      Sir my institution’s name is Khulna University Of Engineering & Technology. I couldn’t talk to my Department Head as he is unavailable right now due to the pandemic crisis. However, I managed to get the optisystem 13 evaluation version. I followed the instruction you provided in the last response. But the problem still persists. I have kept the m.file just as where the optisystem is installed and also provided the correct path in the Matlab component. Still, it says the Matlab engine can not be loaded due to the CIDF scheduler error. I don’t know sir what more I can do. If this does not work I can not start my main project.

    • #68278
      Profile Photo
      Ahmad Atieh
      Moderator

      Dear Adree,
      could you please email me OptiSystem project and the Matlab codes to run them on my computer and check the problem?
      My email is ahmad.atieh@optiwave.com

      From where did you get OptiSystem version 13?
      Regards,
      Ahmad

Login You must be logged in to reply to this topic.