Home Forums FDTD Help regarding error message appearing in Optifdtd

Help regarding error message appearing in Optifdtd

Profile Photo
(joined February 2021)
Participant

Dear Sir/Mam

Whenever I click on the vertical launch input in order to change wavelength and some other parameters, a error message appear every time displaying “Error allocating memory to perform FFT with 1073741823 time steps. 4096 steps used instead.”
I wish to plot wavelength spectrum of the designed resonator. For the purpose pulse excitation is used in the design.

Kindly comment on the error message appearing on clicking on launch.

May it be overlooked? if not what to do in order to remove this error message.

Please Reply

For reference I already attached design file.

Eagerly waiting for the response

Thanking You

Man Mohan Gupta

Attachments:

Responses (4):

    • #69868
      Profile Photo
      Man Mohan Gupta
      Participant

      Dear Sir/Mam

      Whenever I click on the vertical launch input in order to change wavelength and some other parameters, a error message appear every time displaying “Error allocating memory to perform FFT with 1073741823 time steps. 4096 steps used instead.”
      I wish to plot wavelength spectrum of the designed resonator. For the purpose pulse excitation is used in the design.

      Kindly comment on the error message appearing on clicking on launch.

      May it be overlooked? if not what to do in order to remove this error message.

      Please Reply

      For reference I already attached design file.

      Eagerly waiting for the response

      Thanking You

      Man Mohan Gupta

      Attachments:
    • #69871
      Profile Photo
      Scott Newman
      Moderator

      Hello,

      Within the Input Plane form under the Sine Modulated Pulse tab you are presented with the time and frequency domain representations of the pulse. The frequency spectrum is obtained through an FFT of the time domain. It would appear that whatever settings you are changing are resulting in too many data points within this FFT and it is resorting back to a “safe” number. I have reviewed your design in OptiFDTD 16.0RC and I am unable to find the settings that reproduce the error.

      I have 3 questions/requests:

      1. Can you confirm for me what version of the product you are using?
      2. Can you confirm that this error is occuring within OptiFDTD Designer when you edit the input plane and NOT within OptiFDTD Analyzer after a simulation is run.
      3. Is it possible for you to provide me with the sequence of changes you make that will trigger that warning on this design?

      Scott

    • #69874
      Profile Photo
      Man Mohan Gupta
      Participant

      Hi
      Dear Scott

      Thanks for your response.

      Listed below are the answer of questions raised by you to resolve my queries.

      Can you confirm for me what version of the product you are using?
      OptiFDTD 32-bit ver. 12.0.0.611

      Can you confirm that this error is occuring within OptiFDTD Designer when you edit the input plane and NOT within OptiFDTD Analyzer after a simulation is run.

      Yes, this error is appearing only occuring within Optifdtd Designer when I edit input plane. It does not appear within Optifdtd Analyzer after simulation completion.

      I wish to add at this point that now if I allow simulation to run only for default number of time steps in simulation parameter window, error message does not appear. In order to get more precise results I wish to run the simulations for longer time. For this purpose I tick on “Run Until user stops Execution, then finalize results” in simulation parameter window. But with this setting error appears in the design file when click on launch plane. How can we fix this error if wish to run simulation for desired number of time steps?

      Is it possible for you to provide me with the sequence of changes you make that will trigger that warning on this design.
      I set the Half width to 1.5 um under 2D transverse Tab of input. Central wavelength of the pulse is taken to 1.5 um.

      Kindly comment

      Thanks

      Dr. man mohan gupta

      Attachments:
    • #69876
      Profile Photo
      Scott Newman
      Moderator

      Based on your feedback it would appear that the designer is using a number that is too large as an assumption within designer as it does not know how long you wish to run the simulation. This would normally not be an issue as the number would never be used except in the instance you go into the input plane window to view the expected pulse shape in time and frequency domain.

      This was corrected when the product was migrated to 64-bit so it has been corrected and the latest versions of the product can support the behaviour you are requesting. Please keep in mind that the 32-bit application is an unsupported old version of the product provided as a courtesy when we migrated to 64-bit.

      I would advise one of the two following courses of action:

      1. Use the functionality with a set number of time steps during editing and then change it to “Run until user stops execution” just before running the simulation. It is important to note that if this error is a function of it being a 32-bit platform and you run it “too long” Analyzer may have similar issues.
      2. Do not use “Run until user stops execution” at all and simply set the number of time steps to a value that is large enough to get the results you require. As with #1 note it is possible the issue may show up in Designer again and in Analyzer if you set the number too high.

      Scott

    • #69879
      Profile Photo
      Man Mohan Gupta
      Participant

      Thanks

      Dear Scott

      With your suggestions, problem of error message has been solved.

      Thanking you very much for your support

      Regards

      Dr Man Mohan Gupta

Login You must be logged in to reply to this topic.