Home Forums SPICE Problem in Save Spice Stimulus File Optisystem

Problem in Save Spice Stimulus File Optisystem

Profile Photo
(joined March 2015)
Participant

Hi.
I need help in Save Spice Stimulus File in Optisystem.

Responses (7):

    • #22364
      Profile Photo
      abdollah gholami
      Participant

      Hi.
      I need help in Save Spice Stimulus File in Optisystem.

    • #22381
      Profile Photo
      Damian Marek
      Participant

      I switched this to this to the OptiSPICE forum, but perhaps you mean an spice file in general? Can you elaborate about your specific problem? Are you trying to input an electrical signal into an Optical System or is this some type of problem cosimulating with OptiSPICE?

    • #22385
      Profile Photo
      Ashu verma
      Participant

      Hello Abdollah Gholami
      Welcome to optisystem forum,I would suggest you to first go through the optiwave tutorials as there are a co-simulation option of the spice file with optisystem.You can save the file simply by save option.Then the different files with extension .sp etc appear on the location you saved file.You can use this files in optisystem co simulation spice component to use this in optisystem for further work.Visit the links i have given below for overview of optispice and working

      OptiSPICE Overview

      OptiSPICE Netlist Component

      NEW VERSION OptiSPICE 5.0

    • #22396
      Profile Photo
      abdollah gholami
      Participant

      Hi.
      thank you for answering.
      I want to save an electrical signal in my OptiSystem Project for further analyse ,in stl file format.
      Now I understand my problem.
      during simulation, from iteration 1 to 10 , this signal is Null(I connect an oscilloscope visualizer and see nothing! )
      after iteration 11 oscilloscope visualizer shows that signal.
      I guess my problem is because that Input signal of “Save Spice Stimulus File” cant be Null.
      I think a trick to solve this problem!!!
      I work with Optisystem 13.

      • #22417
        Profile Photo
        Damian Marek
        Participant

        Yes I imagine a null signal would not be saved! Without seeing your project file I cannot tell why it would give a null signal, but if you have any other questions please let me know. I just tried a simple example project file and the STL file was saved correctly for me.

        Regards

    • #22476
      Profile Photo
      abdollah gholami
      Participant

      Hi. my project need a lot of time for simulating. but I send for you a Simple Project that can show you my real Problem.
      My problem is that i must enable “Initial delay” in “signal” tab of “Layout Parameters”.

      if i enable “Initial delay”, i get error in “Save Spice Stimulus File”.

      if i dont enable this option, data will be saved in stl format successfully but my output signal is not a valid output and also “MATLAB Component” will not run in Simulation.

      I completely get confused!!!

      I upload for you my simple project and a picture of “Initial delay” setting in my project.

      • #22498
        Profile Photo
        Damian Marek
        Participant

        This seems more like a bug now. You are trying to do some type of bidirectional simulation or feedback application?

    • #22512
      Profile Photo
      abdollah gholami
      Participant

      Yes. my Project is simulation of a sensor system. this sensor send an optical signal through a bidirectional coupler and a bidirectional fiber and then reflect it from bidirectional reflector. I have written a Matlab code to extract Phase of received signal.
      and I also want to save received signal in stl format or any format,that I can.
      what does “Initial delay” exactly do and when must i enable this option?

Login You must be logged in to reply to this topic.