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Introductory Tutorials

This section contains the following introductory tutorials.

• Lesson 1: Transmitter — External modulated laser

• Lesson 2: Subsystems — Hierarchical simulation

• Lesson 3: Optical Systems — WDM Design

• Lesson 4: Parameter Sweeps — BER x Input power

• Lesson 5: Bidirectional Simulation — Working with multiple iterations

• Lesson 6: Time-Driven Simulation — Working with individual samples

• Lesson 7: Optical Amplifiers — Designing optical fiber amplifiers and fiber lasers

• Lesson 8: Optical Systems — Working with multimode components
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Notes:
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Lesson 1: Transmitter — External modulated 
laser

This lesson describes how to create a transmitter using an external modulated laser. You will become 
familiar with the Component Library, the Main layout, component parameters, and visualizers.

To start OptiSystem, perform the following procedure:

Starting OptiSystem

Step Action 

1 On the Taskbar, click Start.

2 Select Programs > Optiwave Software > OptiSystem 9> OptiSystem.
OptiSystem opens and the graphical user interface appears (see Figure 1).

Figure 1 OptiSystem graphical user interface
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Main parts of the GUI

The OptiSystem GUI contains the following main windows:

• Project layout

• Dockers

— Component Library

— Project Browser

— Description

• Status Bar

Project layout

The main working area where you insert components into the layout, edit 
components, and create connections between components (see Figure 2).

Figure 2 Project layout window
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Dockers

Use dockers, located in the Main layout, to display information about the active 
(current) project:

— Component Library

— Project Browser

— Description

Component Library

Access components to create the system design (see Figure 3).

Figure 3 Component Library window
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Project Browser

Organize the project to achieve results more efficiently, and navigate through the 
current project (see Figure 4).

Figure 4 Project Browser window
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Description

Display detailed information about the current project (see Figure 5).

Figure 5 Description window

Status Bar

Displays useful hints about using OptiSystem, and other help. Located below the 
Project layout window.

Figure 6 Status Bar

Menu bar

Contains the menus that are available in OptiSystem (see Figure 7). Many of these 
menu items are also available as buttons on the toolbars or from other lists.

Figure 7 Menu bar
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Using the Component Library

In the following example, you design the external modulated transmitter. You will 
select components from the Component Library and place them in the Main layout.

Note: OptiSystem provides a set of built-in default components.

To use the Component Library, perform the following procedure.

Step Action 

1 To start a new project, from the Main toolbar, select File > New.
A blank Main layout appears in the Project layout window.

2 From the Component Library, select Default > Transmitters Library > 
Optical Sources.

3 Drag the CW Laser to the Main layout (see Figure 8).

Figure 8 Adding a CW Laser to the Main layout

4 From the Component Library, select Default > Transmitters > Modulators 
> Optical.

5 Drag the Mach-Zehnder Modulator to the Main layout (see Figure 9).

Note: By default, the auto connect feature is on. When you place a 
component to the Main layout, the input port of the component connects 
automatically to the output port of a component that it can connect to. To turn 
the auto connect feature off, see “Turning the Auto connect feature off and on” 
on page 12.
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6 From the Component Library, select Default > Transmitters Library > 
Bit Sequence Generators.

7 Drag the Pseudo-Random Bit Sequence Generator to the Main layout.

8 From the Component Library, select Default > Transmitters > 
Pulse Generators > Electrical.

9 Drag the NRZ Pulse Generator to the Main layout (see Figure 9).

Figure 9 Adding components to the Main layout
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Auto connect feature

By default, the Auto Connect on Drop feature is active. There are two ways that 
components can auto connect:

• Auto Connect on Drop: When you place a component from the Component 
Library in the Main layout, the input port of the component connects 
automatically to the nearest output port of another component.

• Auto Connect on Move: When you move a component in the Main layout, the 
input port of the component connects automatically to the nearest output port of 
another component.

Turning the Auto connect feature off and on

To turn the Auto connect feature off and on, perform the following procedure.

Step Action 

1 To turn the Auto connect feature off, click the active Auto Connect on Drop 
button and the Auto Connect on Move button on the Layout Operations 
toolbar.
The buttons are inactive (see Figure 10) and the components no longer 
connect automatically to each other.

Figure 10 Inactive Auto connect buttons

2 To turn the auto connect feature back on, click the inactive Auto Connect on 
Drop button and the Auto Connect on Move button on the Layout 
Operations toolbar.
The buttons are active (see Figure 11) and the components connect 
automatically to each other.

Figure 11 Active Auto connect buttons
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Connecting components manually

The only connectable ports are those which have the same type of signal being 
transferred between them.

The exception to this rule is the ports that can be added to a sub-system and certain 
components in the library that have ports, which support any type of signal (for 
example, Forks).

Note: You can only connect output to input ports and vice versa.

Figure 12 Rubber Band cursor

The rubber band cursor appears when you place the cursor over a port.

To connect components using the layout tool, perform the following procedure.

Step Action 

1 Place the cursor over the initial port.
The cursor changes to the rubber band cursor (chain link) (see Figure 12).
A tool tip appears that indicates the type of signal that is available on this port 
(see Figure 13).

2 Click and drag to the port to be connected.
The ports are connected.

Figure 13 Connecting components symbol

Figure 14 Connecting ports

• To connect the components, click on the port of one component and drag the 
connection to the port of a compatible component (see Figure 16).

a. Connect the Pseudo-Random Bit Sequence Generator output port to 
the NRZ Pulse Generator Bit Sequence input port.
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Figure 15 Connecting components

b. Connect the NRZ Pulse Generator output port to the available Mach-
Zehnder Modulator input port.

c. Connect the CW Laser output port to the Mach-Zehnder Modulator 
input port.

Figure 16 Connecting components

Visualizing the results

OptiSystem allows you to visualize simulation results in a number of ways. The 
Visualizer Library folder in the Component Library allows you to post process and 
display results from a simulation. The visualizer is categorized as an electrical or 
optical visualizer according to the input signal type.

For example, to visualize the electrical signal generated by the NRZ Pulse Generator 
in time domain, use an Oscilloscope Visualizer.
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Visualizing the results

To visualize the results, perform the following procedures.

Step Action 

1 From the Component Library, select Default > Visualizer Library > 
Electrical.

2 Drag the Oscilloscope Visualizer to the Main layout.

The optical signal can be also displayed by selecting visualizers from the 
library. For example, use an Optical Spectrum Analyzer and an Optical 
Time Domain Visualizer to visualize the modulated optical signal in time 
domain.

3 From the Component Library, select Default > Visualizer Library > Optical.

4 Drag the Optical Spectrum Analyzer to the Main layout.

5 Drag the Optical Time Domain Visualizer to the Main layout (see Figure 
17).

Figure 17 Visualizers in Main layout

Connecting visualizers

To visualize the signal from one component, you must connect the component output 
port to the visualizer input port.

You can connect more than one visualizer to one component output port. As a result, 
you can have multiple visualizers attached to the same component output port.

To connect visualizers, perform the following action.
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Action 

• To connect the component and visualizers, click on the output port of the 
component and drag it to the input port of the visualizer (see Figure 18).

Note: You can only connect one component to a visualizer input port.

a. Connect the NRZ Pulse Generator output to the Oscilloscope 
Visualizer input port.

b. Connect the Mach-Zehnder Modulator output to the Optical Spectrum 
Analyzer input port and to the Optical Time Domain Visualizer input 
port.

Figure 18 Connecting components to visualizers
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Visualizers and data monitors

When you connect a visualizer to a component output port, OptiSystem inserts a 
default data monitor to the component output port. You can then connect the 
component to the visualizer.

Note: Visualizers always connect to monitors. You can have multiple visualizers 
attached to the same component output port, because they are actually attached 
to the monitor, not to the component (see the Mach-Zehnder Modulator with 
connections to the OTDV and the OSD in Figure 19). Data monitors are 
represented by a rectangle around the component output port (see Figure 19 for 
examples of monitors on components).

Figure 19 Visualizers and monitors
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Connecting a monitor to a port

Visualizers post-process the data that the data monitor saves. You can connect a 
monitor to a port without connecting to a visualizer, and the monitor will save the data 
after the simulation ends. If you insert a monitor into a port before the simulation 
starts, you can connect visualizer to this monitor after the simulation ends without 
having to run the simulation again.

To connect a monitor to a port, perform the following procedure.

Step Action 

1 From the Layout Tools toolbar, select the Monitor Tool.
The cursor changes to the Monitor tool.

2 Click the CW Laser output port.

3 To disable the Monitor tool, on the Layout Tools toolbar, click the 
Layout tool.
The monitor saves the signals at the CW Laser output.

Note: If a port already has a monitor, clicking the port with the Monitor tool 
removes the existing monitor.
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Component parameters

Viewing and editing component properties

To view the properties of a component, perform the following action.

Action 

• In the Main layout, double click the CW Laser.
The CW Laser Properties dialog box appears (see Figure 20).

Component parameters are organized by categories. The CW Laser has five 
parameter categories.

• Main — includes parameters for accessing a laser (Frequency, Power, Line width, 
Initial phase)

• Polarization

• Simulation

• Noise

• Random numbers

Figure 20 Component parameters
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Each category has a set of parameters. Parameters have the following properties:

• Disp

• Name

• Value

• Units

• Mode

Display parameters in the layout

The first parameter property is Disp. When you select this property, the parameter 
name, value, and unit appear in the Main layout. For example, if you select Disp for 
Frequency and Power, these parameters appear in the Main layout (see Figure 21).

Figure 21 Displaying parameters in the Main layout

Parameter units

Some parameters, such as Frequency and Power, can have multiple units. 
Frequency can be in Hz, THz or nm, and Power can be in W, mW, or dBm (see 
Figure 22). The conversion is automatic.

Note: You must press Enter or click in another cell to update the values.

Figure 22 Parameter units

Changing parameter modes: arithmetic expressions

Each parameter can have three modes: Normal, Sweep and Script. Script mode 
allows you to enter arithmetic expressions and to access parameters that are defined 
globally.
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To change parameter modes, perform the following procedure.

Step Action 

1 In the Main layout, double-click the CW Laser.
The CW Laser Properties dialog box appears (see Figure 23).

2 Click in the Mode cell beside Frequency.
A drop-down list appears.

3 From the drop-down list, select Script.

4 Click in the Value cell beside Frequency.

5 In the Parameter Script Editor dialog box, type:

193.1+0.1

6 Click Evaluate, and OK.

7 Click Evaluate Script.
The value of the script expression appears in the message window at the 
bottom of the CW Laser Properties dialog box. The Frequency result is 
193.200000.

8 To save the settings and return to the Main layout, click OK.

Figure 23 Scripted parameters
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Accessing visualizer parameters

To access the parameters for a visualizer, perform the following procedure.

Note: You must right-click on a visualizer to access the parameters. Double-
clicking on a visualizer brings up a dialog box to visualize the graphs and results 
generated during the simulation, not the parameters.

Step Action 

1 In the Main layout, select and right-click on the Optical Spectrum Analyzer.
A context menu appears (see Figure 24).

2 From the context menu, select Component Properties.
The Optical Spectrum Analyzer Properties dialog box appears (see Figure 
25).

Figure 24 Layout menu
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Figure 25 Visualizers parameter dialog

3 To save the settings and return to the Main layout, click OK.
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Running the simulation

OptiSystem allows you to control the calculation in three different ways: 

• Calculate the whole project: all sweep iterations for multiple layouts 

• Calculate all sweep iterations in the active layout: all sweep iterations for the 
current layout

• Calculate current sweep iteration: current sweep iteration for the current layout

By default, you will calculate the whole project, since there are currently no multiple 
layouts and no sweep iterations.

To run a simulation, perform the following procedure.

Step Action 

1 From the File menu, select Calculate.
The OptiSystem Calculations dialog box appears (see Figure 26).

2 In the OptiSystem Calculations dialog box, click Run to start the simulation 
(see Figure 26).
The calculation output appears in the dialog box, and the simulation results 
appear below the components that were included in the simulation in the 
Main layout.

Figure 26 Running the simulation

Run

Calculation results appear here.
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Saving the simulation results

OptiSystem allows you to save the data from the monitors. This allows you to save 
the project file with the signals from the monitors. Next time you load the file, the 
visualizers will recalculate the graphs and results from the monitors.

To save the simulation results, perform the following procedure.

Step Action 

1 After the calculation ends, from the Tools menu, select Options.
The Options dialog box appears (see Figure 27).

2 Select Save Monitor Data, and click Save.
The results are saved with the project file.

3 Select File > Calculate.
The Optisystem Calculations dialog box appears.

4 In the OptiSystem Calculations dialog box, click Run to start the simulation 
(see Figure 26).

5 When the calculation is finished, select File > Save As.
The Save As dialog box appears (see Figure 28).

6 Save the project.

Note: When saving monitors the project file size may become very large. 
There is also a delay when reloading the project, due to the fact that 
visualizers will recalculate during the loading of the file.

Figure 27 Options dialog box—Save Monitor Data selection
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Figure 28 Save As dialog box

Displaying results from a visualizer

To display results from a visualizer, perform the following action.

Action 

• Double-click a visualizer to view the graphs and results that the simulation 
generates.

Note: Double-click again to close the dialog box.

Oscilloscope

To visualize electrical signals in time domain with an oscilloscope (see Figure 29), 
perform the following action.

Action 

• Double-click the Oscilloscope Visualizer.
The Oscilloscope Visualizer dialog box appears.
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Since OptiSystem can propagate the signal and noise separately, you can visualize 
the results separately. Use the tabs on the left side of the graph to select the 
representation that you want to view.

• Signal

• Noise

• Signal + Noise

• All

Figure 29 Oscilloscope
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Optical Spectrum Analyzer

To visualize optical signals in frequency domain with an Optical Spectrum Analyzer 
(see Figure 30), perform the following action.

Action 

• Double-click the Optical Spectrum Analyzer.
The Optical Spectrum Analyzer dialog box appears.

Since OptiSystem uses a mixed signal representation, you can visualize the signal 
according to the representation. Use the tabs on the left side of the graph to select the 
representation that you want to view.

• Sampled

• Parameterized

• Noise

• All

To access the optical signal polarization, use the tabs at the bottom of the graph.

• Power: Total power

• Power X: Power from polarization X

• Power Y: Power from polarization Y

Figure 30 OSA
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Optical Time Domain Visualizer

To visualize optical signals in time domain with an Optical Time Domain Visualizer 
(see Figure 31), perform the following procedure.

Action 

• Double-click the Optical Time Domain Visualizer.
The Optical Time Domain Visualizer dialog box appears.

In time domain, OptiSystem translates the optical signal and the power spectral 
density of the noise to numerical noise in time domain. Use the tabs at the bottom of 
the graph to select the representation that you want to view.

Power: Total power

Power X: Power from polarization X

Power Y: Power from polarization Y

Note: When you select polarization X or Y, you can also select to display the 
phase or chirp of the signal for that particular polarization. 

Figure 31 Optical Time Domain Visualizer
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Info-Window

When you open the Info-Window, it appears in the work area of a visualizer graph. 
By default, the Info-Window displays the current position (in database coordinates) 
of the cursor. When you zoom, pan, or trace the graph, the coordinates in the 
Info-Window change to reflect the coordinates of the cursor.

Accessing the Info-Window

To access the Info-Window, perform the following procedure.

Step Action 

1 Double-click a visualizer to view the graph.

2 To open the Info-Window, right-click anywhere on the graph and select the 
Info tool from the graph toolbox that appears (see Figure 32),

or

Click the Graph Menu button (top left corner of graph) and select 
InfoWindow.
The Info-Window appears beside the graph.

Note: Enlarge the graph window to increase the size of the graph.

Figure 32 Graph toolbox
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Zoom, Pan, and Trace tools

The Zoom, Pan, and Trace tools help you analyze and extract information from the 
graphs.

Zooming into a graph

To zoom into a graph, perform the following procedure.

Step Action 

1 To open the Optical Spectrum Analyzer display, double-click the Optical 
Spectrum Analyzer.

2 Open the Info-Window (see Accessing the Info-Window).

3 To access the Zoom tool, right-click anywhere on the graph and select the 
Zoom tool from the graph toolbox that appears,

or

Click the Graph Menu button and select Zoom.
The cursor changes into a magnifying glass.

4 Click and drag the magnifying glass cursor over the area of the graph that you 
want to zoom into.
The cursor coordinates appear in the Info-Window.

Note: By default, the zoom operation zooms into the center of the center of 
the grid.

5 Double-click anywhere on the graph to return to the original size.

Panning a graph

To pan a graph and view a specific area, perform the following procedure.

Step Action 

1 To open the Optical Spectrum Analyzer display, double-click the Optical 
Spectrum Analyzer.

2 Open the Info-Window (see Accessing the Info-Window).

3 To access the Pan tool, right-click anywhere on the graph and select the Pan 
from the graph toolbox that appears.

or

Click the Graph Menu button and select Pan.
The cursor changes into a hand.

4 Use the Pan tool to move the graph and view a specific area of the graph.
The cursor coordinates appear in the Info-Window.
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Tracing a graph

To trace a graph and obtain the values for each point in the graph, perform the 
following procedure.

Step Action 

1 To open the Optical Spectrum Analyzer display, double-click the Optical 
Spectrum Analyzer.

2 Open the Info-Window (see Accessing the Info-Window).

3 To access the Tracer tool, right-click anywhere on the graph and select 
Tracer from the graph toolbox that appears.

or

Click the Graph Menu button and select Tracer.
The cursor changes into a double-headed arrow

4 To view the X and Y line coordinates, click anywhere in the graph.
The X and Y line coordinates appear.

5 Move the X and Y line coordinates to the position on the graph curve that you 
want to view the coordinates for.
The cursor and Tracer coordinates appear in the Info-Window.
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Saving graphs

You can obtain the table of points with the values for each point in the graph and then 
save this as a test file. Copy the graph to the clipboard as a bitmap, or export the 
graph in different file formats — for example, metafile or bitmap.

To save a graph, perform the following procedure.

Step Action 

1 From the Graph Menu button, select Export Data.
The Data Table dialog box appears.

2 To save the data as a text file, click Export Curve.
The Save As dialog box appears (see Figure 33).

3 Select the folder where you want to save the data.

4 Type a name for the file, and click Save.

5 To return to the graph, click OK.

Figure 33 Graph menu dialog
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Figure 34 Data Export dialog
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Notes:
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Lesson 2: Subsystems — Hierarchical 
simulation

A subsystem is like a component — it has an icon, parameters, and input and output 
ports. You build a subsystem using a group of components or other subsystems. You 
can easily create a subsystem by grouping selected components in the layout (see 
Figure 1). 

Subsystems help you to create your own components based on the Component 
Library without programming, and to organize the layout in different hierarchical levels 
when there are a large number of components in different levels.

Figure 1 Hierarchical simulation

This lesson describes how to create a subsystem using the External Modulated Laser 
subsystem from Lesson 1: Transmitter — External modulated laser. You will become 
familiar with subsystems and the Component Library.

Loading a sample file

To load a sample file, perform the following procedure.

Step Action 

1 From the File menu, select Open.

2 From your C: drive, select Program Files > Optiwave Software > 
OptiSystem 9 > samples > Introductory tutorials > “Lesson 2 
Subsystems - Hierarchical simulation.osd”.
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Creating a subsystem

To create a subsystem, perform the following procedure.

Step Action 

1 In the Main layout, select the components that you want to include in the 
subsystem.
A box appears around the selected components (see Figure 2)..

2 Right-click the selection.
A context menu appears (see Figure 24 from Lesson 1).

3 From the context menu, select Create Subsystem.
The subsystem appears in a glass box. When you look inside the subsystem, 
a subsystem tab appears at the bottom of the Main layout (see Figure 3).

Note: The visualizers that are not included in the selection are disconnected. 
The subsystem does not add additional ports to connect the visualizers.

Figure 2 Creating a subsystem—Selected components in the Main layout

Looking inside a subsystem

To look inside a subsystem, perform the following procedure.

Step Action 

1 Select the subsystem glass box and right-click.
A context menu appears (see Figure 3)

2 From the context menu, select Look Inside.
The subsystem opens and a Subsystem tab appears beside the 
Main layout tab at the bottom of the subsystem layout window (see Figure 
3).
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Figure 3 Looking inside a subsystem

3 To return to the Main layout and close the subsystem, right-click in the 
subsystem layout and select Close Subsystem from the context menu (see 
Figure 24 from Lesson 1),

or

To return the Main layout and leave the subsystem open, click the Main 
Layout tab.
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Creating a subsystem output port

You can change parameters and create ports in order to access the signals from the 
subsystem.

Step Action 

1 Select the subsystem glass box and right-click.
A context menu appears.

2 From the context menu, select Look Inside.
The subsystem opens.

3 From the Layout Tools toolbar, select Draw – Output Port Tool.
The cursor changes into a cross-hatch.

4 Position the cursor on the edge of the subsystem layout where you want to 
add the output port.
The cross-hatch changes into an output port.

5 Click to place the output port.
The output port is created (see Figure 5).

Connecting a component output port to a subsystem output port

To connect the Mach-Zehnder Modulator output port to the subsystem output port, 
perform the following procedure.

Step Action 

1 From the Layout Tools toolbar, select Layout Tool .
The cursor changes into the Layout Tool.

2 Click the Mach-Zehnder output port.
The cursor changes into a link (see Figure 4).

3 To connect the Mach-Zehnder output port to the subsystem output port, drag 
the cursor from the Mach-Zehnder output port to the subsystem output port 
(see Figure 5).
The output ports are connected.

4 Click the Main Layout tab to return to the Main layout.
The output port appears in the subsystem.

Note: Use the same procedure to create input ports. Because this is a 
transmitter, you will not create input ports in this lesson.
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Figure 4 Link tool in the subsystem

Figure 5 Linking output ports

Changing the port position and location

To change the port position and location, perform the following procedure.

Step Action 

1 In the Main layout, double-click the subsystem port,

or

In the subsystem, double-click the port.
The Port Properties dialog box appears (see Figure 6).

2 Select the position in the subsystem that you want to move the port to:

• Top

• Bottom

• Left

• Right
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3 Move the slider to specify the exact position that you want to select.

4 To return to the Main layout, click OK.

Figure 6 Port properties
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Subsystem properties — name and icon

You can change the name and add an icon for a subsystem by changing the 
subsystem parameters.

Changing a subsystem name

To change the subsystem name, perform the following procedure.

Step Action 

1 In the Main layout, double-click on the subsystem.
The Subsystem Properties dialog box appears.

2 In the Label field, type External Modulated Transmitter (see Figure 7).

3 To return to the Main layout, click OK.
The new subsystem name appears below the subsystem glass box and on 
the subsystem tab (see Figure 8).

Figure 7 Subsystem properties dialog
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Figure 8 Subsystem modified tab name

Adding a subsystem icon

You can load a user-defined image from a file to use as the a subsystem icon.

To add a subsystem icon, perform the following procedure.

Step Action 

1 In the Main layout, double-click the External Modulated Transmitter 
subsystem glass box.
The External Modulated Transmitter Properties dialog box appears.

2 Click the Value cell beside Subsystem Representation.
A drop-down list appears.

3 From the drop-down list, select User Image.

4 Click the Value cell beside Image Filename, and click 
The Open dialog box appears (see Figure 9).

5 Select the image that you want to use as the subsystem icon, and click Open.

Note: You can use the image External.bmp in the samples directory.
The image you selected appears as the External Modulated Transmitter 
subsystem icon (see Figure 10).

6 To return to the Main layout, click OK in the External Modulated 
Transmitter properties dialog box.

Figure 9 Subsystem dialog - User icon import
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Figure 10 User imported subsystem icon in Project layout

Adding global parameters to a subsystem

In this example, use the External Modulated Transmitter subsystem that you 
created. To access any parameter inside of the External Modulated Transmitter, 
look inside of the subsystem. 

To change the subsystem component parameter values without looking inside each 
time you need to access them, you can create global parameters (see Figure 11).

In the following procedures, you will export the Power and Frequency parameters so 
that you will be able to access them without looking inside the External Modulated 
Transmitter subsystem.

To add a global parameter to a subsystem, perform the following procedure.

Step Action 

1 In the Main layout, double-click External Modulated Transmitter 
subsystem.
The External Modulated Transmitter Properties dialog box appears.

2 Click Add Param.
The Add Parameter dialog box appears (see Figure 11).

3 Type the following values:

• Name: Frequency

• Type: floating-point

• Category: Main

• Minimum value: 100

• Maximum value: 200

• Current value: 193.1

• Units: THz

4 Click Add.
The Frequency parameter is added to the Main category. A message 
appears in the message window at the bottom of the dialog box to advise you 
that the Frequency parameter has been added.
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5 Click Add Param.
The Add Parameter dialog box appears.

6 In the Add Parameter dialog box, type the following values:

• Name: Power

• Type: floating-point

• Category: Main

• Minimum value: -100

• Maximum value: 30

• Current value: 0

• Units: dBm

7 Click Add.
The Power parameter is added to the Main category. A message appears in 
the message window at the bottom of the dialog box to advise you that the 
Power parameter has been added.

Figure 11 Add Parameter dialog
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Figure 12 Frequency parameter added to External Modulated Transmitter

Accessing global parameters

In the last section, you added two parameters to the subsystem. Now you must create 
a reference between the components inside the subsystem and the global 
parameters (see Figure 13).

To access global parameters, perform the following procedure.

Step Action 

1 Right-click on the External Modulated Transmitter subsystem.
A context menu appears.

2 Select Look inside.
The subsystem layout appears.

3 Double-click the CW Laser.
The CW Laser Properties dialog box appears.

4 Click in the Mode cell beside Frequency and select Script from the drop-
down list.

5 Click in the Units cell beside Frequency and select THz from the drop-down 
list.

6 Click the button in the Value cell beside Frequency.
The Parameter Script Editor dialog box appears.
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7 Type Frequency and click OK.

8 Click in the Mode cell beside Power and select Script from the drop-down 
list.

9 Click in the Units cell beside Power and select dBm from the drop-down list.

10 Click the button in the Value cell beside Power.
The Parameter Script Editor dialog box appears.

11 Type Power and click OK.

12 To return to the subsystem layout, click OK.

13 To return to the Main layout, click the Main Layout tab.

Figure 13 Using script parameters

For example, now when you change the value of the Frequency parameter for the 
External Modulated Transmitter subsystem, you will change the values for the CW 
Laser inside the External Modulated Transmitter subsystem.
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Component Library

The OptiSystem Component Library consists of four sub-libraries (see Figure 14).

• Default: Read-only — you cannot add or change the parameters of a default 
component.

• Custom: Allows you to add new components and expand the Component Library.

Note: You can base new components on components from the Default library. 
However, the component name must be different from the name of the 
component in the Default library. You can also include subsystems in the Custom 
library.

• Favorites: Allows you to add components to a library that includes the ones you 
use most frequently.

• Recently used: Components that you have used in recent projects are added 
automatically to the Recently used library.

Figure 14 Component Library

Before you add the External Modulated Transmitter to the Custom library, you will 
create a new folder named Transmitters (see Figure 15).
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Creating sub folders in the Custom Library

To create a a sub folder in the Custom library, perform the following procedure.

Step Action 

1 From the Component Library, select Custom.
The Custom library opens.

2 Right-click in the background of the Custom library.
A context menu appears (see Figure 15).

3 Select Add Folder.
The New Folder dialog box appears (see Figure 16).

4 Type Transmitters and click OK.
A new folder named Transmitters appears in the Custom library in the 
Component Library (see Figure 17).

Figure 15 Creating a custom folder menu

Figure 16 Add Folder dialog

Figure 17 Added folder in Custom library
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Adding a component to the library

You can drag components to any folder in the Custom library. To add the External 
Modulated Transmitter to the Custom library in the Transmitters folder (see Figure 
18), perform the following procedure.

Step Action 

1 Double-click the Transmitters folder in the Custom library.

2 In the Main layout, select the External Modulated Transmitter component.

3 Drag the External Modulated Transmitter subsystem into the Transmitters 
folder.
The External Modulated Transmitter subsystem appears in the 
Transmitters folder.

Figure 18 Added component in Custom Library

Creating additional ports

To access the electrical signal from the NRZ Pulse Generator inside the External 
Modulated Transmitter subsystem, create an additional output port in the subsystem 
(see Figure 19).

To create a port, perform the following procedure.

Step Action 

1 In the Main layout, right-click on the External Modulated Transmitter.
A context menu appears.

2 Select Look Inside.
The subsystem layout appears.
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3 Create a new output port in the subsystem (see “Creating a subsystem output 
port” on page 40).

Figure 19 Adding a new output port to the subsystem

Output port

Adding a fork to the subsystem

You cannot connect the NRZ Pulse Generator output to this port because it's already 
connected to the Mach-Zehnder Modulator input. To solve this problem, you can 
duplicate the signal from the NRZ Pulse Generator and connect it to both the Mach-
Zehnder Modulator input and subsystem output ports by adding a fork (see Figure 
20).

To add a fork to the subsystem, perform the following procedure.

Note: To increase the size of the layout, press Ctrl+Shift and drag the cursor 
from the top left corner of the Main layout to the bottom right corner.

Step Action 

1 From the Component Library, select Default > Tools Library. 

2 Drag the Fork 1x2 to the Main layout.

3 Select the blue connection between the NRZ Pulse Generator and the 
Mach-Zehnder Modulator.
The selected connection changes to red.

4 Press Delete to delete the connection.

5 Connect the NRZ Pulse Generator output to the Fork input.
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6 Connect the first Fork output to the subsystem output port.

7 Connect the second Fork output to the available Mach-Zehnder Modulator 
input port (see Figure 20).

Note: To delete the internal data monitors, from the Layout Tools toolbar 
select the Monitor tool and click the monitor in each component output port.

Figure 20 External Modulated Transmitter with two output ports

8 To return to the Main layout, click the Main Layout tab.
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Saving the modified subsystem

To save the modified subsystem, perform the following procedure.

Step Action 

1 In the Transmitters folder in the Custom library, select and right-click the 
External Modulated Transmitter.
A context menu appears.

2 Select Delete.

3 Drag the modified External Modulated Transmitter from the Main layout 
into the Transmitters folder in the Custom library.

Running the External Modulated Transmitter simulation

To run the simulation for the External Modulated Transmitter, perform the following 
procedure.

Note: Before you run the simulation, you must connect the External Modulated 
Transmitter output port to a component or visualizer.

Step Action 

1 Connect the first External Modulated Transmitter output to the 
Oscilloscope Visualizer.

2 Connect the second External Modulated Transmitter output port to the 
Optical Spectrum Analyzer and to the Optical Time Domain Visualizer.

3 Run the simulation:

a. Click Calculate.

b. Click the PLAY button.
The results appear in the Calculation Output window.

4 To view the graphs of the results, double-click each visualizer (see Figure 21).

Note: The center frequency and power of the transmitter are defined by the 
values of the Frequency and Power parameters.
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Figure 21 Results from External Modulated Transmitter



 LESSON 2: SUBSYSTEMS — HIERARCHICAL SIMULATION

56

Notes:
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Lesson 3: Optical Systems — WDM Design 

This lesson describes how to simulate a WDM system with 8 channels. You will 
become familiar with the Component Library, parameter groups, and visualizers such 
as the BER Analyzer.

Global parameters

For this simulation we will use default parameters for the Bit rate, Bit sequence 
length, and Sample rate.

Viewing the global parameters

To view the default global parameters, perform the following procedure.

Step Action 

1 From the File menu, select New.
A blank Main layout appears in the Project layout window.

2 Double-click anywhere in the Main layout.
The Layout 1 Parameters dialog box appears (see Figure 1).

The default global parameters used for this simulation are:

• Bit rate: 2500000000 Bits/s

• Sequence length: 128 bits
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• Time window: 5.12e-008

Figure 1 Global parameters
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Transmitters

To create the transmitters for the WDM system with 8 channels, perform the following 
procedure.

Step Action 

Note: To increase the size of the layout, press Ctrl+Shift and drag the cursor 
from the top left corner of the Main layout to the bottom right corner.

1 Create an external modulated laser using the procedures in Lesson 1: 
Transmitter — External modulated laser.

2 Select the four external modulated laser components.

3 Copy and paste the selected components to create a total of eight 
transmitters (see Figure 2).

Figure 2 Creating eight external modulated lasers
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4 From the Component Library, select Default > WDM Multiplexers Library > 
Multiplexers.

5 Drag the WDM Mux 8x1 to the Main layout.

6 Connect the Mach-Zehnder Modulator outputs to the WDM Mux 8x1 inputs.

Note: You can select the values for the Mux internal filters to be displayed in 
the layout by selecting the Disp option in the Channels tab of the Mux 
properties dialog box (see Figure 3).

Figure 3 Displaying multiplexer frequency channels
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Parameter groups

To enter the frequency values for each channel, double-click each CW Laser and 
enter the frequency value. To simplify the process of entering parameter values for 
each component, use the Parameter groups feature.

Accessing the Parameter groups table

The Parameter groups table gives you access to relevant parameters for the WDM 
simulation (such as Frequency and Power) in one place. You can go into each 
component and enter the values to change the parameters.

To access a parameter group, perform the following procedure.

Step Action 

1 From the Main toolbar, select Layout > Parameter groups.
The Parameter Groups dialog box appears (see Figure 4).

Note: Typically you can access the following parameters from the Parameter 
Groups table (see Figure 4):

• Bit rate

• Convert noise bins

• Frequency

• Iterations

• Output signal type

• Power

• Sample rate

You can also enter the units for the parameter group and edit the parameter 
values by typing new values or using the tools from the context menu.
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Figure 4 Parameter groups

2 Click the Value column.
The Value column is highlighted.

3 In the Parameters Groups table, select the Value column and right-click.
A context menu appears.

4 Select Spread.
The Parameter Group Spread dialog box appears (see Figure 5).

5 In the Start Value text box, type:

193.1

6 In the Increment text box, type:

0.1

7 To return to the Main layout, click Close.
The frequencies in the Value column are updated from 193.1 THz to 
193.8 THz (see Figure 5).
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Figure 5 Entering frequency values

Testing the transmitter

To verify the system setting for this design, use an Optical Spectrum Analyzer and 
a WDM analyzer to obtain the signal spectrum and the total power for each channel.

To test the transmitter, perform the following procedure.

Step Action 

1 From the Component Library, select Default > Visualizer Library > Optical.

2 Drag the Optical Spectrum Analyzer to the Main layout.

3 Drag the WDM Analyzer to the Main layout.

4 Connect the Optical Spectrum Analyzer input and the WDM Analyzer input 
to the WDM Mux output.

5 Run the simulation:

a. Click Calculate.
The Calculation dialog box appears.

b. Click the Run button.
The calculation progress appears in the Calculation dialog box.

6 Double-click Optical Spectrum Analyzer to view the graph (see Figure 6).
The graph appears and displays eight equally-spaced channels.

7 Double-click the WDM Analyzer to view the numerical results (see Figure 6).
The WDM Analyzer dialog box appears and displays the numerical results 
for the eight channels.

Note: The average signal power for each channel is approximately -3.3 dBm 
for a resolution bandwidth of 0.1 nm.
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Figure 6 Simulation results from the visualizers

Fiber + EDFA spans

To create a fiber connected to an EDFA, perform the following procedure.

Step Action 

1 From the Component Library, select Default > Optical Fibers Library.

2 Drag the Optical Fiber to the Main layout.

3 Double-click the Optical Fiber.
The Optical Fiber Properties dialog box appears.

4 To change the parameter length to 80 km, click the Value cell beside Length, 
and type:

80
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5 To return to the Main layout, click OK.

6 From the Component Library, select Default > Amplifiers Library > Optical.

7 Drag the Optical Amplifier to the Main layout.

8 In the EDFA Parameters, change Operation Mode to Power Control.

9 Connect the Optical Fiber output to the EDFA Ideal input (see Figure 7).

Figure 7 Fiber + EDFA span

Connecting the Loop Control

The Loop Control allows you to set the number of times the signal propagates in the 
components that are connected between the Loop Control input and output ports. 
Use the Loop Control to calculate the system performance based on the number of 
fibers and EDFA spans.



 LESSON 3: OPTICAL SYSTEMS — WDM DESIGN

66

To connect the Loop Control, perform the following procedure.

Step Action 

1 From the Component Library, select Default > Tools Library.

2 Drag the Loop Control to the Main layout.

3 Connect the output port of the WDM Mux 8x1 to the first Loop Control input 
port.

4 Connect the first Loop Control output port to the Optical Fiber input port 
(see Figure 8).

5 Connect the output port of the second EDFA Ideal (connected to the Optical 
Fiber) to the Loop Control input port (see Figure 8).

Figure 8 Loop control

Setting the number of signal round trips

You define the number of round trips that the signal makes through the loop by setting 
the Number of loops parameter in the Loop Control.

To set the number of signal round trips, perform the following procedure.

Step Action 

1 Double-click the Loop Control.
The Loop Control Properties dialog box appears (see Figure 9).
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Figure 9 Loop control parameters

2 To set the number of signal round trips, click the Value cell beside number of 
loops, highlight the 0, and type:

3

Note: The signal will propagate 3 x 80km = 240 km.

3 To return to the Main layout, click OK.

4 From the Component Library, select Default > Optical Fibers Library.

5 Drag the Optical Fiber to the Main layout.

6 Set the fiber Length to 100km.

7 From the Component Library, select Default > WDM Multiplexers Library > 
Demultiplexers.

8 Drag the WDM Demux 1x8 to the Main layout.

9 Connect the second Loop Control output port to the Optical Fiber and then 
to the WDM Demux 1x8 input port (see Figure 10).

10 To view the WDM Demux 1x8 frequencies:

a. Double-click the WDM Demux 1x8
The WDM Demux 1x8 Properties dialog box appears.

b. Select the Channels tab.

c. In the Disp column, select the check box beside each frequency.

d. To return to the Main layout, click OK.
The eight frequencies and their values appear below the WDM 
Demux 1x8 (see Figure 10).



 LESSON 3: OPTICAL SYSTEMS — WDM DESIGN

68

Figure 10 Demultiplexer

Obtaining results after the demultiplexer

To verify the system setting for this design, you will use an Optical Spectrum 
Analyzer, a WDM Analyzer, and an Optical Time Domain Visualizer.

To obtain the signal results in time and frequency and the total power for each channel 
after the signal passes through the WDM Demux 1x8, perform the following 
procedure.

Step Action 

1 From the Component Library, select Default > Visualizer Library > Optical.

2 Drag the Optical Time Domain Visualizer to the Main layout.

3 Drag the Optical Spectrum Analyzer to the Main layout.

4 Drag the WDM Analyzer to the Main layout.

5 Connect each of the visualizers to the first output port on the WDM Demux 
1x8 (193.1 THz).

6 Run the simulation:

a. Click Calculate.

b. Click the Run button.
The calculation progress appears in the Calculation dialog box.

Note: This simulation will take some time.
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7 Double-click the visualizers to view the results and graphs (see Figure 11).

Figure 11 Simulation results from the visualizers
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Adding a receiver

To add a photodetector, an electrical amplifier, and a Bessel filter to the design, 
perform the following procedure.

Step Action 

1 From the Component Library, select Default > Receivers Library > 
Photodetectors.

2 Drag the Photodetector PIN to the Main layout.

3 Set the Thermal Noise parameter to 10-21.

4 From the Component Library, select Default > Filters Library > Electrical.

5 Drag the Low Pass Bessel Filter to the Main layout.

6 Connect the first output port on the WDM Demux 1x8 to the Photodetector 
PIN input port.

7 Connect the Photodetector PIN output port to the Low Pass Bessel Filter 
input port (see Figure 12).

Figure 12 Adding the receiver to the WDM system

Note: This design could be made using the WDM Transmitter component from 
the Optical Transmitters library. Fewer steps are required if you use this 
component. When using the WDM Transmitter, the receiver will require the 
3R Regenerator component from the Receivers library (see sample file 
Lesson3B.osd).
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Figure 13 WDM Transmitter layout design (Lesson 3B.osd)
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BER Analyzer

The BER Analyzer calculates system performance. It can predict the BER, Q-factor, 
threshold, and Eye aperture of a system. You can view the BER patterns and the BER 
value in each point of the Eye diagram using 3D graphs.

Adding the BER Analyzer

To add the BER Analyzer to the system, perform the following procedure.

Step Action 

1 From the Component Library, select Default > Visualizer Library > 
Electrical.

2 Drag the BER Analyzer to the Main layout.

Note: The first BER Analyzer input port receives the binary signal.

3 Connect the output port of the first Pseudo-Random Bit Sequence 
Generator to the first BER Analyzer input port.

Note: The second BER Analyzer input port receives the original sampled 
signal. It compensates the delay between the signals that are transmitted and 
received.

4 Connect the output of the first NRZ Pulse Generator to the second 
BER Analyzer input port.

5 Connect the Low Pass Bessel Filter output port to third BER Analyzer input 
port (see Figure 14).

Figure 14 Connecting the BER Analyzer

6 Run the simulation:

a. Click Calculate.

b. Click the Run button.
The calculation progress appears in the Calculation dialog box.

Note: This simulation will take some time.
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7 To display the results and graphs, double-click the BER Analyzer.

Viewing the BER Analyzer graphs and results

To view the BER Analyzer graphs and results, perform the following procedure.

Step Action 

1 Double-click the BER Analyzer.
The BER Analyzer window appears and displays a graph.

2 Select Show Eye Diagram.
The graph is redrawn and displays the Eye Diagram.

Note: When you open the BER Analyzer, the following graphs appear 
together with the Eye Diagram (see Figure 15):

– Q-Factor: Maximum value for the Q-Factor versus Decision Instant.

– Min BER: Minimum value for the BER versus Decision Instant.

– Threshold: Threshold value versus Decision Instant that gives the 
maximum Q-Factor and the Min BER.

– Height: Eye height versus Decision Instant.

– BER Pattern: When Calculate Patterns is selected, displays the regions 
where the BER value is less than the user-defined values.

Figure 15 BER Analyzer graphs
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The Analysis group box displays the following values (see Figure 16):

• Maximum Q-Factor

• Minimum BER

• Maximum eye aperture

• Threshold

• Decision Instant at the Max Q-Factor/ Min BER

Figure 16 BER Analyzer results

Calculating BER patterns

To calculate the BER patterns, perform the following procedure.

Step Action 

Note: The Calculate Patterns check box is only available when you select 
the BER Pattern tab (see Figure 17).

1 In the BER Analyzer window, select the BER Pattern tab.
The graph changes to display the BER Patterns graph.

2 Select the Calculate Patterns check box.
The visualizer recalculates the results and displays a new graph.
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Figure 17 Calculating BER patterns

Calculating the 3D BER graph

To calculate the 3D BER, perform the following procedure.

Step Action 

Note: You must enable the calculation of the BER patterns and the 3D graph.

1 Right-click the BER Analyzer.
A context menu appears.

2 Select Component Properties.
The BER Analyzer Properties dialog box appears.

3 Select the BER Patterns tab (see Figure 18).

4 Select the Value cell beside Calculate Patterns.

5 Select the Value cell beside Calculate 3D graph.

6 In the Disp column, select Calculate Patterns and Calculate 3D graph.

7 To recalculate the results and return to the Main layout, click OK.
The visualizer recalculates the graphs and results.
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Figure 18 Calculating 3D graph

Viewing the 3D graph

To view the 3D graph, perform the following procedure.

Step Action 

1 If the Project Browser is closed:

• From the Main toolbar, select View > Project Browser,

or

• Press Ctrl+2.

2 In the Project Browser, expand the BER Analyzer component.
A list of available options appears.

3 Expand the Graphs item in the list.
A list of BER Analyzer available graphs appears.

4 From the list of BER Analyzer graph items, right-click the BER Pattern 3D 
Graph.

5 Select Quick View.
The 3D graph appears (see Figure 19).
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Figure 19 3D graphs from the project browser
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Lesson 4: Parameter Sweeps — BER x Input 
power

This lesson describes how to combine the results from the BER/Eye Analyzer with the signal input power 
using parameter sweeps. You will become familiar with parameter sweeps, graph builder, results, graphs, 
and views.

The first three procedures describe how to iterate the Power parameter for the CW Laser component.

Opening the sample file

Use the sample file Lesson4 Parameter Sweeps - BER x Input power.osd. 
To open the file, perform the following procedure.

Step Action 

1 From the Main toolbar, select File > Open.
The Open dialog box appears.

2 From your C: drive, select Program Files > Optiwave Software > 
OptiSystem 9 > samples > Introductory tutorials > “Lesson4 Parameter 
Sweeps - BER x Input power.osd”.
The sample file appears (see Figure 1).

Figure 1 Sample file that calculates BER x Input power



 LESSON 4: PARAMETER SWEEPS — BER X INPUT POWER

80

Selecting the parameter to iterate using the Sweep mode

To select the parameter to iterate using the Sweep mode, perform the following 
procedure.

Step Action 

1 Double-click the CW Laser.
The CW Laser Properties dialog box appears (see Figure 2).

2 In the Power row, click the Mode cell.
A drop-down list appears.

3 Select Sweep.

Figure 2 Changing the parameter mode to Sweep

4 To save the settings, click OK.
The CW Laser Properties dialog box closes.
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Changing the number of sweep iterations

We want to be able to calculate the design using different values of the input power.

To change the number of sweep iterations, perform the following procedure.

Step Action 

1 From the Layout menu, select Set Total Sweep Iterations.
The Total Parameter Sweep Iterations dialog box appears (see Figure 3).

2 In the Total Iterations, type:

10

3 To set the value and return to the Main layout, click OK.

Figure 3 Adding iterations
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Changing the values of sweep iterations

To change the values of sweep iterations, perform the following procedure.

Step Action 

1 From the Layout menu, select Parameter Sweeps.
The Parameter Sweeps dialog box appears.

2 Select the Power column (all cells).
The selected cells are highlighted.

3 Under Spread Tools, click Linear.
The Parameter Iteration Spread dialog box appears (see Figure 4).

4 In Start Value, type:

–10

5 In End Value, type:

10

6 To set the values, click OK.
The Parameter Iteration Spread dialog box closes.

7 To return to the Main layout, click OK.
The Parameter Sweeps dialog box closes.

Figure 4 Entering values for all iterations
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Running the simulation

To run the simulation, perform the following procedure.

Step Action 

1 Click Calculate.

2 Click the Run button.
The calculation progress appears in the Calculations dialog box window.

Obtaining results using the Report Page

To create a graph showing the BER versus the power, you must obtain the results 
generated by the BER Analyzer.

To obtain results using the Report Page, perform the following procedure.

Step Action 

1 Select the Report tab in the Project layout window.
The Report window appears.

2 Click the Opti2DGraph button on the Report toolbar and draw a 2D graph in 
the report window.
The 2D graph appears in the Report window.

3 In the Project Browser, select the parameter Power from the CW Laser, and 
drag it to the 2D graph X-axis (a grey triangle appears in the graph in the 
bottom right corner).
The graph appears in the Report window.

4 In the Project Browser, select the Min. log of BER result from the 
BER Analyzer component, and drag it into the Y-axis of the graph (the grey 
triangle appears in the top left corner).
The result is plotted in the graph.
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Figure 5 Building the graph
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Browsing parameter sweep iterations

You can open the BER Visualizer and obtain the Eye diagrams and graphs, such as 
Q-factor and BER, for different iterations changing the current sweep iteration.

To browse parameter sweep iterations, perform the following procedure.

Step Action 

1 In the Main layout, double-click the BER Analyzer.
The BER Analyzer graph opens.

2 Select the Show Eye Diagram check box.
The graph changes to display the Eye Diagram.

3 In the toolbar, change the Sweep iteration (see Figure 6).

Note: You obtain different results for each iteration, one for each input power 
value.

Figure 6 Browsing through the parameter sweep iterations, the Eye diagram, and Q-Factor for each value 
of laser power
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Combining graphs from sweep iterations

Visualizers can generate graphs for all sweep iterations.

You can access the graphs for all sweep iterations by using the Graph subfolder in 
the Project Browser.

Note: A visualizer will display only the current sweep iteration when you access 
the graphs by double-clicking on the graph and browsing for different iterations.

To combine graphs from sweep iterations, perform the following procedure.

Step Action 

1 If the Project Browser is closed:

• From the Main toolbar, select View > Project Browser

or

• press Ctrl+2.

2 Expand the Graphs subfolder for the BER Analyzer.
The list of available graphs appears.

3 Right-click Q Factor, and select Quick view,

or

4 Drag and drop the graph into the Report Page.
A graph appears and displays the iterations for each input power value (see 
Figure 7).

Figure 7 Multiple iterations graph
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Lesson 5: Bidirectional Simulation — Working 
with multiple iterations

Besides the typical global simulation parameters of OptiSystem, such as Bit rate, 
Samples per bit and Sequence length, there are two additional parameters that are 
very important when designing bidirectional systems or systems with closed loops, 
such as ring networks. 

These parameters are 

• Iterations

• Initial delay

Iterations force a component to calculate again until it generates, at the output ports, 
the Iterations number of signals. 

Initial delay forces a component to generate a null signal for each output port.

Because the majority of OptiSystem components will not calculate if a signal is not 
available at the input ports, the Iterations and Initial delay parameter will help the user 
to avoid a situation in which the simulation will not perform because a component 
cannot find signals at the input port - and the system will be deadlocked.

The concept of multiple iterations and delays is very confusing, because it does not 
have a physical meaning. It is a simulation technique and requires an understanding 
of the calculation scheduler of OptiSystem. 

A basic bidirectional simulation

System setup
• Using the default global parameters, we can start adding the components to 

design the basic bidirectional system. 

From the component library, drag and drop the following component in to the layout:

• From "Default/Transmitters Library/Optical Sources", drag and drop the "CW 
Laser" into the layout.

• Change the laser parameter Linewidth to 0 MHz.

• From "Default/Passives/Optical/Isolators", drag and drop the "Isolator" 
components into the layout.

• Change the Isolator parameter Insertion loss to 3 dB.

• From "Default/Visualizers Library/Optical", drag and drop 3 of the "Optical 
Spectrum Analyzer" into the layout.
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The next step is to connect the components according to the Figure 1. Do not forget 
to connect the Isolator Input 2 at the Output 2.

Figure 1 Basic bidirectional system

Running the simulation

We can run this simulation and analyze the results:

• To run the simulation you can go to the File menu and select Calculate. You can 
also press Control+F5 or use the calculate button in the toolbar. After you select 
Calculate, the calculation dialog box should appear.

• In the calculation dialog box, press the Play button.The calculation should 
perform without errors.

Viewing the results - system deadlock

In order to see the results, double click at each of the OSA visualizers. 

The OSA connected at the CW Laser output will have a signal as presented in Figure 
2. 

As expected, we have a CW signal centered at 193.1 THz with peak power around 0 
dBm. However, the other two OSAs have no signals, and this is also expected. 

Why is this expected? It is expected because the Isolator does not have a signal at 
each input port. The laser will send a signal to the first input port of the isolator. 
However, the isolator will not calculate if a signal is not available at the second port - 
the system is deadlocked. 
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Figure 2 CW Laser output

Using delays

What if we add a delay at the second input port of the Isolator? 

• From "Default/Tool library", drag and drop the "Optical Delay" into the layout.

• Add another OSA to the system.

• Connect the component according to Figure 3.

The delay component is important because, unlike the Isolator, it will calculate without 
having a signal at the input port. If the laser and the delay calculate, the Isolator will 
have signals available at both input ports. 

Run the simulation again and open the visualizers.
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Figure 3 Basic bidirectional system using a delay

Viewing the results

Let's take a look at the signal at the second port of the Isolator. As expected, the input 
signal was attenuated by the isolator insertion loss and the peak power is -3 dBm. The 
OSA at the first isolator output shows the value of the return loss of the device and 
the peak power is -60 dBm.

Now, let's see the signal at the Delay output. If we open the OSA at the delay output 
there is no signal - it is empty. This is the result of the first calculation of the delay. 
There was no input signal and the delay generated a null signal. This null signal and 
the laser signal were sent to the Isolator inputs. The isolator calculated with these two 
signals and generated a signal per output port. 

One of the signals went back to the delay, which will then transfer the signal to its 
output port. This means there are two signals at the delay output: the null signal and 
the signal from the isolator.

In order to browse through the signals at the delay output you should use the Signal 
index parameter from the OSA. Set the signal index to 1 and you will see the signal 
from the isolator, with peak power of -3 dBm (Figure 4).
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Figure 4 Second signal at the delay output

This means we could calculate using the isolator, however the results are not exactly 
what we expect in this type of bidirectional system. There is a feedback between the 
second isolator input and output port that did not cause any effect in our results. We 
should force the signal to “circulate” between the laser, isolator and delay in order to 
see the signal evolution in the system. 

In order to force the signal to circulate multiple types in the system, we can force the 
laser to generate the same signal multiple times, forcing the component to calculate 
multiple times - because there will be signals available at the input ports of the isolator 
and delay. 



 LESSON 5: BIDIRECTIONAL SIMULATION — WORKING WITH MULTIPLE ITERATIONS

92

Using Iterations parameter

Change the global parameter Iterations to 10, run the simulation again.

Viewing the results

Let's see the results from the OSAs. The laser generated 10 signals. You can change 
the signal index parameter at the laser output and see that the signal power does not 
change. This is expected, because we have 10 copies of the same signal. 

We expect the second isolator output signal to have -3dBm of power. However we 
don't know the power at the first isolator output port. This port will have the laser input 
power reflected by the return loss, plus the feedback signal attenuated by the isolator 
insertion loss. 

Look at the OSA at the isolator outputs in order to evaluate the results. Do not forget 
to change the signal index!

By changing the signal index you can see how the power changes per iteration. We 
are using 10 iterations but 2 or 3 should be enough to give a “steady-state” value for 
the output power of the OSAs.

Cascading devices

Let's make the system more complicated:

• Duplicate the Isolator.

• Connect the component according to Figure 5.

From what we learned until now, it seems obvious that this system will be deadlocked 
because the two Isolators will not have signals at the input ports. 

You can run the simulation and you will see that the 10 signals from the laser will not 
reach all the visualizers. In order to make the system work, we should add more 
delays:

• Duplicate the delay twice.

• Connect the component according to Figure 6.

If you run the simulation again, the system will run properly. You should increase the 
OSA signals index in order to visualize the proper results. 
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Figure 5 Basic bidirectional system cascading two isolators

Figure 6 Basic bidirectional system cascading two isolators and delays
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Using Initial delay parameter

The main problem with cascading these devices is that the user should add delays 
per each input port, and this can be cumbersome for some designs. This is why 
OptiSystem allows the user to include a delay by default for each input port:

• Remove the delays.

• Connect the component according to Figure 7.

• In the global parameters, enable parameter Initial delay.

• Run the simulation.

This time we have a clean design, without multiple delays. The final results are the 
same as adding the delays. 

There is one main difference between the designs of Figure 6 and 7. By enabling the 
global parameter initial delay, all components will generate a null signal, including the 
laser component. This is not true for Figure 6, in which only the delays generated the 
null signals.

Figure 7 Basic bidirectional system with two isolators in cascade
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Tools library

OptiSystem Tools Library has components that can manipulate signals and signal 
buffers. 

Signals can be duplicated, selected, initialized, etc. For example, Figure 8 presents a 
system that is equivalent to Figure 6, without using global parameters: Iterations = 1 
and Initial delay = disabled.

• Repeat the steps to generate Figure 6 layout.

• Set the global iterations parameter to 1.

• Set the Initial delay parameter to disabled status.

• From "Default/Tool library", drag and drop the "Duplicator" into the layout.

• Change the parameter Iterations mode to Normal. Set the value to 10.

• From "Default/Tool library", drag and drop the "Buffer selector" into the layout.

• Change the parameter Iterations and Selection mode to Normal. Set the value of 
Iterations to 10 and Selection to 9.

• Connect the component according to Figure 8.

• Run the simulation.

Figure 8 Bidirectional system using duplicator, delay and selector

This time the duplicator component will do the job of generating multiple signals. It will 
generate 10 copies of the signal from the laser. The selector will select the last signal 
from the input buffer and sent it to the output port. 
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This means the signal index parameter of the OSA connected to the Selector will have 
only one value:0. This is because the other signals were filtered by the selector 
component.
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Lesson 6: Time-Driven Simulation — Working 
with individual samples

One of the main features of OptiSystem is the mixed signal representation.

Individual sample is a signal type that allows the users to simulate time-driven 
systems in the electrical and optical domain. By using time-driven simulation, users 
can create designs that have closed loops and feedbacks. 

Additionally, the optical individual sample allow for simulation of WDM systems by 
using multiple bands. Each band shares the same sample rate and time window, but 
they can have different center frequencies.

To manipulate individual samples, there are four new components available in the 
component library:

Signal Processing 
Library/Tools/Electrical/

Signal Processing Library/Tools/ 
Electrical/

Signal Processing 
Library/Tools/Optical/

Signal Processing 
Library/Tools/Optical/

To verify if a component is compatible with individual samples, you should check 
OptiSystem component library documentation.

Component name Folder Icon

Convert To Electrical Individual 
Samples

Convert From Electrical 
Individual Samples

Convert To Optical Individual 
Samples

Convert From Optical Individual 
Samples
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A Time-Driven Simulation

Global parameters

To reduce the calculation time, we should reduce the number of samples of the 
signals that will be calculated during the simulation.

To reduce the number of samples, we can reduce the sequence length and the 
number of samples per bit. 

• In the global parameters dialog box, change the parameter Sequence length to 
16, and the Samples per bit to 32. The Number of samples parameter should be 
512 (Figure 1).

Figure 1 Global parameters

This means that we will have 512 individual samples at the output of the Convert To 
Electrical Individual Samples component, and 512 individual samples per WDM 
channel at the output of the Convert To Optical Individual Samples component.
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System setup

We can start adding the components to design the basic time-driven system. 

From the component library, drag and drop the following component in to the layout:

• From "Default/Transmitters Library/Optical Sources", drag and drop the "CW 
Laser" into the layout.

• From "Default/Transmitters Library/Bit Sequence Generators", drag and drop the 
"Pseudo-Random Bit Sequence Generator" into the layout.

• From "Default/Transmitters Library/Pulse Generators/Electrical", drag and drop 
the "NRZ Pulse Generator" into the layout.

• From "Default/Visualizers Library/Optical", drag and drop the "Optical Time 
Domain Visualizer" into the layout.

• From "Default/Visualizers Library/Electrical", drag and drop the "Oscilloscope 
Visualizer" into the layout.

The next step is to connect the components according to the Figure 2. 

Figure 2 First layout
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Running the simulation

We can run this simulation and analyze the results:

• To run the simulation, you can go to the File menu and select Calculate. You can 
also press Control+F5 or use the calculate button in the toolbar. After you select 
Calculate, the calculation dialog box should appear.

• In the calculation dialog box, press the Play button.

Viewing the results

To see the results, double click at each of the time domain visualizers. The optical and 
electrical signals are available in Figure 3.

These are the graphs of the sampled signals. To convert these signals into individual 
samples, we can use the components from Table 1.

Figure 3 CW Laser output and NRZ pulse generator output

System setup - Individual Samples
• Drag and drop the components from Table 1 into the layout.

• Duplicate the time domain visualizers

• Connect the components according to the Figure 4.

• Run the simulation



 LESSON 6: TIME-DRIVEN SIMULATION — WORKING WITH INDIVIDUAL SAMPLES

101

Figure 4 Layout using the individual sample tools

Viewing the results

To see the results, double click at each of the time domain visualizers. 

The optical and electrical signals are available in the Figure 5. You will notice that the 
signals are the same as in Figure 3. 

The CW laser will send a sample signal to the 'Convert to…' component. This 
component will generate 512 samples and send each one of them to the 'Convert 
from…' component. The 512 samples will be combined into a signal that should be 
the same as the original signal from the laser. The same process applies to the 
electrical signal.
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Figure 5 'Convert from…' components outputs

Important remarks
• Visualizers cannot display individual samples. You should use a 'Convert From…' 

component before a visualizer.

• Check if a component is compatible with individual samples before creating a 
project.

• The project scope that requires simulation using individual samples must be 
confined between the 'Convert To...' and 'Convert From…' components.

• For each individual sample a component will run one calculation. This means the 
simulation will be slower when using individual samples.

• Faster simulation can be obtained by disabling calculation scheduler messages. 

Filtering using individual samples

There are two type of filtering techniques used in OptiSystem when working with 
individual samples. 

If a filter has the parameters Digital filter and Digital filter order available, the user can 
enable the FIR filter and enter the number of coefficients for the filter. 

Be aware of the FIR filter latency because the filter will introduce a delay equal to one 
half of the number of coefficients.

If the filter does not have these parameters or if the 'Digital filter' parameter is 
disabled, the individual samples will be attenuated by the value at the filter center 
frequency

In this case, we are assuming that the filter bandwidth is much wider than the sample 
rate. For optical signals, there attenuation will be wavelength dependent. 

This means that every individual sample will have a different value of attenuation 
depending on the filter shape. 

• From "Default/Filters Library/Electrical", drag and drop the "Low Pass Bessel 
Filter" into the layout.

• From "Default/Filters Library/Optical", drag and drop the "Bessel Optical Filter" 
into the layout.
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• For both components, enable the parameter Digital filter.

• Connect the components according to the Figure 6.

• Run the simulation.

Figure 6 Filtering individual samples

Viewing the results

Compare the signals from the two Oscilloscopes (Figure 7). You will see that the 
second signal is delayed and filtered. This is related to the FIR filter used in the low 
pass filter. The same applies to the optical signal.

Figure 7 Electrical signal before and after FIR filter
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Notes:
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Lesson 7: Optical Amplifiers — Designing 
optical fiber amplifiers and fiber lasers

OptiSystem allows the design and simulation of optical fiber amplifiers and fiber 
lasers. 

The projects presented here are available under OptiSystem installation folder 
samples\Optical amplifiers. 

This tutorial will describe part of the library of optical amplifiers. 

There are four categories of components in the library: 

• EDFA

• Raman

• SOA

• Waveguide amplifiers 

The EDFA folder contains the Erbium-doped fiber model and other models to allow 
the simulation of EDFAs in the steady-state condition. Furthermore, the folder 
includes models to simulate erbium-ytterbium codoped fiber, ytterbium-doped fiber 
and dynamic models for the erbium and ytterbium fibers.
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Table 1 Doped fiber models

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

Amplifiers Library/Optical/EDFA

The second category is the Raman models. These components allow the simulation 
of Raman fiber amplifiers. The Raman folder includes the Raman models for steady 
state and dynamic conditions. 

Component name Folder Icon

Erbium Doped Fiber

EDFA

EDFA Black Box

Optical Amplifier

EDFA Measured

EDF Dynamic

EDF Dynamic Analytical

Er-Yb Codoped Fiber

Yb Doped Fiber

Yb Doped Fiber Dynamic
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Table 2 Raman models

Amplifiers Library/Optical/Raman

Amplifiers Library/Optical/Raman

The tutorial will use passive components that allow the design of amplifiers and 
lasers. These components are spread in different folders at the OptiSystem 
component library and some of them are described at Table 3. These are the 
equivalent components to those found in OptiAmplifier.

Component name Folder Icon

Raman Amplifier - Average 
Power Model

Raman Amplifier - Dynamic 
Model
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Table 3 Passive components

Component name Folder Icon

Isolator Bidirectional Passives Library/Optical/Isolators

Reflector Bidirectional Passives Library/Optical/Reflectors

Attenuator Bidirectional Passives Library/Optical/Attenuators

Pump Coupler Bidirectional Passives Library/Optical/Couplers

Coupler Bidirectional Passives Library/Optical/Couplers

Tap Bidirectional Passives Library/Optical/Taps

Circulator Bidirectional Passives Library/Optical/Circulators

Polarization Combiner 
Bidirectional

Passives Library/Optical/Polarization

Reflective Filter Bidirectional Filters Library/Optical/

3 Port Filter Bidirectional Filters Library/Optical/
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Optical Amplifiers

Global parameters

The first step when using OptiSystem is setting the global parameters. 

As we already know, one of the main parameters is the time window, calculated from 
the bit rate and sequence length. 

For the amplifier and laser design, there are other important parameters that will 
define the number of iterations in the simulations and introduce an initial delay in the 
in the simulation. 

Transmission Filter Bidirectional Filters Library/Optical/

Nx1 Mux Bidirectional WDM Multiplexers Library/Multiplexers

2x2 Switch Bidirectional Network Library/Optical Switches

Component name Folder Icon
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These parameters are the Iterations and Initial delay, and are available in the global 
parameters window (Figure 1). 

Figure 1 Global parameters: Signals tab

For this tutorial we will use the default parameters, except for some global 
parameters.

• In the global parameters dialog box, change the parameter Bit rate to 2.5e9, 
Sequence length to 32, and Samples per bit to 32. The Time window parameter 
should be 1.28e-8 s (Figure 2).
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Figure 2 Global parameters: Simulation parameters tab

System setup

After setting the global parameters, we can start adding the components to design the 
basic EDFA design. 

From the component library, drag and drop the following component in to the layout:

• From "Default/Transmitters Library/Optical Sources", drag and drop the "CW 
Laser" and the "Pump Laser" into the layout.

• From "Default/Amplifiers Library/Optical/Doped Fibers", drag and drop the 
"Erbium Doped Fiber" component into the layout.

• From "Default/Passives Library/Optical/Isolators", drag and drop two "Isolator 
Bidirectional" components and a "Pump Coupler Bidirectional" component into 
the layout.

• From "Default/Receivers Library/Photodetectors", drag and drop a 
"Photodetector PIN" component into the layout.

• From "Default/Visualizers Library/Optical", drag and drop the "Dual Port WDM 
Analyzer" into the layout.

The next step is to connect the components according to Figure 3. As we can see, 
there is one input port in the isolator opened, so to be able to run the simulation it is 
necessary to include an optical null in the design (Figure 3 (b)).
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Figure 3 EDFA layout

(a)

(b)

Signals tab

Although all components are in the layout and correctly connected, we are not able 
yet to run the simulation properly. 

First, because we are considering the signals propagating in both directions, we will 
need more than one global iteration for the results in the system to converge. 

Secondly, in the first iteration there are no backward signals in the left input port of the 
bidirectional components, such as the isolator and pump coupler. This will make the 
simulation stop. 

To resolve the first condition, you just have to increase the number of iterations. 

To resolve the second condition, there are two possible solutions: We can enable in 
the Signals Tab the Initial delay parameter (Figure 4) or we can introduce in the layout 
the component "Optical Delay" (Figure 5).
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Figure 4 Global parameters - Increasing the number of iterations and enabling Initial Delay

Figure 5 Including the "Optical Delay" components in the layout
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Running the simulation

We can run this simulation for the system shown in Figure 3 and analyze the results:

• To run the simulation, you can go to the File menu and select Calculate. You can 
also press Control+F5 or use the calculate button in the toolbar. After you select 
Calculate, the calculation dialog box should appear.

• In the calculation dialog box, press the Play button. The calculation should 
perform without errors.

Viewing the results

To see the results, double click the Dual Port WDM Analyzer. You can see the results 
of each iteration by browsing in the Signal Index parameter. 

Figure 6 shows the results in the WDM analyzer for the 6 iterations and initial delay.

Figure 6 Dual Port WDM Analyzer views for different iterations

Running the simulation

To compare the results in the two different designs, Figure 3 and Figure 5, we can run 
the same simulation for the system showed in Figure 5 and analyze the results:

• To run the simulation, you can go to the File menu and select Calculate. You can 
also press Control+F5 or use the calculate button in the toolbar. After you select 
Calculate, the calculation dialog box should appear.

• In the calculation dialog box, press the Play button. The calculation should 
perform without errors.
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Viewing the results

To see the results, double click the Dual Port WDM Analyzer. You can see the results 
of each iteration by browsing in the Signal Index parameter. 

Figure 7 shows the results in the WDM analyzer for the 6 iterations.

Figure 7 Dual Port WDM Analyzer views for different iterations

As we can see, the second design converges faster than the design with 'Initial Delay'. 
The design from Figure 3 takes more iteration because of the 'Initial delay'.

Viewing the gain versus wavelength

We will build the graph gain as a function of the signal wavelength. 

Starting using the layout from Figure 5:

• Double-click on the CW Laser component. The component properties will appear. 
See Figure 8 (a).

• Change the unit of the Frequency parameter to nm.

• Select the parameter that you want put in sweep mode. In this case the parameter 
is Frequency. Change the mode of the Frequency parameter in the CW Laser 
component from Normal to Sweep. See Figure 8 (b).

• Select the Parameter Sweeps tab at the CW laser properties, or at the menu tool 
bar, or at the Layout menu. See Figure 9.
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Figure 8 CW Laser properties (a) Frequency parameter in Normal and (b) Sweep mode

Figure 9 Parameter Sweeps at (a) the menu tool bar and (b) at the Layout menu

(a)

(b)

• After you click in the Parameter Sweeps tab, a window asking you to set the total 
number of sweep iterations will appear.
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• Click on OK and the windows to enter the number of sweep iterations will appear.

• Choose the number of sweep iterations. In this case we select 20 sweeps. After 
you click the OK button, the Parameter Sweeps tab will appear.

• Now we can enter the value of each sweep iteration, or we can select all the 
sweeps and click in one of the buttons (Linear, Exp, Log, Formula, Gaussian, etc.) 
to spread the values in a range. In our case we clicked in the Linear button. A new 



 LESSON 7: OPTICAL AMPLIFIERS — DESIGNING OPTICAL FIBER AMPLIFIERS AND FIBER LASERS

118

window will open to select the wavelength range in which the signal will be 
distributed.

• We chose the range from 1530 nm to 1560 nm, and after we clicked on OK, the 
values were distributed.



 LESSON 7: OPTICAL AMPLIFIERS — DESIGNING OPTICAL FIBER AMPLIFIERS AND FIBER LASERS

119

.

Running the simulation
• To run the simulation, you can go to the File menu and select Calculate. You can 

also press Control+F5 or use the calculate button in the toolbar. After you select 
Calculate, the calculation dialog box should appear.

• In this case, we could select to simulate all sweep iterations, or choose a specific 
iteration and select to calculate the current iteration. For this topic, we selected to 
calculate all iterations. See Figure 10.

• In the calculation dialog box, press the Play button. The calculation should 
perform without errors.
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Figure 10 Calculating all sweep iterations

Viewing the results

To see the results, double click the Dual Port WDM Analyzer. You can see the results 
of each iteration (global iteration) in one specific sweep iteration (wavelength) by 
browsing in the Signal Index parameter.

In our case, we kept the Signal Index in the last (global) iteration (5), and we can 
browse in the results for all (wavelengths) sweep iterations by clicking in the icons 
"Next Sweep Iteration" and "Previous Sweep Iteration". 

Figure 11 shows the results in the WDM analyzer for the sweep iteration number 20 
and 19.
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Figure 11 Results for the sweep iteration (a) 20 and (b) 19

(a)

(b)

Building the graph Gain x Wavelength and Noise Figure x Wavelength 
• The next step would be to visualize gain and noise figure for all wavelengths 

simulated. Therefore, we need to build graphs with the results found in the 
simulation.

• For this task, we will use the Report page.

• Go to the Report tab and click on it. See Figure 12.
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Figure 12 View of the GUI with the system layout

• The report page will appear. After that, select the Opti2Dgraph (graph icon 
highlighted) and open in the report page a 2D graph. See Figure 13.
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Figure 13 View of the report page

• After opening the 2D graph, go to the project browser window and open the 
parameter folder of the component that has the information you want. In this case 
we need the wavelength of the CW Laser, so we selected the Frequency 
parameter. See Figure 14.
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Figure 14 View of the report page with the graph opened and the Frequency parameter selected

• ·The Frequency parameter was then dragged to the 2D graph and dropped at the 
X-axis. See Figure 15.
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Figure 15 View of the report page with Frequency parameter being dropped at the graph

• After dropping the Frequency parameter, we have to get the next variable of the 
graph. So go to the Dual Port WDM Analyzer and open the Results folder.

• Choose one of the results that you want plot in your graph. In this case, we 
choose the Gain parameter. Now, drag and drop it in the y-axis in the graph. See 
Figure 16.



 LESSON 7: OPTICAL AMPLIFIERS — DESIGNING OPTICAL FIBER AMPLIFIERS AND FIBER LASERS

126

Figure 16 View of the report page with the Gain result being dropped at the graph

• After that, the graph Gain x Wavelength is ready. See Figure 17(a). The same 
procedure was used to build the graph NF x Wavelength.

Figure 17 Graphs (a) Gain x Wavelength and (b) NF x Wavelength
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Optimizing the Fiber length

In addition to using the sweep iterations to analyze the amplifier characteristics (such 
as gain versus signal wavelength and gain versus doped fiber length), the user can 
use the optimization tool to find the best parameters for the amplifier design. 

In this example, we will use the optimization tool to find the best doped fiber length to 
get the maximum signal gain.

• Load the same layout presented at Figure 5. Remember to return the Total 
Number of Sweep Iterations to 1 if you had changed it.

• Run the simulation. This step is necessary to setup the Dual Port WDM Analyzer 
for the optimization.

Figure 18 Layout of the system to be optimized

Viewing the results

After you run the system, double click in the Dual Port WDM Analyzer to see the 
results. 

To see the results in different iterations and set the Signal Index to the last iteration, 
see Figure 19. 

To guarantee the optimization will work correctly, you need to set the visualizer Signal 
Index to the last iteration.
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Figure 19 Dual Port WDM Analyzer set with the results of the last iteration

Setting up the Optimization
• Go to the tools menu and click in Optimizations. See Figure 20.

Figure 20 Optimizations option at the Tools menu

• The Optimizations window will appear.

• There are two options for the optimization: the Single Parameter Optimization 
(SPO) and the Multiple Parameter Optimization (MPO). In our case, we want only 
to optimize the Fiber length as a function of the gain, so we can select the SPO 
and insert it on the project. For example, Figure 21 displays the calculation 
window and the optimization tab.
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Figure 21 Optimizations tab during calculation

• When we insert the SPO optimization, the SPO Setup window will open. See 
Figure 22.

• In the Main tab, select the Optimization Type you want. In this case we selected 
to maximize the result.

• Setup the number of passes and the result tolerance.

Figure 22 SPO Setup window at the Main tab
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• Go to the Parameter tab in the SPO Setup and select the parameter that you want 
to optimize. In this case, Length at the Erbium-doped fiber component. See 
Figure 23.

• After you select the parameter, specify the range of values you want to analyze. 
Be careful in choosing these values, they have to match the unit chosen in the 
Component parameter. For this case there is only one unit, meter. But in some 
cases, such as for power, the unit could be W, mW or dBm.

Figure 23 SPO Setup window at the Parameter tab

• In the Result tab, select the result in the Dual Port WDM Analyzer that you want 
to maximize (Gain). See Figure 24.

• Because we want to maximize the gain, the Target value will not be enabled.

• Click on ok in the SPO Setup.

• To run the simulation you can go to the File menu and select Calculate. See 
Figure 25.

• Before you press the Play button, click in the box to run all optimizations. Then, 
press the Play button.
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Figure 24 SPO Setup window at the Result tab

Figure 25 Calculate window

During the calculation, the parameters and results of each pass will appear in the 
Optimization Tab. See Figure 26(a). 

In the calculation output tab will appear the optimum fiber length where we got the 
maximum gain for the signal at 1530 nm.
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Figure 26 (a) Optimization tab and (b) Calc. Output tab

(a)

(b)
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Lesson 8: Optical Systems — Working with 
multimode components

The multimode component library of OptiSystem allows for simulation of links with 
multimode signals. 

The projects presented here are available under OptiSystem installation folder 
Samples/Multimode. 

The first part of this tutorial will describe the library of spatial optical sources and 
transmitters. These components have the ability to include transverse mode profiles 
in the optical signals.   

There are two categories of components in the library: 

• spatial optical sources/transmitters

• transverse mode generators 

The spatial transmitters are “ready-to-use” components that encapsulate an optical 
source or transmitter and a transverse mode generator.

Table 1 Spatial optical sources, transmitters and pulse generators

Component name Folder Icon

Spatial CW Laser Transmitters Library/Optical Sources/

Spatial Laser Rate Equations Transmitters Library/Optical Sources/

Spatial LED Transmitters Library/Optical Sources/

Spatial Optical Gaussian Pulse 
Generator

Transmitters Library/Pulse 
Generators/Optical/

Spatial Optical Impulse 
Generator

Transmitters Library/Pulse 
Generators/Optical/
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Spatial Optical Sech Pulse 
Generator

Transmitters Library/Pulse 
Generators/Optical/

Spatial Optical Transmitter Transmitters Library/Optical 
Transmitters/

Spatial VCSEL Transmitters Library/Optical Sources/

Component name Folder Icon
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The second category is the transverse mode generators. These components allow for 
adding a transverse mode profile in the optical signal.

Table 2 Transverse mode generators

Transmitters Library/Multimode/

Transmitters Library/Multimode/

Transmitters Library/Multimode/

Transmitters Library/Multimode/

Transmitters Library/Multimode/

This means you can directly use one of the components from Table 1 or you can 
combine any optical source, transmitter of pulse generators with one of the transverse 
mode generators from Table 2 and build a new subsystem.

The second part of the tutorial presents the passive components that allow for 
translation and rotation of the optical field, as well as focusing an optical beam or 
applying an aperture in order to limit the optical beam.

Finally, a description of the receiver and photodetector components is presented.

Component name Folder Icon

Multimode Generator

Laguerre Transverse Mode 
Generator

Hermite Transverse Mode 
Generator

Donut Transverse Mode 
Generator

Measured Transverse Mode 
Generator
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Multimode Transmitters

Global parameters

The first step when using OptiSystem is setting the global parameters. 

As we already know, one of the main parameters is the time window, which is 
calculated from the bit rate and sequence length. 

For multimode simulations, there are additional parameters that will define the space 
window for the transverse mode profiles. These parameters are the Space width X 
and Y and the Grid spacing X and Y, and are available in the global parameters 
window (Figure 1). 

Figure 1 Global parameters: Spatial effects tab

For this tutorial we will use the default parameters, except for the bit rate, that should 
be changed to 10 GB/s

• In the global parameters dialog box, change the parameter Bit rate to 10e9. The 
Time window parameter should be 1.28e-8 s (Figure 2).
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Figure 2 Global parameters: Simulation parameters tab
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System setup

After setting the global parameters, we can start adding the components to design the 
basic multimode transmitter. 

From the component library drag and drop the following component in to the layout:

• From "Default/Transmitters Library/Optical Sources", drag and drop the "CW 
Laser" into the layout.

• From "Default/Transmitters Library/Multimode", drag and drop the "Multimode 
Generator" component into the layout.

• From "Default/Visualizers Library/Optical", drag and drop the "Spatial Visualizer" 
into the layout.

The next step is to connect the components according to Figure 3. 

Figure 3 Multimode transmitter

Spatial effects tab

The spatial effects tab is available for all the spatial optical sources, transmitters and 
pulse generators, as well as for the transverse mode generator components. 

One of the main parameters of the spatial effects tab is the Power ratio array. This 
array is a string list with the power ratios for each mode. 

For example, entering a list of 4 values will allow the user to also specify the properties 
of a particular mode type for each of these values.

• Open the parameters of the “Multimode Generator” component.

• In the spatial effects tab, for the Power ratio array parameter, enter the following 
values: 1 2 3 4.

Notice that the parameter Pol. X m,n index array will automatically increase the 
number of values for the LP index pairs for the generated modes (Figure 4).
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Figure 4 Multimode Generator - changing the number of power ratios

• In the spatial effects tab, for the Pol. X m,n index array parameter, enter the 
following values: 0 0, 2 2, 0 3, 1 3.

This means the multimode generator will generate 4 spatial modes per polarization.

The power ratio per mode will be 0.1, 0.2, 0.3 and 0.4. The total is equal to 1 (100% 
of the input power). 

Each mode will have its own Laguerre-Gaussian profiles, with LP indexes LG00, LG22, 
LG03, LG13. Both polarizations will have the same spatial modes (Mode polarization 
parameter is equal to X=Y). 
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Running the simulation

We can run this simulation and analyze the results:

• To run the simulation, you can go to the File menu and select Calculate. You can 
also press Control+F5 or use the calculate button in the toolbar. After you select 
Calculate, the calculation dialog box should appear.

• In the calculation dialog box, press the Play button. The calculation should 
perform without errors.

Viewing the results

In order to see the results, double click the Spatial visualizer. 

Using the spatial visualizer, you can see the profile of each mode presented at the 
visualizer input port. The user can select the polarization (X or Y), the format (Polar 
or Rectangular) and the graph (Power, Phase, Real or Imaginary part). 

Additionally, the sum of the modes can be displayed, as well as the weightened sum 
(Figure 5). 

Observe that the spatial dimensions of the graphs are the same as defined by the 
global parameters Space width X and Y.

Figure 5 Spatial visualizer can display the Individual, Sum and Weightened sum of modes

In order to browse through the modes that are available at the input port, change the 
mode number parameter and press <Enter>. The visualizer will recalculate the 
graphs and present the individual mode at the parameter mode index. 
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Figure 6 presents the real values using rectangular format for each available mode at 
the input port.

Figure 6 Spatial visualizer displays the real part of the individual modes for each mode index

The combination of the CW Laser and the Multimode Generator component can be 
replaced by the Spatial CW Laser component:

• From "Default/Transmitters Library/Optical Sources", drag and drop the "Spatial 
CW Laser" into the layout.

• In the Spatial CW Laser parameters, use the same parameter values of the spatial 
effects tab from the Multimode Generator

The next step is to connect the components according to the Figure 7. 

You can remove the multimode generator and connect the spatial visualizer to the 
Spatial CW Laser. 

Run the simulation again.
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Figure 7 Multimode transmitter using a Spatial CW Laser

This system, built using a component from Table 1, is equivalent to the one in Figure 
3, which was built using the components from Table 2. 

The results from the spatial visualizer will be the same as presented in Figure 5 and 
Figure 6.

Multimode components and Free-Space Propagation

When coupling a signal from a laser into a multimode fiber, or from the fiber into a 
photodetector, we can use the components from Table 3.

Table 3 Spatial passive components: connector, aperture and lens

Passives Library/Optical/Connectors/

Passives Library/Optical/Multimode/

Passives Library/Optical/Multimode/

Passives Library/Optical/Multimode/

Component name Folder Icon

Spatial Connector

Spatial Aperture

Thin Lens

Vortex Lens
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Spatial connector: translating the optical field

One of the main components is the spatial connector. This components can rotate and 
translate the optical field, as well as propagate the optical signal in free-space. 

• From "Default/Passives Library/Optical/Connectors", drag and drop the "Spatial 
Connector" into the layout.

• For the Spatial Connector, change the parameters X and Y shift to 5 m .

• Add another Spatial Visualize to the layout.

• Connect the components according to Figure 8.

• Run the simulation.

Figure 8 Multimode transmitter and spatial connector

Viewing the results

In order to see the results, double click in the second spatial visualizers and compare 
the graphs before and after the connector. 

The connector applied a spatial shift in both X and Y-axis (Figure 9).
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Figure 9 Spatial visualizer displays the transverse mode before and after the connector

In order to see the effects of free-space propagation in the optical field, we can 
increase the connector parameter Distance:

• For the Spatial Connector, change the parameter Distance to 200 m .

• For the Spatial Visualizers, change the parameters Format to Polar.

• Run the simulation.

Figure 10 compares the transverse mode intensity before and after applying 200 m  
of propagation in free-space, you can see that the second beam is larger.

Figure 10 Spatial visualizer displays the transverse mode intensity after a shift of 5 m  in both X and Y 
directions, before and after 200 m  propagation in free-space
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Spatial connector: rotating the optical field

Besides the translation the optical field and the propagation in free-space, the user 
can rotate the optical field by applying a tilt in the X and Y-axis, or a rotation about the 
Z-axis.

• For the Spatial Connector, change the parameters X and Y shift to 0 m , and the 
Distance to 100 m .

• For the Spatial Connector, change the parameters X and Y tilt to 5 deg.

• Run the simulation.

Viewing the results

In order to see the results, double click in the both spatial visualizers and compare the 
graphs before and after the connector. 

The connector applied a spatial tilt in both X and Y-axis, visible after the free-space 
propagation (Figure 10).

Figure 11 Spatial visualizer displays the transverse mode before and after the 5 deg tilt and 100 m  
propagation



 LESSON 8: OPTICAL SYSTEMS — WORKING WITH MULTIMODE COMPONENTS

146

Thin Lens: focusing the optical beam

By using the thin lens component the user can focus or defocus the optical beam. 

• From "Default/Passives Library/Optical/Multimode", drag and drop the "Thin 
Lens" component into the layout.

• Add another “Spatial Connector” and “Spatial Visualizer' to the layout.

• For the “Spatial CW Laser”, set the parameter Pol. X spot size to 15 m .

• For the first spatial connector, set the shift and tilt parameters to 0, and the 
parameter Distance to 10 m

• For the second spatial connector, set the shift and tilt parameters to 0, and the 
parameter Distance to 65 m .

• For the thin lens, the parameter Focal length to 0.1 mm.

• Connect the components according to Figure 12.

• Run the simulation.

Figure 12 Using the thin lens component to focus the optical beam

Viewing the results

In order to see the results, double click in the spatial visualizers and compare the 
graphs before and after the second connector. The large beam after the first 
connector is reduced by the combination of thin lens and free-space propagation. 

Figure 13 presents the optical field at the output of the first connector and at the output 
of the second connector.
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Figure 13 Spatial visualizer displays the transverse mode before and after focusing the beam using the thin 
lens

Spatial Aperture: limiting the optical field

By using the spatial aperture component the user can reduce the optical field by 
filtering the optical power that falls outside the aperture area. 

• From "Default/Passives Library/Optical/Multimode", drag and drop the "Spatial 
Aperture" into the layout.

• Remove the thin lens and the second connector from the layout.

• Connect the components according to Figure 14.

• Run the simulation.

Figure 14 Using the spatial aperture component to limit the optical beam

Viewing the results
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In order to see the results, double click in the spatial visualizers and compare the 
graphs before and after the spatial aperture. 

The output beam is limited to the aperture diameter of 10 m  (Figure 15). 

You can use the spatial aperture to simulate component misalignments, e.g. 
fiber/detector power coupling. 

Figure 15 Spatial visualizer displays the transverse mode before and after the spatial aperture component
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The user can also select a rectangular square type for the spatial aperture:

• For the spatial aperture, set the parameter Aperture type to “Square”.

• Run the simulation.

Observe that the optical beam will have a square shape after the spatial aperture 
(Figure 16).

Figure 16 Spatial visualizer displays the transverse mode after the square spatial aperture component
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Multimode Receivers

Similar to the multimode transmitter, where the use can select a ready-to-use spatial 
component from the library, or build new spatial components by combining the spatial 
and no-spatial components, OptiSystem has also different multimode receiver 
components (Table 4). These components are a combination of the spatial aperture 
component and the optical receivers or photodetectors.

Table 4 Spatial receivers and photodetectors

Receivers Library/Optical Receivers/

Receivers Library/Photodetectors/

Receivers Library/Photodetectors/

The main parameter of the spatial receivers or photodetectors is related to the 
detector active are, defined by the parameter Width. 

System setup

Using the same previous global parameters, we can start adding the components to 
design the basic multimode link. From the component library drag and drop the 
following component in to the layout:

• From "Default/Transmitters Library/Optical Transmitters", drag and drop the 
"Spatial Optical Transmitter" into the layout.

• For the Transmitter, change the parameter Pol. X. spot size (Spatial effects tab) 
to 15 m .

• From "Default/Receivers Library/Optical Receivers", drag and drop the "Spatial 
Optical Receiver" component into the layout.

• For the Receiver, change the parameter Thermal noise (Noise tab) to 5e-22 
W/Hz. This will give a receiver sensitivity of ~ -17 dBm (10 GB/s, Q = 6).

• From "Default/Visualizers Library/Electrical", drag and drop the "BER Analyzer" 
into the layout.

• From "Default/Visualizers Library/Optical", drag and drop two of the "Optical Time 
Domain Visualizer" into the layout.

• Set all the parameters of the spatial connector to 0.

Using the connector and visualizer from the previous layout, the next step is to 
connect the components according to the Figure 17. 

Component name Folder Icon

Spatial Optical Receiver

Spatial PIN Photodetector

Spatial APD Photodetector
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Figure 17 A multimode link using the spatial transmitter and receiver

Run the simulation and after the simulation is finished observer the results from the 
BER Analyzer.

Viewing the results

The link of Figure 17 is almost ideal, because we do not have any major losses or 
misalignments between the transmitter and receiver. The spatial connector is ideal 
and there is only a small loss due to the difference between the input signal spot size 
and active area of the photodetector (10 m  and the mode spot size of 15 m ).

Figure 18 presents the eye diagram for the system of Figure 17, observe the back-to-
back value of the Q factor.
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Figure 18 BER Analyzer displaying the eye diagram of the ideal link

In order to visualize the effects of misalignment between the transmitter and receiver, 
we will apply a longitudinal shift in the optical field using the spatial connector 
component. 

Using OptiSystem parameter sweep feature, we will apply a spatial shift from 0 to 20 
m  in the optical signal.

• For the Spatial connector, change the mode of the parameter X shift to Sweep.

• Set the total number of sweep iterations to 10.

• In the parameter sweep dialog box, use a linear spread for the parameter X shift 
from 0 m  to 20 m  (Figure 19).
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Figure 19 Using parameter sweep for the connector parameter X shift from 0 to 20 m

• Run the simulation

The simulation will run 10 times, one for each value of the X shift parameter. At the 
end of the calculation, we can browse the results selecting the current sweep iteration, 
or we can visualize the results of Q-Factor versus X shift using the report page.

• Select the report page.

• Drag and drop a 2D graph into the report.

• From the Project Browser, select the Spatial Connector and drag and drop the 
parameter X shift into the X-axis of the graph.

• From the Project Browser, select the BER Analyzer and drag and drop the result 
Max. Q Factor into the Y-axis of the graph (Figure 20).
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Figure 20 Combining parameters and results after using report page

As you can see in the Figure 20, the value of Q is decreasing. This is because the 
optical field is being shifted outside of the photodetector active area, centered at (0,0) 
with a width of 10 m . We can achieve similar results by changing the active area 
width additionally to the shifting of the field.

• For the Spatial connector, change the mode of the parameter X shift to Normal, 
and set the value to 0.

• For the Spatial receiver, change the mode of the parameter Width to Sweep.

• In the parameter sweep dialog box, use a linear spread for the parameter Width 
from 10 to 1 m .

• Run the simulation

• From the Project Browser, select the Spatial Optical Receiver and drag and drop 
the parameter Width into the X-axis of the report page 2D graph.

The result is presented in Figure 21, where we can see the increase of the Q-Factor 
with the increase of the active area of the photodetector.
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Figure 21 The value of Q-Factor versus photodetector active area width

Multimode Fibers and Links
• There are two multimode fibers available in the component library that take in to 

account the spatial properties. They are components that take in to account the 
power coupling and propagation of the multiple fiber modes. 

• The first model is a general-purpose multimode fiber, with user-defined refractive 
index profile, and a numerical mode solver. The second model is a graded-index 
fiber with parabolic index, which uses an analytical mode solver.

Table 6 Multimode fibers

Optical Fibers Library/Multimode/

Measured-Index Multimode Fiber

System setup

Following the same steps to generate the layout of Figure 17, we can add the fiber 
component to design the basic multimode link:

• From "Default/Optical Fibers/Multimode", drag and drop the "Parabolic-Index 
Multimode Fiber" into the layout.

Component name Folder Icon

Measured-Index Multimode Fiber

Parabolic-Index Multimode Fiber
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Add additional visualizers to the layout and connect the system according to the 
Figure 22. 

Figure 22 A link using the multimode fiber

Calculating Fiber Properties

The main parameter of the Parabolic-Index multimode fiber is the Core radius. For this 
link we are using a 50 m  fiber. 

In order to evaluate the fiber properties, such as effective index, group delay and the 
number of modes, we can calculate fiber properties before running the simulation:

• For the Fiber, enable the parameter Calculate graphs (Graphs tab).

We can also calculate the spatial profile graphs for individual modes, and the 
overfilled mode profile: 

• For the Fiber, enable the parameter Spatial profile graphs and Spatial overfilled 
graph (Graphs tab).

• Press OK.

After pressing OK, the modes will be calculated and the mode number, radial and 
spatial graphs will be internally calculated.
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Viewing the fiber properties

In order to see the graphs from the multimode fiber, we should use the Project 
Browser (Figure 23). 

Figure 23 Multimode fiber graphs from the Project Browser

By double-clicking on the graph name, we can see the graphs for the different fiber 
properties. 

For example, Figure 24 presents the Refractive index profile graph. 

Figure 25 presents the mode number graphs, e.g. LP(m,n) indexes m and n, Effective 
index and Group delays.
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Figure 24 Refractive index profile for the parabolic index fiber
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Figure 25 Mode index graphs for the parabolic index fiber

The remaining spatial and radial graph for the individual mode is presented in Figure 
26. 

The spatial overfilled graph is presented in Figure 27. 



 LESSON 8: OPTICAL SYSTEMS — WORKING WITH MULTIMODE COMPONENTS

160

Figure 26 Individual mode intensity radial and spatial profile graphs

Figure 27 Spatial overfilled graph

The fiber graphs will be calculated every time you press OK in the component dialog 
box and after the link calculation. In order to save calculation time, we will disable the 
spatial graphs calculation. 

• For the Fiber, disable the parameter Spatial profile graphs and Spatial overfilled 
graph (Graphs tab).

• Press OK.
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The next step is to calculate the multimode link:

• Run the simulation

• During the calculation, in the calculation dialog box select the 'Calc. schedulers' 
tab.

Observe the calculation progress of the multimode fiber (Figure 28). This is important 
to estimate the time that simulation will take when calculating multimode links.

Figure 28 Calculation progress for the multimode fiber

Viewing the results

We can use the visualizer to display the simulation results. The first results that we 
will look at are the spatial profile of the modes at the fiber output.

In order to browse through the modes available at the fiber output port, change the 
mode number parameter of the third spatial visualizer and press <Enter>. The 
visualizer will recalculate the graphs and present the individual mode at the parameter 
mode index. 

Figure 29 presents the real values using rectangular format for some of the modes:
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Figure 29 Spatial visualizer at the fiber output displaying mode index 0, 5, 12 and 15

We can also visualize the coupling coefficients and the modal delay at the fiber output 
for each input signal wavelength and spatial mode by using the multimode fiber 
calculation report (Figure 30):

• For the Fiber, click on the Report parameter (Numerical tab).



 LESSON 8: OPTICAL SYSTEMS — WORKING WITH MULTIMODE COMPONENTS

163

Figure 30 Calculation report from multimode fiber

The graph with the coupling coefficients and group delay is also available from the 
project browser.

Finally you can visualize the graphs from the BER Analyzer (Figure 31). 
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Figure 31 BER Analyzer at the receiver output

The same steps can be applied to second multimode fiber model, the Measured-
Index Multimode Fiber. 

Because the index is measured, the user should provide the refractive index profile 
with the proper format instead of simply changing the core radius of the parabolic 
index fiber. 
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