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Installing OptiFDTD

Before installing OptiFDTD, ensure the system requirements described below are 
available.

Hardware and software requirements
OptiFDTD requires the following minimum system configuration:
• Microsoft Windows XP/Vista/7, 32-bit or 64-bit, note: 64-bit OS is required to run 

64-bit simulators
• Personal computer with Pentium 4 or higher processor 1.2 GHz (or higher). Multi-

core CPU is required for increased performance of parallel processing simulators.
• 2GB of RAM or higher (dependent on the size of calculated problem)
• 500 MB to 10 GB free hard drive disk space depending on calculation size for 

storage of the simulation results
• 1024 x 768 graphic resolution, minimum 256 colors
• Internet Explorer 5.5 (or higher)
• Most recent video and OpenGL drivers for your graphics card

Note: For machines running Windows XP, the “Windows Classic” theme must be 
used.

Protection key
A hardware protection key is supplied with the software. To ensure that OptiFDTD 
operates properly, verify the following:
• The protection key is properly connected to the parallel port of the computer.
• If you use more than one protection key, ensure that there is no conflict between 

the OptiFDTD protection key and the other keys.

Note: Use a switch box to prevent protection key conflicts. Ensure that the cable 
between the switch box and the computer is a maximum of one meter long.
1



USER’S REFERENCE — INSTALLING OPTIFDTD
OptiFDTD directory
By default, the OptiFDTD installer creates an OptiFDTD directory on your hard disk. 
The OptiFDTD directory contains the following subdirectories:
• \BIN – contains executable files, dynamic linked libraries, and help files
• \SAMPLES – contains OptiFDTD examples
• \TMP – temporary directory used by OptiFDTD during operation
• \DOC – OptiFDTD support documentation

Installation
• OptiFDTD can be installed on Windows XP/Vista/7, 32-bit or 64-bit, note: 64-bit 

OS is required to run 64-bit simulators. 
• Linux 64-bit for 3D simulations, Linux enabled versions only (see the Release 

Notes for more information).
• We recommend that you exit all Windows programs before running the setup 

program. 

Installing OptiFDTD on Windows operating systems

To install OptiFDTD on Windows operating systems, perform the following procedure.

Step Action 
1 Log on as the Administrator, or log onto an account with Administrator 

privileges.

2 Insert the OptiFDTD installation CD into your CD ROM drive.

3 On the Taskbar, click Start and select Run.
The Run dialog box appears.

4 In the Run dialog box, type F:\setup.exe, where F is your CD ROM drive.

5 Click OK and follow the screen instructions and prompts.

6 When the installation is complete, remove the CD from the CD ROM drive 
and reboot your computer.
2



FDTD Basics

OptiFDTD is a powerful, highly integrated, user-friendly software that allows computer 
aided design and simulation of advanced passive photonic components.

The OptiFDTD software package is based on the finite-difference time-domain 
(FDTD) method. The FDTD method has been established as a powerful engineering 
tool for integrated and diffractive optics device simulations. This is due to its unique 
combination of features, such as the ability to model light propagation, scattering and 
diffraction, and reflection and polarization effects. It can also model material 
anisotropy and dispersion without any pre-assumption of field behavior such as the 
slowly varying amplitude approximation. The method allows for the effective and 
powerful simulation and analysis of sub-micron devices with very fine structural 
details. A sub-micron scale implies a high degree of light confinement and 
correspondingly, the large refractive index difference of the materials (mostly 
semiconductors) to be used in a typical device design.

2D FDTD Equations
The FDTD approach is based on a direct numerical solution of the time-dependent 
Maxwell's curl equations. The first version of OptiFDTD is in 2D. The photonic device 
is laid out in the X-Z plane. The propagation is along Z. The Y-direction is assumed to 
be infinite. This assumption removes all the  derivatives from Maxwell's 
equations and splits them into two (TE and TM) independent sets of equations.

The 2D computational domain is shown in Figure 1. The space steps in the X and Z 
directions are  and , respectively. Each mesh point is associated with a specific 

∂ ∂⁄ y

Δx Δz
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 FDTD BASICS
type of material and contains information about its properties such as refractive index, 
and dispersion parameters.

Figure 1 Numerical representation of the 2D computational domain

TE waves
In the 2D TE case (Hx, Ey, Hz - nonzero components, propagation along Z, transverse 
field variations along X) in lossless media, Maxwell's equations take the following 
form:

where  is the dielectric permittivity and  is the magnetic permeability of 
the vacuum. The refractive index is .

Each field is represented by a 2D array — Ey(i,k), Hx(i,k) and Hz(i,k) — corresponding 
to the 2D mesh grid given in Figure 1. The indices i and k account for the number of 
space steps in the X and Z direction, respectively. In the case of TE, the location of 
the fields in the mesh is shown in Figure 2.

(1)∂Ey

∂t
-------- 1

ε
--- ∂Hx

∂z
--------- ∂Hz

∂x
---------–⎝ ⎠

⎛ ⎞ ,= ∂Hx

∂t
--------- 1

μ0
-----∂Ey

∂z
--------,= ∂Hz

∂t
--------- 1

μ0
-----∂Ey

∂x
--------–=

ε ε0εr= μ0
n εr=
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 FDTD BASICS
Figure 2 Location of the TE fields in the computational domain

The TE fields stencil can be explained as follows. The Ey field locations coincide with 
the mesh nodes given in Figure 1. In Figure 2, the solid lines represent the mesh given 
in Figure 1. The Ey field is considered to be the center of the FDTD space cell. The 
dashed lines form the FDTD cells. The magnetic fields Hx and Hz are associated with 
cell edges. The locations of the electric fields are associated with integer values of the 
indices i and k. The Hx field is associated with integer i and (k + 0.5) indices. The Hz 
field is associated with (i + 0.5) and integer k indices. The numerical analog in 
Equation 1 can be derived from the following relation:

(2)∂Ey

∂t
-------- 1

ε
--- ∂Hx

∂z
--------- ∂Hz

∂x
---------–⎝ ⎠

⎛ ⎞=
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:

The total set of numerical Equation 1 takes the form:

The superscript n labels the time steps while the indices i and k label the space steps  
and  and  along the x and z directions, respectively. This is the so-called Yee's 
numerical scheme applied to the 2D TE case. It uses central difference 
approximations for the numerical derivatives in space and time, both having second-
order accuracy. The sampling in space is on a sub-wavelength scale. Typically, 10 to 
20 steps per wavelength are needed. The sampling in time is selected to ensure 
numerical stability of the algorithm. The time step is determined by the Courant limit:

(3)

Ey
n i k,( ) Ey

n 1– i k,( )–
Δt

------------------------------------------------ 1
ε
---+

Hx
n 1 2⁄– i k 1 2⁄+,( ) Hx

n 1 2⁄– i k 1 2⁄–,( )–
Δz

--------------------------------------------------------------------------------------------------- 1
ε
---

Hz
n 1 2⁄– i 1 2 k,⁄+( ) Hz

n 1 2⁄– i 1 2 k,⁄–( )–
Δx

------------------------------------------------------------------------------------------------------–=

Ey
n i k,( ) Ey

n 1– i k,( ) Δt
εΔz
--------- Hx

n 1 2⁄– i k 1 2⁄+,( ) Hx
n 1 2⁄– i k 1 2⁄–,( )–[ ]+=

Δt
εΔx
--------- Hz

n 1 2⁄– i 1 2 k,⁄+( ) Hz
n 1 2⁄– i 1 2 k,⁄–( )–[ ]–

Hx
n 1 2⁄+ i k 1 2⁄+,( ) Hx

n 1 2⁄– i k 1 2⁄+,( ) Δt
μ0Δz
------------ Ey

n i k 1+,( ) Ey
n i k,( )–[ ]+=

Hz
n 1 2⁄+ i 1 2 k,⁄+( ) Hx

n 1 2⁄– i 1 2 k,⁄+( ) Δt
μ0Δx
------------– Ey

n i 1 k,+( ) Ey
n i k,( )–[ ]=

Δx Δz

Δt 1 c 1 Δx( )2 1 Δz( )2⁄+⁄( )⁄≤
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TM waves
In the 2D TM case (Ex, Hy, Ez — nonzero components, propagation along Z, 
transverse field variations along X) in lossless media, Maxwell's equations take the 
following form:

The location of the TM fields in the computational domain follows the same 
philosophy and is shown in Figure 3.

Figure 3 Location of the TM fields in the computational domain shown in Figure 112

Now, the electric field components Ex and Ez are associated with the cell edges, while 
the magnetic field Hy is located at the cell center. The TM algorithm can be presented 
in a way similar to Equation 3.

(4)∂Hy

∂t
--------- 1

μ0
----- ∂Ex

∂z
-------- ∂Ez

∂x
--------–⎝ ⎠

⎛ ⎞ ,–= ∂Ex

∂t
-------- 1

ε
---∂Hy

∂z
---------,–= ∂Ez

∂t
-------- 1

ε
---∂Hy

∂x
---------=
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3D FDTD Equations
In 3D simulations, the simulation domain is a cubic box, the space steps are , 

,and  in x, y, and z directions respectively.

Each field components is presented by a 3D array ---Ex(i,j,k), Ey(i,j,k), Ez(i,j,k), 
Hx(i,j,k), Hy(i,j,k), Hz(i,j,k).  The field components position in Yee's Cell are shown 
in Figure 4.  These placements and the notation show that the E and H components 
are interleaved at intervals of  in space and  for the purpose of 
implementing a leapfrog algorithm.

Figure 4 Displacement of the electric and magnetic field vector components about a cubic unit cell of the 
Yee space lattice

Now we can apply the above finite-difference ideas, notations, and field 
displacements to achieve a numerical approximation of Maxwell's equation (1.3-1.4).

Dx
Dy Dz

1 2Dh⁄ 1 2Dt⁄

 

x 

z 

y 

(i,j,k)

Hz(i-1/2 ,j-1 /2,k) 

Hy(i-1/2 ,j,k -1/2) 

Hx(i,j-1/2,k-1/2)

Ez(i,j,k -1/2)

Ex(i-1/2 ,j,k) 

Ey(i,j-1/2 ,k) 
Ey(i,j-1/2 ,k-1) 

Ey(i-1 ,j-1 /2,k)

Ex(i-1/2 ,j,k-1) 

Ez(i,j-1 ,k-1/2) 

Ez(i-1 ,j,k-1/2) 

Ex(i-1/2 ,j-1,k)
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The FDTD can be written as:
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1.12c
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Space Step and Time Step
The fundamental constraint of FDTD method is the step size both for the time and 
space. Space and time steps relate to the accuracy, numerical dispersion, and the 
stability of the FDTD method. Many references and books have discussed these 
problems. In general, to keep the results as accurate as possible, with a low numerical 
dispersive, the mesh size often quoted is "10 cells per wavelength", meaning that the 
side of each cell should be 1/10  or less at the highest frequency (shortest 
wavelength).

Please note that FDTD is a volumetric computational method, so that if some portion 
of the computational space is filled with penetrable material, you must use the 
wavelength in the material to determine the maximum cell size.

The following equation is for the suggested mesh size:

1.15

where nmax is the maximum refractive index value in the computational domain.

Once the cell size is determined, the maximum size for the time step  immediately 
follows the Courant-Friedrichs-Levy (CFL) condition.

For 3D FDTD simulation, the CFL condition is:

1.16

where v is the speed of the light in medium.

For 2D simulations, the above CFL condition can be simplified as:
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OptiFDTD Simulation Procedures
The following is the flow chart for the FDTD simulation in OptiFDTD. It also details the 
work flow in OptiFDTD.

Figure 5 FDTD Simulation Flow Chart in OptiFDTD

 BUILD OBJECT (LAYOUT)

START SIMULATION 

UPDATE E FIELD 

PREPARE INPUT FIELD 

UPDATE H FIELD 

DEFINE PARAMETERS 

DFT ANALYSIS 

Time steps
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POST  DATA ANALYSIS 
l i

OptiFDTD Designer 

OptiFDTD Simulator 

OptiFDTD Analyzer 

No 
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Output data
The fields propagated by the FDTD algorithm are the time domain fields. At each 
location of the computational domain they have a form similar to that given in 
Equation 8:

where B is the amplitude of the field at that particular location, G is the wave profile, 
and  is the corresponding phase. However, the values of B and  are not 
accessible from the time domain field values.

In order to get the full amplitude/phase wave information, we need the stationary 
complex fields that correspond to the waveform Equation 5. The complex fields are 
the source of all useful information, such as output and reflected powers, overlap 
integrals with modal fields, etc. Those complex fields are calculated by a run time 
Fourier transform performed in the last time period of the simulation. The final 
complex fields can be visualized at specific Output Planes located properly in the 
computational domain.

Figure 6 Output Planes

(5)Ey x z,( ) BG x z,( ) ωt ϕi+( )sin=

ϕi ϕi
13
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The Output Plane located on the right side of the Input Plane is in the Total Field 
Region and collects the Total Field data. The Output Plane on the left of the Input 
Plane is in the Reflected Field Region and collects Reflected Field data. It is also 
called the Reflection Plane. Output planes can also be situated along the Z axis.
14



 MATERIAL MODELS
Material Models

One of the main advantages of the FDTD approach is the lack of approximations for 
the propagating field—light is modeled in its full richness and complexity. The other 
significant advantage is the great variety of materials that can be consistently 
modeled within the FDTD context. In this sub-section we make a brief review of some 
of the main material properties that can be handled

Constant Dielectrics
Constant dielectric material is expressed by a complex refractive index value ( ) or 
relative permittivity value ( ).

Here,  is the refractive index indicating the phase velocity informaiton in the 
medium,  while  is called the  extinction coefficient, which indicates the amount of 
absorption loss when the electromagnetic wave propagates through the material. 
Note that the sign of the complex part is a matter of convention, which is important 
due to possible confusion between loss and gain. From OptiFDTD version 9, 
Engineering convention is used for the constant material definition, which means 
negative imaginary part  will bring the loss effect. 

Sellmeier equation can be used for calculating the permittivity with the reference 
wavelength ( ).

 

Where  is the strength,  is the damping factor or collision wavelength.  is the 
oscillating wavelength
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εr ñ2=

n
K

λ

εr εr0
Aiλ

2

λ2 jΓiλ λ2
i–+

-------------------------------------

i 1=

M

∑+=

Ai Γi λi
15



 MATERIAL MODELS
Lossy dielectrics
Before proceeding with a more detailed description it should be emphasized that the 
fact that in the time domain all the fields (Hx, Ey, Hz) are real quantities. Thus, 
accounting for loss is possible only through a non-zero conductivity  of the medium:

where

Here we have assumed that 

and

corresponds to time-to-frequency domain Fourier transform. The real and imaginary 
part of the permitivity can be expressed through the real and imaginary part of the 
refractive index:

This makes the refractive index approach and the conductivity approach equivalent.

(6)

(7)
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Lorentz dispersion materials
By Lorentz dispersion materials, we mean materials for which the frequency 
dependence of the dielectric permitivity can be described by a sum of multiple 
resonance Lorentzian functions:

where

In the lossless case Equation 8 is directly related to the Sellmeier equation which in 
the three resonances can be presented as:

In the lossy case, the Sellmeier equation can be written in a generalized form, 
accounting for a non-zero damping coefficient   as well as for anisotropy in the 
dispersion properties:

(8)

are the resonant frequencies

is related to the oscillator strengths

is the damping coefficient

is the permittivity at infinite frequency

and 

is the permittivity at .
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 MATERIAL MODELS
There are different ways to implement Equation 8 into the FDTD formalism. Here we 
consider the so-called polarization equation approach in the single resonance case. 
It uses the dielectric susceptibility function:

and the relation between the polarization and the electric field . 
Taking the Fourier transform of the last equation leads to the following differential 
equation:

By substituting  the above equation becomes:

Then Equation 13 is solved numerically together with the modified Equation 1:

The FDTD approach can also account for a large variety of materials such as Drude 
dispersion materials, perfect metal, second-order, and third-order materials.

Lorentz model only supports 2D simulation. Lorentz_Drude material that covers 
Lorentz model supports both 2D and 3D simulation.

Drude Model
Drude material in OptiFDTD is marked as

(11)
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 MATERIAL MODELS
Where  is the permittivity for infinity frequency,  is the plasma frequency, and 
 is the collision frequency or damping factor.

Drude model only supports 2D simulaiton, Lorentz_drude model that covers Drude 
model supports both 2D and 3D simulation.

Nonlinear material model
In general, the nonlinear behavior is due to the dependence of the polarization P(t) on 
the applied electric field, E(t). Assuming an isotropic dispersive material, Maxwell's 
equations are:

(15)
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 MATERIAL MODELS
where  represents the linear polarization, in general  is the 
dispersive polarization which is controlled by Lorentz model in Equation 18 and  
denotes the nonlinear polarization. For more information, see “Dispersive third-order 
nonlinear material” on page 21.
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The nonlinear polarization  may come from various model sources that produce 
the different nonlinear phenomenon. Currently OptiFDTD can handle four kinds of 
nonlinearity:
• Dispersive second-order nonlinear material
• Dispersive third-order nonlinear material
• Dispersive Kerr effect
• Dispersive Raman effect

Dispersive second-order nonlinear material 

In this model, the electrical displacement D is

where  is the linear relative permittivity and  is the second order isotropic 
susceptibility. They are the real values. In order to simulate second order nonlinear 
effect, you should input two parameters: the linear relative permittivity  and the 
second order isotropic susceptibility . 

Dispersive third-order nonlinear material

Like the second-order nonlinearity, OptiFDTD takes third-order susceptibility to 
calculate the nonlinear polarizationn

where  is the linear relative permittivity and  is the third order isotropic 
susceptibility. 

Dispersive Kerr effect

If the time scale over which the medium changed is greater than the pulse width, we 
should take into account the effects of the finite response time of the medium. 
Followed by Prof. Richard W. Ziolkowski 's work [1]-[4],  OptiFDTD treats the 
nonlinear effect with a finite response time as well as an instantaneous manner by 
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solving the phenomenological susceptibility equation simultaneously with Maxwell's 
equation: 

where

Therefore, in order to simulate the Kerr effect, you should setup the three parameters, 
, , and . Due to the numerical difficulties to update the susceptibility in the 

FDTD scheme, currently OptiFDTD for Kerr model is good for high-nonlinearity.

Dispersive Raman effect

Raman model allows another way to simulate the nonlinear phenomenon where the 
nonlinear susceptibility was modeled by a second-order derivative equation which is 
related to the resonant wavelength and the response time

(21)

(22)

(23)
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is the response time

is the Kerr model permittivity
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where 

In order to simulate the Raman effect, set four parameters for Raman model: , , 
, and .

Nonlinearity simulation
• To observe nonlinear effects in common used materials, a high-intensity light 

source is required. You should pay special attention to the input wave amplitude 
and/or the power level; each model with different parameters may need different 
input power or amplitude. If the input power is too low, you may not observe the 
nonlinear phenomenon. If the power is too strong, the nonlinear effect may be 
over saturable.

• The OptiFDTD takes Lorentz dispersive effect to the nonlinear effect. But it can 
work independently.

(25)

(26)

is the linear relative permittivity
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is the response time

is Raman model permittivity

is the Raman model resonant frequency
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Lorentz-Drude Model

Lorentz-Drude Model in Frequency Domain

It has been shown [1] that a complex dielectric function  for some metals and surface 
plasmas can be expressed in the following form:

This form separates explicitly the intraband effects (usually referred to as free electron 
effects) from interband effect (usually referred to as bound-electron effects). The 
intraband part  of the dielectric function is described by the well know free-
electron or Drude model [2][3]:

The interband part of the dielectric function   is described by the simple semiquantun 
model resembling the Lorentz results for insulators:

where  is the plasma frequency,  is the number of oscillators with frequency  
and lifetime , where  is the plasma frequency as associated 
with intraband transitions with oscillator strength  and damping constant .

The above Lorentz-Drude Model can be expressed as the more general equation:

where  is the relative permittivity in the infinity frequency.   is the plasma 
frequency,  is the resonant frequency, and  is the damping factor or collision 
frequency.

In this general equation, if only the term  exists, and , then the 
general equation describes the Drude model as in (2).  If only the  term 
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exists, and  then the general model becomes the Lorentz 
model as in (3). This model can also work as the separate Drude and Lorentz models.

Reference [1] also gives the LD parameters for 11 noble metals; their unit is in electron 
volts. Lorentz_Drude parameters for selected materials contains parameters 
compiled by Optiwave that describe noble metals.

Lorentz-Drude Model in Time Domain

The Lorentz-Drude model in (4) is in the frequency domain. However, FDTD is a time 
domain method and therefore would be suitable for broadband simulations. We need 
to transform (4) to time domain so that FDTD can handle the fullwave-analysis for the 
Lorentz-Drude material. This transformation to time domain is accomplished by using 
the Polarization philosophy within Maxwell's equation.  The Lorentz-Drude model in 
time domain can be expressed:

The FDTD algorithm can be derived based on the above equation.

(5)
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Lorentz-Drude model user interface in OptiFDTD

The Lorentz-Drude model user interface is shown in Figure 22.

Figure 7 Lorentz-Drude material definition data entry interface

where:
• S = Strength of the corresponding resonance terms
• P (rad/s) = Plasma frequency
• R (rad/s) = Resonant frequency
• D (rad/s) = Collision frequency (or damping factor )

Note: Refer to the Technical Background description when you first start 
preparing metal simulations. The parameters of aluminum are located in 
Lorentz_Drude parameters for selected materials.
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 OPTIFDTD BOUNDARY CONDITIONS
OptiFDTD Boundary Conditions

PML Boundary Conditions
The basic FDTD algorithm must be modified at the boundaries of the computational 
window where suitable numerical absorbing boundary conditions (ABC) are applied. 
This is one of the most challenging parts of FDTD simulations. There are several 
choices for the type of boundary conditions.  The Perfectly Matched Layer (PML) 
boundary conditions have the best performance. Our FDTD simulator uses the 
Anisotropic PML, or so-called Un-split PML (UPML) version. The theory of the UPML 
is very well explained in some of the references given here. The UPML boundary 
conditions are physical rather than numerical because their implementation is based 
on a Maxwellian formulation rather than on a mathematical model. Their absorbing 
properties are physically equivalent to the properties of an absorbing uni-axial 
anisotropic medium with the following permittivity and permeability tensors:

A plane wave incident on a half space composed of the above uni-axial medium with 
an interface in the x = const plane is purely transmitted into it. The reflectionless 
property is completely independent of the angle of incidence, polarization and 
frequency of the incident wave. The numerical implementation of the UPML in a 2D 
(X-Z) computational window requires the introduction of such perfectly matched 
absorbing layers on all the sides. The corner regions need special attention. In these 
regions the tensor  from Equation 4 must be modifed to:
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 OPTIFDTD BOUNDARY CONDITIONS
The minimization of the numerical reflectance of the Anisotropic PML layers requires 
spatial scaling of the conductivity profile from zero (at the interface of the PML) to a 
maximum value at the end of the computational window:

where L is the thickness of the Anisotropic PML. Typical values for the parameter m 
are between 2 and 4. 

PMC/PEC boundary conditions and plane wave simulation
OptiFDTD now has options to use Perfect Electrical Conductor (PEC) and Perfect 
Magnetic Conductor (PMC) boundary conditions.  You can choose which boundaries 
use the new conditions, and Anisotropic PML can be used for the remaining 
boundaries.  With this PEC/PMC/Anisotropic PML combination, the following 
simulations may be obtained:
• Plane wave simulation
• Domain reduced simulation for symmetric, periodic, or photonic band gap 

structures

Image value of PEC/ PMC
The following graphs show the field set up in the PEC/PMC wall (zero thickness) and 
its image value

Figure 8 Field in PMC and image area

(  is the vertical electric component in the PMC wall, and  is the parallel 
magnetic component in the PMC wall.)
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 OPTIFDTD BOUNDARY CONDITIONS
Figure 9 Field in PEC and image area

As we can see from Figure 8, PMC is a symmetric wall for the symmetric structure 
with symmetric wave propagation. The following two cases details the results when 
PMC occurs.

Figure 10 PMC wall in a symmetric waveguide—excited by symmetric TE waveguide mode

Figure 11 PMC wall in a periodic structure for TE plane wave propagation
31
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PMC can be seen as the special case for Bloch's boundary condition (periodic 
boundary condition) where the k-vector is set to zero in the corresponding direction.

PEC line is the complement of PMC, so in Figure 10, and Figure 11, the PMC line will 
become the PEC line if the wave polarization is changed to TM.

Plane wave realized in symmetric/periodic structure
Figure 12 shows how the plane wave simulation can be realized for a symmetric 
structure. For a 2D TE simulation, the edge of transverse plane should be set to the 
PMC boundary condition to realize the plane wave.

Figure 12 Plane wave in TE simulation

For a 2D TM simulation, the edge of transverse plane should set to the PEC boundary 
condition to realize the plane wave (see Figure 13).

Figure 13 Plane wave in TM simulation

For a 3D simulation, the plane wave realization depends on the wave polarization and 
the boundary condition setup at different edges of the transverse plane. If the wave 
goes in z-direction, and the input wave is in y-direction polarization, then the y plane 
(x-z) edge should be set to the PEC and x-plane (y-z plane) edge set to the PMC 
boundary (see Figure 14).
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Figure 14 Y-polarization plane wave (z-direction propagation) with boundary conditions

For 3D simulation, if the wave goes in z-direction, and the input wave is in x-direction 
polarization, then the y plane (x-z) edge should be set to the PMC and x-plane 
(y-z plane) edge set to the PEC boundary (see Figure 15).

Figure 15 X-polarization plane wave (z-direction propagation) with boundary conditions

The plane wave shape can be set by setting the rectangular wave parameters in the 
Input Wave Properties dialog box. Currently, plane wave does not support the tilting 
angle. Currently, the plane wave simulation is only effective for symmetrical 
structures.
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PBC Boundary Conditions
This version of OptiFDTD provides the option to use simplified Periodic Boundary 
Condition (PBC).  PBC can work with other boundary conditions such as Anisotropic 
PML, PMC, and PEC.  With PBC, you can generate a simple plane wave simulation 
or periodic layout simulations.

The simplified PBC is based on the Bloch's Theorem:
• For the periodic layout, the wave function is written as the combination of a cell 

periodic component and a wave-like component:

• The equation above needs to have a pre-defined value for the k-vector; which is 
not so feasible for an FDTD simulation, especially for Pulse input.

Therefore, we simplified the application by setting the k-vector in one specific 
direction as zero, which then leads to the input wave being the axis-propagated wave, 
and then the equation becomes:

In an OptiFDTD application,  in the simplified is the periodic length or one 
dimensional length the edge of which is set to periodic boundary condition.

 is  the field component at the edge of the simulation domain.

 is the corresponding field value at the boundary of the opposite edge of 
the .

The following graph shows the relationship.

ψ γ Δγ+( ) ϕ γ( ) jkΔγ( )exp⋅=

ψ γ Δγ+( ) ϕ γ( )=

Δγ

ϕ γ( )

ψ γ Δγ+( )
ϕ γ( )
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Input Wave

Incident wave source excitation — Total/Reflected field formulation
The FDTD numerical scheme yields the solution of an initial value problem. At the first 
time step of the simulation all the fields are set to zero. The algorithm needs the initial 
field excitation that will be propagated through the computational domain. The FDTD 
Total/Reflected Field formulation gives the methodology in defining a +Z propagating 
incident field. The computational domain is separated into two sub-regions — the 
total field region and the reflected field region. The plane separating these regions 
is called the incident field (Figure 16).

In the Total Field Region, the waveguide structures of interest are designed. The 
interaction between the incident field and the waveguide structure will take place in 
this region. That is why the Total Field Region contains information for both the 
incident and scattered (reflected) waves. In the Reflected Field Region the geometry 
is uniform and the propagating waves are presented by the fields reflected from the 
Total Field Region. There are no objects in this region and the signal will not be 
reflected back to the total field region.

Figure 16 Total/Reflected field formulation

CW or pulsed excitations can be used. One can consider the incident field as being 
generated by a flashlight located on the incidence plane facing the +Z direction. 
Before starting the simulation the flashlight is turned off and the field values in the 
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whole computational domain are equal to zero. The flashlight is switched on at  t = 0 
and illuminates only the Total Field Region. If the excitation scheme is perfect, there 
should not be any light detected by an observer located in the Reflected Field Region, 
unless there are some obstacles which would generate the reflections. The incident 
wave can be generated by specifying the exact field distribution on the incident plane 
at each time interval.

CW excitation 
In CW excitation, the time dependence of the incident field is a single frequency 
sinusoidal function. For example the incident Ey field has the following form:

where A is the field amplitude,  is the transverse field distribution at the 
incident plane location .

The initial phase offset  is the phase difference between points in the incidence 
plane. This offset can be adjusted to define the direction of the incident field. 

 is the frequency of the input wave. In the CW case the optical wave 
analog propagates until it reaches the stationary state everywhere in the 
computational window.

Pulsed excitation
For pulsed excitations the incident field has the form:

where

is the pulse envelope function,  is the time offset and  is the pulse width 
parameter.

For pulsed excitations the time stepping continues until the desired late-time pulse 
response is observed at the field points of interest.

Point Source
This version of OptiFDTD includes a new type of excitation - Point Source. Point 
source can also be referred to as a radiation source. For this new source, the input 
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wave is only functional with one field component at one single point. You can specify 
which field component is required to add this source.

In the case of CW, the point source is expressed as:

where (i,j,k)  is the user-specified position and F is the user specified component, A 
is the point source amplitude, T is the time delay and w is the angle frequency.  
represents the FDTD simulation results, and the last term in the equation is the 
enforced point source excitation.

For the GMCW, point source is expressed as 

where  is time offset and T is the half width.

Note: 

• Point sources can work with other kinds of source (such as input plane 
source).

• Point sources can be either continuous wave (CW) or Gaussian 
modulated continuous wave (GMCW).

• Point sources works for both 2D and 3D simulations.
• Multiple point sources can be utilized in OptiFDTD.
• When Point source is used as the key input. The normalized power 

calculation will be disabled in analyzer

Gaussian Beam Size
In OptiFDTD, transverse Gaussian Beam is expressed as 

where  is the center position and T is being called as half width.

In general, Gaussian Beam radius is the radius at which the field amplitude and 
intensity drop to 1/e and , respectively. Gaussian Beam Size or Gaussian 
Beam Spot size is the beam diameter which is two times of Beam Radius. Suppose 
the beam size is denoted as a, which means
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This means

Please use the above formula to set the half width in OptiFDTD for your desired 
Gaussian Beam size.

2D Total Field /Scattering Field (TF/SF) region. 
The Total-field/Scattered-field (TF/SF) technique results from attempts to realize any 
tilting plan-wave source that avoids the difficulties caused by using either the hard 
source or the boundary conditions. 2D TF/SF is a special type of formula that 
generates a wave in the enclosed rectangular surface. Inside the rectangular region, 
it generates the total field (including incident wave and scattering wave together). 
Outside of this rectangular region, it generates the pure scattering field or reflected 
field. Figure 17 shows a 2D sketch for 2D TF/SF.  TF/SF used special numerical 
formula to separate the total field and scattering field. A 2D free space TF/SF  
response is shown in Figure 18

E x a
2
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Figure 17 TF/ST Sketch

Figure 18 Field response for a TF/SF sketch

In OptiFDTD, it is the user’s choice to set up the total field working area position, size 
and the scattering field detector position. After the simulation, the steady state 
scattering field response can be obtained in the scattering field detector.  If all four 
scattering- field detector lines are active, Radar Cross Section (RCS) can also be 
performed based on the near scattering field response, RCS calculation formula is 
listed in the post-simulation data analysis section.
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 2D FDTD BAND SOLVER
2D FDTD Band Solver

The band solver in OptiFDTD is an integrated CAD tool and simulation engine for 
analyzing the photonic crystal and photonic band gap structure. Currently it employs 
the FDTD method and generates band-diagrams.

Simulation concept introduction
As we know, the periodic structure or the lattice structure has the mode selection 
function. The task of the band solver is to find these mode positions based on one or 
several basic lattice cell. The key points for FDTD simulation come from:
• How can the FDTD method extract the mode?
• How can the FDTD method handle several basic cells and generate global 

results?

The first question can be addressed in two parts:
• set the reasonable initial fields that can excite out all necessary modes
• get the eigenvalues (frequencies) from the Fourier spectrum of the field time 

sequence somewhere in the periodic cell.The second question can be solved by 
using the Bloch's boundary condition with defined k-vector. 

In summary, when a field pattern is excited in the first time step, the steady state 
oscillating mode which will satisfy the Bloch's boundary condition will be found 
through FDTD simulation in the defined periodic cell.

Note: 
• To extract all the excited eignevalues, observation points to record the time 

domain series are needed.
• Some of the mode may not be excited.
• Because of the above points, the FDTD band solver cannot be guaranteed to find 

all the eigenvalues.
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Basic equation for TE mode 2D simulation

Basic equation for TM mode 2D simulation

Note: 
• The above equations are same as the equations used in conventional FDTD 

simulations. However, because the Bloch's boundary condition is used in the 
simulation, all the field components in band solving are complex values.

• The discretization treatment for the FDTD method and simulation domain is same 
as conventional FDTD simulation.

Bloch's boundary condition
Bloch's theorem tells us that for periodic structure, field components have the 
following properties:

where  is the lattice vector,  is the wave vector.  Equation 12 is the boundary 
condition used in the OptiFDTD band solver.
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 2D FDTD BAND SOLVER
Initial excitation
Unlike conventional FDTD simulations where time domain excitation is continuous 
wave and lasts on only some time steps, the FDTD band solver sets the initial value 
in the first time step, and this initial field is expected to have non-zero projection on 
the normal modes we are interested in.

Example: At :

 is chosen as the unit vector along the Cartesian system coordinator.

This keeps  .

(13)

(14)

(15)

t 0=

E r( ) 0=

H r( ) h0 k G+( )ek k G+( )r

G
∑=

h0 k G+( ) v k G+( )×=

v

∇ μH 0=⋅
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 2D FDTD BAND SOLVER
Figure 19 Flow chart of FDTD band solver

Note: 
• In OptiFDTD, the FDTD band solver only deals with the 2D square lattice and 2D 

hexagonal lattice.
• In OptiFDTD, the band solver only accept lossless Isotropic and Anisotropic 

materials.

Unit cell and Brillouin zone
The following figures show the unit cell and Brillouin zone in the OptiFDTD 
2D FDTD band solver.
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Figure 20 Unit cell and associated Brillouin zone for square lattice

Figure 21 Unit cell and Brillouin zone for Hexagonal lattice
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Post-simulation Data Analysis

OptiFDTD provides comprehensive post-simulation data analysis tools in the 
Simulator and Analyzer.

Discretized Fourier Transform (DFT) and Fast Fourier Transform 
(FFT)

As a time domain simulation method; FDTD can get all the relevant spectral response 
with a single simulation. To get the spectral response, you need to use the DFT, FFT, 
and Analysis. Discretized Fourier Transform gets a single wavelength response from 
a time series.

1.33

where s(n) are the time domain response, N is the number of time steps, and  is 
the angle frequency.

When DFT is running in the simulator, it will get the frequency domain response only 
for the center wavelength, while DFT for the observation point, area, and line gives 
the spectral response for a series of wavelengths which are identified by the user.

Fast Fourier Transform uses the traditional fast Fourier transform scheme to get a 
spectral response from the zero frequency to the cutoff frequency ; and the 
frequency domain sampling step is .

In general, the sampling frequency step for FFT is comparable to the wavelength due 
to the fact that the FDTD required time step is very small. Therefore, the FFT results 
may have a larger error than that of the DFT results, but the FFT method is much 
faster than DFT.

Power calculation and Poynting vector
For the z-direction propagation wave. The total power in x-y plan can be divided into 
two power values: x-direction polarized z-direction propagation power (Pz-x) and y-
direction polarized z-direction propagation power (Pz-y). The corresponding formulas 
are:
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y-polarixation power  1.34b

Total power  1.34c

where the cap dot indicates the complex value that comes from the DFT calculation, 
and the superscript star indicates the complex conjugate value.

The z-direction Poynting for a point (i,j,) in x-y plane is:

 1.35

The Poynting vector is a complex value. In OptiFDTD, only the amplitudes are 
displayed to the user.

Overlap Integral (OI)
Overlap Integral do the inner product and integral calculation for the two electric fields 
in a specified region. The results can also be seen as the Correlation Function, or as 
a comparison between the two fields. The Overlap Integral (MOI) is defined as:

 1.36

The cap dot represents the complex value, and the superscript star represents the 
conjugate value,  is the first field component, and  is the second field 
component.

Mode Overlap Integral (MOI)
For mode overlap integral calculation, the first component   in eq.1.36 are the 
OptiFDTD simulated DFT results in a selected x-y plane, and the second components   
are the modal components that come from the mode solver for the same x-y plane.

Input Overlap Integral (IOI)
For Input Overlap Integral, the first component  in Equation 1.36 are the OptiFDTD 
simulated DFT results in a selected x-y plane, and the second component  is the 
input wave in the input plane. The input overlap integral is also called the power 
overlap integral.  The input overlap integral provides the criteria to do the comparison 
between the output in the selected plane and the input wave.
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Input Overlap Integral Scan (IOIS)
The Input Overlap Integral Scan makes the Input Overlap Integral calculations for  all 
the x-y slices in the z-direction.  This means that it scans the IOI calculation in the z-
direction, and the results are provided to the user interface. Users can observe 
percentages of output power in each slice.Far Field Transform.

Far Field Transform

Fraunhofer approximation
Narrow angle far-field transform being used in OptiFDTD is based on the Fraunhofer 
approximation [1]:

(1)

At a large distance d, the far field position can be expressed by the far field angle,
(2)

Where the x-directional angle  is the angle between the original yz-plane and the 
shortest straight line connecting the point and the Y axix, and y-directional angle 

 is the angle between the orginal xz-plane and the shortest straight line 
connecting the point and the x axis. The far field angle is also shown in the Figure 20.

Associated with the angle where to observe the far-field, far-field formula now can be 
simplified as

(3)

Please note that the above formula assumes that the far-field plane is far away from 
the near field one. OptiFDTD uses equation (3) to calculate the narrow angle far field 
transform.
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Figure 22 Far-field angle (the red region is the near field)

Fresnel-Kirchhoff Diffraction Formula
Wide angle far field transform is based on the Fresnel-Kirchhoff diffraction formula [1].

(3)

Where R is the vector from near-field to far-field.

The far-field position can be expressed with far field angle the far-field distance z=d. 
So in the wide angle far field transform, the user needs to specify the far-field 
distance.

E x y z, , d=( ) i
λ
--- E x′ y′ z,,(∫∫– 0 )e

ikR

R
------- 1 R z,( )cos+

2
-------------------------------- dx′dy′= =
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Heating Absorption
It is known that the real electromagnetic power transmitted through the closed surface 
S into the volume V is equal to the power loss produced by conduction current 
resulting in Joule heating plus the power loss resulting from polarization damping 
forces.

From the complex Poyntin vector theorem, the time-average heating absorption 
intensity is expressed as

where  is the conductivity that maybe varied with wavelenth, E is the electrical field 
components.

In OptiFDTD, for each cell in a given observation area, the heating absorption 
intensity for each polarization then can be expressed as 

where the subscript letter, x,y and z means the polarization direction, i and j is the 
position index.

Then the total heating absorption for one observation slice will be the integral of the 
heating absorption intensity in the volume
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Where du and dv are the mesh size in the observation plane,  is the third 
dimensional (vertical to the observation area) space step. The total heating 
absorptionin the whole observation slice will be

Heating absorption calculation needs the conductivity. Basic formula between 
permittivity and refractive index is 

So the permittivity and conductivity is 

For Lorentz_Drude model material

The conductivity can be delivered as 

RCS Calculation
Consider figure 21, which depicts an obeservation point  in the far field many 
wavelengths away from the near field path . In this case, the Far Field 
can be idetified as:
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for TE simulation and

for TM simulation.

Then the bistatic radar cross section (RCS) in two dimension can be defined as:

Figure 23 Geometry of far-field point relative to the new field contour
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 PLANE WAVE EXPANSION (PWE) METHOD
Plane Wave Expansion (PWE) method

The Maxwell equation in a transparent, time-invariant, source free, and non-magnetic 
medium can be written in the following form:

where  is the space dependent dielectric function,  is speed of light in vacuum, 
and  is the optical magnetic field vector of a definite frequency  with time 
dependence .  This equation is sometimes called the master equation [1], and 
represents a Hermitian eigen-problem, which would not be applicable if the wave 
equation were derived in terms of the electric field.

The Bloch theorem says that, due to the infinite periodicity, the magnetic field will take 
the form:

where  for all combinations of lattice vectors .  Thus, we end up 
with the master equation in operator form:

This is the fundamental equation, which needs to be solved. The equation is 
transformed into a finite problem by expanding the magnetic field in a finite basis of 
simple plane waves.  Different approaches can be explored to solve the final 
discretized problem, e.g. [2] and [3]. The result of solving the discretized problem is 
the dispersion relationship between the frequencies of the modes and wave vector , 
usually plotted in the form of a band diagram.
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Power Transmittance Calculation with VB 
Scripting

Access to the simulation results data of Observation objects is a critical feature 
required for layout sweep simulations and optimization of designed devices. During 
the simulations, observation objects collect time domain data. The time domain data 
are stored in the Analyzer file. The OptiFDTD Analyzer provides all tools necessary 
for post-simulation analysis of the results. However, this requires manual interaction 
with the application. In order to provide the means for automated processing of the 
simulation results, VB Script interfaces have been designed, which access the 
required data. For more information, see “Power Transmittance Calculations - 
Observation Line” of the VB Script Reference Guide for a description and usage 
details for the VB script functions and interface.
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Tutorials

The following are tutorial lessons. Each one concerns different applications and 
features. The first four lessons are recommended for first time users to learn the 
basics of OptiFDTD.
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  INTRODUCTION TO THE LAYOUT DESIGNER CONCEPT
Introduction to the layout designer concept

This lesson is designed to familiarize you with the OptiFDTD layout designer concept. 
The same basic steps need to be followed to layout any device in OptiFDTD.  This 
document will guide you through these steps and provide you with a detailed 
explanation.

OptiFDTD comes as 4 main applications:
1. Layout Designer – This is where you define your structure and sim-

ulation conditions.
2. Profile Designer – This is used to define the materials and profiles 

used in the simulation.
3. Simulator – This program loads the designer file and performs the 

simulation. The simulator is started from the layout designer.
4. Analyzer – This program is used to view the results and perform 

some post processing. As soon as the simulation is done, the sim-
ulator will ask if you would like to open the analyzer. 

This document focuses on using the layout designer. To start an OptiFDTD project, 
your first step will be to open up the layout designer. From here the process of defining 
a layout begins.  

Figure 1 is a flow chart that illustrates the main steps for building a layout.
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Figure 1 Flow chart for building a Layout

The simulation domain can be 2D (finite xz-area) or 3D (xyz-volume) depending on 
the simulation that you choose. For 3D simulations, the domain is divided into 2 parts 
called substrate and cladding for historical reasons. The boundary between substrate 
and cladding define y = 0. Structures such as waveguides and lenses are placed 
within this domain. An example layout to illuminate the design concept is illustrated in 
Figure 2.  We can see the substrate is the volume defined by y < 0 and the cladding 
is the volume defined by y > 0.  The substrate and cladding each have a material 
associated with them. They define the default background material that other 
structures are imbedded in. There is a channel waveguide consisting of two 
rectangular layers; it is suspended in the cladding volume and extends along the z-
direction. Another fiber waveguide consisting of two circular fiber layers is imbedded 
in the substrate and also extends along z-direction.

The cross-sections of the rectangular waveguide and the fiber are what we call 
profiles. By combining profiles with waveguide that are drawn in the layout, we can 
define 3D shapes in the simulation domain. 
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The following is the relevant data for this layout 

1)Material that will be used in the project
a. Substrate material: n=2.0
b. Cladding material: n=1.0 (Air)
c. Material for channel waveguide layer 1: n=3.0
d. Material for channel waveguide layer 2: n=2.5
e. Material for fiber waveguide core layer: n=3.0         ( same as channel 

waveguide layer 1)
f. Material for fiber waveguide cladding layer: n=2.5  ( same as channel 

waveguide layer 2)

2)Waveguide profile  (waveguide cross section) and material
a) Channel profile  

Layer 1:  width: 1.5µm; thickness: 1.0µm; Material: n=3.0
Layer 2:  width: 1.0µm; thickness: 0.5µm; Material: n=2.5

b) Fiber  profile 
Core layer:  radius: 0.5µm  ; Material: n=3.0
Cladding layer:  radius: 1.0µm; Material: n=2.5

3)Simulation domain properties. 
a) Length: 8µm (z-direction:  0µm +8µm);
b) Width : 6µm (x-direction: -3µm +3µm)
c) Substrate layer thickness:  3µm (y-direction: -3µm 0 µm), material: 

n=2.0
d) Cladding thickness:  3um (y-direction: 0 µm  3µm), material: n=1.0 (Air)

4)Waveguide properties
a) Channel waveguide

Position:  (1.5, 1.0, 0) µm  (1.5, 1.0, 8) µm
Width: 1.5 µm;  Thickness: 1.5 µm

b) Fiber waveguide
Position:  (-1.5, 1.5, 0) µm  (1.5, -1.5, 8) µm
Width: 2.0 µm
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Figure 2 Example Layout

The following detailed steps are used to build the project layout demonstrated in 
Figure 2.

Step Action 

1 Open OptiFDTD Waveguide layout Designer
From the Start menu, select Programs >Optiwave Software > 
OptiFDTD >
Waveguide Layout Designer. OptiFDTD_Designer window opens (see 
Figure 3)
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Figure 3 OptiFDTD Designer (No layout)

2 Create a new project

From the OptiFDTD_Designer File menu, select New. The Initial 
Properties dialog box appears. (See Figure 4)
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Figure 4 Initial Properties 

3 Start Profile Designer
To define the material(s) and waveguide profile(s) that will be used in the 
project,

Click Profiles and Materials button in Initial Properties Dialog. The

Profile Designer OptiFDTD opens. (See Figure 5)
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Figure 5 Profile designer 

Note: 
(1)Profile Designer can work independently. It can be started from the start 

menu of OptiFDTD, or started in the layout designer.
(2)Material and waveguide profile defined in the “Master” folder can be worked 

as database

4 Define material in Profile Designer 
Perform the following sub-steps to define the material that will be used in the 
example project.

(1) In the directory under OptiFDTD_Designer1, Materials folder, right-click the 
Dielectric folder. A context menu appears (see Figure 6).
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Figure 6 Context Menu

(2) Select New. The Dielectric dialog box appears (see Figure 7).

Figure 7 Dielectric dialog box

(3) Type the following information
Name: n=2.0
refractive index (isotropic)(Re): 2.0

(4) To save the material, click Store.  Material n=2.0 will be listed in the Dielectric 
folder.

(5) Repeat above sub steps (1) - (4) to define second material as 
Name: n=2.5
refractive index (isotropic)(Re): 2.5

(6) Repeat above sub steps (1) - (4) to define third material as 
Name: n=3.0
refractive index (isotropic)(Re): 3.0
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(7) Air material is the OptiFDTD default material that will be always exist in the 
material folder. If Air material does not appear in the material folder list, 
please follow the step (1) - (4) to define this Air material: 

Name: Air
Constant refractive index (isotropic)(Re): 1.0

Explain:

(1) Right Click on the defined material in the Material folder list, A context menu 
appears. you can copy, remove, Edit, rename and check properties of this 
material by select the corresponding item. 

(2) You can also select one defined material from the material folder list and drag 
it into corresponding other material folder in Master folder or other project 
folder (when you open more projects)

5 Define Channel profile

Channel profile is a waveguide cross section that may contain single or 
multiple rectangular shapes.

(1) In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears.

(2) Select New. The Channel Profile dialog box appears (see Figure 8).
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Figure 8 Channel Profile dialog box

(a) 
(3) Type the following Profile name: ChannelPro1.
(4) To define the 2D profile, in the Material list under 2D profile definition, 

select N=3.0.
Explain:

(a)2D Profile will be used as 2D simulation. 
(b)Only the material is needed for the 2D profile definition.  The 2D 

waveguide shape will be defined in the layout window

(5) To define the 3D channel profile, under 3D profile definition:
(a)Type the following information (refer to Figure 7):

Layer name: Layer1
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Width: 1.5
Thickness: 1.0
Offset: 0.

(b)In the Material list, select n=3.0
(c)Click Add.
(d)Repeat above step (a)-(c) to add another layer that has the 

following properties.
Layer name: Layer2
Width: 1.0
Thickness: 0.5
Offset: 0.

(e)To save the defined channel profile, click Store, ChannelPro1 will 
be listed under the Channel profile folder.

Note: 
(a) Now we have created a waveguide cross section as shown in Figure 9.

Figure 9 Two layer channel  profile

(b) Each layer’s dimension is a ratio value. The waveguide real dimension will be 
set in the waveguide properties dialog box in the layout window.

(c) “Offset” can make the layers shift along the horizontal direction.
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6 Define fiber profile

Fiber profile is a waveguide cross section that may contain single or multiple 
circular or elliptical shapes.

(1) In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Fiber folder. A context menu appears.

(2) Select New. The Fiber Profile dialog box appears (see Figure 10).
(3) Type the following Profile name: FiberPro1.
(4) To define the 2D fiber profile, in the Material list under 2D profile 

definition, select N=3.0.
(5) To define the 3D fiber profile, under 3D profile definition:

(a)Type the following information (refer to Figure 11):

Layer name: Core
Rx: 0.5(x-directional radius)
Ry: 0.5(y-directional radius)

(b)In the Material list, select n=3.0
(c)Click Add.
(d)Repeat above step (a)-(c) to add another layer that has the 

following properties.

Layer name: Cladding
Rx: 1.0
Ry: 1.0
Material: n=2.5

(e)To save the defined channel profile, click Store, FiberPro1 will 
be listed under the Fiber Profile folder.
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Figure 10 Two layers fiber profile

Note: 

(a) Now we have created a fiber waveguide cross section as shown in Figure 11.
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Figure 11 Sketch for Two Layers fiber profile 

(b) The Input dimension is a ratio value. The real fiber waveguide dimension can 
be re-set in the layout window.

The material and waveguide cross-section have now been defined. We can either 
leave the Profile designer window open or close it. In the next step we return to the 
initial properties dialog box to finish the layout dimension setting. 

 

7 Set initial simulation domain properties
(1) In the Initial Properties dialog Box, click Waveguide Properties button.

(a) In the Width input box, input the initial waveguide width as 1.5µm

Explain: This is the waveguide width default setting, i.e. when you draw a waveguide 
in the layout window; the drawn waveguide will has this default width.

(b) From the Profile list, Select ChannelPro1 as the default waveguide 
profile

Note: When you draw a waveguide direction, this channel profile will be linked to 
your drawn waveguide

(2) In the Initial Properties dialog box, click Wafer Dimension button.
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(a) Input 8.0 (µm) in the Length input box
(b) Input 6.0 (µm) in the Width input box

Note: 
(a) In OptiFDTD, we refer to the whole simulation domain as the wafer
(b) Length direction is designated as z-direction. And the z-directional 

coordination for the layout  will be from 0 µm to 8 µm for the current 
setting

(c) Width direction is designated as x-direction. And the x-directional 
coordination for the layout will be from -3 µm to 3 µm for the current 
setting

(3) In the Initial Properties dialog box , Click 3D Wafer Properties
(a) In the Substrate area, input the following information

Material: n=2; thickness: 3 (µm)
(b) In the Substrate area, input the following information

Material: Air; thickness: 3 (µm)

Explain:
(1) 3D Wafer Properties control the y direction simulation domain 

properties. By default, Optiwave automatically set the wafer has two 
layers in y-direction. One layer is named “Substrate”, and another layer 
is named “Cladding”. Here the word “Substrate” and “Cladding” may 
not be your real layout’s substrate and cladding. 

(2) Interface between substrate and cladding layer will be the y-directional 
original point. The Substrate thickness can be set as zero to make the 
whole simulation domain as one background material, later in the layout 
window, user can fill in other waveguide shape with different materials. 

(3) For the current setting, the y-direction coordination for the layout will be 
from -3 µm to +3um. 

i.e, from -3 µm to 0 um, it is the substrate layer with material as n=2, and 
from 0 um to 3 µm, it is the cladding layer. 

(4) In the Initial Properties dialog box , Click 2D Wafer Properties. In the Wafer 
Refractive Index region set, the material as Air

Explain:

This step will be set the back ground material for 2D layout. 
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The initial properties settings have now been completed. The user can always modify 
these settings by selecting Wafer Properties or Profile and Material in the edit menu 
of the OptiFDTD Designer.

8 Start OptiFDTD Designer window

Click OK in the Initial Properties Dialog box, OptiFDTD Designer appears 
(see Figure 12).

Figure 12 OptiFDTD layout Designer

Explain
(1) OptiFDTD Designer window is the xz- plane viewer of your layout. 
(2) For the first time user, we recommend that all the shortcut toolbars are visible. 

Also for your convenience the waveguide shape shortcut toolbar can be 
moved to the left side of the layout window.

(3) Click shortcut toolbar “+” or “-” to zoom in or zoom out the layout window.
(4) Try to click on the different menu to view the software provided items.
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9  Draw the channel waveguide in the layout window

(1) From the Draw menu, select Linear Waveguide. 
(2) In the layout window, drag the linear waveguide from the start point to the end 

point. A linear waveguide appears in the layout window.

Note: Release the Linear Waveguide selection tool by clicking the Select 
tool after the Linear Waveguide is drawn in the layout.

(3) To adjust the position and the shape of the waveguide, in the layout window, 
double-click the Linear Waveguide. The Linear Waveguide Properties 
dialog box appears (see Figure 13).

Figure 13 Channel waveguide Properties. 

(4) Click the Start tab and type the following values
Horizontal offset (μm): 0
Vertical offset (μm): 1.5
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(5) Click the End tab and type the following values:
Horizontal offset (μm): 8.0
Vertical offset (μm): 1.5

Explain
(a) Here the Start and End tab control the waveguide x and z coordinator 

position. 
(b) Horizontal direction is z-direction; Vertical direction is x-direction.
(c) In OptiFDTD, all the input boxes marked “fx” can accept variable and 

expression input. Click Evaluate to see the final value of the expression.
(6) Input 1.5 (μm) In the Width box 

Explain:  This is the channel waveguide Width

(7) Input 1 (μm) In the Depth box 

Explain:  This is the channel waveguide y-direction position. It is the distance from the 
channel waveguide bottom to the y-directional original point. 

(8) Input Linear1 in the Label box.  This is the object name 
(9) Input ChannelPro1 in the Profile box 

Explain:  This will link the linear waveguide trends with the defined channel profile.

(10)  Click OK to finish the Channel waveguide setting.

Explain:
(a) In summary, the values for Start Horizontal, Start Vertical, and Depth 

control the waveguide start point coordinator (1.5, 1.0, 0.0) μm. The 
values for End Horizontal, End Vertical, and Depth control the 
waveguide end point coordinator (1.5, 1.0, 8.0) μm.  The width and 
thickness controls the waveguide dimension.

(b) If the user wants to set the waveguide thickness ( y-direction thickness), 
please unselect “Use Default”  checkbox under the Channel Thickness 
Tapering region.  The user can then put a start position thickness and an 
end position thickness. If Use Default checkbox is select, then the 
waveguide thickness will be the total thickness that is defined in the 
profile designer. 
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10  Draw the Fiber waveguide in the layout window

(1) From the Draw menu, select Linear Waveguide. 
(2) In the layout window, drag the linear waveguide from the start point to the end 

point. A linear waveguide appears in the layout window. Release the Draw 
mode by select the select toolbar

(3) To adjust the position and the shape of fiber waveguide, in the layout window, 
double-click the Linear Waveguide. The Linear Waveguide Properties 
dialog box appears 

(4) In the Linear Waveguide Properties dialog box, Select FiberPro1 as the 
profile from the Profile list box (See Figure 14).

Figure 14 Fiber waveguide properties

(5) Click the Start tab and insert the following values
Horizontal offset (μm): 0
Vertical offset (μm): -1.5
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(6) Click the End tab and type the following values:
Horizontal offset (μm): 8.0
Vertical offset (μm): -1.5

(7) In the Fiber Ry Tapering region, unselect User Default, select Linear in the 
Taper list box. Set the Start and End values as 2.0 ( the Fiber’s thickness in 
the y direction)

(8) Input the value 2.0 (μm) in the Width box ( the Fiber’s Width in the x-direction)
(9) Input the value -1.5 (μm) in the Depth box (the Fiber’s center position in the 

y direction).
(10) Input Linear2 as the Lable name.
(11) Click OK to finish the Fiber waveguide setting

Now the sample layout has been created. Please review the following for the further 
understanding of the layout concept

Explain

(a) Please note that the OptiFDTD designer environment is a 2D plane for x-
z view as shown in Figure 15. Each object may have the different depth 
reference to y-direction original position, but the OptiFDTD designer will 
show all these objects in this x-z plane top view as shown in figure 15.
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Figure 15 OptiFDTD designer for the example layout.

(b) Figure 16 is the sketch for the OptiFDTD Designer concept fro the 
example layout. 
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Figure 16 Sketch for the designed layout 

(c) OptiFDTD designer works only in the x-z plane, but a slice viewer is 
provided for you to observe the refractive index distribution in any slice in 
xy plane, yz palne and xz plane.  To do this, Please set and input plane 
first, and Click 3D_Refr_Idx_Re(y) button that is under the layout 
window. You can specify the slice position and orientation to view to 
layout See Figure 17 (a)-(c).

Note: The refractive index image resolution is determined by the OptiFDTD 
simulation mesh size. Click Simulation Parameters in the Simulation menu to re-
set the mesh size. 
82



  INTRODUCTION TO THE LAYOUT DESIGNER CONCEPT
(d) To modify the material or the simulation domain. Please click “ Profile 
and Material “ or the Wafer Properties to open the corresponding 
interface.

Figure 17 (a) Refractive indes distribution in xy plane at z=4.00µm
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Figure 18 (b) Refractive index distribution in yz plane at x=-1.5µm
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Figure 19 (C) Refractive index distribution in xz plane at y=1.5µm
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Know the difference between 32-bit and 64-bit 
simulations

OptiFDTD provides two types of FDTD simulations: 
• 32-bit simulations (performed by 32-bit Simulators).
• 64-bit simulations (performed by 64-bit Simulators).

These simulation options differ in certain aspects of supporting features or.

Memory

The most important difference between these two simulator types is the memory 
limitation imposed on 32-bit simulators. All the 32-bit applications may utilize up to 
2GB-4GB of memory for its purposes, dependent on the operating system.

In case of 64-bit applications (simulators), this limit is in the range of Tera-Bytes. In 
the current Windows 64-bit this limit is around 16TB, which is far beyond RAM 
capacity supported by standard PC configurations.

Operating System

The 32-bit simulations can be executed under Windows 32-bit and Windows 64-bit 
operating systems. In case of Windows 32-bit, the operating system can provide to 
the simulator up to 2GB-3GB of memory, while the remaining 2GB-1GB is used by the 
operating system. Under Windows 64-bit, the operating system can provide the 32-bit 
simulator with up to 4GB of memory, while it will utilize another ~4GB for its operating 
system memory mapping needs.

In case of 64-bit simulators, they can be executed only under Windows 64-bit 
operating system. One cannot execute a 64-bit application under a 32-bit operating 
system.

Processor

All the references to 64-bit Windows operating systems assume usage of a processor 
supporting EM64T architecture. In layman terms it means “hardware support for 32-
bit and 64-bit applications”. The currently manufactured Intel or AMD processors 
support this architecture, for example Intel’s Core 2 based multi-core processors.

Summary

In short - the main difference between the 32-bit and 64-bit simulations is that 64-bit 
simulators are capable of processing much larger designs. Due to the amount of data 
volume processed and generated by 64-bit simulators, the approach to the simulation 
result handling has changed.

The notes below describe the main differences.
— Layout size 

• 32Bit simulation can only use maximum 2GB of RAM. This means for a 
3D simulation, the maximum mesh point number that can be handled will 
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be roughly 300X300X300. When the mesh size exceeds this value, 64bit 
simulation is recommended. 

— Time domain dynamic response 
• 32bit simulation shows the dynamic field response in Simulator window 
• 64bit simulation does not show the dynamic field response.  Simulation 

process (percentage of the simulation) is displayed.  The snapshot for 
time domain response in the certain time step for user selected 
observation area/line/point can be saved and viewed by Optiwave graph 
viewer 

— Volume DFT field results (steady state response)
• 32bit simulators calculate and record volume DFT field response (steady 

state response) for center wavelength
• 64bit simulators do not store the DFT field response for the whole volume 

anymore. However, the steady state response is calculated and stored 
for Observation Area/Line/Point for user-defined wavelength range. This 
data can be observed in the Analyzer, after completion of the simulations.

— Observation Detector and Spectrum Analysis
• 32bit simulations will record all the time domain response in the 

Observation detector (observation area, line).  User can specify any 
wavelength to perform the DFT spectrum analysis.  

• 64bit simulations perform the spectrum analysis for observation line and 
observation area in simulator.  No time domain response is recorded for 
Observation line and area.  Spectrum results, for user pre-defined 
wavelength, are saved to analyzer (result) file. In the Analyzer, the user 
can select a wavelength from the previously defined list and observe the 
corresponding spectral results in observation area analysis.  The user 
may define a wavelength range in the Layout Designer, in the “64-bit 
Simulation Parameters” dialog box (click the Spectrum button).

• One must set an observation detector (Observation Point, Observation 
Line, and Observation Area) to collect calculation results for 64bit 
simulation.

— Simulation
• 32bit FDTD simulation supports single processor.
• 2D 64bit FDTD simulation support single processor in OptiFDTD 8.0.
• 3D 64bit FDTD simulation support multi-processor (core)
• 2D TFSF excitation is only supported in 2D 32bit simulation in OptiFDTD 

8.0
— Tutorial lessons

• Tutorial lessons specify the 32bit simulation to demonstrate the product 
features. However, one can always use the 64-bit simulations to perform 
calculations, or simulate an equivalent example configured for 64-bit 
simulations. Typically, the 64bit simulations are faster. 

• If you use a 64-bit simulation instead of 32-bit one, then make sure that 
the following items are addressed:

— Please define an Observation Area/Line to collect steady state 
response, transmission function and reflection function

— If the input wave is Gaussian Modulated Continuous Wave, please 
define the wavelength range (click on the “Spectrum” button) in the “64-
bit Simulation Parameters” dialog box.
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This chapter is to help you familiarize yourself with the OptiFDTD Designer 
environment. Please use the following lessons for more detailed simulations on each 
project. 
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Lesson 1—Getting started

The OptiFDTD software has seven interdependent modules:
• OptiFDTD_Designer—Create the photonic devices to model
• OptiFDTD_Simulator—Perform the FDTD simulation and DFT analysis
• OptiFDTD_Analyzer—Post-process the simulated data
• FDTD Band Solver—Generate band diagram for photonic crystal
• PWE Band Solver- Band diagram analysis by PWE method
• Cross Section Layout Designer- Design Layout Cross Section and perform 

mode analysis
• Tool Box- Allows different post-date analysis

This lesson describes how to start using OptiFDTD to perform FDTD simulation. The 
procedures are:
• Create a new project

— Opening OptiFDTD_Designer

— Initializing the project

— Opening the Waveguide Profile Designer

— Defining the material

— Defining the 2D and 3D channel profile

— Setting up the initial properties

• Create a design
— Drawing a Linear Waveguide

— Drawing a Ring Waveguide

• Set up the Input Plane
— Inserting the Input Plane

• Observe the Refractive Index Distribution
— Observing the Refractive Index Distribution

• Set up observation points, areas, and lines
— Setting up an Observation Point

• Run the simulation
— Setting up the simulation parameters

— Running the 32bit simulation
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• Analyze the simulation results
— Opening OptiFDTD_Analyzer

— Analyzing the results

— Calculating the Mode Overlap Integral (MOI)

— Calculating the Input Overlap Integral (IOI)

— Calculating the Input Overlap Integral Scanner (IOIS)

— Calculating the Far Field Transform

— Performing the Observation Object Analysis

• Export results
— Exporting results
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Create a new project
The following lesson uses a micro-ring resonator as a sample design.

Note: The corresponding project file can also be found in the Sample file folder, 
Sample02_3D_Ring_Resonator.fdt.

To create a new project, perform the following procedures.

Opening OptiFDTD_Designer

Action 
• To open OptiFDTD_Designer, from the Start menu, select Programs > 

Optiwave Software > OptiFDTD > Waveguide Layout Designer.
OptiFDTD_Designer appears (see Figure 1)

Figure 1 OptiFDTD_Designer
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Initializing the project

Action 
• To initialize the project, from the OptiFDTD_Designer File menu, select 

New.
The Initial Properties dialog box appears (see Figure 2)

Figure 2 Initial Properties dialog box

Opening the Waveguide Profile Designer

Step Action 
1 To define the materials, in the Initial Properties dialog box, click Profiles 

And Materials.
The Waveguide Profile Designer opens (see Figure 3).
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Figure 3 Waveguide Profile Designer

Note: You can also open the Waveguide Profile Designer from the Start menu 
(see “Opening OptiFDTD_Designer” on page 93).

Defining the material

Step Action 
1 In the directory under OptiFDTD_Designer1, Materials folder, right-click the 

Dielectric folder.
A context menu appears (see Figure 4).

Figure 4 Context menu

2 Select New.
The Dielectric dialog box appears (see Figure 5).
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Figure 5 Dielectric dialog box

3 Type the following information

Name: Waveguide2.0

Refractive index (isotropic)(Re): 2.0

4 To save the material, click Store.

Note: Repeat steps 2 to Note: to create additional Dielectric materials.

Defining the 2D and 3D channel profile

Step Action 
1 In the directory under OptiFDTD_Designer1, under the Profiles folder, right-

click the Channel folder.
A context menu appears.
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2 Select New.
The Channel Profile dialog box appears (see Figure 6).

Figure 6 ChannelPro1 dialog box

3 Type the following Profile name: waveguide

4 To define the 2D profile, in the Material list under 2D profile definition, select 
Waveguide2.0 (refer to Figure 6).

5 To define the 3D profile, under 3D profile definition:

a. Type the following information (refer to Figure 6):

Layer name: WG

Width: 0.5

Thickness: 0.5

Offset: 0.

b. In the Material list, select Waveguide2.0
c. Click Add.
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6 To save the channel profile, click Store.
Waveguide appears in the Channel folder in the directory, in the dialog box 
title bar, and on the tab at the bottom of the layout.

7 To return to OptiFDTD_Designer, either minimize or close the Waveguide 
Profile Designer.

Setting up the initial properties

To set up the initial properties, perform the following procedure.

Step Action 
1 In the Initial Properties window, click the Waveguide Properties tab.

2 Type the following value (see Figure 7):

Width (µm): 0.5

3 From the profile list, select waveguide (Figure 7).

Figure 7 Initial Properties dialog box—Waveguide Properties tab

4 Click the Wafer Dimensions tab.

5 Type the following value (see Figure 8):

Length (µm): 8

Width (µm): 6
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Figure 8 Initial Properties dialog box—Wafer Dimensions tab

6 Click the 2D Wafer Properties tab.

7 From the Material list, select Air (see Figure 9).

Figure 9 Initial Properties dialog box—2D Wafer Properties tab
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8 Click the 3D Wafer Properties tab (see Figure 10).

Figure 10 Initial Properties dialog box—3D Wafer Properties tab

9 Under Cladding, from the Material list, select Air.
10 Under Substrate, from the Material list, select Air.
11 Type the following values:

Cladding thickness (µm): 2.5

Substrate thickness (µm): 0

Note: Cladding and substrate are two layers in the Y-direction that can have 
different materials and thicknesses. The Y-axis origin is at the interface 
between the substrate and cladding.

12 To finish the initial properties setup, click OK.
The layout window appears (see Figure 11).

Note: Click Zoom tool to enlarge the layout window.
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Figure 11 Layout window
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Create a design
To draw a micro-ring resonator, first draw a linear waveguide by performing the 
following procedures.

Drawing a Linear Waveguide

Step Action 
1 From the Draw menu, select Linear Waveguide.

2 In the layout window, drag the linear waveguide from the start point to the end 
point.
A linear waveguide appears in the layout window (see Figure 12).

Note: Release the Linear Waveguide selection tool by clicking the Select tool 
after the Linear Waveguide is drawn in the layout.

Figure 12 Linear Waveguide

3 To adjust the position and the shape of the waveguide, in the layout window, 
double-click the Linear Waveguide.
The Linear Waveguide Properties dialog box appears (see Figure 13).
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Figure 13 Linear Waveguide Properties dialog box

4 Click the Start tab and type the following values:

Horizontal offset (µm): 0

Vertical offset (µm): 2.0

Width (µm): 0.5

Depth (µm): 1.0

Label: linear1
Channel Thickness Tapering: Use Default (Channel: None)

5 Click the End tab and type the following values:

Horizontal offset (µm): 8.0

Vertical offset (µm): 2.0

Note: 
– You can also set a variable and even the expression—click Evaluate to 

see the final value of the expression.

– Horizontal means the z-direction.

– Vertical means the x-direction.

– Depth means the y-direction.
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6 From the Profile list, select Waveguide.

7 To save the new values and update the Linear Waveguide, click OK.
The modified Linear Waveguide appears in the new position (see Figure 14).

Figure 14 Modified Linear Waveguide
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Drawing a Ring Waveguide

Step Action 
1 From the Draw menu, select Ring Waveguide.

2 In the layout window, drag the Ring Waveguide from what will be the center, 
to a point which will be the radius of the outside ring (see Figure 15).

Figure 15 Ring Waveguide

3 To adjust the position and the shape of the Ring Waveguide, in the layout 
window, double-click the Ring Waveguide.
The Ring Waveguide Properties dialog box appears (see Figure 16).
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Figure 16 Ring Waveguide Properties dialog box

4 Type the following values:

Horizontal offset (µm): 4.0

Vertical offset (µm): –0.35
Major radius (µm): 1.8

Minor radius (µm): 1.8

Orientation Angle (degrees): 0
Channel Thickness Tapering: Use Default (Channel: None)

Width (µm): 0.5

Depth (µm): 1.0

Label: Ring1
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Note: The Ring Waveguide will be an elliptic ring if the two radii are set to different 
values.

5 From the Profile list, select Waveguide.

6 To save the new values and update the Ring Waveguide, click OK.
The modified Ring Waveguide appears in the new position (see Figure 17).

Figure 17 Modified Ring Waveguide

7 click 3D Layout Model button under layout window to observe the design in 
3D mode. (see Figure 18)
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Figure 18 3D Layout

Note: In 3D Layout window, left clicking the mouse and moving it can change the 
view angle. Right clicking and holding the mouse and moving it can change the 
position. Rolling the mouse can zoom in or out in the 3D layout.
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Set up the Input Plane
To insert the Input Plane and set the excitation, perform the following procedures.

Inserting the Input Plane

Step Action 
1 From the Draw menu, select Vertical Input Plane.

Note: 
– The Vertical Input Plane is in the x-y plane for 3D.

– The Horizontal Input Plane is only functional with a 2D simulation.

– Multiple Input Planes are only allowed in a 2D simulation.

2 Click in the layout window at the position where you want to insert the Input 
Plane.
A red line that presents the input plane appears in the layout window (see 
Figure 19).

Figure 19 Input Plane
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3 To set up the Input Plane properties, double-click the red line (Input Plane) in 
the layout window.
The Input Field Properties dialog box appears (see Figure 20).

Figure 20 Input Field Properties dialog box

4 Set the time domain Input Plane information.

a. Select Gaussian Modulated Continuous Wave.
The Gaussian Modulated CW tab appears.

b. Wavelength (µm): 1.4

Note: 
– For Continuous Wave, Wavelength is the single wavelength to be 

simulated.

– For Gaussian Modulated Continuous Wave, Wavelength is the carrier 
wavelength (center wavelength) for the pulse.

5 Click the Gaussian Modulated CW tab. 
The time domain pulse graphics appear.
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6 Type the following values for the time domain input plane (see Figure 21).

Time offset (sec.): 4.5e-14

Half width (sec.): 1.2e-14

Figure 21 Gaussian Modulated CW tab

Note: 
– Both the time domain wave and frequency domain wave for the Input 

Plane appear.

– The Frequency domain information is obtained by FFT from the time 
domain series.

– Right clicking on the graph allows you to select the graph tools.

– Time offset controls the time domain beam center.

– Half width controls the beam size and bandwidth.
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7 To set up the general information (transverse field distribution) for the Input 
Plane, click the General tab (see Figure 22).

a. Input Field Transverse: Modal
b. Z Position (µm): 0.63

c. Plane Geometry: Positive direction
d. Label: InputPlane1 (default)

Figure 22 General tab

Note: Positive Direction means the that the Input Plane is excited to the 
positive z-direction. Negative Direction means that the Input Plane is excited 
to the negative z-direction.
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8 To solve the 3D transverse mode, click the 3D Transverse tab (see 
Figure 23).

Figure 23 3D Transverse tab

9 Type the following Input Amplitude value (V/m): 1.0

10 Click Find Modes.
The Waveguide selection window appears (see Figure 24).
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Figure 24 Waveguide selection dialog box

11 Select the Linear Waveguide check box, select ADI-BPM Method.

12 To open the mode solver, click Calculate Mode.
The Globe Data: ADI Method dialog box appears (see Figure 25).

Figure 25 Global Data: ADI Method dialog box

13 Set the following:

Solver: Complex
Waveguide: Straight
Mode (initial excitation): Full Vector, Along Y
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Wavelength (µm): 1.4 (the same as the input wavelength by default, 
Read-Only)

Number of Modes: 1

14 Click the Settings tab and set Boundary Condition: TBC
15 To solve the mode, click Run.

The 3D Mode Solver opens (see Figure 26).

Figure 26 3D Mode Solver

Note: 
– The 3D Mode Solver can take a while to start up.

– It can take several minutes to solve the mode.

– A message appears to advise you if no mode has been found.

16 After solving the mode, click the field (Ex, Ey) tab to view the field pattern (see 
Figure 27).
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Figure 27 Major component Ey tab

17 To return to the Input Field Properties dialog box, close the 3D Mode Solver. 

18 To complete the Input Plane setup, click OK.
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Saving the layout

To save the layout you have created, perform the following procedure.

Note: Do not save your project over the sample file provided.

Step Action 
1 From the File menu, select Save As.

The SaveAs dialog box appears.

2 In the sample folder, enter the name of the file and click Save.
The new sample file is saved in the sample folder.

Note: .fdt is the file extension generated by OptiFDTD_Designer.
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Observe the Refractive Index Distribution
OptiFDTD provides a refractive index viewer to observe the refractive index 
distribution on any plane in three orientations. To observe the refractive index 
distribution, perform the following procedure.

Observing the Refractive Index Distribution

Step Action 
1 Click the 3D Ref. Index tab at the bottom of the layout window.

The 3D Refractive Index window opens (see Figure 28).

Figure 28 3D Refractive Index tab
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2 To view the graphic in height plot format, from the View menu, select 
3D Graph Items > Height Plot.

3 To view the x-y plane refractive index distribution, under Orientation, select 
X-Y Plane (see Figure 29).

Figure 29 Orientation—X-Y Plane

4 Move the Slicer slider to the desired position (see Figure 30)

Figure 30 Slicer
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5 To set more graphic view options, right-click anywhere in the graph (see 
Figure 31).

Figure 31 3D Graph Item view options menu

Set up observation points, areas, and lines 

Observation point, Line, area, are the post-data detector. Field pattern, transmission 
function and reflection function (versus wavelength) can be obtained with these 
detectors
• Observation Point—Observe the time domain and frequency domain response. 

The transmission function can be obtained from the Observation Point analysis If 
the point detector is put in the waveguide center where the peak value happens.

• Observation Area— Observe the field pattern for a give wavelength. compute 
power transmission ratio, and normalized power versus wavelength. When 
Observation area is put at the transmitted area, the power transmission function 
can be obtained. When Observation area is put at reflection area (beyond the 
input plane), reflection function can be obtained.  32bit simulation will record all 
the time domain response in the Observation area, user can specify any 
wavelength to perform the DFT spectrum analysis in analyzer. 64bit simulation 
performs the spectrum analysis, no time domain response is recorded. Spectrum 
results for user pre-defined wavelength will be save to analyzer. User can select 
the wavelength form the list to check the corresponding spectral results in 
observation area analysis.  To Pre-define the wavelength range for 64bit 
simulation, please click the Spectrum button in the 64bit simulation parameters 
dialog box.

• Observation Line—Only available for a 2D simulation. Observe the frequency 
domain response, compute power, and normalized power versus wavelength. 
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Setting up an Observation Point

Step Action 
1 From the Draw menu, select Observation Point.
2 Click in the layout window where you want to place the Observation Points 

(see Figure 32).

Figure 32 Observation Points

3 Double-click the first observation point.
The Observation properties -- Point dialog box appears (see Figure 33).
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Figure 33 Observation properties -- Point dialog box

4 To adjust the position of the observation point, click the General tab and type 
the following:

Horizontal Offset (µm): 1.2

Vertical Offset (µm): 2.0

Center depth (µm): 1.25

Label: ObservationPoint1 (default)
122



  LESSON 1—GETTING STARTED
5 To select the field components, click the Data Components tab (see 
Figure 34).

Figure 34 Data Components tab

a. Under 3D, select the Ex check box.

b. Under 3D, select the Ey check box.

6 Repeat steps 3 to 5 for the second observation point, using the following 
values:

Horizontal Offset (µm): 7.0

Vertical Offset (µm): 2.0

Center depth (µm): 1.25

Label: ObservationPoint2 (default)

Data Components:

 i. Under 3D, select the Ex check box.

 ii. Under 3D, select the Ey check box.
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Run the simulation
To run the simulation, perform the following procedures.

Note: When you run this simulation for the first time, it is recommended that you 
run the 2D simulation first. To run the 3D simulation based on this sample file may 
take up a lot of CPU resources. It is suggested that you use FDTD_Analyzer to 
open the corresponding results file that can be found on the set-up CD.

Setting up the simulation parameters
Step Action 
1 From the Simulation menu, select 3D 32bit Simulation Parameters.

The 3D Simulation Parameters dialog box appears (see Figure 35).

Figure 35 3D Simulation Parameters dialog box

2 Type the following values for the mesh size:

Mesh Delta X (µm): 0.08
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Mesh Delta Y (µm): 0.05

Mesh Delta Z (µm): 0.08

Note: The total mesh number for each orientation will be calculated 
automatically, once focus is removed from the specific edit region.

3 To set up the boundary condition parameters, click Advanced.
The Boundary Conditions dialog box appears (see Figure 36).
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Figure 36 Boundary Conditions dialog box

4 Type the following values for the boundary condition:

Anisotropic PML layer number: 15

Theoretical Reflection Coefficient: 1.0e-12

Real Anisotropic PML Tensor Parameter: 1.0

Power of grading Polynomial: 3.5

Note: 
– Un-split Perfectly Matched Layer (UPML) was used for the boundary 

condition in this software. For more information, refer to the OptiFDTD 
Tutorials and Technical Background.

– The default setting for UPML parameters in OptiFDTD ensures that the 
outgoing waves are absorbed properly. We recommend that you use the 
default setting unless you are familiar with UPML boundary conditions.

5 To save the boundary condition setting, click OK.

6 Under Time Parameters, perform the following:

a. Click Calculate to calculate the time step value.
The new value — 8.3391023799538e-017 — appears in the Time Step 
Size field (see Figure 37).

b. Type the number of time steps to run: 10000 (see Figure 37).
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Note: The time step value is calculated from the minimum mesh size.

Figure 37 Time Parameters

7 From the Key Input Field drop-down list, select Input Plane1 and 
wavelength 1.4 (see Figure 38).

Note: 
– Key input selection is used to obtain the wavelength for DFT calculation 

in the simulation.

– For 3D simulations, there is only one input plane.

Figure 38 Key Input Field

8 Under DFT Options, select the DFT components that you want to simulate 
(see Figure 39).

Figure 39 DFT Options

9 Select Ey check box.

Note: 
– The discretized Fourier transform (DFT) will run for the selected field 

components for the key input wavelength in the simulator.

– The DFT results will be saved for performing post simulation analyses, 
such as Far Field Pattern, Mode Overlap Integral calculation, Input 
Overlap Integral calculation, and observation of the frequency domain 
field pattern.
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10 To start 3D 32bit simulation, click Run in the simulation dialog box.

Note: 64bit simulation on multiple core system will be much faster than 32bit 
simulation. To perform the 64bit simulation, please read the chapter “know the 
difference between 32bit simulation and 64bit simulation” or tutorial lesson 18
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Running the 32bit simulation

OptiFDTD_Simulator is a separate window that displays the simulation as it runs.

Step Action 
1 To observe the simulated field components in one slice, perform one of the 

following (see Figure 40):

Figure 40 3D Simulation results

– From the View menu, select 3D Graph Items, and then select the type 
of view that you want (for example, Height Plot, Image Map, or Plane 
View).

– To open the a context menu listing the 3D Graph Items, right-click 
anywhere in the graph (see Figure 41).
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Figure 41 3D Graph Items list

– Select the field components and refractive index that you want to view by 
clicking the corresponding tab (see Figure 42).

Figure 42 Component tabs

– To specify the slice orientation and the position, move the Slice Chooser 
slider to the desired value (see Figure 43)

Figure 43 Slice Chooser

– To specify the step interval number for updating the simulated field data, 
select a new value from the View Update list (see Figure 44).

Figure 44 View Update list

2 To pause, resume, stop and finalize the simulation, from the Simulation 
menu, select the action you want to perform

OR

Click the corresponding button on the Simulation toolbar (see Figure 45).

Figure 45 Simulation toolbar
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3 To view the observation point in the simulator, from the View menu, select 
Observation Points.
The Observation Area Analysis dialog box appears (see Figure 46).

Figure 46 Observation Area Analysis dialog box

4 To observe the time domain response on a single point, select the following 
(refer to Figure 46):
– field components

– observation point

– time
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5 To observe the frequency domain response on a single point, select the 
following (refer to Figure 46):
– field components

– observation point

– Frequency FFT 

6 To change the x-axis to frequency or wavelength, click 
Frequency/Wavelength.
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Analyze the simulation results
In this lesson, you have created a design, run a simulation, and loaded the 
corresponding simulation results file into OptiFDTD_Analyzer. The following analysis 
is based on this sample.

OptiFDTD_Analyzer displays the simulation results and allows you to perform a post-
simulation analysis. To analyze the simulation results, perform the following 
procedures.

Note: If you do not use the simulation results file sample you created, the 
OptiFDTD software CD has the results file available. Copy it and open the file 
using the OptiFDTD_Analyzer.

Opening OptiFDTD_Analyzer

OptiFDTD_Analyzer can be opened in one of two ways.

From OptiFDTD_Simulator

When the simulation ends, a message appears and prompts you to open 
OptiFDTD_Analyzer (see Figure 23).

Figure 47 Message box

Action 
• To open OptiFDTD_Analyzer and view the simulated results, click Yes.

Note: When the simulation ends in OptiFDTD_Simulator, the results are 
saved automatically as a file with same name, but with a different file 
extension (*.fda).

From the Start menu

Step Action 
1 From the Start menu, select Programs > Optiwave Software > OptiFDTD  

> Results Analyzer.
OptiFDTD_Analyzer opens (see Figure 48).
133



  LESSON 1—GETTING STARTED
Figure 48 OptiFDTD_Analyzer

2 To open an existing simulation results file (*.fda), from the File menu, 
select Open (see Figure 49).

Figure 49 File menu
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Analyzing the results

Step Action 
1 View the field distribution (after the DFT results) for the center (carrier) 

wavelength (see Figure 50).

Figure 50 Field distribution

Note: 
– You can specify the orientation and the observation plane position.

– You can only view the simulation results and the Poynting Vector for the 
components that you selected for DFT calculation in the 3D Simulation 
Parameters dialog box.

Note: Proceed to the next step if the required components have been selected in 
the layout for the Power calculations.

2 Calculate and observe the Power value and the Normalized Power value (to 
the input plane) for the current slice position.

Note: 
– The power calculation is available only if related components are 

selected in the 3D Simulation Parameters dialog box.
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– The power types for each slice are power in two-direction polarization 
and the total power.

Calculating the Mode Overlap Integral (MOI)

You can perform the Mode Overlap Integral (MOI) calculation on the X-Y plane only.

Step Action 
1 Under Orientation on the Slice Chooser, select X-Y Plane.

2 Move the slider position to 7.2µm (see Figure 51).

Figure 51 Slice Chooser

3 In the Analysis Tools window, click the MOI tab.
The MOI tab appears (see Figure 52).
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Figure 52 MOI tab

4 Type or select the following information:

DFT Result: Y-Polarization
Region: Index
X Lower: 0

X Upper: 75

Y Lower: 0

Y Upper: 50

Offset: 0

Note: The default parameters are for the entire slice region.

5 To find the mode on the current slice, click Mode.
When the mode solver finds a mode, the Calculate button becomes 
available.
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Note: Ensure that the mode solving in this step has the same conditions are 
as the ones you used when you solved the mode for the Input Plane. Refer 
to Steps 13, 14, and 15 on page 114.

6 To perform the MOI calculation, click Calculate.
The results appear under Statistics in the Result field (see Figure 53).

Figure 53 MOI calculation results

Calculating the Input Overlap Integral (IOI)
• Compare the simulated output and the input

Step Action 
1 Under Orientation on the Slice Chooser, select X-Y Plane.
2 Move the slider position to 7.6µm
3 In the Analysis Tools window, click the IOI tab.

The IOI tab appears (see Figure 54).

Figure 54 IOI tab
138



  LESSON 1—GETTING STARTED
Note: Use the default settings for the IOI calculation parameters.

4 To perform the IOI calculation, click Calculate.
The results appear in Statistics in the Results field (see Figure 55).

Figure 55 IOI calculation results

Calculating the Input Overlap Integral Scanner (IOIS)
• Compare the input field and the output field at each X-Y slice. 
• Power transmission ratio to the input wave at z-direction

Step Action 
1 Under Orientation in the Slice Chooser, select X-Y Plane.

2 In the Analysis Tools window, click the IOIS tab.
The IOIS tab appears (see Figure 56).

Figure 56 IOIS tab
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Note: Use the default settings for the IOIS calculation parameters.

3 To perform the IOIS calculation, click Calculate.
The results graph appears in the Overlap Scan window (see Figure 57).

Figure 57 IOIS calculation results

Note: 
– The IOIS calculation goes through the entire Z-direction.
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Calculating the Far Field Transform

Step Action 
1 Under Orientation on the Slice Chooser, select X-Y Plane.

2 Move the slider position to 7.6µm

3 In the Analysis Tools window, click the Far Field tab.
The Far Field tab appears (see Figure 58).

Figure 58 Far Field tab

Note: You can select DFT components at any slice to perform the far field 
calculation.

4 Select the following information:

DFT Result: Ey
X-axis angle: 83.3056

Y-axis angle: 81.3692

Wavelength: 1.4µm

Refractive Index: 1
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5 To perform the far field transform, click Calculate.

6 To view the far field distribution, click the Far Field tab at the bottom of the 
layout window (see Figure 59).

Figure 59 Far field calculation result

7 To save the Far Field Transform results, in the Analysis Tools window, click 
Export.
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Performing the Observation Object Analysis

Step Action 
1 From the Tools menu, select Observation Area Analysis.

The Observation Area Analysis dialog box appears (see Figure 60).

Figure 60 Observation Area Analysis dialog box

2 Click the Observation Point tab to perform the observation point analysis.

a. To view the Time Domain Response:

 i. Click Times (fs).
 ii. Under Label, select the check box for the observation point or points 

that you want to view.

 iii. Select the tab under the graph for the field component that you want 
to view.
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Figure 61 Observation Point analysis—Time Domain Response

b. To view the Frequency Domain Response:

 i. Click Frequency DFT.

 ii. Under Label, select ObservationPoint2.

 iii. Select the field component Ey.

 iv. Set the wavelength/frequency range and the sampling point number.
Minimum wavelength: 1.2µm
Maximum wavelength: 1.6µm
Sampling point: 1000

 v. Click Update Graph to view the graph (see Figure 62).

 vi. To set the X-axis units, click Wavelength/Frequency.
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Figure 62 Observation Point analysis—Frequency Domain Response

Note: You can specify the type of curve—amplitude, phase, real part, 
Imaginary part, or decibel.

c. To calculate the transmission/normalized response:

 i. Click Frequency DFT.

 ii. Under Label, select ObservationPoint2.

 iii. Select the field component Ey.

 iv. Set the wavelength/frequency range and the sampling point number.
Minimum wavelength: 1.2µm
Maximum wavelength: 1.6µm
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Sampling point: 1000
 v. Select Normalized with.

 vi. In the Input plane list, select Input Plane1.

 vii. Select dB to view the transmission function.

 viii.Click Update Graph to view the graph (see Figure 62).

Figure 63 Observation Point Analysis—Normalized response

Note: The following two steps can only be executed if the Observation Area 
and the Line have been designed in the Layout window.

3 Click the Observation Area tab to perform the observation area analysis and 
follow the substeps for Observation Point.

4 Click the Observation Line tab to perform the observation line analysis (2D 
simulation only) and follow the substeps for Observation Point.
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Export results
You can export the DFT results, refractive index, Poynting Vector, and layout in the 
desired slice from OptiFDTD_Analyzer to a location that you choose.

Exporting results

Step Action 
1 From the File menu, select Export.

The Export Data dialog box appears (see Figure 64).

Figure 64 Export results

2 Select the results that you want to export, and click Export.
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Lesson 2—Input wave setup

OptiFDTD contains more features in the Input Wave set up and the simulation set up. 
The excitation set up for the simulation is done by the Input Plane which contain the 
following features:

Time Domain Input Wave formation
• Continuous Wave with single wavelength
• Pulse wave with broad band spectrum

Transverse field distribution
• Modal Input
• Gaussian beam
• Rectangular beam
• User defined Transverse

Polarization formation
• Linear polarization
• Circular Polarization

Input Wave direction

Power

Amplitude

The following procedures illustrate how to set up the input wave.

There is no specific layout used to show the input wave setup in this lesson. The text 
explanation and graphs are in general format only.

Note: This lesson presumes that you are familiar with the layout design and you 
use the sample lessons for reference.
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Drawing an Input plane in the layout

To draw an input plane in the layout, perform the following procedure.

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 Place the Input Plane in the layout at the desired position.
A red line that presents the input plane appears in the layout window (see 
Figure 65).

Figure 65 Vertical Input Plane

3 To set up the input wave properties, double-click the red line (Input Plane).
The Input Field Properties dialog box appears (see Figure 66).
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Figure 66 Input Field Properties dialog box

4 In the Input Field Properties dialog box, set the Position and the desired 
wave propagation direction.

Note: For 2D simulations, a multiple input plane in vertical and horizontal 
position can be designed.

5 To select a Single Wavelength Input Wave:

a. Click Continuous Wave (CW).

b. Type the wavelength value.

6 To select a Pulse Input----Spectral Input Wave:

a. Click Gaussian Modulated Continuous Wave (GMCW).
The Gaussian Modulated CW tab appears in the Input Field Properties 
dialog box (see Figure 67).
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Figure 67 Input Field Properties dialog box—Gaussian Modulated CW tab

7 Type the center wavelength value in Wavelength box.

8 Click the Gaussian Modulated CW tab to edit the Pulse parameters.
Time domain and frequency domain input wave curves appear in the user 
interface (see Figure 68).

Note: Right-click on the curve to use the graph tool to view or edit the graph 
(zoom in or out, for example).

Figure 68 Time domain and frequency domain input wave curves
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9 Set the time offset and the half width of the input wave in time domain.
This will adjust the spectrum width.

10 Right-click in the graph.
The graph tool appears.

11 Select Zoom in the toolbar, and zoom into the region to see the detail of the 
time domain and frequency domain wave.

Setting up the 3D Transverse Mode Input

Step Action 
1 Click the General tab to return to the Transverse selection page

2 Click Modal.
3 Click the 3D Transverse tab to solve the 3D mode.

The 3D modal transverse field summary page appears (see Figure 69).

Figure 69 3D Modal Transverse field summary

4 Input power value or the amplitude of the input transverse mode.

Note: Amplitude value will be the maximum value of the input electrical field.
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5 Click Find Modes to solve the mode.
The Waveguide selection dialog box appears (see Figure 70).

Figure 70 Waveguide selection dialog box

6 In the Waveguide list, select a waveguide to solve the mode.

7 Click Calculate Mode.
The Global Data: ADI Method dialog box appears (see Figure 71).

Figure 71 Global Data: ADI method dialog box
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8 In the Global Data: ADI Method dialog box, set up the mode solver 
parameters, as shown in Figure 71.

9 Click the Settings tab to set the initial guess field for solving the mode by ADI 
method.

Note: Three types of Boundary condition are available—Homogeneous, 
Neumann, and TBC. TBC is suggested.

10 Set the Accuracy and Acceleration parameters for controlling the mode 
solver.

11 Click the Wafer and Waveguide tabs to see the summaries of the wafer and 
waveguide properties.

12 Return to the Global Data: ADI Method dialog box.

13 Click Run.
The Mode Solver interface appears (see Figure 72).

Figure 72 Mode Solver interface—Refractive Index graph

When the Mode Solver finds the mode, results will be shown in the Mode 
solver as well as the Effective refractive index and transverse layout (see 
Figure 73).
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Figure 73 Major component Ey view
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Setting up the 2D Transverse Mode Input

Step Action 
1 Click the General tab in the Input Plane Properties dialog box.

2 Click Modal.

3 Click the 2D Transverse tab to solve the 2D mode (see Figure 74).

Figure 74 Input Plane Properties dialog box—2D Transverse tab

4 Click Find Modes to set the 2D mode Solver.
The Mode Solver 2D dialog box appears (see Figure 75).
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Figure 75 Mode Solver 2D dialog box

5 Select the waveguides for Mode calculation.

6 Click the Parameters tab to edit the calculation parameters (see Figure 76).
– Set Sample points

– Number of modes

– TE or TM selection

Figure 76 Parameters tab
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7 Click Calculate Mode.
The calculation summary appears in the Mode Solver 2D dialog box (see 
Figure 77).

Figure 77 Mode Solver 2D dialog box—Modes tab

8 From the mode list, select the mode.
The mode distribution will be shown in the dialog box (see Figure 78).
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Figure 78 Mode Solver 2D dialog box

9 Click Graph Setting to select the graph feature.

10 Select a mode and click Apply Data.
This mode will be used as the 2D transverse input wave. 

Setting up the 3D Transverse Gaussian Beam Input

Step Action 
1 Click the General tab in the Input Field Properties dialog box.

2 In the Input Field Transverse area, select Gaussian.

3 Click the 3D Transverse tab.
The 3D Transverse tab appears (see Figure 79).
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Figure 79 3D Transverse dialog box

4 Define the Gaussian beam in the Gaussian Transverse region.

5 Select the Auto check box.
The Waveguide tab appears (see Figure 80).

Figure 80 Waveguide tab
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6 Click the waveguide in the list to observe the position (see Figure 81).

Figure 81 Waveguide position

7 Click the 3D Transverse tab, and select Modal, Local, or User in the 
Effective Refractive Index area.

Note: This refractive index will be used for calculating the magnetic 
components from electrical components and calculating the projection field if 
the tilting waveguide is used.

8 Specify the Gaussian beam polarization formation in the Polarization area 
(see Figure 82).

Figure 82 Polarization area
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OptiFDTD provides five polarization options:

– Linear X

– Linear Y

– Linear Theta

– Left Hand Circular 

– Right Hand Circular 

9 Set the Gaussian beam's power and amplitude.

Setting up the 2D Transverse Gaussian Beam Input

A 2D Gaussian beam setup is the same as 3D definition except that:
• 2D Gaussian beam is defined in one dimension
• TE /TM polarization

Setting up the 3D Transverse Rectangular Beam

The setup for a 3D rectangular beam is the same as that of the 3D Gaussian beam, 
except the wave formation stays in a rectangular shape in the rectangular region.

Setting up the 2D Transverse Plane Wave Input (rectangular beam)

The setup for a 2D rectangular beam is same as that of the 2D Gaussian beam, 
except the wave formation stays in a rectangular shape in the rectangular region.

Point Source
More information regarding the Point Source can be found in the Technical 
Background.

Setting up a Point Source

Step Action 
1 Click Select Point Source from the toolbar.

2 Place the Input Plane in the layout at the desired position.
A red circle indicates the location of the point source (see Figure 83).
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Figure 83 Point Source in Input Plane layout

3 To set up the input wave properties, double-click the Point Source in the 
layout.
The Point Source Properties dialog box appears.
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Figure 84 Point Source Properties dialog box

4 In the Point Source Properties dialog box, set up the position information:

Note: 
• Horizontal direction is z-direction

• Vertical direction is x-direction

• Depth controls the y-direction which is for 3D simulation.

5 Specify the Time Domain Waveform and enter a value in Wavelength.

Note: If you want to use Gaussian Modulated Continuous Wave, select 
Gaussian Modulated Continuous Wave in the Time Domain Waveform 
Selection dialog box.

6 Enter the Amplitude value in the Amplitude box (bottom right).

7 In the 3D Field Component area, select an electrical component to hold the 
point source.

Note: For 2D TE simulation, the point source is functional to major 
component  Ey. For 2D TM simulation, point source is functional to major 
component Hy.

Note: You can edit any point source using the Point Source Properties 
dialog box by making a selection from the drop-down list accessible with 
Select a point source. Also, multiple point sources can be placed in the 
same position.
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Lesson 3—Photonic crystal and photonic band 
gap simulation

OptiFDTD provides comprehensive design, simulation, and post-analysis tools for 
photonic crystal (PhC) and photonic band gap (PBG) analysis:
• layout designer provides the tools to define the lattice relation, atom properties, 

defects, wave path, and observation projects
• band solver is an independent simulation engine that gives the band-diagram for 

the defined lattice structure
• simulator can perform the plane wave simulation based on the periodic cell with 

a periodic boundary condition
• analyzer can view the field pattern and extract the transmittance/reflection 

coefficients

Note: The band solver is investigated in Lesson 9.

This lesson includes two samples:
• Sample 1 demonstrates how to define the PBG layout and how to extract the 

transmittance/reflection. The corresponding project file can be found in the 
Samples folder: Sample10_2D_TE_PBG_Y_Branch.FDT.

• Sample 2 demonstrates a plane wave simulation based on the periodic cell of 
PhC. The corresponding project file can be found in the Samples folder: 
Sample09_2D_TE_PBG_Domain_Reduced_Square_Lattice.FDT.

Sample 1---PGB Layout

Designing a PBG structure
To design a PBG structure, perform the following procedures.

Step Action 
1 Start Waveguide Layout Designer.
2 To create a new project, select File > New.

The Initial Properties dialog box appears.

3 Click Profiles and Materials.
The Profile Designer window appears.

4 Under the Materials folder of OptiFDTD Designer1, right-click the Dielectric 
folder and select New.
A new Dielectric material dialog box appears.

5 Type the following information:
Name: PBG_atom
Refractive index (Re:): 3.1

6 To save the material, click Store.
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PBG_atom appears in the Dielectric folder in the directory and in the dialog 
box title bar.

To define the channel profile, perform the following procedure.

Step Action 
1 Under the Profiles folder of OptiFDTD Designer1, right-click the Channel 

folder and select New.
The ChannelPro1 dialog box appears.

2 Create the following channel profile:

Profile name: Profile_PBG

2D profile definition
Material: PBG_atom

3D profile definition
Layer name: layer_01
Width: 1.0
Thickness: 1.0
Offset: 0.0
Material: PBG_atom

3 Click Store.

4 Close the Profile Designer.

To define the wafer and waveguide properties, perform the following procedure.

Step Action 
1 In the Initial Properties dialog box, , type/select the following:

Waveguide Properties
Width [μm]: 1.0
Profile: Profile_PBG

Wafer Dimensions
Length [μm]: 21.0
Width [μm]: 15.0

2D Wafer Properties
Material: Air

3D Wafer Properties
Cladding

Thickness [μm]: 1.0
Material: Air

Substrate
Thickness [μm]: 1.0
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Material: Air
2 Click OK.

The Initial Properties dialog box closes.
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Creating the PBG structure

Step Action 
1 From the Draw menu, select PBG Crystal Structure.

2 In the layout window, drag the cursor from a designated starting point and 
release, to create the PBG area.
The PBG Crystal Structure appears in the layout window (see Figure 85).

Figure 85 BPG crystal structure in layout

3 To edit the crystal structure, double-click on the PBG structure in the layout.
The Crystal Lattice Properties dialog box appears (Figure 86).
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Figure 86 Crystal Lattice Properties dialog box

4 In Origin, Offset, type/select the following:

Horizontal: 1.0

Vertical: -6.928

5 Click Evaluate.

6 Type/select the following:
Depth: 0.0
Azimuth [deg]: 0.0

7 In Lattice Properties, Type, select 2D Hexagonal.

8 In Fill, select Block.

9 In Lattice Dimensions, type/select the following:
Scale: 1.0
#A: 17
#C: 19
Note: When a 2D lattice is selected, the Y-direction cell #B is set to the 
default value of 1.

10 In Label, type PBGCrystalStruct1.

Note: Do NOT close the Crystal Lattice Properties dialog box.
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Setting the atom properties
To set the atom properties, perform the following procedure in the Crystal Lattice 
Properties dialog box.

Step Action 
1 In Atom Waveguide in Unit Cell, Add New, select Elliptic Waveguide from 

the drop-down menu and click New.
The Elliptic Waveguide Properties dialog box appears (see Figure 87).

2 In Center, Offset, type/select the following:
Horizontal: 0.0
Vertical: 0.0

3 Type/select the following:
Major radius: 0.3
Minor radius: 0.3
Orientation angle: 0.0
Channel thickness tapering: Use Default (Channel: None)
Depth: 0.0
Label: Atom
Profile: Profile_PBG.

4 Click OK.
The Elliptic Waveguide Properties dialog box closes.

Note: When you return to the Crystal Lattice Properties dialog box, you will see 
the defined elliptic waveguide listed in Atom Waveguide in Unit Cell.
Note: If you close the Crystal Lattice Properties dialog box, you will see the 
defined PBG structure in the layout window (see Figure 88).
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Figure 87 Elliptic Waveguide Properties dialog box
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Figure 88 PBG structure in layout window

There are three ways to create a cell with special properties.

Step Action 
1 In the Crystal Lattice Properties dialog box, set the cell position nodes:

Edit Options
i: 8
j: 0
k: 0

2 Click Edit Cell (i,j,k) button.
The Edit Basis Cell dialog box appears (see Figure 89).
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Figure 89 Edit Basis Cell dialog box

Note: To deactivate the basic cell, deselect Cell On. The region will then be 
recovered to the wafer material.

3 Select an atom in the list to edit (in this case, Elliptic Waveguide 
[5.000,0.000]).

4 Click Edit Properties.
The Elliptic Waveguide Properties dialog box appears.

5 Type/select the following:
Major radius: 0.5
Minor radius: 0.4

6 Click OK.

The cell's index definition for Hexagonal is shown in Figure 90.

Figure 90 Cell index definition for Hexagonal
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Figure 91 PBG layout with defective cell

OR

Step Action 
1 In the layout designer, to select the PBG lattice, click the PBG area.

A green dot appears in the PBG structure and the PBG Crystal Structure 
Cell Editing Tool becomes active.

2 Select the PBG Crystal Structure Cell Editing Tool icon.

3 Double click on the atom in the Cell (13, 0, 5).
The Elliptic Waveguide Properties dialog box appears.

4 Type/select the following:
Major radius: 0.4
Minor radius: 0.5

5 Click OK to return to the layout window.
The atom at cell (13,0,5) becomes the defective atom (see Figure 92).
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Figure 92 Defective atom at Cell 13,0,5

OR

Step Action 
1 In the layout designer, to select the PBG lattice, click the PBG area.

A green dot appears in the PBG structure and the Tools toolbar, including the 
PBG Crystal Structure Cell Editing Tool, becomes active.

2 Select the PBG Crystal Structure Cell Editing Tool, and right-click on the 
atom in cell (3, 0, 10).
The PBG Cell Edit context menu appears (see Figure 93).

3 Select Cell Properties.
The Edit Basis Cell at 3,0,10 dialog box appears.
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4 Click Edit Properties.
The Elliptic Waveguide Properties dialog box appears.

5 Type/select the following:
Major radius: 0.3
Minor radius: 0.3

Figure 93 PBG Cell Edit context menu

6 In Center, Offset, type/select the following:
Horizontal: 12.2
Vertical: -4.1

7 Click OK to close the Elliptic Waveguide Properties dialog box.
8 Click OK to close the Edit Basis Cell at 3,0,10 dialog box.

The atom at cell (3,0,10) becomes the defective atom (see Figure 94).

Figure 94 Defective atom at Cell 3,0,10
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In general, you define the lattice and atom for all the cells in the PBG Lattice 
Properties dialog box. This is called the Unit cell information. It works like a template; 
the information in a specified cell is called Basic Cell information. The defect is made 
in the selected basic cell.

In order to reset defective cells to the unit cell properties, in the Crystal Lattice 
Properties dialog box, Reset All to Unit Cell must be selected.

Note: If you already tried this, please select Undo in the Edit menu, because the 
next step in this lesson uses the layout including the defective cells.

Recovering a defective cell at (8, 0, 0) to unit cell 

Step Action 
1 In the layout designer, to select the PBG lattice, click the PBG area.

A green dot appears in the PBG structure and the Tools toolbar, including the 
PBG Crystal Structure Cell Editing Tool, becomes active.

2 Select the PBG Crystal Structure Cell Editing Tool, and right-click on the 
atom in cell (8, 0, 0).
The PBG Cell Edit context menu appears.

3 Select Reset to Unit Cell.
The cell values are reset to correspond to the basis cell.

Now you will create a Y-branch wave path in this PBG layout.

Step Action 
1 In the layout designer, to select the PBG lattice, click the PBG area.

A green dot appears in the PBG structure and the Tools toolbar, including the 
PBG Crystal Structure Cell Editing Tool, becomes active.

2 Select the PBG Crystal Structure Cell Editing Tool, and right-click on the 
atom in cell (8, 0, -4).
The PBG Cell Edit context menu appears.

3 Select Cells Off.
The cell is disabled.

4 Repeat steps 2 to 3 to disable the following cells:
– (8,0,-3) to (8,0,1)
– (9,0,1) to (13,0,1)
– (13,0,2) to (13,0,12)
– (7,0,2), (6,0,3),(5,0,4), (4,0,5)
– (3,0,6) to (3,0,17)
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Figure 95 PBG layout with new wavepath

Now you have finished the PBG layout. The next step is to set up the FDTD 
simulation.

After you define a lattice, you can use the FDTD band solver to get the preliminary 
band-diagram ( see “Lesson 9—FDTD Band Solver” on page 263).

The PBG layout can also be defined by using VB scripting. The corresponding sample 
file for VB scripting can be found in the Samples folder: 
Sample21_Vbscript_PBG_Layout.FDT.

Inserting the input plane
To insert the input plane, perform the following procedure.

Step Action 
1 From the Draw menu, select Vertical Input Plane.
2 To insert the input plane, click in the layout window where you want it placed.

The input plane appears in the layout.
3 To edit the input plane, double-click on the input plane in the layout.

The Input Plane Properties dialog box appears.
4 Set Wavelength to 1.9 μm.
5 Select Gaussian Modulated Continuous Wave.
6 On the Gaussian Modulated CW tab, type/select the following:

Time Offset [Sec]: 5.5e-14
Half Width [Sec]: 1.1e-14
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7 On the General tab, select Input Field Transverse: Gaussian.

8 On the 2D Transverse tab, type/select the following:

Center Position [μm]: 0.0

Halfwidth [μm]: 0.8

Tilting Angle [deg]: 0.0

Effective Refractive Index: Local

Amplitude [V/m]: 1.0

9 On the General tab, type/select the following:

Plane Geometry
Z Position [μm]: 1.3
Positive direction

10 Click OK.
The Input Field Properties dialog box closes.

Setting up the Observation Point

Step Action 
1 From the Draw menu, select Observation Point.
2 Place the Observation Point in the desired position in the layout.

3 Double-click the observation point.
The Observation Properties -- Point dialog box appears.

4 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 19.5μm
Vertical: 4.33μm

Center depth: 0.0 μm
Label: Observation Point1

5 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

6 Click OK.
The Observation Properties -- Point dialog box closes.

7 Repeat steps 1 to 5 and create another Observation Point with the following 
information.

8 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 19.5μm
Vertical: -4.33μm

Center depth: 0.0 μm
Label: Observation Point2
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9 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

10 Repeat steps 1 to 5 and create another Observation Point with the following 
information.

11 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 0.8μm
Vertical: 0.0μm

Center depth: 0.0 μm
Label: Observation Point3

12 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

Note: Observation Point1 and Observation Point2 are used to get the 
transmittance, while Observation Point3 is for the reflection.

Setting the 2D TE FDTD simulation parameters

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears.

2 Type/select the following information:

Polarization: TE
Mesh Delta X [μm]: 0.1

Mesh Delta Y [μm]: 0.1

3 Click Advanced....
The Boundary Conditions dialog box appears.

4 Type/select the following information:

-X: Anisotropic PML
+X: Anisotropic PML
-Z: Anisotropic PML
+Z: Anisotropic PML
Anisotropic PML Calculation Parameters

Number of Anisotropic PML Layers: 10
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameters: 5.0
Power of Grading Polynomial: 3.5

5 In Time Parameters, click Calculate.
The default time step size is calculated.

6 Select Run for 10000 Time Steps (Results Finalized).
7 Select Key Input Information: Input Plane1 and 

wavelength:1.9.
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Note: The input plane’s center wavelength is used for DFT calculations.

8 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.

Note: Before running the simulation, save the project to a file.

Observing the simulation results in OptiFDTD Simulator

Key things to observe:
• Refractive index distribution
• Observe the wave propagation in OptiFDTD Simulator (see Figure 96)
• Select View > Observation Point to observe the dynamic time domain and 

frequency domain response (see Figure 97).

Figure 96 Wave propagation in OptiFDTD Simulator
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Figure 97 Dynamic time domain and frequency domain response
184



  LESSON 3—PHOTONIC CRYSTAL AND PHOTONIC BAND GAP SIMULATION
Performing data analysis

In OptiFDTD_Analyzer, you can perform the following analysis for this sample:
• Observe the Layout, Refractive index, Poynting Vector, and field propagation 

pattern (DFT results) for the center wavelength (see Figure 98 for Poynting 
Vector-Z).

Figure 98 OptiFDTD Analyzer

• Observe the transmission/reflection calculations

Step Action 
1 To start the observation point analysis, from the Tools menu, select 

Observation Area Analysis.
The Observation Area Analysis dialog box appears (see Figure 99).

2 Select ObservationPoint1 and ObservationPoint2.
The simulation results from the observation points displays in the graph 
window.

3 Type/select the following:

Frequency DFT
Min. /f : 1.5μm
Max. /f : 2.3μm
Sample Point: 1000

λ
λ
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Normalize With
InputPlane1

dB
Amplitude

Figure 99 Observation Area Analysis dialog box
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Sample 2---Plane wave simulation based on the periodic cell of PhC

Most of the photonic crystal has the periodic lattice. In some cases, you may 
want to know the band gap effect for such a lattice. As discussed in the 
OptiFDTD Technical Background, this task can be simplified in an FDTD 
simulation using plane wave excitation and PEC/PMC boundary conditions. 
For example, Figure 100 shows a 2D square lattice going to infinity in both 
x- and  z directions.

Figure 100 2D square lattice

You can simulate the structure shown in Figure 100 by taking a domain-reduced 
region (shown in Figure 101) with a plane wave and PMC boundary conditions for 2D-
TE wave.

Figure 101 Domain reduced region
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Designing a PBG structure

To design a PBG structure, perform the following procedures.

Step Action 
1 Start Waveguide Layout Designer.
2 To create a new project, select File > New.

The Initial Properties dialog box appears.

3 Click Profiles and Materials.
The Profile Designer window appears.

4 Under the Materials folder of OptiFDTD Designer1, right-click the Dielectric 
folder and select New.
A new Dielectric material dialog box appears.

5 Type the following information:

Name: PBG_atom

Refractive index (Re:): 3.1

6 To save the material, click Store.
PBG_atom appears in the Dielectric folder in the directory and in the dialog 
box title bar.

To define the channel profile, perform the following procedure.

Step Action 
1 Under the Profiles folder of OptiFDTD Designer1, right-click the Channel 

folder and select New.
The ChannelPro1 dialog box appears.

2 Create the following channel profile:

Profile name: Profile_PBG

2D profile definition
Material: PBG_atom

3D profile definition
Layer name: layer_01
Width: 1.0
Thickness: 1.0
Offset: 0.0
Material: PBG_atom

3 Click Store.

4 Close the Profile Designer.
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To define the wafer and waveguide properties, perform the following procedure.

Step Action 
1 In the Initial Properties dialog box, type/select the following:

Waveguide Properties
Width [μm]: 1.0
Profile: Profile_PBG

Wafer Dimensions
Length [μm]: 10.0
Width [μm]: 1.0

2D Wafer Properties
Material: Air

2 Click OK.
The Initial Properties dialog box closes.

3 In the Layout Designer, from the Draw menu, select PBG Crystal Structure.

4 In the layout window, drag the cursor from a designated starting point and 
release, to create the PBG area.
The PBG Crystal Structure appears in the layout window.

5 To edit the crystal structure, double-click on the PBG structure in the layout.
The Crystal Lattice Properties dialog box appears (see Figure 86 as a 
reference).

6 In Origin, Offset, type/select the following:

Horizontal: 2.0

Vertical: -0.5

7 Click Evaluate.

8 Type/select the following:
Depth: 0.0
Azimuth [deg]: 0.0

9 In Lattice Properties, select 2D Rectangular.

10 In Lattice Dimensions, type/select the following:
Scale: 1.0
#A: 1
#C: 6
Note: When a 2D lattice is selected, the Y-direction cell #B is set to the 
default value of 1.

11 In Label, type PBGCrystalStruct1.

Note: Do NOT close the Crystal Lattice Properties dialog box.
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Setting the atom properties
To set the atom properties, perform the following procedure in the Crystal Lattice 
Properties dialog box.

Step Action 
1 In Atom Waveguide in Unit Cell, Add New, select Elliptic Waveguide from 

the drop-down menu and click New.
The Elliptic Waveguide Properties dialog box appears (see Figure 87 as a 
reference).

2 In Center, Offset, type/select the following:
Horizontal: 0.5
Vertical: 0.5

3 Type/select the following:
Major radius: 0.2
Minor radius: 0.2
Orientation angle: 0.0
Channel thickness tapering: Use Default (Channel: None)
Depth: 0.0
Label: Atom
Profile: Profile_PBG.

4 Click OK to close the Elliptic Waveguide Properties dialog box.
Note: When you return to the Crystal Lattice Properties dialog box, you will see 
the defined elliptic waveguide listed in Atom Waveguide in Unit Cell.

5 Click OK to close the Crystal Lattice Properties dialog box.
The defined PBG structure appears in the layout window (see Figure 102).

Figure 102 Defined PBG structure in layout window
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Inserting the input plane
To insert the input plane, perform the following procedure.

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 To insert the input plane, click in the layout window where you want it placed.
The input plane appears in the layout.

3 To edit the input plane, double-click on the input plane in the layout.
The Input Plane Properties dialog box appears.

4 Set Wavelength to 1.9 mm

5 Select Gaussian Modulated Continuous Wave.
6 On the Gaussian Modulated CW tab, type/select the following:

Time Offset [Sec]: 6.0e-14

Half Width [Sec]: 1.0e-14

7 On the General tab, select Input Field Transverse: Rectangular.

8 On the 2D Transverse tab, type/select the following:

Center Position [μm]: 0.0

Halfwidth [μm]: 2.0

Tilting Angle [deg]: 0.0

Effective Refractive Index: Local

Amplitude [V/m]: 1.0

9 On the General tab, type/select the following:

Plane Geometry
Z Position [μm]: 0.5
Positive direction

10 Click OK.
The Input Field Properties dialog box closes.

Setting up the Observation Point

Step Action 
1 From the Draw menu, select Observation Point.
2 Place the Observation Point in the desired position in the layout.

3 Double-click the observation point.
The Observation Properties -- Point dialog box appears.

4 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 0.25μm
Vertical: 0.0μm
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Center depth: 0.0 μm
Label: Observation Point1

5 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

6 Click OK.
The Observation Properties -- Point dialog box closes.

7 Repeat steps 1 to 5 and create another Observation Point with the following 
information.

8 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 8.5μm
Vertical: 0.0μm

Center depth: 0.0 μm
Label: Observation Point2

9 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

10 Repeat steps 1 to 5 and create another Observation Point with the following 
information.

11 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 9.5μm
Vertical: 0.0μm

Center depth: 0.0 μm
Label: Observation Point3

12 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

Note: Observation Point1 is used to calculate the reflection, while 
Observation Point2 and Observation Point3 are used to calculate the 
transmittance.

Setting the 2D TE FDTD simulation parameters

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears.

2 Type/select the following information:

Polarization: TE
Mesh Delta X [μm]: 0.05

Mesh Delta Y [μm]: 0.05

3 Click Advanced....
The Boundary Conditions dialog box appears.

4 Type/select the following information (see Figure 103):
192



  LESSON 3—PHOTONIC CRYSTAL AND PHOTONIC BAND GAP SIMULATION
-X: Anisotropic PML
+X: Anisotropic PML
-Z: Anisotropic PML
+Z: Anisotropic PML
Anisotropic PML Calculation Parameters

Number of Anisotropic PML Layers: 10
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameters: 5.0
Power of Grading Polynomial: 3.5

Figure 103 2D simulation parameters

Note: The rectangular beam with PMC boundaries on the edge realizes the 
TE plane wave simulation for the periodic structure.

5 In Time Parameters, click Calculate.
The default time step size is calculated.

6 Select Run for 12000 Time Steps (Results Finalized).
7 Select Key Input Information: Input Plane1 and 

wavelength:1.9.
Note: The input plane’s center wavelength is used for DFT calculations.

8 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.

Note: Before running the simulation, save the project to a file.
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Observing the simulation results in OptiFDTD Simulator

Key things to observe:
• Refractive index distribution
• Observe the wave propagation in OptiFDTD Simulator (see Figure 104).
• Select View > Observation Point to see the dynamic time domain and frequency 

domain response (see Figure 105).

Figure 104 OptiFDTD Simulator—Wave propagation
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Figure 105 OptiFDTD Simulator—Dynamic time domain and frequency domain response
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Performing data analysis

In OptiFDTD_Analyzer, perform the following procedure.

Step Action 
1 To start the observation point analysis, from the Tools menu, select 

Observation Area Analysis.
The Observation Area Analysis dialog box appears (see Figure 99).

2 Select ObservationPoint1, ObservationPoint2, and ObservationPoint3.
The simulation results from the observation points displays in the graph 
window.

3 Type/select the following:

Frequency DFT
Min. /f : 1.5μm
Max. /f : 2.3μm
Sample Point: 1000
Normalize With

InputPlane1
4 Click Update Graph to view the transmittance and reflection curves 

(see Figure 106).

λ
λ
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Figure 106 Observation Area Analysis dialog box

Sample 3---Periodic Boundary Condition for PBG simulation
OptiFDTD has options to use simplified Periodic Boundary Condition (PBC).  It can 
work with other boundary conditions such as Anisotropic PML, PMC, and PEC.  With 
PBC, you can simulate a simple plane wave simulation, or a periodic layout 
simulation.

For more information regarding PBC, see the Technical Background.

The following procedure is based on . You can also open the project file 
Sample09_2D_TE_PBG_Domain_Reduced_Square_Lattice.FDT that can be 
found in the Sample file folder.
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Setting the 2D TE FDTD simulation parameters

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears.

2 Type/select the following information:

Polarization: TE
Mesh Delta X [μm]: 0.05

Mesh Delta Y [μm]: 0.05

3 Click Advanced....
The Boundary Conditions dialog box appears.

4 Type/select the following information (see Figure 107):

-X: PMC
+X: PMC
-Z: Anisotropic PML
+Z: Anisotropic PML
Anisotropic PML Calculation Parameters

Number of Anisotropic PML Layers: 10
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameters: 5.0
Power of Grading Polynomial: 3.5
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Figure 107 2D simulation parameters

Note: The rectangular beam with PMC boundaries on the edge realizes the 
TE plane wave simulation for the periodic structure.

5 In Time Parameters, click Calculate.
The default time step size is calculated.

6 Select Run for 12000 Time Steps (Results Finalized).
7 Select Key Input Information: Input Plane1 and 

wavelength:1.9.
Note: The input plane’s center wavelength is used for DFT calculations.

8 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.

Note: Before running the simulation, save the project to a file.

9 Perform the simulation and Post-processing analysis as shown in . You will 
get the same result as shown in Figure 104.
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Lesson 4—Multiple resonant Lorentz dispersive 
material simulation

Lorentz dispersive material currently can only be simulated in 2D. This lesson 
describes how to create, run, and analyze a Lorentz dispersive material simulation.

The corresponding layout file is available in the sample folder of OptiFDTD: 
Sample06_2D_TE_Multi-Lorentz_Dispersion_Multi-Input.FDT. 

The corresponding results file is available on the OptiFDTD setup CD: 
Sample06_2D_TE_Multi-Lorentz_Dispersion_Multi-Input.FDA.

Creating a layout

Step Action 
1 Open Waveguide Layout Designer.
2 To create a new project, from the File menu, select New.

The Initial Properties dialog box appears.

3 To open the Profile Designer and set up the material and profile, click 
Profiles And Materials.
The Profile Designer opens.

4 In the directory under OptiFDTD_Designer1, under the Material folder, right-
click the FDTD-Dispersive folder.
A context menu appears.

5 Select New.
The FDTDDielectric1 material definition dialog box appears.

6 In the FDTDDielectric1 material definition dialog box, click Lorentz 
Dispersive.
The Lorentz Dispersive dialog box appears (see Figure 1).
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Figure 1 Lorentz Dispersive

7 Select Lorenz Dispersive, and define the following parameters:

Name: FDTD_Lorentz_res3

 (F/m): 1.630130e00

 (F/m): 2.630130e00

Resonance number: 3

8 Click Sellmeier Equation and input the corresponding values in the 
Sellmeier Equation table shown in Figure 1.

9 Click Transform To Lorentz Model, then click Lorentz Model radio button.
The Lorentz model resonant frequency, damping factor, and strength are 
shown in Figure 2.

Figure 2 Frequency, damping factor, and strength

10 Click Store to save the material.

ε∞
ε0
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11 Repeat Step 4 to design a linear material with refractive index equal to 2.1 
and the material with the name FDTDDielectric2.1, and click Store.

12 In the directory under Profile Designer, under the Profile folder, right-click 
the Channel folder.
A context menu appears.

13 Select New.
The ChannelPro1 dialog box appears.

14 In ChannelPro1 dialog box, set the Profile Name as Lorentz_res3 and the 
2D profile material as FDTD_Lorentz_res3.

15 Save the profile.

16 Repeat Steps 12 to 14 design another 2D channel profile with the name 
Linear2.1 and the material as FDTDDielectric2.1.

17 Click Store to save the defined profile.

18 Close the Profile Designer.
19 In the Initial Properties dialog box, set the following parameters:

Waveguide Properties
Width: 1.0
Profile: Lorentz_res3

Wafer dimension
Length: 10
Width: 8
2D Wafer Material: Air

20 Click OK to start the layout designer.
The Designer window appears.

21 In the Waveguide Layout Designer window, from the Draw menu, select 
Linear Waveguide.

22 Draw the waveguide in the layout at the desired position.
The waveguide appears in the layout.

23 To edit the waveguide position and properties, double-click the waveguide in 
the layout.
The Linear Waveguide Properties dialog box appears.
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24 Type the following parameters:

Waveguide start position
Horizontal: 0
Vertical:     2

Waveguide end position
Horizontal: 10
Vertical:     2

Select the Use Default checkbox.

Width: 1.0

Depth: 0

Profile: Linear2.1

25 Repeat Steps 21 to  23 design another linear waveguide with following 
properties:

Waveguide start position
Horizontal: 0
Vertical:     -2

Waveguide end position
Horizontal: 10
Vertical:     -2

Select the Use Default checkbox.

Width: 1.0

Depth: 0

Profile: Lorentz_res3
The two waveguides appear in the layout. The upper one is the Linear 
waveguide, and the lower one is the Lorentz Dispersive waveguide (see 
Figure 3).
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Figure 3 Linear and Lorentz Dispersive waveguides

Setting the Input Plane 

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 Click in the layout to place the Input Plane in the desired position.
A red line that presents the input plane appears in the layout window. 

3 To edit the Input Plane properties, in the layout, double-click the Input Plane.
The Input Field Properties dialog box appears.
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4 Click Gaussian Modulated Continuous Wave. 

5 Set the center wavelength to 1.35um

6 To edit the Input Pulse, click the Gaussian Modulated CW tab.

7 Type the following values:

Time offset (sec): 4.0e-14

Half width (sec):   1.5e-14

8 Click the General tab, and then click Modal.
9 Click the 2D Transverse tab to start solving the 2D TE fundamental mode for 

the lower waveguide, and then apply the solved mode as the input plane.

10 Repeat Steps 1-8 to design another vertical input plane in the same position 
as Input Plane1, and set the Mode input for the upper waveguide.

Setting up the Observation point

Step Action 
1 From the Draw menu, select Observation Point.
2 Click in the layout to place the observation point in the desired position.

3 To edit the observation point properties, double-click the observation point in 
the layout.
The Observation Point Properties dialog box appears.

4 Type the following values:

Center Position
Horizontal: 7.5um
Vertical: –2
Depth: 0

Data Components
2D TE: Ey (default)

5 Repeat Steps 1 to 4 to design another observation point with the following 
values:

Center Position
Horizontal: 7.5um
Vertical: 2
Depth: 0

Data Components
2D TE: Ey (default)
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Setting up the 2D simulation parameters 

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears (see Figure 4).

Figure 4 Simulation Parameters dialog box

2 Click TE.

3 Type the following Mesh Delta X and Mesh Delta Z values: 0.05

4 To set the Anisotropic PML boundary condition parameters, click Advance.
The Boundary Conditions dialog box appears.

5 Type the following values:

Number of Anisotropic PML layer: 10

Theoretical Reflection Coefficient: 1.0e-12

Real Anisotropic PML Tensor Parameter: 5.0

Power of Grading Polynomial: 3.5

6 Click OK.

7 Click Calculate for time step size.

8 In the Run for Time Steps (Results Finalized) field, type 3000.
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9 From the Key Input Plane drop-down list, select Input Plane1 and 
wavelength:1.35
Note: The Key Input Plane center wavelength is used for the DFT calculation.

10 To save the settings and start the 2D simulation, click Run.

11 After the simulation ends, open OptiFDTD_Analyzer.

Performing the simulation

Step Action 
1 In OptiFDTD_Simulator, view the refractive index distribution and the wave 

propagation (see Figure 5).

Figure 5 View simulation results in OptiFDTD_Analyzer

Note: 
– The two input waves have the same parameters.

– The wave in the Dispersive waveguide is delayed because of the 
Dispersive effect.
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2 To view the dynamic time domain and frequency domain response, from the 
View menu in the OptiFDTD_Simulator, select Observation Point 
Analysis.
The Observation Area Analysis dialog box opens (see Figure 6).

Figure 6 Observation Area Analysis dialog box
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Performing data analysis

Using this example, you can perform the following analysis in OptiFDTD_Analyzer.

Step Action 
1 View the layout, refractive index, Poynting vector, and field propagation 

pattern (DFT results) for the center wavelength (see Figure 7).

Figure 7 View simulation results for the center wavelength

2 To view the Mode Analysis, from the Tools menu, select Crosscut Viewer.
The X-Z Cut Visualizer dialog box appears (see Figure 8).
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Figure 8 X-Z Cut Visualizer dialog box

3 To start the observation point analysis, from the Tools menu, select 
Observation Area Analysis.
The Observation Area Analysis dialog box opens (see Figure 9).
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Figure 9 Observation Area Analysis dialog box
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Lesson 5—Drude model for noble metal and 
surface plasma simulation

OptiFDTD provides two types of Dispersive material simulations:
• Multiple Resonant Lorentz
• Drude

The Drude model is supposed to be used for the Noble Metal and Surface Plasma in 
optical band.

Note: It is recommended that you read the section in the Technical Background 
describing the Drude model equation. OptiFDTD also provides a sample for a 
Drude model simulation. The following explanation uses this sample file as an 
example.

The corresponding layout file is available in the sample folder of OptiFDTD: 
Sample15_2D_TE_Drude_Model_Emitting_Diode.FDT.

The corresponding results file is available on the OptiFDTD setup CD: 
Sample15_2D_TE_Drude_Model_Emitting_Diode.FDA.

Creating a project with Drude material

Step Action 
1 Start Waveguide Layout Designer.
2 To create a new project, from the File menu, select New.

The Initial Properties dialog box appears.

3 Click the Profiles And Materials.
The Profile Designer appears.

4 In the directory under OptiFDTD_Designer1 of the Profile Designer, under 
the Materials folder, right-click the FDTD-Dispersive folder, and select New.
The FDTDDielectric1 material definition dialog box appears.

5 In the FDTD Dielectric1 material definition dialog box, select Drude 
Dispersive.
The Dispersive Material Definition dialog box appears (see Figure 1).
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Figure 1 Dispersive Material Definition dialog box

6 In the Drude Material Definition dialog box, define the following parameters:

Name: Drude_Silver_Ag

 (F/m): 1.999

Plasma Frequency: 1.346390e+016

Collision Frequency: 9.617120e+013

7 Click Store to save the material.

8 In the directory under OptiFDTD_Designer1 of the Profile Designer, under 
the Materials folder, right-click the Dielectric folder, and select New.
The Dielectric1 material definition dialog box appears.

9 Design a linear material with refractive index equal to 1.414 and Material 
name Dielectricn=1.414.

10 Click Store.

11 In the directory under OptiFDTD_Designer1, Profile folder, right-click the 
Channel folder, and select New.
The ChannelPro1 dialog box appears.

ε∞
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12 In the ChannelPro1 dialog box, set Profile Name to Ag and 2D Profile 
Material to Drude_Silver_Ag.

13 Save the profile.

14 Design another 2D channel profile with the name Core and material 
Dielectricn=1.414.

15 Click Store.

16 Close the Profile Designer.

Designing the waveguides

Step Action 
1 In the Initial Properties dialog box, set the following parameters:

Waveguide Properties
Width: 0.12μm
Profile: Core

Wafer dimension
Length: 1.8μm
Width: 1.4μm

2D Wafer Material: Air
2 Click OK to start the Layout Designer.

The OptiFDTD designer window appears.

3 From the Draw menu, select Linear Waveguide.

4 Draw the waveguide in the layout at desired the position.
The waveguide appears in the layout.

Note: Click the Select tool after drawing the waveguide.

5 Double click the waveguide to edit the waveguide position and properties.
The Linear Waveguide properties dialog box appears.

6 Set the following parameters:

Waveguide start position
Horizontal: 0
Vertical: 0

Waveguide end position
Horizontal: 1.8
Vertical: 0

Select Use Default checkbox.

Width: 0.12

Depth: 0.0

Profile: Core
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7 Design another linear waveguide with following properties:

Waveguide start position
Horizontal: 0
Vertical: –0.24

Waveguide end position
Horizontal: 1.8
Vertical: –0.24

Select Use Default checkbox.

Start thickness: 1.0

End thickness: 1.0

Width: 0.36

Depth: 0.0

Profile: Ag
The two waveguides appear in the layout, the upper one is the linear 
waveguide, which will guide the wave, and the lower one is the Substrate 
Silver layer in the emitting diode (see Figure 2).

Figure 2 Waveguides in the layout
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To enhance the Light Fitting, a corrugated surface plasma is deposited in the core. To 
do this, periodic rectangular linear waveguides are designed following the waveguide 
design outline in the previous procedure.

Each of the rectangular linear waveguides that make up the corrugated surface 
plasma has the following common parameters (see Figure 3):

Width: 0.02μm

Depth: 0.0μm

Select Use Default checkbox.

Note: Thickness is only used for 3D layout definitions.

Profile: Ag
Start vertical: 0.05μm

End vertical: 0.05μm

The six Start/End horizontal positions are:

 i. 0.4μm/0.5μm

 ii. 0.6μm/0.7μm

 iii. 0.8μm/0.9μm

 iv. 1.0μm/1.1μm

 v. 1.2μm/1.3μm
 vi. 1.4μm/1.5μm
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Figure 3 Waveguide materials

Setting the Input Plane

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 Insert the Input Plane into the layout at the desired position.
A red line representing the input plane appears in the layout window. 

3 Double-click the Input Plane.
The Input Field Properties dialog box appears.

4 Select Continuous Wave.

5 Set the center wavelength to 0.4um.

6 Click the General tab, and then click Modal.
7 Click the 2D Transverse tab to start solving the 2D TE fundamental mode for 

the Core (Waveguide Linear1) waveguide.

8 Click Calculate Mode button.

9 On the Modes tab, select Solved Mode.

10 Click Apply Data.
218



  LESSON 5—DRUDE MODEL FOR NOBLE METAL AND SURFACE PLASMA SIMULATION
11 Return to the Input Field Properties dialog box and click General tab.

12 Set Plane Geometry Position to 0.125.

13 Select Positive direction.

14 Click OK.

Setting up 2D Simulation parameters 

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears (see Figure 4).

Figure 4 Simulation Parameters dialog box

2 Click TE.
3 Set x-direction mesh and z-direction mesh to 0.005.
4 Click Advanced.
5 Set the Anisotropic PML boundary condition parameters:

Number of Anisotropic PML layer: 14
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameter: 1.0
Power of Grading Polynomial: 3.5
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6 Click Calculate to get the Time Step Size.

7 Set Run for 2000 time steps for finalization.

8 From the Key Input Plane drop-down list, select Input Plane1 and 
Wavelength to 0.4.

Note: The Key Input Plane's Center Wavelength will be used for the DFT 
calculation.

9 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.

Performing the simulation
When the Simulator starts, the emitting field can be observed (see Figure 5).

Note: Please use the Rainbow_Banded Palette to view the graph. Right-click 
on the graph to set the graph control.

Figure 5 OptiFDTD_Simulator
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Performing data analysis

With the example used in this lesson, in the Analyzer you can perform the following 
analysis:
• Observe the Layout, Refractive Index Poynting Vector, field propagation 

pattern (DFT results) for the Input Wavelength (see Figure 6).

Figure 6 X-direction Poynting Vector

• Select the Cross Cut in the Tools menu to get the Mode Analysis, slice power, 
and far field transformation. The X-Z Slice viewer appears (see Figure 7).
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Figure 7 X-Z Slice viewer
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Lesson 6—2nd-Order nonlinearity simulation

OptiFDTD provides four types of nonlinear materials.
• 2nd Order
• 3rd Order
• Kerr-effect
• Raman-effect

All of these nonlinearities can be combined with the Lorentz dispersive model, which 
leads to dispersive nonlinear properties. To simulate the nonlinear material correctly, 
we recommend that you read the FDTD Basics.

Note: 
• Because the nonlinear material may have a high frequency response, a finer 

mesh size for the simulation may be required.
• Set a suitable power level in the input plane. If the input power is too low, the 

material may not be excited to nonlinear levels. If the power is too high, the output 
will be an unstable modulated wave.

• Nonlinear material parameters must have physical meanings.

The following examples explain how to design, simulate, and analyze the nonlinear 
materials. 

2nd Order nonlinear material simulation

Creating the layout

Step Action 
1 Start Waveguide Layout Designer.
2 To create a new project, select File > New.

The Initial Properties dialog box appears.
3 Click Profiles and Materials.

The Profile Designer window appears.
4 Under the Materials folder, right-click the FDTD-Nonlinear folder and select 

New.
A new FDTDNonlinear1 material dialog box appears.

5 Select 2nd order.
The 2nd order tab appears in the dialog box.

6 Select/type the following:
Name: NL 2nd
Relative Linear Permittivity : 2.7225εL
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2nd Susceptibility : 1.0e-6

7 To save the material, click Store.

Figure 8 FDTDNonlinear1 material definition dialog box

8 Under the Materials folder, right-click the Dielectric folder and select New.
A new FDTDDielectric1 material dialog box appears.

9 Select/type the following information:

Name: Dielectric_1.65

Const Ref. Idx
N Re: 1.65

10 To save the material, click Store.
Dielectric_1.65 appears in the Dielectric folder in the directory and in the 
dialog box title bar.

To define the channel profile, perform the following procedure.

Step Action 
1 Under the Profiles folder, right-click the Channel folder and select New.

The ChannelPro1 dialog box appears.

2 Create the following channel profile:

Profile name: NL 2nd_1

2D profile definition

x 2( ) m V⁄
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Material: NL 2nd
3 Click Store.
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4 Create a second profile:

Profile name: Dielectric 1.65_1

2D profile definition
Material: Dielectric 1.65

5 Click Store.

6 Close the Profile Designer.

To define the wafer and waveguide properties, perform the following procedure.

Step Action 
1 In the Initial Properties dialog box, type/select the following:

Waveguide Properties
Width [μm]: 1.0
Profile: NL 2nd_1

Wafer Dimensions
Length [μm]: 10.0
Width [μm]: 5.0

2D Wafer Properties
Material: Air

2 Click OK.
The Initial Properties dialog box closes and the layout window appears.

To create the waveguide, perform the following procedure.

Step Action 
1 From the Draw menu, select Linear Waveguide.

2 In the layout window, drag the linear waveguide from the start point to the end 
point.
A linear waveguide appears in the layout window.

3 To adjust the position and the shape of the waveguide, in the layout window, 
double-click the Linear Waveguide.
The Linear Waveguide Properties dialog box appears.

4 Click the Start tab.

5 Under Offset, type the following values:

Horizontal: 3

Vertical: 0

6 Click the End tab.

7 Under Offset, type the following values:

Horizontal (µm): 10.0

Vertical (µm): 0.0

8 In Channel Thickness Tapering, select Use Default (Channel:None).
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9 Type/select the following:

Width (µm): 1.0

Depth (µm): 0.0

Label: Linear2

Profile: NL 2nd_1

10 Repeat steps [1] through [9] to create another linear waveguide in the layout.

Step Action 
1 In Start > Offset, type the following values.

Horizontal: 0

Vertical: 0

2 In End > Offset, type the following values:

Horizontal: 3

Vertical: 0

3 Type/select the following:

Width (µm): 1.0

Depth (µm): 0.0

Label: Linear1

Profile: Dielectric 1.65_1

The two waveguides appear in the layout. The one on the left is the linear waveguide, 
and the one on the right is the nonlinear waveguide (see Figure 9).
227



  LESSON 6—2ND-ORDER NONLINEARITY SIMULATION
Figure 9 Waveguides in layout

Inserting the input plane
To insert the input plane, perform the following procedure.

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 To insert the input plane, click in the layout window where you want it placed.
The input plane appears in the layout.

3 To edit the input plane, double-click on the input plane in the layout.
The Input Plane Properties dialog box appears.

4 Select Continuous Wave.
5 Set Wavelength to 1.5 μm.

6 On the General tab, type/select the following:

Input Field Transverse: Modal

Plane Geometry
Z Position [μm]: 1.25
Positive direction
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7 On the 2D Transverse tab, click Find Modes.
The Mode Solver 2D dialog box appears.

8 On the Waveguides tab, select Linear1.

9 Click Calculate Mode.
The Modes tab is activated.

10 On the Modes tab, select the mode.

11 Click Apply Data.
The Mode Solver 2D closes.

12 On the 2D Transverse tab, select the Power radio button, and type the 
following:

Power [W/m]: 16.0

13 Click OK.
The Input Field Properties dialog box closes.

Setting up the Observation Point

Step Action 
1 From the Draw menu, select Observation Point.
2 Place the Observation Point in the desired position in the layout.

3 Double-click the observation point.
The Observation Properties -- Point dialog box appears.

4 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 2.5μm
Vertical: 0.0μm

Center depth: 0.0μm
Label: ObservationPoint1

5 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

6 Click OK.
The Observation Properties -- Point dialog box closes.

Repeat steps 1 to 5 to create the following additional observation points with 
the following information:

On the General tab:

In Center, Offset, type/select the following:
Horizontal: 4.5μm
Vertical: 0.0μm

Center depth: 0.0μm
Label: ObservationPoint2

Click OK.
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On the General tab:

In Center, Offset, type/select the following:
Horizontal: 6.0μm
Vertical: 0.0μm

Center depth: 0.0μm
Label: ObservationPoint3

Click OK.

On the General tab:

In Center, Offset, type/select the following:
Horizontal: 7.4μm
Vertical: 0.0μm

Center depth: 0.0μm
Label: ObservationPoint4

Click OK.

On the General tab:

In Center, Offset, type/select the following:
Horizontal: 9.0μm
Vertical: 0.0μm

Center depth: 0.0μm
Label: ObservationPoint5

Click OK.

On the General tab:

In Center, Offset, type/select the following:
Horizontal: 0.625μm
Vertical: 0.0μm

Center depth: 0.0μm
Label: ObservationPoint6

Click OK.

Setting the observation area

Step Action 
1 From the Draw menu, select Observation XZ.

2 Place the Observation Area in the desired position in the layout.

3 Double-click the observation area.
The Observation Properties -- XZ Area dialog box appears.
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4 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 3.0μm
Vertical: 0.0μm

Center depth: 0.0μm
Z length: + 1.5

X length: + 1.5
Label: ObservationArea1

5 On the Data Components tab, select the following:

2D TE: Ey, Hx, Hz

6 Click OK.

Setting the observation line

The observation line is only used for 2D simulations. It is used to show
• field distribution along the line for the user input wavelength
• calculate the outgoing power in the line for user input wavelength
• calculate the absolute power spectrum and normalized transmittance power 

spectrum (to the input power)

Step Action 
1 From the Draw menu, select Observation Vertical Line.

2 Place the Observation Line in the desired position in the layout.

3 Double-click the observation line.
The Observation Properties -- Vertical Line dialog box appears.

4 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 9.5μm
Vertical: 0.0μm

X length: + 2.0
Label: ObservationLine1

5 On the Data Components tab, select the following:

2D TE: Ey, Hx, Hz

6 Click OK.

Repeat steps 1 to 5 to create an additional observation line with the following 
information:

7 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 6.5μm
Vertical: 0.0μm
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X length: + 2.0
Label: ObservationLine2

8 On the Data Components tab, select the following:

2D TE: Ey, Hx

9 Click OK.

The observation components of the project can be seen in Figure 10.

Figure 10 Observation components of project

Setting the 2D simulation parameters

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears (see Figure 11).

2 Type/select the following information:

Polarization: TE
Mesh Delta X [μm]: 0.05

Mesh Delta Y [μm]: 0.05
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Figure 11 Simulation Parameters dialog box

3 Click Advanced....
The Boundary Conditions dialog box appears.

4 Type/select the following information:

Anisotropic PML Calculation Parameters
Number of Anisotropic PML Layers: 20
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameters: 5.0
Power of Grading Polynomial: 3.5

5 In Time Parameters, click Calculate.
The default time step size is calculated.

6 Select Run for 2000 Time Steps (Results Finalized).
7 Select Key Input Information: Input Plane1 and 

wavelength:1.5.

Note: The input plane’s center wavelength is used for DFT calculations.

8 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.

Note: Before running the simulation, save the project to a file.
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Observing the simulation results in OptiFDTD Simulator

Key things to observe:
• Field propagation pattern in OptiFDTD Simulator (see Figure 12)

Select View > Observation Point to observe the dynamic time domain and frequency 
domain response (see Figure 13).

Figure 12 Field propagation pattern
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Figure 13 Observation point

Performing data analysis

When the simulation ends, a message appears and prompts you to open 
OptiFDTD_Analyzer (see Figure 23).

Figure 14 Message box
235



  LESSON 6—2ND-ORDER NONLINEARITY SIMULATION
Action 
• To open OptiFDTD_Analyzer and view the simulated results, click Yes.

Note: When the simulation ends in OptiFDTD_Simulator, the results are 
saved automatically as a file with same name, but with a different file 
extension (*.fda).

Observe the layout, refractive index, Poynting vector, and field propagation pattern 
(DFT results) for the input wavelength (see Figure 15 for Poynting vector in 
z-direction).

Figure 15 Poynting vector in z-direction

• Select Tools > Crosscut Viewer.
The X-Z Cut Visualizer dialog box appears.

You can do the mode analysis, mode overlap integral calculation, slice power 
calculation, and far field transformation (see Figure 16).
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Figure 16 X-Z Cut Visualizer

• Select Tools > Observation Area Analysis.
The Observation Area Analysis dialog box appears (see Figure 17).
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Figure 17 Observation Area Analysis dialog box

• Click the Observation Line tab to start the observation line analysis.
The field pattern and the corresponding power for the user input wavelength 
in the observation line appear in the dialog box (see Figure 18).
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Figure 18 Observation field pattern and power in observation line

You can also follow the same procedure to perform another nonlinear material 
simulation.

See the following sample files:

• Sample12_2D_TE_3rd_Order_Nonlinear.fdt

• Sample13_2D_TE_Kerr_Nonlinear.fdt

In general, the Kerr effect and Raman effect belong to the 3rd-order nonlinearity. 
However, the Kerr effect uses a special model to consider photonic response time, 
while the Raman model considers both the response time and the oscillating 
frequency.
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Lesson 7—Four wave mixing

OptiFDTD provides two dimension nonlinearity and multiple input wave simulations, 
thereby enabling you to simulate the Four Wave Mixing (FWM) effect. The following 
lesson outlines how OptiFDTD performs a FWM simulation.

To create the Four Wave Mixing layout, perform the following procedures.

Designing a four-wave mixing layout

To design the four-wave mixing materials, perform the following procedures.

Step Action 
1 Start Waveguide Layout Designer.
2 To create a new project, select File > New.

The Initial Properties dialog box appears.

3 Click Profiles and Materials.
The Profile Designer window appears.

4 Under the Materials folder, right-click the Dielectric folder and select New.
A new FDTDDielectric1 material dialog box appears.

5 Select/type the following information:

Name: FDTD_1.65

Const Ref. Idx
N Re: 1.65

6 To save the material, click Store.
FDTD_1.65 appears in the Dielectric folder in the directory and in the dialog 
box title bar.

7 Under the Materials folder, right-click the FDTD-Nonlinear folder and select 
New.
A new FDTDNonlinear1 material dialog box appears.

8 Select Kerr.
The Kerr tab appears in the dialog box.
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9 Select/type the following:

Name: FDTD_NL_Kerr

Relative Linear Permittivity: 2.7225

Response Time: 2.0e-15

Permittivity: 2.0e-18

10 To save the material, click Store.

Figure 19 FDTD_NL_Kerr material

To define the channel profile, perform the following procedure.

Step Action 
1 Under the Profiles folder, right-click the Channel folder and select New.

The ChannelPro1 dialog box appears.

2 Create the following channel profile:

Profile name: NL_Kerr

2D profile definition
Material: FDTD_NL_Kerr

3 Click Store.
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4 Create a second profile:

Profile name: Linear_WG

2D profile definition
Material: FDTD_1.65

5 Click Store.

6 Close the Profile Designer.

To define the wafer and waveguide properties, perform the following procedure.

Step Action 
1 In the Initial Properties dialog box, , type/select the following:

Waveguide Properties
Width [μm]: 1.0
Profile: NL_Kerr

Wafer Dimensions
Length [μm]: 15.0
Width [μm]: 10.0

2D Wafer Properties
Material: Air

2 Click OK.
The Initial Properties dialog box closes and the layout window appears.

To create the waveguide, perform the following procedure.

Step Action 
1 From the Draw menu, select Linear Waveguide.

2 In the layout window, drag the linear waveguide from the start point to the end 
point.
A linear waveguide appears in the layout window.

Note: Release the Linear Waveguide selection tool by clicking the Select tool 
after the Linear Waveguide is drawn in the layout.

3 To adjust the position and the shape of the waveguide, in the layout window, 
double-click the Linear Waveguide.
The Linear Waveguide Properties dialog box appears.

4 Click the Start tab.

5 Under Offset, type the following values:
Horizontal: 4.0
Vertical: 0

6 Click the End tab.

7 Under Offset, type the following values:

Horizontal (µm): 13.00

Vertical (µm): 0.0
243



  LESSON 7—FOUR WAVE MIXING
8 In Channel Thickness Tapering, select Use Default (Channel:None).
9 Type/select the following:

Width (µm): 8.0

Depth (µm): 0.0

Label: linear4

Profile: NL_Kerr

10 Click OK.

11 Repeat steps [1] through [3] to create three input linear waveguides in the 
layout.

Note: The input waveguide is used to input three different wavelength waves 
into the nonlinear material.

Input Waveguide 1 properties:

Step Action 
1 In Start > Offset, type the following values.

Horizontal: 0

Vertical: 0

2 In End > Offset, type the following values:

Horizontal: 4

Vertical: 0

3 In Channel Thickness Tapering, select Use Default (Channel:None).
4 Type/select the following:

Width (µm): 1.0

Label: linear1

Depth (µm): 0.0

Profile: Linear_WG

5 Click OK.

Input Waveguide 2 properties:

Step Action 
1 In Start > Offset, type the following values.

Horizontal: 0

Vertical: 1.2
2 In End > Offset, type the following values:

Horizontal: 4

Vertical: 1.2
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3 In Channel Thickness Tapering, select Use Default (Channel:None).
4 Type/select the following:

Width (µm): 1.0

Depth (µm): 0.0

Label: linear2

Profile: Linear_WG

5 Click OK.

Input Waveguide 3 properties:

Step Action 
1 In Start > Offset, type the following values.

Horizontal: 0

Vertical: -1.2

2 In End > Offset, type the following values:

Horizontal: 4

Vertical: -1.2

3 In Channel Thickness Tapering, select Use Default (Channel:None).
4 Type/select the following:

Width (µm): 1.0

Depth (µm): 0.0

Label: linear3

Profile: Linear_WG

5 Click OK.
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Figure 20 Input waveguides

Setting the input wave

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 To insert the input plane, click in the layout window where you want it placed.
The input plane appears in the layout.

3 To edit the input plane, double-click on the input plane in the layout.
The Input Plane Properties dialog box appears.

4 On the General tab, type/select the following:

Continuous Wave

Wavelength [μm]: 1.4

Input Field Transverse: Modal

Plane Geometry:
Z Position [μm]: 1.0
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5 On the 2D Transverse tab, click Find Modes.
The Mode Solver 2D dialog box appears.

6 On the Waveguides tab, select Linear1.

7 Click Calculate Mode.
The Modes tab is activated.

8 On the Modes tab, select the mode.

9 Click Apply Data.
The Mode Solver 2D closes.

10 On the 2D Transverse tab, select the Amplitude radio button and type the 
following:

Amplitude [V/m]: 2.0e09

11 Click OK.
The Input Field Properties dialog box closes.

12 Repeat steps [1] through [10] to create a second vertical input plane with the 
following data:

Vertical Input Plane 2 properties:

Step Action 
1 In the Input Field Properties dialog box, select/type the following:

Continuous Wave

Wavelength [μm]: 1.55

2 On the General tab, type/select the following:

Input Field Transverse: Modal

Plane Geometry:
Z Position [μm]: 1.0

3 Click Find Modes.
The Mode Solver 2D dialog box appears.

4 On the Waveguides tab, select Linear2.

5 Click Calculate Mode.
The Modes tab is activated.

6 On the Modes tab, select the mode.

7 Click Apply Data.
The Mode Solver 2D closes.

8 On the 2D Transverse tab, select the Amplitude radio button and type the 
following:

Amplitude [V/m]: 2.0e09

9 Click OK.
The Input Field Properties dialog box closes.
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Vertical Input Plane 3 properties:

Step Action 
1 In the Input Field Properties dialog box, select/type the following:

Continuous Wave

Wavelength [μm]: 1.60

2 On the General tab, type/select the following:

Input Field Transverse: Modal

Plane Geometry:
Z Position [μm]: 1.0

3 Click Find Modes.
The Mode Solver 2D dialog box appears.

4 On the Waveguides tab, select Linear3.

5 Click Calculate Mode.
The Modes tab is activated.

6 On the Modes tab, select the mode.

7 Click Apply Data.
The Mode Solver 2D closes.

8 On the 2D Transverse tab, select the Amplitude radio button and type the 
following:

Amplitude [V/m]: 2.0e09

9 Click OK.
The Input Field Properties dialog box closes.

Setting up the Observation Point

Step Action 
1 From the Draw menu, select Observation Point.
2 Place the Observation Point in the desired position in the layout.

3 Double-click the observation point.
The Observation Properties -- Point dialog box appears.

4 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 6.0μm
Vertical: 0.0μm

Center depth: 0.0 μm
Label: Observation Point1
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5 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

6 Click OK.
The Observation Properties -- Point dialog box closes.

7 Repeat steps 1 to 5 and create another Observation Point with the following 
information.

8 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 6.0μm
Vertical: 1.2μm

Center depth: 0.0 μm
Label: Observation Point2
Click OK.

9 Repeat steps 1 to 5 and create another Observation Point with the following 
information.

10 On the General tab:

In Center, Offset, type/select the following:
Horizontal: 6.0μm
Vertical: -1.2μm

Center depth: 0.0 μm
Label: Observation Point3

11 On the Data Components tab, ensure that 2D TE: Ey is selected (default).

12 Click OK.

Setting the 2D simulation parameters

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears.

2 Type/select the following information:

Polarization: TE
Mesh Delta X [μm]: 0.1

Mesh Delta Y [μm]: 0.1

3 Click Advanced....
The Boundary Conditions dialog box appears.

4 Type/select the following information:

-X: Anisotropic PML
+X: Anisotropic PML
-Z: Anisotropic PML
+Z: Anisotropic PML
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Anisotropic PML Calculation Parameters
Number of Anisotropic PML Layers: 10
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameters: 5.0
Power of Grading Polynomial: 3.5

5 In Time Parameters, click Calculate.
The default time step size is calculated.

6 Select Run for 3000 Time Steps (Results Finalized).
7 Select Key Input Information: Input Plane1 and 

wavelength:1.4.

Note: The input plane’s center wavelength is used for DFT calculations.

8 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.

Note: Save your layout before starting the simulation.
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Observing the simulation results

Key things to observe:
• wave propagation pattern in time domain (see Figure 21)
• field response in time domain and frequency domain for observation point (select 

View > Observation Point to see the dynamic time domain and frequency 
domain response (see Figure 22).

Figure 21 OptiFDTD Simulator—wave propagation pattern in time domain
251



  LESSON 7—FOUR WAVE MIXING
Figure 22 OptiFDTD Simulator—time domain and frequency domain for observation point

Performing data analysis

Spectral analysis in observation point 
When the simulation ends, a message appears and prompts you to open 
OptiFDTD_Analyzer (see Figure 23).

Figure 23 Message box

Step Action 
1 To open OptiFDTD_Analyzer and view the simulated results, click Yes.

Note: When the simulation ends, the results are saved automatically as a file 
with same name but a different file extension (*.fda).
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2 Select Tools > Observation Area Analysis.
The Observation Area Analysis dialog box appears.

3 On the Observation Point tab, type/select the following:

Observation Point1
Frequency DFT
Min. /f : 0.9μm
Max. /f : 2.8μm
Sample Point: 1000

4 Click Update Graph to view updated results.
The spectral response in Observation Point1 are displayed, and the four 
wave mixing effect can be seen in the curve (see Figure 24).

Figure 24 OptiFDTD_Analyzer—Observation point results analysis

λ
λ
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Notes:
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Lesson 8—Plane wave simulation

OptiFDTD provides two special boundary conditions---perfect electrical conductor 
(PEC) boundary and perfect magnetic conductor (PMC) boundary. The two boundary 
conditions can works with Anisotropic PML together to realize the plane wave 
simulation. For more details of these boundary conditions, please see the Technical 
Background. This lesson presents a 2D plane wave simulations and 3D plane wave 
simulation.

Note: Due to the PMC and PEC setting, plane wave simulation is only functional 
with symmetrical structures.

2D-TE plane wave in unique material

Creating a layout

Step Action 
1 Open the Waveguide Layout Designer.
2 To create a new project, select File > New.

The Initial Properties dialog box appears.

3 Click Profiles and Materials.
The Profile Designer window appears.

4 Under the Materials folder, right-click the Dielectric folder and select New.
A new Dielectric material dialog box appears.

5 Type the following information:

Name: N=2

Refractive index (Re:): 2.0

6 To save the material, click Store.
N=2 appears in the Dielectric folder in the directory and in the dialog box title 
bar.
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Defining the channel profile

Step Action 
1 Under the Profiles folder, right-click the Channel folder and select New.

The ChannelPro1 dialog box appears.

2 Create the following channel profile:

Profile name: Profile_n=2

2D profile definition
Material: N=2

3D profile definition
Layer name: layer_01
Width: 1.0
Thickness: 1.0
Offset: 0.0
Material: N=2
Click Add.

3 Click Store.

4 Close the Profile Designer.

Defining wafer and waveguide properties

Step Action 
1 In the Initial Properties dialog box, type/select the following:

Waveguide Properties
Width [μm]: 1.0
Profile: Profile_n=2

Wafer Dimensions
Length [μm]: 8.0
Width [μm]: 4.0

2D Wafer Properties
Material: Air

3D Wafer Properties
Cladding

Thickness [μm]: 2.0
Material: Air

Substrate
Thickness [μm]: 2.0
Material: Air

2 Click OK.
The Initial Properties dialog box closes.
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Inserting the input plane

To insert the input plane, perform the following procedure.

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 To insert the input plane, click in the layout window where you want it placed.
The input plane appears in the layout.

3 To edit the input plane, double-click on the input plane in the layout.
The Input Plane Properties dialog box appears.

4 On the General tab, type/select the following:

Continuous Wave

Wavelength [μm]: 1.55

Input Field Transverse: Rectangular

Plane Geometry:
Z Position [μm]: 1.0

5 On the 2D Transverse tab, type/select the following:

Center Position [μm]: 0.0

Halfwidth [μm]: 5.0

Tilting Angle [deg]: 0

Effective Refractive Index: Local

Amplitude [V/m]: 1.0

6 Click OK.
The Input Field Properties dialog box closes.

Setting the 2D TE FDTD simulation parameters

Step Action 
1 From the Simulation menu, select 2D Simulation Parameters.

The Simulation Parameters dialog box appears.

2 Type/select the following information:

Polarization: TE
Mesh Delta X [μm]: 0.05

Mesh Delta Z [μm]: 0.05

3 Click Advanced....
The Boundary Conditions dialog box appears.

-X: PMC
+X: PMC
-Z: Anisotropic PML
+Z: Anisotropic PML
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Anisotropic PML Calculation Parameters
Number of Anisotropic PML Layers: 10
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameters: 5.0
Power of Grading Polynomial: 3.5

4 Click OK.
The Boundary Conditions dialog box closes.

5 In Time Parameters, click Calculate.
The default time step size is calculated.

6 Select Run for 1000 Time Steps (Results Finalized).
7 Select Key Input Information: Input Plane1 and 

wavelength:1.55.

8 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.
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Running the 2D TE plane wave simulation

When you start the simulation, the plane wave propagation can be observed 
(see Figure 25).

Figure 25 OptiFDTD Simulator
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3D-Y-direction polarized plane wave in unique material
Using the same layout created in 2D-TE plane wave in unique material, create 
another file with the same layout by selecting File > Save As and using a different file 
name.

Step Action 
1 From the Edit menu, select Wafer Properties.

The Wafer Properties dialog box appears.

2 Click the 3D Wafer Properties tab and set the Cladding: Material and 
Substrate Material to N=2.

3 Click OK.
The Wafer Properties dialog box closes.

4 To edit the input plane, double-click on the input plane in the layout.
The Input Plane Properties dialog box appears.

5 On the General tab, type/select the following:

Continuous Wave

Wavelength [μm]: 2.0

Input Field Transverse: Rectangular

Plane Geometry:
Z Position [μm]: 1.0

6 On the 3D Transverse tab, type/select the following:

Center Position [μm] X: 0.0

Halfwidth [μm] X: 5.0

Center Position [μm] Y: 0.0

Halfwidth [μm] Y: 5.0

Tilting Angle [deg]: 0

Effective Refractive Index: Local

Polarization: LinearY

Select the Amplitude radio button and type:
Amplitude [V/m2]: 1.0

7 Click OK.
The Input Field Properties dialog box closes.
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Setting the 3D-Y-direction polarized plane wave simulation parameters

Step Action 
1 From the Simulation menu, select 3D Simulation Parameters.

The 3D Simulation Parameters dialog box appears.

2 Type/select the following information:

Mesh Delta X [μm]: 0.1

Mesh Delta Y [μm]: 0.1

Mesh Delta Z [μm]: 0.1

3 Click Advanced....
The Boundary Conditions dialog box appears.

-X: PMC
+X: PMC
-Y: PEC
+Y: PEC
-Z: Anisotropic PML
+Z: Anisotropic PML
Anisotropic PML Calculation Parameters

Number of Anisotropic PML Layers: 10
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameters: 1.0
Power of Grading Polynomial: 3.5

4 Click OK.
The Boundary Conditions dialog box closes.

5 In Time Parameters, click Calculate.
The default time step size is calculated.

6 Select Run for 1000 Time Steps (Results Finalized).
7 Select Key Input Information: Input Plane1 and 

wavelength:2.00.

8 Select DFT Options: Electric Components: Ey.

9 Click Run to start the OptiFDTD Simulator.

When the simulation is running, the plane wave effect can be observed in the 
simulator (see Figure 26).
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Figure 26 3D Y-direction polarized plane wave
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Lesson 9—FDTD Band Solver

FDTD Band Solver in OptiFDTD is a supplementary tool for the Photonic Crystal 
(PhC) and Photonic Band Gap (PBG) structure. Currently it employs the FDTD 
method and generates what is called the Band Diagram. For the transmission and 
reflection analysis for PhC and PBG, it is still suggested to use the conventional FDTD 
method demonstrated in Lesson 3—Photonic crystal and photonic band gap 
simulation, because the FDTD simulation for generating the band diagram is 
dependent on  the initial condition, Bloch's periodic boundary condition, and sufficient 
monitor points. This means that there is no guarantee that all bands will be found. In 
future releases, we will update the PWE method, which will guarantee that all the 
necessary bands will be found.

To start the band solving, you need to define a photonic lattice structure in the layout 
window.  If no photonic crystal lattice exists in the layout window, then the FDTD band 
solver is not active—the 2D band solver item in the simulation menu is disabled.

Photonic crystal structure

Creating a layout

Step Action 
1 Open the OptiFDTD Waveguide Layout Designer.
2 To create a new project, select File > New.

The Initial Properties dialog box appears.

3 Click Profiles and Materials.
The Profile Designer window appears.

4 Under the Materials folder, right-click the Dielectric folder and select New.
A new Dielectric material dialog box appears.

5 Type the following information:

Name: er=8.9

Refractive index (Re:): 2.983287

6 Click Store.
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Defining the channel profile

Step Action 
1 Under the Profiles folder, right-click the Channel folder and select New.

The ChannelPro1 dialog box appears.

2 Create the following channel profile:

Profile name: Profile_PhC

2D profile definition
Material: er=8.9

3D profile definition
Layer name: layer_01
Width: 1.0
Thickness: 1.0
Offset: 0.0
Material: er=8.9

3 Click Add.

4 Click Store.

5 Close the Profile Designer.

Defining wafer and waveguide properties

Step Action 
1 In the Initial Properties dialog box, type/select the following:

Waveguide Properties
Width [μm]: 1.0
Profile: Profile_PhC

Wafer Dimensions
Length [μm]: 10.0
Width [μm]: 10.0

2D Wafer Properties
Material: Air

3D Wafer Properties
Cladding

Thickness [μm]: 1.0
Material: Air

Substrate
Thickness [μm]: 1.0
Material: Air

2 Click OK.
The Initial Properties dialog box closes.
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Creating the PBG crystal structure

Step Action 
1 From the Draw menu, select PBG Crystal Structure.

2 Click in the layout window to create the PBG area.
The PBG Crystal Structure appears in the layout window.

3 Click on the Select tool.

4 To set the PBG properties, double-click on the PBG Crystal Structure in the 
layout.
The Crystal Lattice Properties dialog box appears (see Figure 27).

Figure 27 Crystal Lattice Properties dialog box

5 In Origin, Offset, type/select the following:

Horizontal: 3.0

Vertical: -3.0

6 Click Evaluate.

7 Type/select the following:
Depth: 0.0
Azimuth [deg]: 0.0
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8 In Lattice Properties, select Type: 2D Rectangular.

9 In Lattice Dimensions, type/select the following:
Scale: 1.0
#A: 6
#C: 6

10 In Label, type PBGCrystalStruct1.

Note: Do NOT close the Crystal Lattice Properties dialog box.

Setting the atom properties

To set the atom properties, perform the following procedure in the Crystal Lattice 
Properties dialog box.

Step Action 
1 In Atom Waveguide in Unit Cell, Add New, select Elliptic Waveguide from 

the drop-down menu and click New.
The Elliptic Waveguide Properties dialog box appears.

2 In Center, Offset, type/select the following:

Horizontal: 0.0

Vertical: 0.0

3 Type/select the following:
Major radius: 0.2
Minor radius: 0.2
Orientation Angle: 0.0
Channel Thickness Tapering: Use Default (Channel: None)

Depth: 0.0

Label: Atom

Profile: Profile_PhC.

4 Click OK.
The Elliptic Waveguide Properties dialog box closes.

Note: When you return to the Crystal Lattice Properties dialog box, you will 
see the defined elliptic waveguide listed in Atom Waveguide in Unit Cell 
(see Figure 29).

5 Click OK in the Crystal Lattic Properties dialog box.
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Figure 28 Defined elliptic waveguide in Unit Cell Edit table

Figure 29 Defined PhC structure in layout
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Band Solver parameters
When you open the 2D Band Solver Parameters dialog box (from the layout 
designer Simulation menu), OptiFDTD automatically checks to see if the lattice 
structure exists in the layout. Available lattice structures are listed under Domain, in 
the Lattice Name drop-down list. Currently only 2D square lattice and 2D hexagonal 
lattice are supported.

The FDTD simulation takes one unit cell as the fundamental periodic cell.  You can 
specify how many unit cells are to be used for the simulation under Domain. This is 
controlled by Supercells #X (in x -direction) and #Z (in z-direction). Usually a 1×1 cell 
(unit cell) is good enough for extracting the band diagram.

You can also specify the TE or TM wave under Polarization.

When you specify the supercell, you then need to set the mesh size for the FDTD 
simulation, in Mesh.

The FDTD simulation finds the eigen modes for one given K-vector. The K-vectors (a 
series value) are defined under K-vector Path. The Division number refers to how 
many K-vector sampling points there are for each sub-K-vector path. Please refer to 
the Technical Background to see how we set the default K-path.

The FDTD band solver calculation is controlled by four items, other than the mesh:
• # Bands—the number of modes extracted from the FDTD simulation.
• Threshold—the eigen value is obtained from the spectrum response which the 

peak value is normalized to unit. If sub-peak value is smaller than this threshold 
value, then the value is not regarded as a mode.

• Time Step Size (s)—domain size, time interval for FDTD simulation.
• Time Steps (Power of 2)—FFT is used to get the spectrum response. The FDTD 

simulation needs to run for 2N time steps to match the FFT requirement. So the 
value of N should be specified.
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Setting the band solver simulation parameters

Step Action 
1 From the Simulation menu, select 2D Band Solver Parameters.

The 2D Band Solver Parameters dialog box appears (see Figure 30).
2 Type/select the following information:

Lattice Name: PBGCrystalStruc1
Supercells:

#X: 1
#Z: 1

K-vector Path:

# Divisions: 10

Polarization: TE

Mesh:
# Steps X: 20
# Steps Z: 20

Calculation:
# of Bands: 12
Threshold: 0.05

Time Step Size [s]: Auto
Time Steps [Power of 2]: 14

3 Click Run to start the OptiFDTD_BandSolver (see Figure 31).

Figure 30 2D Band Solver Parameters dialog box
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The band diagram is updated instantaneously for each K-vector value. The 
corresponding K-vector value is shown in the output box at the bottom of the 
OptiFDTD_BandSolver dialog box.

Figure 31 OptiFDTD_BandSolver

When the simulation is finished, the results are saved to a file with a *.bnd 
extension.
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Viewing the simulation results

Step Action 
1 In the OptiFDTD_BandSolver, select File > Load results.

The Select 2D Band Solver Result File dialog box appears.

2 Select the *.bnd file that you want to view and click Open.
The results are displayed in the OptiFDTD_BandSolver dialog box.
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Notes:
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Lesson 10 - Lorentz_Drude model for metal and 
surface plasma simulation

OptiFDTD versions 2 through 4 provided a Drude model and a separate Lorentz 
model for metal, plasma and dispersive material simulation.  The two models work 
only for 2-dimensional (2D) layouts.  Based on feedback from our customers, 
OptiFDTD 5.0 introduced a combined model called the Lorentz-Drude model.  This 
model can handle both the Drude and Lorentz dispersive effects and works for both 
2D and 3D simulations.  

The Lorentz-Drude model is intended for use with Noble Metals and Surface Plasma 
in the optical band.  This new material model provides more accurate results than the 
older Drude model and Lorentz model. 

Note: It is recommended that you read the section in the Technical Background 
describing the Lorentz-Drude model equation.  OptiFDTD also provides a sample 
for this Lorentz- Drude model simulation.  The following explanation uses this 
sample file as an example.

The corresponding layout file is available in the OptiFDTD set up CD:

Sample29_2D_TE_Lorentz_Drude_Model_Ag_ Filter.FDT.

The corresponding results file is available on the OptiFDTD setup CD:

Sample29_2D_TE_Lorentz_Drude_Model_Ag_ Filter.fda.

In this lesson we will use a 2D project to demonstrate the Lorentz-Drude model 
material definition and the corresponding simulation.  A 3D project can use the same 
basic techniques described in this lesson, but using a 3D layout instead of a 2D 
layout.

The layout we are going to simulate is shown in Figure 1.  It is an aluminum-grating 
layout with air as the background material.  Because the input wave is plane wave and 
it is a periodic structure, we can use just one periodic unit cell for the simulation.  The 
step-by-step method for this is the basis of this tutorial.
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Figure 1 Design of the layout to be simulated

Creating a project with Lorentz-Drude material

Step Action 
1 Start Waveguide Layout Designer.

2 To create a new project, from the File menu, select New.
The “Initial Properties” dialog box appears.

3 Click the “Profiles And Materials” button.
The Waveguide Profile Designer appears.

4 In the directory under OptiFDTD_Designer1 of the Profile Designer, under 
the Materials folder, right-click the FDTD-Dispersive folder, and select 
New.The “FDTDDielectric1” material definition dialog box appears.

5 In the “FDTD Dielectric1” material definition dialog box, select “Lorentz-
Drude Dispersive” option.
The Lorentz-Drude material data-entry tab appears (see Figure 2).
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Figure 2 Lorentz-Drude Dispersive Material dialog box 

6 In the Lorentz-Drude material definition dialog box, define following 
parameters

Name:  Lorentz_Drude_Al
Select:  “User Frequency” radio button 
Check:  “Isotropic” checkbox

: 1.0
Resonance: 5

Resonance S P(rad/s) R (rad/s) D (rad/s)

1 0.523 2.2758e16 0.0 7.140e13

2 0.227 2.2758e16 2.461e14 5.059e14

3 0.050 2.2758e16 2.346e15 4.740e14

4 0.166 2.2758e16 2.747e15 2.053e15

5 0.030 2.2758e16 5.276e15 5.138e15

)/( mF∞ε
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Where:
S - Strength of the corresponding resonance terms
P (rad/s) - Plasma frequency
R (rad/s) - Resonant frequency
D (rad/s) - Collision frequency (or damping factor )

Note: 
• Refer to the Technical Background description when you first start 

preparing metal simulations. 
• Parameters of aluminum are located in the appendix of Technical 

Background

Enhancement 

In the above parameter set up, if we only set one term, and set resonant frequency 
as zero, we will simulate a Drude model material

7 Click “Store” to save the defined material
The “Lorentz_Drude_Al” will be listed in the FDTD-Dielectric folder of the 
Waveguide Profile Designer

8 In the directory under “OptiFDTD_Designer1” Profile folder, right-click the 
“Channel“ folder, and select New. 
The “ChannelPro1” will be created and its data entry dialog box will appear.

9 In the “ChannelPro1 dialog box, set Profile Name to “ChannelPro1_Al” and 
2D ProfileMaterial to “Lorentz_Drude_Al”

10 Save the profile.

11 Close the Profile designer  

Designing the waveguides

Step Action 
1 In the “Initial Properties” dialog box, set the following parameters:

Waveguide Properties
Width: 0.135 [mm]
Profile: ChannelPro1_Al

Wafer dimension
Length: 1.0 [mm]
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Width:  0.54 [mm]

2D Wafer Material: Air

2 Click OK to start the Layout Designer.
The OptiFDTD designer window appears. Click Zoom ( “+”) to enlarge the 
layout

3 From the Draw menu, select Linear Waveguide.

4 Draw the waveguide in the layout at desired the position.
The waveguide appears in the layout.

Note: Click the Select tool after drawing the waveguide.

5 Double click the waveguide to edit the waveguide position and properties.
The Linear Waveguide properties dialog box appears.

6 Set the following parameters:

Waveguide start position (offset)

Horizontal: 0.225
Vertical: 0.2025
Waveguide end position

Horizontal: 0.625
Vertical: 0.2025
Select “Use Default” checkbox for channel thickness tapering

Width: 0.135
Depth: 0.0
Profile: ChannelPro1_Al

7 Design another linear waveguide with following parameters:

Waveguide start position (offset)

Horizontal: 0.225
Vertical: -0.2025
Waveguide end position

Horizontal: 0.625
Vertical: -0.2025
Select “Use Default” checkbox for channel thickness tapering.

Width: 0.135
Depth: 0.0
Profile: ChannelPro1_Al
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The layout will look as presented in Figure 2.

Figure 3 Waveguide in the layout

Setting the Input Plane

Step Action 
1 From the Draw menu, select Vertical Input Plane.

2 Insert the Input Plane into the layout at the desired position.
A red line representing the input plane appears in the layout window.

3 Double-click the Input Plane.
The “Input Field Properties” dialog box appears.
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4 Select Gaussian Modulated Continuous Wave radio button

5 Set the center wavelength to 0.55um.

6 Click Gaussian Modulated CW button, and set the following parameters

Time offset (sec): 1.0e-14
Half Width (sec): 1.0e-15

Note: This step set the time domain input as pulse

7 Click the General tab, and then click Rectangular radio button.

8 Click the 2D Transverse tab to Set the plane wave properties

Center Position: 0.0
Half Width: 0.27
Tilting Angle: 0.0
Effective Refractive Index: Local
Input Amplitude or Power: 1.0

9 Click the “General” tab, set “Plane Geometry Position” to 0.125 and select 
“Positive direction”.

10 Click OK to close the input plane properties dialog box

Setting the observation line

The observation line is only used for 2D simulations. It is used to show

• Field distribution along the line for the user input wavelength
• Calculate the outgoing power in the line for user input wavelength
• Calculate the absolute power spectrum and normalized transmittance power 

spectrum (to the input power)

Step Action 
1 From the Draw menu, select Observation Vertical Line.

2 Place the Observation Line in the desired position in the layout.

3 Double-click the observation line.

4 The “Observation Properties -- Vertical Line” dialog box appears.

5 The “General” tab settings:

6 In “Center”, “Offset”, type (select) the following:

Horizontal: 0.9 mm
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Vertical: 0.0 mm
X length: 0.54mm
Label: ObservationLine1

7 On the “Data Components” tab, select the following:

2D TE: Ey, Hx, Hz
8 Click OK.

Setting up 2D Simulation parameters

Step Action 

1 From the Simulation menu, select 2D Simulation Parameters.
The “Simulation Parameters” dialog box appears 

2 Select TE polarization option.

3 Set x-direction mesh and z-direction mesh to 0.005.

4 Click Advanced.

5 Set the Anisotropic PML boundary condition parameters:

+x: PMC
-x: PMC
+z: Anisotropic PML
-z: Anisotropic PML

Number of Anisotropic PML layers: 25
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameter: 5.0
Power of Grading Polynomial: 3.5

Note: The x- edge is set as PMC because we perform the simulations on a 
periodic cell and use the plane wave excitation.  It works like a symmetric 
boundary. Please refer to the Technical Background for Plane wave simulation
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6 Click Calculate to get the Time Step Size.

7 Set Run for 6000 time steps for finalization.

8 From the “Key Input Plane” drop-down list, select “Input Plane1” and 
“Wavelength” equal to 0.55

Note: The Key Input Plane's Center Wavelength will be used for the DFT 
calculation.

9 Click OK to close the Simulation Parameters dialog box without running the 
simulation, or click Run to start the OptiFDTD Simulator.
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Performing the simulation

When the Simulator starts, the propagation field can be observed as presented in 
Figure 4.

Figure 4 Dynamic field pattern in OptiFDTD simulator

Performing data analysis

After the simulations are completed, you can open the analyzer to do the post-
simulation analysis. The tools for post-processing data analysis are already 
discussed in other lessons. In this lesson we will demonstrate usage of an 
observation line to extract the transmittance. 
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Step Action 

1 In the OptiFDTD analyzer, select Observation Area Analysis in the tools 
menu

2 Click Observation Line button.  Observation line page appears. 
This page can show the field pattern in observation line for user specified 
wavelength

3 Click “Power Spectrum” button, and set the following parameters to extract 
the power transmittance.

Minimum wavelength: 0.4 [mm]
Maximum wavelength: 1.1 [mm]
Sample point: 71
Normalized with: Input Plane1

4 Click “Calculate” button to start transmittance calculation. The results will be 
shown in the graph. (see Figure 5)

Note: It will take a while for this calculation to complete, because DFT is 
calculated for each field component of each point in the line
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Figure 5 Power normalization (Transmittance)

Discussion:

• This lesson utilizes 2D layout to demonstrate usage of Lorentz-Drude materials 
in OptiFDTD simulations. 

• Materials in this layout can be switched to perfect conductor or other metals to 
observe their interaction with the optical field

• 3D simulation for Lorentz-Drude material has the same concept as 2D simulation. 
However, if Lorentz-Drude material in 3D layout touches the boundary, the 
corresponding Anisotropic PML will use the air instead. This approach has been 
chosen, since calculations for Lorentz-Drude material in Anisotropic PML 
consume too much time and memory. 

• Lorentz-Drude material needs very fine mesh. In general the mesh size should be 
at least 2 percent of the smallest simulated wavelength. A large mesh size will 
render the FDTD method algorithm unstable. The FDTD scheme for coarse mesh 
is unable to properly represent quick changes in signal attenuation within a few 
mesh points.
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NOTES:
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Lesson 11 - Analyzing 1D Photonic Crystals 
(Bragg gratings)

Introduction
The simplest photonic crystal consists of alternating layers of material with different 
dielectric constants. Such multilayer structures have been widely studied and are 
frequently referred to as Bragg gratings. 

In this tutorial we design simple Bragg Grating that consists of alternating layers with 
permittivity contrast 1/13 as discussed and analyzed in [1]. We will show how to use 
PWE band solver to analyze cases of both normal and oblique incidence, while 
pointing out other features of the software, namely output normalization and inversion 
symmetry. 

The tutorial is structured as follows 

1 Define the Lattice Structurer

2 PWE Band Solver Parameters

3 Run Simulation and View Results

4 Bragg grating with layers of different width

5 Off-axis propagation

Define the Lattice Structure

Note: 
• For the details on how a lattice can be created, please refer to Lesson 3—

Photonic crystal and photonic band gap simulation and Lesson 9—FDTD 
Band Solver. 

• For the details on how material and waveguide profile can be created, 
please refer to Lessons 1 through to Lesson 9.

We start investigating system of equally thick alternating layers with dielectric 
constants e1=13 and later on we will change layer thickness ratio. Open a new project.  
Create new materials named ‘eps13’ with constant isotropic refractive index of 
3.6056.  Material  “Air” is a default material in OptiFDTD and will be used in this 
project. Here we use the relationship between refractive index and permittivity . 
We will also need a channel profile with permittivity eps13. Create a new channel 
profile named ‘chan_eps13’ and specify its 2D refractive index as eps13. In this 
tutorial we will not use 3D profile definition. 

ε n2=
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It is a good practice to parameterize the layout design so that later modifications can 
be done in a fast and flexible way. We will first create several variables, which will 
represent some of the physical properties of the design. 

Note: To define the variable, please input the variable name in the Initial 
Properties dialog box.  Click OK to access the Variables and Function dialog 
box to define the values.

Finish the initial steps by defining wafer, cladding and default waveguides as follows:

– Default profile: chan_eps13
– Waveguide width: wdth
– Wafer dimensions: lngth / wdth 
– 2D Wafer: Air

Save the project under a new name. 

There are several ways how to create a Bragg grating structure. You can create the 
structure by placing individual waveguides on the layout one by one, using script or 
lattice generator. We use the lattice generator to create 1D lattice with alternating 
layers represented by simple linear waveguides surrounded by air.

In the layout designer create a new PBG Crystal structure, double click on it to open 
the Crystal Lattice Properties dialog box. Use the default 2D rectangular lattice and 
specify the Lattice dimensions  #A=1 and #C=8. This will create 1D lattice with 8 unit 
cells along C vector direction. Center the lattice on the layout by setting the origin as 
(2, 0) (horizontal, vertical).  See Figure 1

Table 1: 

lngth 10 Layout lenght

wdth 10 Layout width

offset 0.0 Horizontal offset of the unit cell elements fromthe lattice 
point (important in case of exploiting inversion symmetry).

scale 1.0 Scale factor - scales grating dimensions.

a 0.5 ac will define width of a Bragg layer (c is lattice vector).
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Figure 1 Crystal lattice Properties dialog box

Add new linear waveguide atom to the unit cell. Now you need to edit the properties 
of the linear waveguide. As the atom uses absolute coordinates we have to use our 
scale variable to preserve scalability of the design. Set the linear waveguide position. 
(See Figure 2)
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Figure 2 Atom---Linear Waveguide Properties Dialog box

– Start horizontal: scale*offset
– Start vertical: 0.0
– End horizontal: scale*(offset+a)
– End vertical: 0.0

Select chan_eps13 profile. Get back to the layout designer.  Put vertical input plane 
in the z-position of 1.0um. Check the layout and refractive index visually. Persuade 
yourself that the design will scale when you change the scale factor scale. You can 
also experiment with the filling factor a. To view the refractive index you need to enter 
an input plane to the design.
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Figure 3 Layout design (left) and refractive index view (right)

When you are finished experimenting make sure that a=0.5 and scale=1.0. To get 
final band diagrams in the same form as in the [1] we chose the lattice constant to be 
1. 
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PWE Band Solver Parameters 
Open PWE Parameters dialog box (Simulation->PWE Band Solver Parameters…)

Figure 4 PWE parameters dialog box

Unless stated otherwise use default values.  In the Solver group select 1D, TE 
Polarization. Domain parameter group gives you the option to modify the lattice 
vectors, mesh size as well as simulation center. Select Use defaults in ‘Lattice 
Vectors’ group. The band solver in 1D assumes a periodicity in z-direction; only the z-
component of c vector can be changed. In solver 1D option the periodicity lattice 
vector is (0,0,z) where z-can be define by user or is setup as z-projection of the lattice 
vector C. Band solver automatically sets a and b vectors to (1,0,0) and (0,1,0) 
automatically. Notice that using defaults for the lattice vector you are not allowed 
editing them unless you uncheck the default check box. 
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In the Mesh group increase the number of #Steps c to 64 and leave the domain origin 
set to defaults, i.e. (0,0,0). Domain origin is the origin of the numerical domain 
expressed in terms of the lattice vectors A, B, and C.

By default the domain origin coincides with the origin of the lattice. 

To perform band calculations we need to have a defined K-vector path. By default the 
k-path is not specified. Select User defined from pull-down menu in the ‘K-vector 
Path’ group. Add two new major k-vectors by right clicking on the k-path table and 
selecting ‘Add’ twice.  Edit the vectors so that they lie on the opposite boundaries of 
the 1D Brillouin zone. As the k-path is specified in terms of reciprocal lattice vectors, 
the two vectors are (0,0,-0.5) and (0,0,0.5).  Number of division determines overall 
number of the k-vectors along the path. The first vector has number of division 
automatically set up to 1, since there is no vector in the k-path preceding it. Set 
number of division next to the second major vector to 10 to generate path containing 
11 k-vectors. 

Origin Olattice AA BB CC+ + +=
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Run Simulation and View Results
When finished with editing band solver parameters click Run… to start the 
simulations. A simulation window will be launched and simulation starts. You will be 
notified in the in the output window at the bottom (Notification tab) about progress of 
the simulations. After the simulation is finished the graph is populated with set of 
eigenfrequencies of individual k-vectors. By default no processing is applied to the 
output data and the normalized frequencies are displayed as an unconnected set of 
points. 

Figure 5 Band structure of the Bragg grating with layers of equal thickness 0.5mm (permittivity 13.0/1.0)

Use the Connect button on the Diagram toolbar to connect the eigenfrequencies of 
individual bands to get clearer picture of the band diagram. On occasions the current 
version of the engine will calculate the eigenvalues not in an exact order, in which 
case the connect button will produce incorrect band diagram. You can zoom on the 
diagram by right clicking and selecting the zoom tool. To identify the band gaps, if 
present, use the Locate band gaps button on the Diagram toolbar. It is possible to set 
a tolerance for the bandgaps detection in the adjacent input field. By default the 
tolerance is set to 0.01. Setting a high tolerance you can get rid of the highlighted 
band gaps. 
294



 LESSON 11 - ANALYZING 1D PHOTONIC CRYSTALS (BRAGG GRATINGS)
Bragg grating with layers of different width
Thanks to the parameterized design we can easily verify other published results as 
well as point out other features of PWE band solver. Let’s change a variable to 0.2 to 
simulate grating with alternating layers of different widths. The layer of the high 
permittivity (waveguides) will be 0.2a thick, whereas the air layer will be 0.8a thick (for 
scale=1).  Below you see the resulting band structure as reported in reference [1]. 

Figure 6 Band structure of the Bragg grating with dielectric layers of thickness 0.2 mm (period =1mm, 
permittivity 13.0/1.0).

The calculated eigenfrequencies are plotted in a normalized fashion as,

in units [1/mm], which is not the same as usually reported results in a non-dimensional 

form ( ). To get the non-dimensional results, you need to scale the results by a 

frequency ω
2πc
---------=

ωa
2πc
---------
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lattice constant in microns. As we have chosen the lattice constant to be 
scale*|c|=1.0micron, our results look the same as published ones. Let’s now scale the 
design so that the lattice constant is equal to 2microns by setting the variable scale to 
2.0. Run the simulation again, detect the band gaps and compare the values. The first 
gap is now (0.1604, 0.3068) compared to the original (0.203, 0.453). The normalized 
frequency can be readily transform into a wavelength in microns as 

which means that the first band in our original simulation lies between 3.898and 6.631 
microns.

Off-axis propagation 

In the previous examples we intentionally selected propagation direction (k-vector) 
normal to the multilayer structures. Changing the polarization from TE to TM we are 
getting the same results, which confirm that the TE/TM modes are degenerate. In 
case of an off-axis propagation the k-vector has a component parallel to the Bragg 
layers, and the degeneracy of TM/TE modes is lifted.  The band solver allows you to 
investigate cases of off-axis incidence. This can be achieved by an appropriate k-path 
definition. We will be considering propagation along G2 reciprocal lattice vector, i.e. 
k=(0, k2, 0).  As the ordering of the lattice vectors in the band solver is (c, a, b) due 
to the layout designer G2 vector in this sample will correspond to x-direction (see 2D 
FDTD Band Solver). 

First save the current k-path in a file so that you can easily reload the path again later 
on. Click on ‘Save File’ and in the ‘SaveAs’ dialog box input the name, e.g. BraggZ. 
Next redefine the k-path by adding one more major k-point and editing the k-path in 
the following manner:

– k1=( 0.0, 0.0,-0.5), div=1
– k2=( 0.0, 0.0, 0.0), div=5
– k3=( 0.0, 1.5, 0.0), div=15

Thus the first part of the k-path from k1 to k2 will be the same as in the previous 
simulations but path from k2 to k3 will refer to propagation in y-direction (direction of 
the G2 reciprocal vector), parallel to the dielectric layers. The results of the simulations 
run for TE and TM polarizations are shown below.

λ 1
frequency
--------------------------=
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Figure 7 Band structure of the Bragg grating for TE (left) and TM (right) polarizations. The first part of each 
diagram (indices 0-5) depicts on-axez propagation, where the TE and TM modes are degenerate (the same 
diagram) and band gaps are present. The right part of the diagrams (k-vector indices 5-20) shows lift od 

degeneracy and splitting of the TE/TM bands.

TE/TM solustions can also be described in the fashion of referecence [1] as solutions 
with electric field bector in x-direction in case of TE and electric in yz plane in case of 
TM.

References:

[1] Joannopoulos, J.D., Meade, R.D., Winn, J.N., “Photonic Cystals, Molding the flow of light”, 
Princeton University Press 1995
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Lesson 12 - Analyzing 2D Photonic Crystals 

Introduction

The tutorial demonstrates analysis of 2D photonic crystal using PWE Band solver. 
First we create a lattice model of dielectric cylinders (permittivity=8.9) suspended in 
air. We then proceed with a simple simulation on a predefined k-vector path and result 
analysis. Finally we discuss the meaning of the Domain Origin in the PWE dialog box. 

Step Action 
1 Create layout of the 2D rectangular photonic crystal lattice

2 Set Parameters of PWE Band Solver

3 Simulation Run and Results Analysis

4 Using Inversion Symmetry and Domain Origin

5 2D Hexagonal lattice

6 Band solving of rotated lattices

1. Create a 2D rectangular lattice of dielectric cylinders

Note: 

• For the details on how a lattice can be created, please refer to Lesson 3—
Photonic crystal and photonic band gap simulation and Lesson 9—FDTD 
Band Solver. 

• For the details on how material and waveguide profile can be created,  
please refer to lesson 1 to lesson 9

• To define the variable, please input the variable name in the Initial 
Properties dialog box.  Click “OK” to access the Variables and Function 
dialog box to define the values.

We are going analyze 2D photonic crystals with rectangular and hexagonal lattices as 
reported in reference [1].  Start defining necessary materials and channel profiles in 
the Profile Designer. Two tables below show the materials and channels needed for 
the project, next to proposed names and lattice, in which they are used. For the 
following exercise we will employ only 2D materials and channels.  
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After creating the materials and channels specify the dimensions of the wafer as 
10x10microns and wafer material as eps1_0 (air).  Create a 2D rectangular lattice of 
dielectric cylinders with permittivity 8.9 suspended in air, with radius of 0.2a where a 
is the lattice constant of the square lattice. 

On the waveguide toolbar select the PBG Crystal Structure and click on the layout. 
Open the lattice properties by double clicking on the empty lattice structure.  In the 
Crystal Lattice Properties dialog box set the Origin as (1,-4), in Lattice Properties 
select Type as 2D Rectangular and set both #A and #C to 8. We will build the lattice 
parameterized so that it is easy to change physical dimensions later on. Define a 
variable called ‘a’ and set it to 1. It will be our lattice constant. You can do so either 
from the Crystal Lattice Propeties box by clicking any field which contains fx symbol 
or from the designer (Simulation >> Edit Parameters). As the basis vectors are in unit 
length by default, by setting Scale in Lattice Dimensions group to ‘a’ the lattice 
constant of the lattice is expressed by scale in microns. 

In ‘Atom Waveguides in Unit Cells’ group add new elliptical waveguide with major and 
minor radius set to 0.2a and profile ‘Chan8_9’. Now the lattice is defined. 

To test the parametrized lattice go to ‘Simulation->Edit Parameters…’ and change 
‘a’ variable value to e.g. 1.5, click ok and you will see that the whole lattice has the 
lattice constant of 1.5, and cylinders have radius of 0.2a. Set scale to its original value 
1.0.

Table 1 

Material Name 2D Permittivity/regractive index [-} Used in

eps8_9 8.9 /2.983287 2D rectangular lattice

eps1_0 1.0 /1.0 2D rectangular & hexagonal 
lattice

eps13_0 13.0 /3.605551 2D hexagonal lattice

Table 2 

Channel Name 2D Material [-] Used in

Chan_eps8_9 eps8_9 2d rectangular lattice

Chan_eps1 eps1_0 2D hexagonal lattice
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2. PWE Band Solver Parameters 

Open PWE Parameters dialog box (Simulation->PWE Band Solver 
Parameters…). By default the PWE solver should be set to 2D Solver, TE 
polarization, no inversion symmetry. The Lattice vectors should use defaults, i.e. the 
mesh (#Steps a, #Steps c) should be set to 16x16. Also make sure the Domain origin 
is set to (0,0,0). Set number of bands to 6 and tolerance to 10-6 for best results. 

Now you have to define only the k-vector path. In case of a square 2D lattice with 
atoms having at least the same symmetry as the lattice you can use the predefined 
SquareZX path from the pull down menu in ‘K-vector Path’ group. This is a standard 
Reducible Brillouin zone of a square lattice as shown in technical background.  The 
default path, defined in terms of reciprocal lattice vectors, automatically populates the 
K-vector path table. The path is defined by set of major k-points and associated 
number of division along the path from one major vector to another

Figure 1 PWE Band Solver Parameters Dialog Box
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3. Simulation Results

When finished with editing band solver parameters click Run… to start the 
simulations. A simulation windows will be launched and simulation starts. You will be 
notified in the in the Notification tab window at the bottom about progress of the 
simulations. The engine first reports on the permittivity averaging process, then on the 
progress of calculations for individual k-vectors and finally informs you when the 
simulation is finished. At the end of the simulation the graph is populated with set of 
eigenfrequencies of individual k-vectors. You can use the ‘Connect’ button on the 
Diagram toolbar to connect the eigenfrequencies of individual bands as in the 1D 
case. You can also identify band gaps if there are any.  To get band structure for TM 
modes you have to run the simulation again with TM polarization setting.

It is always possible to run with hybrid polarization setting. In this case both TE and 
TM modes are displayed but the band solver cannot distinguish the modes. 

Figure 2 Band Diagram from PWE Band Solver

You can compare the calculated band diagrams with the results in reference [1].
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Inversion Symmetry and Domain Origin

In case the simulated unit cell or supercell structure has inversion symmetry the 
operator matrix in the eigenvalue problem becomes a real symmetric matrix. This can 
be used to achieve significant savings in storage and as well as speed improvement. 
The inversion symmetry in the design is not detected automatically but user can notify 
the solver about its presence by checking the Inversion Symmetry check box. To 
obtain correct results,however, the unit cell (or supercell) has to have the inversion 
symmetry around the Domain Origin. The Domain Origin is specified in terms of  the 
original lattice vectors ( ) and the lattice origin :

It has great importance when one wants to use inversion symmetry option as well 
when a defect supercell is simulated. Figure 3 below shows the simulation domain of 
a unit cell for Domain Origin (2,0,1) and (0.5,0,2.5). Notice that the refractive index for 
the simulation is obtained from different parts of the layout. For the current sample we 
can leave the domain origin as (0,0,0) knowing that the unit cell has inversion 
symmetry. Check the Inversion Symmetry check box and run the simulation again 
(either TE, TM or both). Notice the simulation time improvement. You can deduce the 
simulation time from the Notification tab messages. What is going to happen if the 
simulation domain does not have an inversion symmetry? In such case the results will 
be incorrect. The solver simply samples the refractive index only on half of the domain 
assuming the second half is defined by the inversion symmetry. Set the Domain Origin 
to (3.2,0,3.2). Clearly Domain selected does not have an inversion symmetry (see 
figure below) and the results are incorrect.  On the other hand the Domain Origin can 
be selected as (0.5,0,2.5) and possess the inversion symmetry again (green unit cell).

A B C, , Olattice

DomainOrigin Olattice AA BB CC+ ++=
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Figure 3 Inversion Symmetry and Domain Origin

It should be now clear that for simulations of unit cell it would be sufficient to have 
lattice structure of dimensions 1x1. The Domain Origin becomes also important in 
defining the supercells containing defects as for example a PC fiber or linear defects 
(waveguides).

2D hexagonal lattice  

We are now going to verify band structure of 2D hexagonal lattice as reported in 
reference [1]. At this point you might want to save the current file under different 
name. The photonic structure we want to analyze consists of a hexagonal pattern of 
air holes in dielectric with permittivity 13. We have defined all the necessary materials 
and profiles at the beginning of this tutorial so the transition is easy. 

To change the layout double click on the lattice to open Crystal Lattice Properties 
dialog. Change the lattice type from 2D Rectangular to 2D Hexagonal. Then Edit the 
properties of the elliptic waveguides (lattice atom waveguide). Change the minor and 
major radius from 0.2a to 0.48a and the profile to Chan_eps1. The last thing is to 
change the substrate from air to dielectric material eps13 (Edit >> Wafer Properties… 
>> 2D Wafer Properties) and check the index distribution in the 2D Refractive Index 
View.
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Before running simulation we want to change the Simulation parameters of the PWE 
band solver, to get desired polarization, number of bands, and mainly to set up correct 
k-path. 

In the PWE Parameters dialog uncheck the Inversion Symmetry, select TE 
polarization, use defaults for lattice vectors and mesh (16x16). Make sure the Domain 
Origin is set to (0,0,0). Set Number of Bands to 6 and tolerance to 10-5. In the K-
vector Path select the predefined HexagonalZX option. The definition of the Brillouin 
zone can be found in the Technical Background. 

Run the simulation to obtain the results for TE and TM. Keep the results for further 
comparison. Now increase the mesh resolution to 32x32. Also notice that the 
structure has an inversion symmetry so you might check the Inversion symmetry 
check box. Run the simulation with new parameters and compare the results with the 
first simulations. Even though the structures might look similar you will notice a 
difference in band gaps. This is due to the rough discretization, which cannot make 
details of the layouts. The air occupies most of the unit cell with filling factor of 0.836. 
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Figure 4 Band Diagram for Hexagonal Lattice

Rotated 2D lattice

Occasionally you might use a lattice to build a more complicated 2D layout design. In 
such design the lattice might also be rotated. You do not have to create a new layout 
to analyze the lattice. Use the Default Lattice Vectors and Domain Origin to set the 
computational domain and to capture the correct periodicity. As an example rotate the 
2D hexagonal lattice above by 10 degrees. Double click the lattice and in Lattice 
properties dialog box set the Azimuth angle to 10 degrees. Close the dialog box and 
open PWE Simulation Parameters dialog.  Make sure you have selected defaults for 
the lattice vectors and Run. The band diagrams should be the same. 

References:

[1] Joannopoulos, J.D., Meade, R.D., Winn, J.N., “Photonic Crystals, Molding the flow of light”, 
Princeton University Press 1995
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Lesson 13 - Analyzing 3D Photonic Crystals 

Introduction

Most of the features of PWE band solver were demonstrated in Lessons 11 and 12. 
In this tutorial we apply the solver to a 3D problem of a fcc (face centered cubic) and 
diamond lattices of spherical air balls suspended in a dielectric medium. Such 
structures have been intensively studied in the past [2]. The fcc structure is known to 
lack a full photonic bandgap, whereas the diamond lattice, as first reported by Ho, 
Chan and Soukoulis in 1990, have a complete photonic band gap. 

1. FCC Lattice of Air Spheres Suspended in Dielectric
• Create the Structure in Layout Designer
• Set Parameters of PWE Band Solver
• Run Simulation and Analyze Results

2. Diamond Lattice of Air Spheres Suspended in Dielectric
• Design the Lattice Structure
• Set Parameters and Run Simulation

1.  FCC lattices of Air Spheres in Dielectric

1.1 Create a 3D rectangular lattice of dielectric spheres

Note: 
– In this lesson, it is assumed that you already read the PWE tutorial 

Lesson 11 - Analyzing 1D Photonic Crystals (Bragg gratings) and Lesson 
12 - Analyzing 2D Photonic Crystals. 

– For the details on how a lattice can be created, please refer to Lesson 3—
Photonic crystal and photonic band gap simulation and Lesson 9—FDTD 
Band Solver. 

– For the details on how material and waveguide profile can be created, 
please refer to tutorial Lessons 1 through to Lesson 9.
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– To define the variable, please input the variable name in the Initial 
Properties dialog box.  Click OK to access the Variables and Function 
dialog box to define the values.

When a project is initialized, in the profile designer, please define two constant 
materials with name as “Air” and “eps13”, and the refractive index as 1.0 and 3.6055 
respectively. . As the air is already predefined as a default material we only need to 
create one new material with refractive index of ~3.6055.

Please also define a channel default profile use Air or eps13.  OptiFDTD layout 
designer requires this default even though you will not need it to build the photonic 
crystal. 

In the project initial properties dialog box, Please define wafer dimensions as 5x5 
microns, cladding material as eps13 and thickness 3 micron, substrate material eps13 
and thickness 1micron.

In the layout designer click on the PBG Crystal Structure icon and place a lattice 
structure on a layout. Open Crystal Lattice Properties dialog box and specify Lattice 
Type as FFC. The lattice vectors will be automatically generated.  Make sure the scale 
is set to 1.0 and number of lattice vector translations is set as (#A,#B,#C)=(3,3,3). 
(See Figure 1)
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Figure 1 Crystal lattice Properties dialog box. 

Enter new 3Dsphere object in the Atom Waveguides in Unit Cell. Edit the properties 
of the Sphere objects by setting the radius of 0.3716 and its material to Air. Return to 
the layout designer. Check the refractive index in the refractive index viewer and 
persuade yourself you created FCC lattice of air spheres submerge in dielectric. 

1.2 Set simulation parameters

Open the PWE Simulation Parameters dialog box and set 3D solver. Hybrid 
polarization option will be automatically selected. The current version does not allow 
applying any symmetry constraints in 3D simulations. As our lattice vectors in case of 
FCC lattice are not standard FCC lattice vector, we want to set the lattice vectors for 
PWE simulation manually so that they correspond to the standard way. Uncheck the 
Use Defaults and set vectors as 
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a=(0.5, 0.0, 0.5)
b=(0.5, 0.5, 0.0)
c=(0.0, 0.5, 0.5)

In this simulation use the mesh resolution as 16x16x16. To increase accuracy you 
might want to increase the mesh size later. The simulation time will significantly 
increase. 

Next step is to define the k-path in terms of the reciprocal vectors. In this case we want 
to scan the irreducible first Brillouin zone. The definition of the points of higher 
symmetry will define the zone can be found elsewhere. The symmetry point, we will 
define are shown in Figure 2. 

Figure 2 Schematic of the first Brillouin zone of FCC lattice (truncated octahedron) with high symmetry 
points (left) and defined k-path across the irreducible Brillouin zone (right).

To edit the k- path, Please chose the “User defined” in the K-Vector Path list, then 
right click on the k-path area, and select “Add” to edit the terminal point or stop point 
for a k-vector path. 

Figure 3 shows the PWE simulation parameter dialog box.
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Figure 3 PWE simulation parameters dialog box

Add an input wave plane in the layout, and then you can perform the PWE band solver 
simulation. The resulting band structure does not contain any complete band gap. 
Similar results can be found for example in reference [1][2].  (See Figure 4).
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Figure 4 Hybrid band structure of FCC lattice (mesh16*16*16)

2. Diamond Lattice of Air Spheres in Dielectric 

2.2 Layout design of the diamond lattice

The fcc lattice of air balls in dielectric was not found to posses band gaps. However, 
it has been shown that in case of diamond lattice band gap structure can be detected. 
The diamond lattice is composed of two interpenetrating fcc lattices, one displaced ¼ 
of a lattice constant in each direction from the other. We can easily create such 
structure in the layout designer by simply adding another fcc lattice. 

Save the file under different name to keep the original fcc lattice design. Double click 
on the fcc layout, the Crystal Lattice Properties dialog box presents.  In the “Atom 
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Waveguides in Unit Cell” region, select ‘True 3D Sphere Waveguide ” and click 
new will start to add another atom in the existing fcc layout.  Please shift this new atom 
position by ¼ in all the (x, y, z) direction. Set the two Sphere atom’s radius as 0.325. 
Check the refractive index and persuade yourself this is indeed a diamond lattice.  As 
reported in [1] the band gap should be maximized for sphere radius of 0.325. 

2.2 Set parameters and run simulation

Keep the PWE band solver simulation parameter setting from the previous example, 
and run the simulation 

The obtained band structure of the diamond lattice clearly has a complete band gap. 
Click on the Locate Band Gap button on Diagram toolbar to find details on the band 
gap: (0.4954, 0.6656), gap=0.170. 
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Figure 5 Hybrid band structure of diamond lattice  (mesh16*16*16)

References:

[1] Joannopoulos, J.D., Meade, R.D., Winn, J.N., “Photonic Crystals, Molding the flow of light”, 
Princeton University Press 1995

[2] Ho, K.M., Chan, C.T., Soukolis, C.M., “Existence of photonic gaps in periodic dielectric 
structures,” Phys.Rev.Lett. 65, p3152.
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Lesson 14 - Analyzing 2D Defects in Photonic 
Crystals 

Introduction

In the previous tutorials we were interested in finding band gaps of 1D, 2D and 3D 
photonic crystal structures. No modes are allowed with frequencies inside the gap. By 
perturbing a lattice at a single site we may permit an existence of a localized point-
defect mode or set of such modes that have frequencies within the gap. We will show 
how to detect and view such defects in 2D photonic crystals in this tutorial.  

Note: 
• In this lesson, it is presumed that you already read the PWE Tutorials 1 

to 3. 
• For the details on how a lattice can be created, please refer to Lesson 3—

Photonic crystal and photonic band gap simulation and Lesson 9—FDTD 
Band Solver. 

• For the details on how material and waveguide profile can be created, 
please refer to Lesson 1 through to Lesson 9.

• To define the variable, please input the variable name in the Initial 
Properties dialog box.  Click OK to access the Variables and Function 
dialog box to define the values.

1. Square 2D lattice 

1.1 Setting and Simulating Supercell

The rectangular lattice of dielectric rods with permittivity 8.9 suspended in air was 
investigated earlier in Lesson 2—Input wave setup. We found that the TE solutions 
(Optiwave convention) exhibit a band gap in the range between 0.324 and 0.442. First 
we have a look what is going to happen if we increase the simulation domain so that 
it contains several unit cells. Change the supercell definition to (#a,#b,#c)=(1,1,2) and 
mesh to 16x16x32. Run a TE simulation again. Notice that the band diagram looks 
very much different than in the case of 1x1x1 supercell (See Figure 1a). A band gap 
can be still located but this time it is wider and spans from 0.291 to 0.442. Change the 
supercell again to (2,1,2) and mesh to 32x16x32 and run simulation again. This time 
the band structure is again totally different (See Figure 1b). Nevertheless, the band 
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gap in the last simulation is correct. The important fact to notice is so called folding of 
the bands. For (1,2) supercell there are two bands below the band gap, and in case 
of (2,2) supercell there are four bands. This is due to the fact that the new domain 
contains 2 and 4 elementary unit cell within the supercell. 

Figure 1 Band diagram of a supercell 1x2 (left) and supercell 2x2 (right) for k-path selected along the 
irreducible Brillouin’s zone for square lattice (‘SquareZX’: G-X-M-G).

By creating a (1,2) supercell we broke up the 4-fold symmetry of the original square 
cell and what used to be an irreducible Brillouin zone in case of square lattice is only 
a part of a new irreducible zone in case of rectangular supercell. To get a correct band 
gap we need to scan along the edges of the irreducible Brillouin zone. Add two new 
major k-points to the k-path: 

X2=(0.5, 0.0, 0.0) 10 divisions
M =(0.5, 0.0, 0.5) 10 divisions

Run the simulation for (1,2) supercell. You will again observe the band folding and this 
time you will get correct band gap in agreement with our original simulation. 
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Figure 2 Band diagram of the supercell 1x2 for k-path along the edges of irreducible Brillouin’s zone for 
rectangular lattice (G-X-M-G-X2-M)

1.2 Setting up a defect

Changing the size or refractive index of a selected atom on the lattice can create a 
defect in the lattice. We will investigate a defect created by a missing dielectric rod.  
First please set the cell number to 9X9 on the original layout, then we need to remove 
the element from the lattice. Select the lattice in the layout, the  ‘PBG Crystal Structure 
Cell Editing Tool becomes highlighted in the Tools toolbar. Select it, then right click 
on the unit cell (5,5) and select Cells Off. The cylinder in the center of the lattice will 
be turned off. You can check this in 2D refractive index view (see Figure 3). 
317



 LESSON 14 - ANALYZING 2D DEFECTS IN PHOTONIC CRYSTALS
Figure 3 Layout (left) and refractive index (right) of a square lattice with missing dielectric rod (defect). 
Supercells 5x5 and 6x6 are shown with domain origins.

What is going to happen if we run a simulation on a supercell domain with the defect? 
If there is a localized defect mode confined close to the defect we should see a 
straight band within the band gap of the unperturbed square lattice, i.e. in the interval 
(0.324, 0.442). If the simulation domain is small and the localized mode extends to 
the simulation boundaries there is coupling between the adjacent defect on the 
supercell lattice and its result will be a defect band within the original band gap. Thus 
when simulation defects we need to insure that the simulation domain is large enough 
so that the localized band if it exist is narrow within our tolerance. The following 
simulation of the whole k-path is often not necessary to study point defects. A single 
k-vector simulation will usually suffice. It is however illustrative. We will perform 
simulation on a supercell 5x5 so that we can observe the localized state. We have 
already created the defect on the layout. Now we have to set the simulation Domain 
Origin. In the figure above you can see two rectangular regions marked by different 
colors. The inner region defines a suitable 5x5 supercell, the outer rectangle 6x6 
supercell. Notice that a supercell selected in such manner possesses an inversion 
symmetry, which we can use to speed up simulations. The picture also shows the 
domain an origin coordinates.  For the 5x5 supercell set the Domain Origin to (1.5, 
0.0, 1.5). We need to have a reasonable resolution. Selecting 64x64 mesh will be 
enough for demonstration. For the supercell of dimensions 5x5 we expect the first 
band will be folded 25 times and thus we will need more than 26 bands to see the 
defect if it exist. Select 30 bands. Make sure TE polarization is selected. As we have 
a square supercell a default SquareZX k-path is selected. Also check the inversion 
symmetry to speed up calculations.  The simulated results are shown in Figure 4.
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Figure 4 Band diagram of the rectangular supercell. The defect bands are flat bands within the band gap.

To detect a point defect it is usually enough to run a simulation and ideal lattice, find 
band gaps and then run simulation for a defect and a single k-vector. The solutions 
within a band gap will be the modes of interest and by a visual check of the field 
profiles we can estimate whether the selected supercell domain is large enough. 
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Next step, we what show how can we get the modal field distribution, in the PWE 
Band Solver Parameters dialog box,  k-path section leave only the gamma point and 
delete all the other major points. Leave the mesh set to 64x64, TE polarization and 
set the supercell to 5x5 with Domain origin at (3/2,0,3/2). Set number of bands to 30 
to account for the first band folding. Click on the File Export button to open the PWE 
Data Export dialog box (See Figure 5). Select User selection for K points and in the 
right input field enter the index for the exported k-vector. In this case we run simulation 
for single k-vector and as the indexing of the k-vector starts from zero enter 0. In 
Bands section select User Selection. The first band is going to be folded 
5x5=25times, so that index 24 corresponds to the defect. Choose 23, 24, and 25 to 
export both the defect profiles as well as the profiles of modes below and above the 
defect. Select all the fields and components for export. Close the dialog box and run 
simulation. 

Figure 5 PWE Data Export dialog box. User specifies k-vectors, bands as well as individual components to 
be exported.

The exported field pattern is in the sub folder where the current project is saved, you 
can use our OptiWave 3D viewer to observe these field patterns, and Figure 6 shows 
simulated results under different condition.  
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Figure 6 Localized defect mode of a rectangular lattice of dielectric cylinders (r=0.2, e=8.9) in air. From left 
to right there are electric field amplitude, magnetic field amplitude of 5x5 supercell and magnetic field 

amplitude for a supercell 6x6.

References:

[3] Joannopoulos, J.D., Meade, R.D., Winn, J.N., “Photonic Crystals, Molding the flow of light”, 
Princeton University Press 1995

[4] Ho, K.M., Chan, C.T., Soukolis, C.M., “Existence of photonic gaps in periodic dielectric 
structures,” Phys.Rev.Lett. 65, p3152
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NOTES:
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Lesson 15 - Grating Simulation

Part 1 --- Simulations of Gratings Created with VB Script
Grating layouts in most cases are the periodic structure. There are two ways in 
OptiFDTD to realized the periodic layout: PBG editor and VB scripting, PBG layout 
and corresponding simulations are discussed in Lesson 3, Lesson 11 - 14.  This 
lesson will focus the following features:

• Using VB scripting to generate the grating (or periodic) layout.
• Grating layout simulation and post-processing analysis

Note: It is assumed that you are familiar with Lesson 1—Getting started and with 
material and profile definition.

Introduce the layout
We are going to simulate a 2D grating layout that is shown in the Figure 1.

Figure 1 Layout 

Note: Note: The corresponding project file can also be found in the Sample file 
folder, Sample37_2D_VB_Script_Grating.FDT
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Define a 2D grating layout with VB scripting

Step Action 
1 Start a new project from Waveguide Layout Designer by select “New”  in 

the file menu. 
Initial Properties dialog box appears

2 In the Initial Properties dialog box set the following parameters

Wafer Dimensions
Length (mm):  8.5
Width (mm):  3.0

2D wafer properties:
Wafer refractive index: Air

3 Click Profiles and Materials.
The Profile Designer window appears.

4 Click Profiles and Materials.
In the Profile designer, under the folder “OptiFDTD_Designer1”, define and 
store the following dielectric materials.

Name: N=1.5
Refractive index (Re:): 1.5

Name: n=3.14
Refractive index (Re:): 3.14

5 In the profile designer, under the folder OptiFDTD_Designer1, define the 
following channel profiles

Name:  ChannelPro_n=3.14
2D profile definition, Material:  n=3.14

Name:  ChannelPro_n=1.5
2D profile definition, Material:  n=1.5

6 In the Initial Properties dialog box,  Set ChannelPro_n=3.14 as the default 
profile, and click “OK” to start the main designer
OptiFDTD_Designer windows appears

7 In the OPtiFDTD_Designer window, Draw the following Objects

a. Linear waveguide 1
Label:  linear1
Start Horizontal offset: 0.0
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Start vertical offset:     -0.75

End Horizontal offset: 8.5
End vertical offset:    -0.75

Channel Thickness Tapering:  Use Default
Width:   1.5
Depth:   0.0
Profile:   ChannelPro_n=1.5

b. Linear waveguide 2
Label:  linear2
Start Horizontal offset: 0.5
Start vertical offset:     0.05

End Horizontal offset: 1.0
End vertical offset:      0.05

Channel Thickness Tapering:  Use Default
Width:   0.1
Depth:   0.0
Profile:   ChannelPro_n=3.14

8 In the In the OPtiFDTD_Designer window, define an horizontal input plane 
with following properties:

Continuous Wave
Wavelength:  0.63
General: 

Input field Transverse:  Rectangular
X Position: 0.5
Direction: Negative Direction 
Label:  InputPlane1

2D Transverse:
Center Position:  4.5
Half width: 5.0
Titlitng Angle:  45
Effective Refractive Index:  Local
Amplitude: 1.0
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Figure 2 OptiFDTD Designer window after Step 8.

9 Click “Layout Script” Shortcut tool bar or select “Generate Layout Script…” 
under the Simulation menu. This step will transform the layout object to the 
VB scripting code. The software will ask:  “Generate Layout Script? This will 
overwrite the current script.” Click Yes.
The Scripting page appears

10 Click “Layout” button to go to the Layout window, and delete all the objects in 
the layout window. 

11 Click “ Test Script” shortcut toolbar or select “Test Script” in the Simulation 
Menu. This will run the VB script code. 
Now all the designed objects come back from VB scripting code. The layout 
should look like figure 2

(This steps shows that the layout can be designed by VB script)

12 Click “ Scripting” button to go to the scripting page. Modify the Linear2 code 
paragraph as the following:
Dim Linear2
for m=1 to 8 

    Set Linear2 = WGMgr.CreateObj ( "WGLinear", "Linear2"+Cstr(m) ) 
    Linear2.SetPosition  0.5+(m-1)*1.0, 0.05,    1+(m-1)*1.0, 0.05 
    Linear2.SetAttr "WidthExpr", "0.1" 
    Linear2.SetAttr "Depth", "0" 
    Linear2.SetAttr "StartThickness", "0.000000" 
    Linear2.SetAttr "EndThickness", "0.000000" 
    Linear2.SetProfileName "ChannelPro_n=3.14" 
    Linear2.SetDefaultThicknessTaperMode True 
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13 Click “ Test Script” shortcut toolbar to run the Modified VB script code. The 
grating layout is generated, the layout is shown in Figure 3.

Figure 3 Grating layout generated by VB scripting after Step 13.

Note: As has been demonstrated:

a. VB scripting provides a way to generate the periodic layout. 

b. VB script can also design other objects that can be draw in the layout. 
such as input plane, Observation Objects.

c. For more detail information about VB scripting, please refer to the VB 
Scripting Reference.

Make sure you save the layout.
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Setup simulation parameters

Step Action 
1 Select  “ 2D simulation parameters…” under the Simulation 

menuSimulation Parameters dialog box appears  

2 In the Simulation Parameters dialog, set up the following parameters
TE simulation 
Mesh Delta X:  0.015
Mesh Delta Z:  0.015
Time Step Size:  Auto
Run for 1000 Time steps

3 Click Advanced Button to set up the Boundary condition 
Set X and Z edge as Anisotropic PML boundary condition.

Number of Anisotropic PML layers: 15
Set other parameters with default value.

Perform the simulation 
• Click Run button in the Simulation Parameters to start the Simulation
• In the Analyzer, the time domain response for each field components can be 

observed
• After the simulation, click “Yes” to start the Analyzer.

Perform far field analysis for the diffraction wave. 

Step Action 
1 In the OptiFDTD Analyzer, select “Crosscut Viewer” in the Tools 

Crosscut Viewer window appear 

2 In the crosscut viewer, select “ Definition of the Cross Cut” as z-direction.

3 Move the slice position to mesh point equal to 92, ( Position: -0.12)
Observe the near field in the current slice

4 Select “Far Field” in the tools menu of cross cut viewer.
Far field transform dialog box appears. (Figure 4)
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Figure 4 Far-field Calculation dialog box

5 In the Far Field Calculation dialog box. Set up the following parameters.
Wavelength: 0.63
Refractive index: 1.5+0i
Angle Initial: -90.0
Angle Final: 90.0
Number of Steps: 721
Distance: 100, 000*wavelength
Intensity

6 Click “Calculate” button to start the calculation and save the results as 
Farfield.ffp.

7 Start the “Opti 2D Viewer” and load the Farfield.ffp. The far field is shown in 
Figure 5.
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Figure 5 Far field Pattern in “Opti 2D Viewer”

Part 2 --- Calculate the transmission and reflection spectrum from 
grating unit cell

Silicon subwavelength gratings on quartz substrates can function as a color filter. This 
has been shown the following published paper:

[1] Yoshiaki Kanamori, Masaya Shimono, and Kazuhiro Hane,  “Fabrication of Transmission Color 
Filters Using Silicon Subwavelength Gratings on Quartz Substrates”, IEEE PHOTONICS 
TECHNOLOGY LETTERS, VOL. 18, NO. 20, OCTOBER, 2006, pp. 2126-.  

The layout sketch taken from the above reference is shown in Figure 6.  The 
published reference paper also shows the measurement results and the simulation 
results with RCWA method.  For such a periodic grating with normal incident wave, 
OptiFDTD simulation can only pick up one unit cell with the transverse boundary set 
as the periodic boundary condition and input transverse beam pattern is set as 
rectangular wave (plane wave). The corresponding project file can be found in the 
Sample file folder, the file is named as: 
“X64_sample55_2D_Silicon_Subwavelength_Grating.fdt”
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Figure 6 Figure 6 Silicon Subwavelength Gratings [1]

Please open this layout with OptiFDTD layout designer.  Double clicking on each 
object in the layout to check the settings:
• The layout 2D wafer width (x-direction domain width) is set as 0.4µm, which is the 

red color filter grating’s periodic length.
• The groves material is silicon which uses the Lorentz_Drude model
• Time domain input wave is Gaussian Modulated Continuous Wave (GMCW); the 

center wavelength is set as 0.55µm.  Right click on the input spectrum graph and 
select the zoom in tool to enlarge the spectrum region, the bandwidth can be 
found covers 0.4um to 0.8um.

• Transverse input beam pattern is set as rectangular wave with size larger than the 
x-direction domain size.  This makes the input beam works as a truncate plane 
wave. 

• The x-direction boundary condition is set as periodic boundary condition (PBC). 
This can be found by clicking the advanced button in the Simulate 2D using 
64bit simulator dialog box. 

• The spectrum wavelength range is set as from 0.4 µm to 0.8 µm with sampling 
point as 161. This can be found by click the DFT Spectrum button in the 
Simulate 2D using 64bit simulator dialog box

• One observation line is put after the grating, it detects the transmission spectrum.  
Another observation line is put behind the input plane, it detects the reflection 
spectrum
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Please perform the 2D 64bit simulation for this sample layout (32bit simulation is also 
OK but will be slow).  After the simulation, open the results file to get the transmission 
spectrum and reflection spectrum

Step Action 
1 Under tools menu, select Observation Area Analysis
2 Select Observation Line in Observation Area Analysis dialog box. 

3 Select “Observationline1” in the observation line check list

4 Select Power Spectrum button, Power Spectrum dialog box appears 

5 Check “normalize with” checkbox and click Calculate button, Power 
Transmission spectrum appears, (refer to Figure 7).  Power transmission 
spectrum matched the measurement results  published in the referenced 
(refer to Figure 8)

6 Repeat step 3 to 4 for Observationline2, reflection spectrum can be 
calculated, (refer to Figure 9).

Figure 7 Transmission spectrum obtained by OptiFDTD
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Figure 8 Transmission spectrum in reference [1]

Figure 9 Reflection spectrum obtained from OptiFDTD

Part 3 --- Calculate the diffraction efficiency and diffraction angle 
based on grating unit cell simulation

This part shows how to extract the diffraction angle and diffraction efficiency based 
the FDTD near field simulation and far-field transform.  The simulation concept is to 
use the FDTD method to get the near field pattern and near field transmission and 
reflection.  The diffraction angle and power ratio for different diffraction beam can be 
evaluated from the far-field pattern. Then the power ratio for each diffraction beam 
multiplies the near field transmission (or reflection) will be the grating efficiency.

The sample used in this part is a 2D periodic grating with both substrate and grooves 
are made of SiO2 (n=1.5).  Normal incident plane waves come from the air then pass 
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through the grooves and goes to the substrate.  For such a periodic layout with normal 
incident plane wave, we can still pick up one unit cell to perform the simulation with 
transverse boundary condition set as PBC.  In case of tilting angle input, more 
periodic cells should be used for the simulation and transverse boundary should be 
AMPL.   

The sample file can be found in the Sample file folder, the file is named as:  
“X64_sample56_2D_Caululate_Grating_Efficiency.fdt”.  Please open this layout with 
OptiFDTD layout designer.  Double clicking on each object in the layout to check the 
settings:
• The periodic length is 1.0 , the groove length is 0.5 , and depth is 

0.15 . Substrate layer connects to the z-direction end, which is supposed the 
transmitted waves are all goes out. 

• Time domain input waves is continued, wavelength is 0.63 , for this single 
wavelength simulation. We can set the input plane wave power as 1.0, then 
where the power in the observation line is put in the transmission region will be 
the transmission value.

• X-direction boundary is set as PBC
• An  observation line is put after the grating, it detects the near field transmission 

and the field pattern

Please perform the 2D 64bit simulation for this sample layout (32bit simulation is also 
acceptable, but will be slower).  After the simulation, open the results file to check the 
near field properties. 

Step Action 
1 Under tools menu, select Observation Area Analysis.

2 Select Observation Line in Observation Area Analysis dialog box.  Select 
“Observationline1” in the observation line check list

3 Click Update Graph button, near field pattern along the observation line and 
the power value 0.9771162755 appears (refer to Figure 10).  The power 
value shown here is the power transmission, because the input power is set 
as 1.0

μm μm
μm

μm
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Figure 10 Field pattern in Observation line

4 Click Export Data button to export the field pattern alone the line. The export 
data dialog box appears. (Refer to Figure 11). Select the Ey components, and 
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then right lick this Ey component to change the file folder and name.  Name 
the exported data file as “Sample56EyUnitcell.f2d”

Figure 11 Export near field pattern

5 The exported data file is for one periodic cell.  Now extend this data for 40 
periodic cells so that far field transform will be more accurate. Open the 
exported field file by using the Notepad or other text editor.   

• The first line  in the data file is the version number.
• The second line is data point number which is 101.
• The thirds line is the observation line dimension start value and end value. 
• The remaining lines are complex field data. 

To extend the field data as for 40 periods, please do the following.
a Copy the data from fifth line to the end, totaling 100 lines.
b In the end of data file, paste the copied data 39 times.
c Change the second line data point number as 4001.
d Change the third line as -20.0   20.0.
e Save the new data file as “Sample56Ey40cells.f2d”    
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6 From the OptiFDTD program start menu, select tools box and select the far 
field button, then select the  “Wide angle far field 2D”, Wide Angle Far Field 
Calculation dialog box appears (refer to Figure 12)

Figure 12 Wide angle far field calculation

7 In the ”, Wide Angle Far Field Calculation dialog box,

• Click “…”, button to locate the near field file “Sample56Ey40cells.f2d”

• Click Load button to load the data into the calculation

• Set wavelength as 0.63

• Set refractive index as 1.5

• Initial angle: -90degree, final angle: 90Degree, Number of steps:  3601

• Set results as Intensity

• Click Calculate button and save the results as “sample56FFP40Cells.ffp”

8 From the OptiFDTD program start menu, select the “Opti 2D viewer”, then 
use it to  open the far field file “sample56FFP40Cells.ffp”  (refer to figure 12)

μm
337



 LESSON 15 - GRATING SIMULATION
Figure 13 Far field pattern

9 In the Far field pattern, right click the graph and select the zoom in tools to 
zoom in each peak value, or open the data file by any text editor to read each 
diffraction angle and peak value

• The diffraction angle  matched the diffraction equation
• 0th-order power ratio (to the total power) can be evaluated form the peak intensity 

ratio. i.e. 

 

Diffraction order Angle(Degree) Peak value

0 0 3.562191e+012

±1 ±24.82 4.780688e+011

±2 ±57.14 3.998404e+010

3.562191e 012+
3.562191e 012 2.∗4.780688e 011 2.∗3.998404e 010+ + + + +( )

------------------------------------------------------------------------------------------------------------------------------------------------------------ 0.7746=
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• 0th-order diffraction efficiency is power ratio multiply the near field transmission

0.7746∗0.9771 0.75686166=
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Lesson 16 – Calculating Power Transmittance 
and Reflection using VB Script

OptiFDTD provides comprehensive post-simulation analysis tools. Such as 
transmittance spectrum analysis, mode overlap calculation, input overlap calculation, 
far field calculation, Poynting vector analysis, polarized power calculation and so on. 
These analysis tools were mainly used in the analyzer. Some users may want to 
perform the sweep simulation and want feedback the results to the layout designer so 
that the layout can be optimized, or some users may want to get the power 
transmission/reflection spectrum results without the manipulation of opening the 
analyzer. Now these works are possible by using the VB script for the 2D layout.

Access to the simulation result data of Observation Objects is a critical feature 
needed for optimization of the designed devices. Exposure of the available data 
through the VB Script interface allows for implementation of the basic optimization 
algorithms within the script and provides the means to access third party solutions 
supporting COM Automation

OptiFDTD provides the following VB script function based the Observation Line 
Power post-simulation analysis.

10 PowerAtCenterWavelength()
Purpose: Calculates power at the Center Wavelength. The Center 
Wavelength value is specified at the primary (key) Input Plane. All types of 
2D (CW, GMCW) simulations support this function.

11 PowerAtWavelength( double dWavelength )
Arguments:

dWavelength- specifies a wavelength value for which the calculations 
should be performed. Wavelength value must be greater than zero

Purpose:  Calculates power at the specified Wavelength. This function 
should be used with 2D GMCW simulations. It can be used with 2D CW 
simulations as well. However, in this case it makes sense only when non-
linear materials have been used to construct project components, and one 
can expect some harmonic frequencies to be generated.

12 CalcPowerSpectrum( dStartWavelength, dEndWavelength, 
nNumberOfPoints )
Arguments:

dStartWavelength- a double value of the spectrum start wavelength. Its 
value has to be smaller than the value of End Wavelength argument.
dEndWavelength- a double value of the spectrum end wavelength. Its 
value has to be greater than the value of Start Wavelength
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nNumberOfPoints- an integer value of the number of sampling points 
within the spectrum. Its value has to be greater than one.

Purpose:  Calculates power spectrum for the specified number of 
wavelength sampling points. This function can be used only with 2D GMCW 
simulations. When used with other type of simulations, the function will return 
zero as the power value.

13 GetPowerAtSpectralPoint( nPointIndex )
Arguments:

nPointIndex- an integer value of the spectral point. The points are 
indexed starting from zero

Purpose:  Retrieves a value of previously calculated power at the specified 
sampling point. The function will return zero if called before the 
CalcPowerSpectrum() has been executed.

14 CalcNormalizedPowerSpectrum( dStartWavelength, dEndWavelength, 
nNumberOfPoints, sInputPlaneLabel )
Arguments:

dStartWavelength- a double value of the spectrum start wavelength. Its 
value has to be smaller than the value of End Wavelength argument.
dEndWavelength- a double value of the spectrum end wavelength. Its 
value has to be greater than the value of Start Wavelength
nNumberOfPoints- an integer value of the number of sampling points 
within the spectrum. Its value has to be greater than one.
sInputPlaneLabel- label of the Input Plane, which signal is going to be 
used for normalization. The Input Plane with the specified label must be 
one of the active ones generating GMCW signal.

Purpose:  Calculates power spectrum normalized to the power signal of the 
specified Input Plane, for the specified number of wavelength sampling 
points. This function can be used only with 2D GMCW simulations. When 
used with other type of simulations, the function will return zero as the power 
value.

Note: Normalization is calculated against an existing, active Input Plane. The 
Input Plane must generate GMCW signal.

15 GetNormalizedPowerAtSpectralPoint( nPointIndex )
Arguments:

nPointIndex- an integer value of the spectral point. The points are 
indexed starting from zero

Purpose:  Retrieves a value of previously calculated power at the specified 
sampling point. The function will return zero if called before the 
CalcNormalizedPowerSpectrum() has been executed.
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Note: For more detail on this function, please refer to the VB Script Reference 
manual. 

OptiFDTD provides a template in a sample file to show you how to use these 
functions. Users are encouraged to copy this template as their own project.  The 
template sample can be found in the sample folder: Sample36_VBS_ 
ToGet_Power_Spectrum.FDT

The following demonstrates these functions. 

Step Action 
1 In the OptiFDTD Sample folder, open 

Sample36_2D_TE_VBS_PowerSpectrum.FDT in the Waveguide Layout 
Designer.

2 Double-click on the Input Plane to check the 2D input wave settings.

3 Select all the objects in the layout, then click “Delete” key  to delete all the 
objects 

4 Click “ Test Script” shortcut toolbar or  select “ Test Script” in the Simulation 
menu

Now al the objects in the layout are recreated by VB script.

5 Click the Scripting tab to go to the Script page.

6 This layout is designed by VB script.  In the Scripting page, the first 110 lines 
is the VB code to generate the layout.   After the first 110 lines, it is the code 
to get the power transmittance and reflection.   A VB subroutine is designed 
which contained the above VB function. The user can just copy the 
subroutine to their own design to get the corresponding power or power 
transmittance value.  

7 Save this layout to a different folder.

Note: You can change the project name 

8 Select “Simulation 2D using Script” to start the simulation. 

9 After the simulation, you will find that the following result files are exported 
from the VB function.

Sample36_2D_TE_VBS_ 
Power_Spectrum_NormalizedPowerSpectrum.txt
Sample36_2D_TE_VBS_ 
Power_Spectrum_PowerAtCenterWavelength.txt
Sample36_2D_TE_VBS_ Power_Spectrum_PowerAtWavelength.txt
Sample36_2D_TE_VBS_ Power_Spectrum_PowerSpectrum.txt

Note: Each file contains the results for two Observation lines due to the fact that 
the  VB Script function called the spectrum calculation for each observation line.
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Lesson 17 - Analysis of Photonic Crystal Fibers 
(PCF) in OptiFDTD

Introduction

In the past 10 years, photonic crystal fibers (PCF) have attracted much scientific and 
commercial interest.  The research and design work for PCF starts from accurate 
modal analysis of the fiber. Once the modes are found, all of the PCF properties such 
as loss, dispersion, and cutoff can be determined.

There are general three types of PCF: holey fiber (HF), field-confined holy fiber 
(FCHF) and Hole-Assisted Light-guide Fiber (HALF), as shown in figure 1.

In OptiFDTD, the mode solver is combined with the FDTD engine so that FDTD 
simulation can use the modal field as input directly. In addition to this integrated mode 
solver, OptiFDTD also provides an independent mode solver to allow user to solve 
and study the modal solutions outside of an FDTD calculation. The PCF mode solver 
will mainly be used as an independent mode solver.   Modal analysis requires two 
main steps:

a. Create the layout representing a PCF

b. Calculate the modes

We will use our Waveguide Layout Designer to define the PCF layout, and then 
convert the layout to a refractive index distribution file. The mode solver will load-in 
the index distribution file and perform the modal analysis.

Some users may want to scan the wavelength to find out the cutoff wavelength, or 
scan the layout parameters. All of this is possible with OptiFDTD package.

The following section will demonstrate how a photonic crystal fiber can be analyzed 
in OptiFDTD.  
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Sample 1- Photonic Crystal Fiber-Holey Fiber 

The most common PCF is Holey Fiber as shown in Figure 1, the cladding region 
consists of a hexagonal array of air holes; One missing air-hole defines the core 
region. The real layout may have more layers of air holes, but it is sufficient to model 
only three layers since the mode is well confined [2].  To be safe, here we take five 
layers for the mode solving. We use the PBG array editor to define the hexagonal air 
hole. To make the core center in the simulation domain’s center, we need to draw a 
graph (see Figure 2) so that the detail dimension information can be marked. Such a 
graph can make the layout creation easier, so it is highly recommended.

Figure 1 Photonic Crystal Fiber cross-section 
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Figure 2 Five layers holey fiber

Please note:

For this five layer holey fiber

(a) The background material refractive index n = 1.46

(b) Hexagonal Air hole, periodic: a = 2.3um, n = 1.0, radius R = 0.6um

(c) Simulation domain: z = 11*a, x = 11*a*sin(60º)

(d) The green dot is the hexagonal lattice original point: x = -5*a*sin(60o); 
z = 0

Create the layout 

To design a holey fiber structure, follow these steps.

Step Action 
1 Start Waveguide Layout Designer.
2 To create a new project, select File > New.

The Initial Properties dialog box appears.
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3 Click Profiles and Materials.
The Profile Designer window appears.

4 Under the Materials folder, right-click the Dielectric folder and select New.
A new Dielectric material dialog box appears.

5 Type the following information:
Name: n=1.46
Refractive index (Re:): 1.46

6 To save the material, click Store.
N=1.46 appears in the Dielectric folder in the directory and in the dialog box 
title bar.

7 Under the Profiles folder, right-click the Channel folder and select New.
The ChannelPro1 dialog box appears.

8 Create the following channel profile:
Profile name: Channel_Air
2D profile definition
Material: Air

9 Click Store.
(Close the Profile Designer.or leave it open)

10 Switch to the Layout Designer, and in the Initial Properties dialog box 
type/select the following:

Waveguide Properties
Width [µm]: 0.6
Profile: Channel_Air

Wafer Dimensions
Length: length
Width: width

2D Wafer Properties
Material: n=1.46

11 Click OK in the initial dialog box. Click Yes in the question dialog box to start 
define the variables. Variables and Functions dialog box appears
Because variable (length, width) is used in the initial dialog box .clicking OK 
will open the Parameter Editor dialog box 

12 In the Variables and Functions dialog box, define the following variables in 
the specified order then click OK to close the dialog box

Name value 

a 2.3um ~lattice constant

b a*sin(pi/3) ~height of triangle cell
length 11*a ~length of domain

width 11*b ~width of domain

c -5*b ~X original point of lattice

R 0.6um ~Radius of air hole
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Figure 3 Variable and function dialog box

Note: you can access Variables and Functions dialog box at any time by 
selecting “Simulations->Edit Parameters” menu of Layout Designer

13 From the Draw menu, select PBG Crystal Structure.

14 With the mouse cursor click once on the layout window, The PBG Crystal 
Structure appears in the layout window (see Figure 4). Click Select tool 
button (the arrow) on the shortcut toolbar to release the PBG selection.
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Figure 4 Layout window with initial PBG layout

15 To edit the crystal structure, double-click on the PBG structure (a rectangular 
shape) on the layout. The Crystal Lattice Properties dialog box appears 
(Figure 5).
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Figure 5 Crystal Lattice properties dialog box

16 In the Crystal Lattice Properties dialog box, Set the following parameters

Origin
Horizontal, expression:0
Horizontal Offset:0
Vertical Expression:c
Vertical Offset:0

Depth:  0.0
Azimuth: 0.0

Lattice Properties:

Type:  2D Hexagonal

Fill:  Block

Lattice Dimension:
Scale: a
#A 11
#C 12
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17 In Atom Waveguide in Unit Cell, Add New, select Elliptic Waveguide from 
the drop-down menu and click New. The Elliptic Waveguide Properties 
dialog box appears (see Figure 6).  In  Elliptic Waveguide Properties dialog 
box set following value

In Center, Offset, type/select the following:

Horizontal: 0.0
Vertical: 0.0
Type/select the following:

Major radius: 0.6
Minor radius: 0.6
Orientation angle: 0.0
Channel thickness tapering: Use Default (Channel: None)
Depth: 0.0
Label: Atom
Profile: Channel_Air.

Click OK.

The Elliptic Waveguide Properties dialog box closes.
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Figure 6 Elliptic Waveguide Properties dialog box

Note: When you return to the Crystal Lattice Properties dialog box, you will see 
the defined elliptic waveguide listed in Atom Waveguide in Unit Cell.

Note: If you close the Crystal Lattice Properties dialog box, you will see the 
defined PBG structure in the layout window (see Figure 7).
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Figure 7 PBG layout in designer window

18 In the layout designer, to select the PBG lattice, click the PBG area. The PBG 
Crystal Structure Cell Editing Tool (a shortcut toolbar beside the Arrow 
select tool as shown in figure 8) becomes active. Select this shortcut tool bar. 
When this tool is selected, right click on the photonic cell and click “Cells Off” 
to disable the cells. With this step, a five layer Holey fiber can be realized (see 
Figure 9).
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Figure 8 Shortcut toolbar button of “PBG Crystal Structure Cell Editing Tool”

Figure 9 Five layers holey fiber
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19 To observe the index distribution, please set a point source in the layout. The 
center Wavelength is 1.3um with Gaussian Modulated Continuous Wave 
as time domain waveform

20 Click 2D Simulation Parameters under Simulation menu, set following 
parameters and Click OK.

Mesh Delta X:  0.08um

Mesh Delta Z:  0.08um

Run for 1  time steps
21 Click “2D Refr_Idx_Re(y)” tab under the layout window to observe the 

refractive index distribution. (see Figure 10)

Figure 10 Refractive index distribution
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Convert Refractive index distribution to a file
To perform modal calculations we will use the stand-alone Mode Solver application. 
We need to export the refractive index distribution of the PCF cross-section and 
transfer it to the Mode Solver. To export the refractive index, follow these steps:

Step Action 
1 Set an input wave (with Gaussian Modulated Continuous Wave as time 

domain waveform) in the layout, (This work was done in step 18 in a previous 
section) 

2 Set proper mesh size for mode solving (This work was done in step 19 in a 
previous section)

3 Click “2D Refr_Idx_Re(y)” tab to observe the refractive index distribution. 
(see figure 10)

4 Select “File->Export Refractive Index Distribution” menu, Export 
Refractive Index Distribution dialog box appears (see Figure 11)

Figure 11 Export refractive index dialog box

5 Click OK,  the refractive index distribution will be saved to a file called 
PCF_Holey_Fiber_five_layers01_2D.rid 
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Perform the Modal analysis 

Step Action 
1 Open the stand-alone 3D Mode Solver from Tools: from the Start menu, 

select Programs > Optiwave Software > OptiFDTD 6.0 > Tools > Mode 
3D. 3D Mode Solver appears (see Figure 12)

Figure 12 3D Mode Solver

2 Click “File->New” menu, select “User Defined File” and click OK in the pop 
up window.

3 Click Browse button to load the previously exported refractive index file 
(PCF_Holey_Fiber_five_layers01_2D.rid--- in this tutorial ) 

4 Click Simulation menu and select ADI Method under Global Parameters.   
Global Data:ADI Method dialog appears ( see Figure 13)
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Figure 13 Global data: ADI Method dialog box

5 In the Global Data: ADI Method dialog box, enter the following values, then 
click OK button to accept settings and close the dialog box

Wavelength: 1.3um

Number of Modes: 1

General:
Solver: Complex

Mode: Full Vector
Initial Excitation:  Along X

Waveguide: Straight

Setting:
Start Field: Gaussian

Accuracy:
Index Tolerance: 1E-007
Field Tolerance: 1E-005

Boundary Condition: TBC

Note: Other setting leave as specified by default
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6 Select “Calculate ADI” under simulation menu. Click Run button to start the 
modal analysis. 3D mode solver resulting window appears (see Figure 14).  

First, the refractive index distribution is displayed. Once the mode is solved 
(it takes a while), the view will change and display the modal field. (Clicking 
Display under Structure View will display the refractive index distribution 
structure again)

Note: :
• Save the field pattern by click Save As button
• Save the modal index by click “Save Table
• Click Close in the file menu to close this window 

Figure 14 3D mode solver results window
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Perform the wavelength scanning mode analysis 

Step Action 
1 In the 3D Mode Solver Window, click Edit Parameters under Simulation 

menu. Edit Parameter dialog box appears (see Figure 15).

Figure 15 Edit Parameters dialog box

2 In the Edit Parameter dialog box, Name field, enter “wavelength” and set its 
Value as 0.8, Click Add/Apply button to make the defined variable to be 
listed.  Click Close to close the dialog box

3 Click Scan Parameters under Simulation menu. Scan parameters dialog box 
appears (see Figure 16).
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Figure 16 Scan Parameters dialog box

4 Select “wavelength” under Unassigned Parameters table, Click Add button 
to add variable wavelength as the scan parameter.  Parameter “wavelength” 
will be listed in the bottom table.

5 Set Number of Iteration as 31 and click Apply button.  The table will extend 
to 31 lines.

6 Click Assign button in the “Leading parameter” section, our “wavelength” will 
be set as Leading Parameter

7 In the table grid, click “wavelength”, the whole column will be selected.  
inscroll to the line 31, Double click  its edit cell and input iteration End Value 
of 1.4

8 Re-select the wavelength column and click Fill button. The data cells in the 
column will automatically be filled with the sampling points for each simulation 
sweep of the “wavelength” value.

9 Click OK to close this Scan Parameter dialog box

10 Select “Simulations->Calculate ADI” menu. In the Wavelength box enter 
the previously specified parameter name “wavelength”, select Full vector 
with initial excitation along Y. Set Complex Solver with TBC boundary 
conditions. Run the simulations

11 The Mode Solver will perform a set of modal calculations sweeping the 
wavelength value. This approach is used to obtain the cutoff wavelength (see 
Figure 17)
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Figure 17 Monitor the wavelength scan simulation
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NOTES:
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Lesson 18 - Simulations with 64-bit 3D Simulator 

The workflow required to perform simulations with 64-bit 3D Simulator is almost the 
same as for the “regular” 32-bit simulator(s):

Step Action 
1 Create a New Layout

a. Define the material and waveguide in profile designer

b. Set up the initial simulation domain

c. Draw the waveguide 

2 Define simulation parameters

3 Define input wave

a. Set up time domain input

b. Set up the transverse domain input

4 Observe the refractive Index

5 Set up the Observation Objects (data-detectors) to extract the field pattern 
and transmission/Reflection spectrum.

6 Launch 64-bit 3D Simulator (menu “Simulation->Simulate 3D using 64-bit 
Simulator…”).

7 Perform the post-simulation analysis

The 64-bit simulator differs from 32-bit mainly in the aspect of DFT calculations. The 
32-bit simulators perform DFT calculations and time domain data are stored for the 
whole volume. However, the calculation domain of the 64-bit simulator can occupy TB 
(Tera Bytes) of computer memory. In this case, the amount of generated data would 
be enormous, which would be impractical and unmanageable. To resolve this issue, 
the DFT calculations are performed only for the Observation Areas, and time domain 
data are collected only for Observation Points.

You can configure the DFT settings in Simulation Parameters for 3D 64-bit 
Simulations. When you choose menu option “Simulation->Simulate 3D using 64-bit 
Simulator…” you will be presented with “3D Simulation Parameters” dialog box 
specific for the 64-bit simulator. OptiFDTD provides default configuration of Spectral 
DFT settings. See User Reference manual for description.

Note: 

Performance of simulations on multiprocessor (multi-core) computers. 
In order to acheive the highest performance (speed) of the simulation, it is 
recommended that the computer is not used while the simulations are in 
progress:

The calculations are performed on all available processors in so called 
true-parallel algorithm (the only applicable parallel processing method for 
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FDTD algorithm). In result the overall performance (speed) of the simulations 
depends on the processing speed of the slowest processor, since all other 
processors have to wait until the last processor completes its simulation 
sequence.

If the computer is used for other tasks during the simulations, the 
operating system will take some CPU time to support the user running his 
application (e.g. email, internet browser, word editors, etc.). It will decrease 
the CPU time spent by one (or more) of the processors on simulations.

DFT Calculations.
When performing simulations with 64-bit Simulator, make sure that the 
designed project has Observation Objects (Areas or Points) defined. 
Otherwise, the simulation results will not be stored for the post-simulation 
analysis.

All 32-bit simulators are also available under 64-bit machine. However, their 
memory usage is still limited to 2GB.

Create a new Layout
The following lesson uses straight channel waveguide as an example.

Note: 
• The corresponding project file can be found in the Sample file folder, 

Sample43_64bit_3D_Simulations_Getting_Started.fdt.
• If you already familiar with layout creation, please open the example 

project and go to the step “Perform the 64Bit-FDTD FDTD Simulation”
• Please see other tutorial lessons to get familiar with the Layout Designer 

features

Layout creation steps

Step Action 
1 Open OptiFDTD Waveguide layout Designer

From the Start menu, select Programs >Optiwave Software > OptiFDTD > 
Waveguide Layout Designer.  OptiFDTD_Designer window opens

2 Create a new project
From the OptiFDTD_Designer File menu, select New.  The Initial 
Properties dialog box appears 

3 Define the material(s) and waveguide profile(s) that will be used in the project
Click Profiles and Materials button in the area in Initial Properties Dialog.  
The Profile Designer OptiFDTD opens, 

Note: Profile Designer can also be opened independently at any time

a. In the directory under OptiFDTD_Designer1 of Profile Designer 
OptiFDTD, under Materials folder, right-click the Dielectric folder. A 
context menu appears.  Select New, the Dielectric dialog box appears. 
By default the constant refractive index (Const Ref. Idx) is selected.  
Type the following information
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Name: n=1.5
Constant refractive index (isotropic) (Re): 1.5
Click Store to save this material, Material n=1.5 will be listed under the 
Dielectric folder

b. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears. Select New. The 
Channel Profile dialog box appears.  

•  Type the following Profile name: waveguide
•  Under 3D profile definition: Type the following information:

Layer name: WG
Width: 1.0
Thickness: 1.0
Offset: 0.0

•  In the Material list, select n=1.5
•  Click Add.
•  To save the channel profile, click Store.

Waveguide appears in the Channel folder in the directory, 

4 Return to Initial Properties Dialog box of Waveguide Layout Designer
Either minimize or close the Waveguide Profile Designer. 

5 Type the following information in each corresponding area in Initial 
Properties Dialog box

Waveguide Properties:
Width (um):  1.0
Profile:  Waveguide 

(This profile will be used by default when 
drawing a waveguide in the layout window) 

Wafer Dimension
Length (um): 7.0 (z-direction dimension) 
Width (um): 3.0  (x-direction dimension)

3D Wafer Properties
Cladding Material: Air
Cladding Thickness: 2.0 (y-direction dimension)
Substrate Material: Air
Substrate Thickness: 1.0 (y-direction dimension)

6 Click OK in Initial Properties Dialog box.  OptiFDTD Designer- 
[OptiFDTDigner1] window appears. 

Note: 
• Your shortcut Toolbars may not all appear in the window. You can 

change it from the “View->Toolbars” menu option.
• Click “+” (zoom) toolbar button to enlarge the layout window
367



 LESSON 18 - SIMULATIONS WITH 64-BIT 3D SIMULATOR
7 Draw a linear waveguide in the layout window

• From the Draw menu, select Linear Waveguide. Or select the Linear 
Waveguide shortcut toolbar.

• In the layout window, drag the linear waveguide from the start point to the 
end point. A linear waveguide appears in the layout window.

• (Change the mouse drawing tool by selecting the arrow shortcut icon on 
the toolbar)

• To adjust the position and the shape of the waveguide, in the layout 
window, double-click the Linear Waveguide.  The Linear Waveguide 
Properties dialog box appears.

• Click the Start tab and type the following values:

• Horizontal offset (um):0.0(Start point for z-direction)
Vertical offset (um): 0.0 (Start point for x-direction)
Width (um): 1.0 (Waveguide x-direction width)
Depth (um): 0.0 (Waveguide y direction bottom)
Label: Linear1
Channel Thickness Tapering:Use Default (Channel: None)

(Waveguide y-direction thickness setting)

• Click the End tab and type the following values:
Horizontal offset (um): 7.0
Vertical offset (um): 0.0

Note: 
• You can also set a variable in the expression - click Evaluate to verify the 

final value of the expression.
• Horizontal means the z-direction.
• Vertical means the x-direction.
• Depth means the y-direction.

• From the Profile list, select Waveguide.
• Click OK to finished the waveguide setting

Now, you have defined a simple straight waveguide. For more complex layout, Please 
refer to other tutorial lessons.

Note: 
• To add new materials and waveguide profiles select the Profiles and 

materials under the Edit menu of OptiFDTD Designer window to start 
the Profile Designer.

• To change the simulation domain dimension, select Wafer Properties 
under the Edit menu of OptiFDTD Designer window.
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Define Input Wave
The Input Wave signal is defined within the Input Plane. To insert the Input Plane and 
set the excitation wave, follow the steps below:

Step Action 
1 From the Draw menu, select Vertical Input Plane, or select Vertical Input 

Plane shortcut toolbar (The Vertical Input Plane is in the x-y plane for 3D.)

2 Click in the layout window at the position where you want to insert the Input 
Plane. A red line that represents the input plane appears in the layout 
window.

3 To set up the Input Plane properties, double-click the red line (Input Plane) in 
the layout window. The Input Field Properties dialog box appears.

4 Set the time domain Input Plane basic information.

a. Select Gaussian Modulated Continuous Wave.
The Gaussian Modulated CW tab appears.

b. Wavelength (um): 1.5

Note: 
• Continuous Wave
• Wavelength is a single wavelength that is used in simulations.
• Gaussian Modulated Continuous Wave
• Wavelength is the carrier wavelength (center wavelength) for the pulse 

simulations.
5 Click the Gaussian Modulated CW tab. To set the time domain input 

waveform. The time domain pulse graphics appear. Type the following values 
for the time domain input plane 

Time offset (sec.): 2.0e-14
Half width (sec.): 0.5e-14

Note: 
• Both the time domain wave and frequency domain wave for the Input 

Plane appear.
• The Frequency domain information is obtained by FFT from the time 

domain series.
• Right Click on the graph and select the Zoom In tool to enlarge the 

selected graph region. You can observe the bandwidth in this way.
• Adjust half width can adjust the bandwidth

6 To set up the general information (transverse field distribution) for the Input 
Plane, click the General tab

Input Field Transverse: Modal
Z Position (um): 1.5
Plane Geometry: Positive direction
Label: InputPlane1 (default)
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Note: Positive Direction means that the Input Plane is excited to the positive 
z-direction. TF/SF technique is used for the excitation algorithm, which 
makes sure the wave is excited and propagates only in one direction, and 
then behind the input wave the pure reflection wave can be detected. 

7 To solve the 3D transverse mode, click the 3D Transverse tab. Select one 
waveguide (it is selected by default in this sample) and click Find Mode.  ADI 
Method mode solver dialog box appears.  Follow the default setting to solve 
the mode:

General 
Solver:  Real
Waveguide: Straight

Mode:
Semi-vector TM,   (y-polarization input wave)

Click Calc Mode to start the mode solving. The modal field and the modal 
index will be shown in the M3DTmp3 window. Clicking this window will save 
the mode solver setting and come back to input plane dialog box.

Note: Click Data in mode solver M3DTmp3 window to save (export) the 
results.

8 To complete the Input Plane setup, click OK.
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Define Simulation Parameters

Step Action 
1 From the Simulation menu, select Simulate 3D Using 64-bit Simulator.  

The 3D Simulation Parameters dialog box appears (see Figure 1).3D 
simulation parameters dialog box

Figure 1 3D Simulation parameters dialog box

2 Type the following values for the mesh size:

Mesh Delta X (mm): 0.07
Mesh Delta Y (mm): 0.07
Mesh Delta Z (mm): 0.07
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Note: The total mesh number for each orientation will be calculated 
automatically, once focus is removed from the specific edit region.

3 To set up the boundary condition parameters, click Advanced. The 
Boundary Conditions dialog box appears.  Type the following values for the 
boundary condition:

Anisotropic PML layer number: 12
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameter: 1.0
Power of grading Polynomial: 3.5

4 Run for 900 time steps

5 Time sampling interval:   5

Note: 
- Time steps size

The default value ensures stability and accuracy of FDTD 
simulations

- Time step number
The default value ensures that the wave completes propagation 
through the whole layout

- Time sampling interval
This sampling rate applies to observation areas. It determines how 
many time domain response sample points are used for the spectrum 
calculation. 

6 Click the “Spectrum” button to set the spectrum range (refer to Figure 2)
Set “Number of Samples” to 61, 
Uncheck the “Auto” checkbox, 
Check the “Use Wavelength” radio button
Set Start wavelength as 1.35um
Set end wavelength as 1.65um
and press Ok button to accept changes
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Figure 2 Spectrum DFT simulation parameters

7 Click Ok button to accept the specified simulation parameters 

Observe the Refractive Index

Step Action 
1 Click on “3D_Ref_Idx-Re(y)” tab on the bottom of the layout frame or select 

“Refractive Index” in the View Menu. View of the refractive index distribution 
slice appears.

2 Change the slice orientation and move the slice position to observe the index 
distribution (refer to Figure 3, and Figure 4)

— Select Height Plot shortcut toolbar to observe the refractive index in height 
plot format.

— Right click on OptiFDTD graph to display the available graph tools/menus
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Figure 3 Refractive index in x-z orientation at y=0.5
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Figure 4 Refractive index in x-y orientation at z=0

Setup the Observation Objects (result data-detector)
For the 32-Bit FDTD simulation, observation objects will record all the time domain 
response so that spectrum analysis can be performed in analyzer. For 64-Bit FDTD 
simulation, Observation points will still record all the time domain response in each 
single point, but Observation area will perform the spectral analysis in simulator and 
save the spectrum DFT results to the analyzer file. For 64bit FDTD simulation, 
Observation Points or Observation Area must be present; otherwise simulations will 
not store any results for further analysis.
• Observation Point

Observes the time domain and frequency domain response. The 
transmission function can be obtained from the Observation Point analysis.

• Observation Area

It is used to compute power transmission ratio, and normalized power (power 
transmission /reflection) versus wavelength.
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Step Action 
1 From the Draw menu, select Observation Point. ( or select Observation Point 

shortcut from the toolbar)

2 Place the Observation Point in the desired position in the layout.

3 Double-click the observation point.  The “Observation Properties – Point” 
dialog box appears. Type the following values in the dialog box

General
Center Horizontal Offset: 5.2
Center Vertical Offset: 0.0
Center depth:  0.5
Label: ObservationPoint1

Data Components
Ex,  Ey

4 Click OK to close the dialog box

5 Repeat step 1-4 to design another Observation point with the following 
properties

General
Center Horizontal Offset: 0.7
Center Vertical Offset: 0.0
Center depth:  0.5
Label: ObservationPoint2

Data Components
Ex,  Ey

Note: 
• The Observation points are placed at the position where the peak value 

is expected. This will make sure that the response in observation point 
can be compared with the input wave peak value.

• Observation point 1 will detect the transmitted wave while Observation 
Point 2 will detect the reflected wave.

6 From the Draw menu, select Observation XY Area ( or select Observation 
XY Area shortcut from the toolbar)

7 Place the observation XY area in the desired position in the layout.

8 Double-click the observation area.  The “Observation Properties – XY area” 
dialog box appears. Type the following values in the dialog box
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General
Center Horizontal Offset: 5.5
Center Vertical Offset: 0.0
Center depth:  0.5
X Length: 3.0
Y length: 3.0
Label: ObservationArea1

Data Components
Ey,  Hx

Note: 
• The time domain response for selected data components will be 

recorded through the simulation.
• Ey and Hx together will determine the y-polarization z-propagation 

Poynting vector
9 Click OK to close the Observation area dialog box

10 Repeat step 6-9 to design an Observation XZ Area with the follow properties

General
Center Horizontal Offset: 3.5
Center Vertical Offset: 0.0
Center depth:  0.5
X Length: 2.0
Z length: 7.0
Label: ObservationArea2

Data Components
Ey

Click Save under File menu to save the designed project. Now your layout should 
look like the one on Figure 5
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Figure 5 Layout

Perform the 64Bit-FDTD FDTD Simulation

Step Action 
1 From the Simulation menu, select the “Simulate 3D using 64-Bit 

Simulator…” option.  The 3D Simulation Parameters dialog box appears.

2 Click Run to start the simulation. The progress window appears (see 
Figure 6).  It displays status of the simulations.
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Figure 6 FDTD simulation progress window

3 Visualization of intermediate simulation results.

First, configure the snapshot settings. Select “Simulation ->Take Snapshot” 
menu option. The “Set Snapshot” dialog box appears (Figure 7)

• Click Browse button to select the location of the output file

• Check the observation areas or observation points.  The time domain 
response in the selected observation objects for the current time-step will be 
save to the file

• Click OK to close this dialog box
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Figure 7 Setting Snapshot dialog box

4 Click the “Take Snapshot” button in the simulation progress dialog box to 
save the time domain response in the current displayed time step 

5 Go to the folder where the snapshot is saved and with 2D or 3D Viewer 
observe the time domain response for a certain time step (refer to Figure 8)

Figure 8 The time domain snapshot observed in 3D Viewer from observation area 2

When Simulation is finished, you will be asked if you want to open the analyzer to view 
the results. Click yes to start the analyzer
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Post-Simulation Data Analysis
Our Analyzer provides a number of tools allowing for evaluation simulation results.

Observation Point 

Step Action 
1 Select “Observation Area Analysis” under the “Tools” menu in the Analyzer. 

Observation Point dialog box appears 

2 To observe the time domain response in the observation point, check the 
observation point object, select the field components button, and select Time 
radio button.  (See Figure 9)
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Figure 9 Time domain response in observation point

3 To get the transmission /reflection function response in an observation point, 
select Frequency FDT radio button. And type the following values (See 
Figure 10)

Minimum wavelength: 1.3
Maximum wavelength: 1.6
Sample point: 1000
Normalize with: InputPlane1 

Click Update Graph button
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Figure 10 Transmission/Reflection function based on Observation point
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Field pattern in Observation Area

Step Action 

1 Select Observation Area in Observation Area Analysis dialog box. 

2 Select “ObservationArea2” in the observation area check list

3 Select wavelength 1.5 from the l/f   list box

Note: 
• Click l/f button to alternate the unit between wavelength and frequency
• The wavelength or frequency value is pre-set in the spectrum setting 

dialog box (refer to Figure 2)

4 Click Update Graph (see Figure 11)

5 Repeat step 2 to step 4 for ObservationArea1 (See Figure 12)
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Figure 11 Field pattern in Observation area 2 
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Figure 12 Field pattern in Observation area 1
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Power transmission/reflection function 

Step Action 
1 Select Observation Area in Observation Area Analysis dialog box. 

2 Select “ObservationArea2” in the observation area check list

3 Select Power Spectrum button, Power Spectrum dialog box appears

4 Check  “normalize with” checkbox and click Calculate button, Power 
Transmission spectrum appears, (refer to Figure 13)

Figure 13 Power transmission spectrum
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Note: 
• In order to perform power calculations, the necessary field components have 

to be selected for different polarization power.
• When an observation area is behind the input wave, it can detect the 

reflection power spectrum
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Lesson 19 - Heating absorption simulation using 
64bit processor

Metallic and lossy materials in solar cells or other semiconductor devices in general 
absorb part of the light wave energy, converting it to heat. This lesson demonstrates 
the heating absorption simulation in OptiFDTD

The layout we will simulate is shown in Figure 1, the corresponding project file 
(Sample44_3D_Heating_Absorption_64bit.fdt) can be found under the Sample folder 
of your software installation directory

Sample44_3D_Heating_Absorption_64Bit.fdt.

Figure 1 simulated layout

The layout represents a square of periodic cones with height (z-direction length) of 
1µm deposited on the flat substrate. The diameter of the cone’s bottom is 1µm, the 
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cone and substrate have the same refractive index which is n=2.4-j0.056. The cone 
lattice extends to infinity in x and y-direction, the input wave is the plane wave with 
zero tilting angle. In this case a 5X5 cone layout is taken for simulation with the x- and 
y-edge set as periodic boundary condition.  The following are the detailed steps for 
the layout creation, simulation, and post-simulation analysis.

Layout creation steps

Step Action 
1 Open OptiFDTD Waveguide layout Designer

From the Start menu, select Programs ->Optiwave Software -> OptiFDTD 
-> Waveguide Layout Designer. OptiFDTD_Designer window opens.

2 Create a new project.

From the OptiFDTD_Designer File menu, select New. The Initial
Properties dialog box appears.

3 Define the material(s) and waveguide profile(s) that will be used in the 
project.

Click the Profiles and Materials button in the Initial Properties dialog.

The Profile Designer OptiFDTD opens.

Note: At any time, you can open the Profile Designer from the “Edit->Profiles 
and Materials...” menu of the Layout Designer or from the Start menu. So you 
can make appropriate modifications to the defined materials and profiles 
whenever it is needed.

a. In the three listing of profiles and materials of Profile Designer under 
OptiFDTD_Designer1 in the Materials folder, right-click the Dielectric 
folder. A context menu appears. Select New, the Dielectric dialog box 
appears. By default the constant refractive index (Const Ref. Idx) is 
selected. Type the following information:

• Name: n=2.4-j0.056
• Constant refractive index (isotropic):

(Re): 2.4,  (Im): 0.056
• Click Store to save this material, Material n=2.4-j0.056 will be 
listed under the
• Dielectric folder

b. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears. Select New. The
Channel Profile dialog box appears. Type the following information:

• Profile name: ChannelPro1
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• Under 3D profile definition: Type the following information:
Layer name: Layer1
Width: 5
Thickness: 5
Offset: 0.0

• In the Material list, select n=2.4-j0.056
• Click Add.
• To save the channel profile, click Store.

ChannelPro1 appears in the Channel folder,

c. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Fiber folder. A context menu appears. Select New. The 
Fiber Profile dialog box appears. Type the following: 

•Profile name: FiberPro1
•Under 3D profile definition: Type the following information:

Layer name: Layer1
Rx (x-direction radius): 0.5
Ry (y-direction radius): 0.5

•In the Material list, select n=2.4-j0.056
•Click Add.

• To save the channel profile, click Store.

FiberPro1 appears in the Channel folder,

4 Return to Initial Properties dialog box of Waveguide Layout Designer 
Either minimize or close the Waveguide Profile Designer.

5 Type the following information in each corresponding area in Initial 
Properties dialog box
• Waveguide Properties:

Width (um): 1.0
Profile: FiberPro1

(This profile will be used by default when drawing a waveguide in the layout window)
• Wafer Dimension

Length (um): 5.0 (z-direction dimension)
Width (um):   5.0 (x-direction dimension)
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• 3D Wafer Properties
Cladding Material: Air
Cladding Thickness: 5 (y-direction dimension)
Substrate Material: Air
Substrate Thickness: 0 (y-direction dimension)

6 Click OK in Initial Properties dialog box. OptiFDTD Designer-
[OptiFDTDigner1] window appears.

Note: 
• If not all Toolbars appear in the Layout Desinger window, you can change it 

from the “View->Toolbars” menu option.
• Click “+” (zoom) toolbar button to enlarge the layout window.
• Open “Wafer Properties” from the Edit menu to modify simulation domain 

properties. 
• Select “Profiles and Materials” from the Edit menu to open the Profile 

Designer where you can add and modify materials and profiles. 

7 Draw a linear waveguide (the substrate in Figure 1) in the layout window 

• From the Draw menu, select Linear Waveguide. Or select the Linear 
Waveguide shortcut toolbar.

• In the layout window, drag the linear waveguide from the start point to the end 
point. A linear waveguide appears in the layout window.(Change the mouse 
drawing tool by selecting the arrow shortcut icon on the toolbar)

• To adjust the position and the shape of the waveguide, in the layout window, 
double-click the Linear Waveguide. The Linear Waveguide Properties 
dialog box appears.

• From the Profile list, select ChannelPro1.
• Click the Start tab and type the following values:

Horizontal offset (um): 3.0 (Start point for z-direction)
Vertical offset (um):  0.0 (Start point for x-direction)

• Click the End tab and type the following values:

Horizontal offset (um): 5.0
Vertical offset (um): 0.0

• Channel Thickness Tapering:
Use Default (Channel: None): Uncheck
Taper: Linear 
Start:  5
End:   5

•     Width (um): 5.0 (Waveguide x-direction width)
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•     Depth (um): 0.0 (Waveguide y direction bottom)
•     Label: Linear1
•     Click OK to finished the waveguide setting

Note: 
• You can parameterize the waveguide by entering a user-defined variable 

(parameter) in the Expression field. The expression fields are marked with 
"fx". For example you can enter StartPosZ (or an expression like 
2*StartPosZ), in the Expression field of Horizontal position definition. After 
that press the Evaluate button, to see the resulting Position value. If the 
specified parameter has not been defined, then the software will prompt you 
to define it.

• Horizontal means the z-direction.
• Vertical means the x-direction.
• Depth means the y-direction.

8 Draw Cones

• From the Draw menu, select PBG Crystal Structure.
• With the mouse cursor click once on the layout window, The PBG Crystal 

Structure appears in the layout window. Click Select tool button (the arrow) 
on the shortcut toolbar to release the PBG selection.

• Double-click on the PBG structure (a rectangular shape) on the layout. The 
Crystal Lattice Properties dialog box appears.

• In the Crystal Lattice Properties dialog box, set the following lattice 
reference  position parameters:

Origin
Horizontal Offset:  2.0
Vertical Offset: -2.0

Depth:  0.5

• In the Crystal Lattice Properties dialog box, set the following Lattice vector 
parameters:

Lattice Properties:
Type: 3D rectangular
Fill: Block

Lattice Dimension:
Scale: 1.0
#A:   5
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#B:   5 
#C:   1

• In the Crystal Lattice Properties dialog box, set the Atom Waveguide 
( Cone) properties:

In Atom Waveguide in Unit Cell, Add New, select Linear Taper 
Waveguide from the drop-down menu and click New. The Linear Taper 
Waveguide Properties dialog box appears. In Linear Taper Waveguide 
Properties dialog box set following value:

Profile:    FiberPro1

Start 
Horizontal Offset: 0
Vertical Offset: 0

End
Horizontal Offset: 1
Vertical Offset: 0

Fiber Diameter Tapering
User Default (checked)

Width
Start:   0
End 1.0
Depth: 0

Click OK to close the Linear Taper Waveguide setting. 

• In the Crystal Lattice Properties dialog box, click OK to close the Crystal Lattice 
setting.

The layout creation is finished; the layout window should like the Figure 2
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Figure 2 Layout in OptiFDTD

Define Input Wave

The Input Wave signal is defined within the Input Plane. To insert the Input Plane and 
set the excitation wave, follow the steps below:

Step Action 
1 From the Draw menu, select Vertical Input Plane, or select Vertical Input 

Plane shortcut toolbar (The Vertical Input Plane is in the x-y plane for 3D.)

2 Click in the layout window at the position where you want to insert the Input 
Plane. A red line that represents the input plane appears in the layout 
window.

3 To set up the Input Plane properties, double-click the red line (Input Plane) in 
the layout window. The Input Field Properties dialog box appears.

4 Set the time domain Input Plane basic information.
• Select Gaussian Modulated Continuous Wave.

  The Gaussian Modulated CW tab appears.
• Wavelength (um): 1.55
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Note: 
• Continuous Wave

The specified wavelength is a single wavelength that is used in 
simulations.

• Gaussian Modulated Continuous Wave
The specified wavelength is the carrier wavelength (center wavelength) 
for the pulse simulations.

5 Click the Gaussian Modulated CW tab. To set the time domain input 
waveform. The time domain pulse graphics appear. Type the following values 
for the time domain input plane:

Time offset (sec.): 1.5e-14
Half width (sec.): 0.4e-14

Note: 
• Both the time domain wave and frequency domain wave for the Input Plane 

appear.
• The Frequency domain information is obtained by FFT from the time domain 

series.
• Right Click on the graph and select the Zoom In tool to enlarge the selected 

graph region. You can observe the bandwidth in this way.
• Adjust half width can adjust the bandwidth

6 To set up the general information (transverse field distribution) for the Input 
Plane, click the General tab 
• Input Field Transverse:  Rectangular

• Click 3D transverse to set the rectangular wave properties as the 
following:

Center Position X:  0.0
Half width X       3.0
Center Position Y:  2.5
Half width Y 3.0
Tilting Angle: 0.0

Effective refractive Index:  Local

Polarization: Linear Y

Amplitude:  1.0
7 Click General tab. Set z-position in the Geometry and Wave Configure 

region as 1.0
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Define Simulation Parameters

Step Action 

1 From the Simulation menu, select Simulate 3D Using 64-bit Simulator. 
The 3D Simulation Parameters dialog box. 3D simulation parameters dialog 
box ( Figure 3)

Figure 3 3D Simulation parameters dialog box
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2 Uncheck Auto in the mesh parameters region, type the following values for 
the mesh size:

Mesh Delta X (mm): 0.025
Mesh Delta Y (mm): 0.025
Mesh Delta Z (mm): 0.025

3 To set up the boundary condition parameters, click Advanced. The 
Boundary Conditions dialog box appears (Figure 4). Type the following 
values for the boundary condition:

• Boundary Condition
X:  PBC
Y:  PBC
Z:  APML

• APML Calculation Parameters:

Anisotropic PML layer number: 10
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameter: 5
Power of grading Polynomial: 3.5
398



 LESSON 19 - HEATING ABSORPTION SIMULATION USING 64BIT PROCESSOR
Figure 4 Boundary condition dialog box

4 Set the Time Steps to 2400.

5 Set the Time Sampling Interval at 4.

Note: This is the time domain data sampling rate for spectrum analysis.

6 Click the “Spectrum” button to set the spectrum range (refer to Figure 5)
• Set “Number of Samples” to 81,
• Uncheck the “Auto” checkbox,
• Check the “Use Wavelength” radio button
• Set Start wavelength as 1.35um
• Set end wavelength as 1.75um
• and press Ok button to accept changes
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Observe the Refractive Index (Optional)

Step Action 
1 Click on “3D_Ref_Idx-Re(y)” tab on the bottom of the layout frame or select 

“Refractive Index” in the View menu. View of the refractive index cross-cut 
slice appears.

2 In the Orientation region which is in the left-bottom area of the window, 
change the slice orientation and move the slice position to observe the index 
distribution (refer to Figure 5, and Figure 6)
• Select Height Plot shortcut toolbar to observe the refractive index in 

height plot format.
• Right click on OptiFDTD graph to display the available graph 

tools/menus.

Figure 5 Refractive index distribution in xz plane at y=0.5
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Figure 6 Refractive index distribution in xy plane at z=2.4

Setup the Observation Objects (result data detector)

For the 32-Bit FDTD simulation, observation objects will record the entire time domain 
response so that spectrum analysis can be performed in analyzer. For 64-Bit FDTD 
simulation, Observation Points will still record the time domain response in each 
single point, but Observation Area will perfrom the spectral anaycis during the 
simulations and save the resulting DFT spectral data only. No time domain response 
data is stored for Observation Areas, due to its huge volume. For 64bit FDTD 
simulations, Observation Points or Observation Areas must be present, otherwise no 
result data will be stored during the simulations.
• Observation Point

Observes the time domain and frequency domain response. The transmission 
function can be obtained from the Observation Point analysis.

• Observation Area

It is used to compute power transmission ratio, normalized power (power 
transmission /reflection) versus wavelength and Heating Absorption. 
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Step Action 
1 From the Draw menu, select Observation Point. (Or select Observation 

Point shortcut from the toolbar). 

2 Place the Observation Point in the desired position in the layout. Double-
click the observation point. The “Observation Properties – Point” dialog box 
appears. Type the following values in the dialog box

• General
Center Horizontal Offset: 4
Center Vertical Offset: 0.0
Center depth: 2.5

• Label: ObservationPoint1
• Data Components (3D)

Ex, Ey
3 Click OK to close the dialog box.

4 From the Draw menu, select Observation XY Area ( or select Observation 
XY Area shortcut from the toolbar)

5 Place the Observation XY area in the desired position in the layout. 

6 Double-click the Observation Area. The “Observation Properties – XY 
area” dialog box appears. Type the following values in the dialog box

• General
Center Horizontal Offset: 2.5
Center Vertical Offset: 0.0
Center depth: 2.5
X Length: 5.0
Y length: 5.0

• Label: ObservationArea1
• Data Components (3D)

Ey, Hx, Ex, Hy
7 Repeat step 4-6 to design an Observation XY Area with the following 

properties:
•General
Center Horizontal Offset: 3.5
Center Vertical Offset: 0.0
Center depth: 2.5
X Length: 5.0
Y length: 5.0

• Label: ObservationArea2
• Data Components

Ey, Hx, Ex, Hy
402



 LESSON 19 - HEATING ABSORPTION SIMULATION USING 64BIT PROCESSOR
8 Repeat step 4-6 to design an Observation XZ Area with the following 
properties:

• General
Center Horizontal Offset: 2.5
Center Vertical Offset: 0.0
Center depth: 0.5
Z Length: 5.0
X length: 5.0

• Label: ObservationArea3
• Data Components

Ex, Ey, Ez

Click Save under File menu to save the designed project.

Perform the 64Bit-FDTD FDTD Simulation

Step Action 

1 From the Simulation menu, select the “Simulate 3D using 64-Bit 
Simulator…” option. The 3D Simulation Parameters dialog box appears.

2 Click Run to start the simulation. The progress window appears, it displays 
the status of the simulations.

3 Visualization of intermediate simulation results.
• When the Simulation Process window appears, from menu, select 

“Simulation ->Take Snapshot” menu option. The “Setting Snapshot” 
dialog box appears.

• Click the Browse button to select the location of the output file.
• Check the observation areas or observation points. The time domain 

response in the selected observation objects for the current time-step will be 
saved to the file

• Click OK to close this dialog box.
• Click the “Take Snapshot” button in the simulation progress dialog box to 

save the time domain response in the current displayed time step. Go to the 
folder where the snapshot is saved and with 2D or 3D Viewer observe the 
time domain response for a certain time step.

4 When the simulation is complete, click Yes to open the annalyzer.
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Post-Simulation Data Analysis

Our Analyzer provides a number of tools allowing for evaluation of different simulation 
results. The Heating absorption can be evaluated only in the Observation Area. 

Step Action 

1 Open results file by analyzer.

2 In the Tools menu, select Observation Area Analysis to open the dialog 
box.

3 Click on the Observation Area button to open “ObservationArea2” in the 
observation area check list. Select wavelength 1.5 from the l/f list box

4 Click the Update Graph button, the steady state field pattern in the 
observation area will be updated for the user specified wavelength.

5 Click the Heating Absorption button, the “Heating Absorption” dialog 
appears

• From the wavelength list box, select the wavelength as 1.5µm
• Click the Wx, Wy tab under the graph to observe the x-polarization, y-

polarization heating absorption distribution.
• Click W to observe the total heating absorption distribution (refer to Figure 7)
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Figure 7 Heating absorption distribution

• The absorbed heating in this whole observation can be read in this dialog box.  
When this value normalizes to the input power for the specified wavelength, 
it will give the heating absorption ratio as shown the right column in the dialog 
box.

• Equations for the heating absorption calculation  can be found in the technical 
background

• To get the normalized heating absorption spectrum for the selected heating 
absorption polarization, (i.e.  Wx, Wy or W) Click the Save Spectrum button, 
and specify the file name for the output file. 

• Use the 2D viewer to load the exported file (refer to Figure 8)
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Figure 8 Normalized total heating absorption spectrum.

6 Repeat steps 1-4 to observe the heating absorption for observation area 2 
and 3.
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Lesson 20 - 2D Total Field/Scattering 
Field(TF/SF) simulation and Radar Cross 
Section(RCS) Detection

2D Total Field/Scattering Field (TF/SF) is a special excitation type that excites 
arbitrary tilting plane wave in the enclosed rectangular surface. Inside the rectangular 
region, it generates the total field. Outside of this rectangular region, it is the pure 
scattering field.  TF/SF  simulation enable RADAR cross Section analysis. Complex 
grating layout analysis and other plane wave simulation will benefit from this TF/SF 
technique.

The following lesson show how TF/SF separate the total field and scattering field in 
free space and how RCS is detected for an infinite dielectric rod.

Note: The corresponding project file can also be found in the 32bit Sample file 
folder,

Sample49_2D_TE_TFSF_without_object.FDT
Sample50_2D_TE_TFSF_inf_Cylinder.FDT

Layout creation steps

Step Action 
1 Open OptiFDTD Waveguide layout Designer

From the Start menu, select Programs ->Optiwave Software -> OptiFDTD-
> Waveguide Layout Designer. OptiFDTD_Designer window opens.

2 Create a new project.
From the OptiFDTD_Designer File menu, select New. The Initial
Properties dialog box appears.

3 Define the material(s) and waveguide profile(s) that will be used in the 
project.
Click the Profiles and Materials button in the Initial Properties dialog. 
The Profile Designer OptiFDTD opens.

Note: At any time, you can open the Profile Designer from the “Edit->Profiles 
and Materials...” menu of the Layout Designer or from the Start menu. So you 
can make appropriate modifications to the defined materials and profiles 
whenever it is needed.

a. In the tree listing of profiles and materials of Profile Designer under 
OptiFDTD_Designer1 in the Materials folder, right-click the Dielectric 
folder. A context menu appears. Select New, the Dielectric dialog box 
appears. By default the constant refractive index (Const Ref. Idx) is 
selected. Type the following information: 

•   Name: er=2.0
•   Constant refractive index (isotropic):

(Re): 1.414214, (Im): 0.0
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•   Click Store to save this material, Material er=2.0 will be listed under 
the Dielectric folder.

b. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears. Select New. The 
Channel Profile dialog box appears. Type the following information: 

•   Profile name: ChannelPro1
•   Under 2D profile definition, In the Material list, select er=2.0 
•   To save the channel profile, click Store. ChannelPro1 appears in the 

Channel folder.
4 Return to Initial Properties dialog box of Waveguide Layout Designer.  

Either minimize or close the Waveguide Profile Designer.

5 Type the following information in each corresponding area in Initial 
Properties dialog box
• Waveguide Properties:

Width (um): 1.0
Profile: ChannelPro1

• Wafer Dimension
Length (um): 2.0 (z-direction dimension)
Width (um): 2.0 (x-direction dimension)

• 2D Wafer Properties
Material: Air

6 Click OK in Initial Properties dialog box. OptiFDTD Designer- 
[OptiFDTDigner1] window appears.

Note: 
• If not all Toolbars appear in the Layout Designer window, you can change 

it from the “View->Toolbars” menu option.
• Click “+” (zoom) toolbar button to enlarge the layout window.
• Open “Wafer Properties” from the Edit menu to modify simulation 

domain properties.
• Select “Profiles and Materials” from the Edit menu to open the Profile 

Designer where you can add and modify materials and profiles.

Now we have defined a 2µm×2µm 2D Air free space domain.  We will generate a 
TF/SF plane wave in a rectangular region in this space.  The total field region size will 
be 0.9µm×0.9µm in the center space. To detect the pure scattering field, we will also 
put four observation line detector surrounding this TF/SF generated region. Each  
Observation line detector will be 0.15µm apart from the each developed line.
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Define Input Wave
To insert the TF/SF plane wave excitation follow the steps below:

Step Action 
1 From the Draw menu, select TFSF region.

2 Click in the layout window at the position where you want to insert the TFSF 
region.
A Green/red rectangular region that represents the TFSF appears in the 
layout window. (Figure 9)

Figure 9 Initial TFSF in the layout

3 To set up the TFSF Input wave properties, double-click the TFSF lines in the 
layout window. The TFSF Properties  dialog box appears. Set the time 
domain Input Plane basic information.
• Select Continuous Wave
• Wavelength (um): 1.5
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Note: 
• Continuous Wave
The specified wavelength is a single wavelength that is used in simulations.
• Gaussian Modulated Continuous Wave
The specified wavelength is the carrier wavelength (center wavelength) for 
the pulse simulations.

4 In the General Tab, input the following information: (Figure 10)
• Input Wave Angle:   0.0 [deg]
• X min:   -0.45µm
• X max: +0.45µm
• Z min:   0.55µm
• Z max:  1.45µm

Figure 10 General Information for TF/SD input wave

a. In the 2D Transverse Tab, input the following information:
• Effective Refractive index :   Background (wafer)
• Input Amplitude or Power

Amplitude: 1.0 
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5 To set up the scattering field detector properties, in the 2D SF Detectors Tab, 
input following information:

a. In the Detector Distance tab, input following information (Figure 11)
• Distance X min side:  0.15µm,Enabled
• Distance X max side: 0.15µm, Enabled
• Distance Z min side:  0.15µm,Enabled
• Distance Z max side:  0.15µm, Enabled

Note: 
• Scattering field detectors are four observation lines beside the TFSF 

input lines, the position is determined by the distance to the input plane. 
• In this case the Scattering field detector is out of the wave, this detector 

will be disabled. 

Figure 11 2D SF Detector Distance

b. In the 2D Data Components tab, input the following information (default) 
(Figure 12)

• For x-direction detector, Select x-direction Poynting vector Sx.
• For z-direction detector, Select z-direction Poynting vector Sz
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Figure 12 2D data Components for Scattering field detector

6 Click OK in TFSF Properties dialog box. A modified TFSF region appears in 
the layout window. (Figure 13)

7 Click Save in the file menu to save this project to a file.
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Figure 13 TF/SF input plane in the layout window

Note: 2D TF/SF cannot work with other input wave type such as point source, 
input plane. 
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Define Simulation Parameters

Step Action 
1 From the Simulation menu, select 2D 32bit Simulation Parameters. 

Simulation parameters dialog box appears 

2 Select TE as the 2D simulation type

3 Turn off the auto check for Mesh Delta. Type the following values for the mesh 
size:

Mesh Delta X (um): 0.01
Mesh Delta Z (um): 0.01

4 To set up the boundary condition parameters, click Advanced. The 
Boundary Conditions dialog box appears. Type the following values for the 
boundary condition:

• Anisotropic PML layer number: 10

• Theoretical Reflection Coefficient: 1.0e-12

• Real Anisotropic PML Tensor Parameter: 10.

• Power of grading Polynomial: 3.5

5 Run for 800 time steps
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Perform the 32Bit-FDTD FDTD Simulation

Step Action 
1 From the Simulation menu, select the “2D 32bit simulation parameters" 

2 Click Run to start the simulation. The Simulator window appears (Figure 14). 
It displays the time domain response for TFSF excitation.

Figure 14 2D Simulator window

When Simulation is finished, you will be asked if you want to open the analyzer to view 
the results. Click yes to start the analyzer.
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Observe Steady state response in Analyzer

Step Action 
1 In the analyzer window, Click Ey(DFT) AMP button under the graph window 

to observe the steady state response for this TFSF excitation in free space 
(Figure 15).

2 Click Hx(DFT) AMP button or Hz(DFT) AMP button to Observe other field 
components.

3 In the Components menu, click field components and select phase will bring 
the phase distribution for each field component.

Figure 15 Steady state response
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RCS calculation for an infinity cylinder

Step Action 
1 Re-open this layout in the OptiFDTD Designer. 

2 Select "Elliptic Waveguide" under the Draw menu, or select the Elliptic 
Waveguide in the shortcut toolbar

3 Left-click and do not release the mouse to draw an elliptic waveguide in the 
layout. release the mouse by clicking the arrow toolbar.

4 To adjust the position and the shape of the elliptic waveguide, in the layout 
window, double-click the Elliptical Waveguide. The Elliptic Waveguide 
Properties dialog box appears.

5 In the Elliptic  Waveguide Properties dialog box, input following information
• Horizontal Offset:   1.0µm
• Vertical Offset:      0.0µm
• Major Radius Offset: 0.15µm
• Minor Radius Offset: 0.15 µm
• Orientation Angle offset: 0
• Channel Thickness Tapering :  User default
• Depth:                   0.0µm
• Label;'Elliptic1
• ProfileChannelPro1

6 Click OK in the Elliptic Waveguide Properties dialog box, the elliptic 
waveguide appears inside the TFSF region center. (Figure 16)
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Figure 16 Elliptic waveguide in the TFSF region

7 Click Save as in the file menu to save this project to another file name.

8 Click Run in the 2D 32bit simulation parameter dialog box to start the 
simulation. 

9 After the simulation, start the analyzer.

10 In the analyzer, Click Observation Area Analysis under the tools menu, 
Observation area analysis dialog box appears. 

11 Click Scattering Field Analysis tab in the Observation Area Analysis dialog 
box, four Scattering Field(SF) detector is listed in this dialog box, select one 
of them, select the field components tab. then click update graph, the pure 
scattering field will be displayed. (Figure 17).
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Figure 17 Scattering field

12 Click RCS (Radar Cross Section)  tab, the input the following information 
(default value)

• Start angle: 0o 
• End Angle: 360o
• Sampling Point Count:  361
• Far field Distance:   10, 000* wavelength 
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Note: 
• For single wavelength simulation,  by default Wavelength is the center 

wavelength
• For Gaussian Modulated Continuous Wave (GMCW), user can input new 

wavelength.
• RCS far-field formula is explained in the technical background.

13 Click Calculate in the RCS tab page, RCS results will be displayer (Figure 
10)

Figure 18 RCS results

Note: 
• The above RCS results agreed with the results in the reference [1] as shown 

below (Figure 11)
420



 LESSON 20 - 2D TOTAL FIELD/SCATTERING FIELD(TF/SF) SIMULATION AND RADAR CROSS SECTION(RCS) 
DETECTION
Figure 19 RCS results in reference

• Click Export in RCS results dialog box can store the results to a file, RCS 
results file is an text file, the first three line is file header, the remaining first 
column is the angle, the second column is the far-field amplitude. 

Reference: 

[1] Umashhankar K. R, Taflove A.A "Novel method to analyze electromagnetic scattering of 
complex objects", IEEE Trans. On EMC, 1982, 24(4), pp. 397-450
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Lesson 21 - Simulation on 3D surface Plasmon 
based layout

Surface plasma wave is sensitive to the metallic material and the layout geometries. 
OptiFDTD provided build in time domain Lorentz_Drude for noble metals.  In the 
following we will discuss two surface Plasmon layout simulations

Example 1   nano-gold particle simulation 
In this example, we will show how a gold particle is simulated by OptiFDTD.  In some 
surface Plasmon layouts, gold particles may distribute in an array format, if the input 
plane wave propagate straight forward and the array is periodic, then we can take one 
periodic cell for the simulation with transverse boundary set as periodic boundary 
condition (PBC).  If single gold particle works independently, we can either set 
transverse boundary as absorbing condition or still set transverse boundary as PBC 
with simulation space is two three time larger than the nano particle size.

The sample layout can be found in the 64bit sample folder, it is named as  
“X64_Sample52_100nmGoldSphere_400nm_900nmPulse.fdt”

Layout Creation steps

Step Action 
1 Open OptiFDTD Waveguide layout Designer From the Start menu, select 

Programs ->Optiwave Software -> OptiFDTD-> Waveguide Layout 
Designer. OptiFDTD_Designer window opens. 

2 Create a new project. 
From the OptiFDTD_Designer File menu, select New. The Initial 
Properties dialog box appears.

3 Define the material(s) and waveguide profile(s) that will be used in the 
project. Click the Profiles and Materials button in the Initial Properties 
dialog. The Profile Designer OptiFDTD opens. 

Note: At any time, you can open the Profile Designer from the “Edit->Profiles 
and Materials...” menu of the Layout Designer or from the Start menu. So you 
can make appropriate modifications to the defined materials and profiles 
whenever it is needed.

a. In the material folder of Master. Find build in gold material 
“Gold_Au_Lorentz_Drude_Model”, select this material and drag it to 
FDTD-Dispersive folder under Materials folder of current project 
OptiFDTD_Designer1, Click Store button in the 
Gold_Au_Lorentz_Drude_Model dialog box to save this material to the 
project. 

b. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears. Select New. The 
Channel Profile dialog box appears. Type the following information:
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• Profile name: ChannelPro1
• Under 3D profile definition: Type the following information:

Layer name: Layer1
Width: 0.1
Thickness: 0.1
Offset: 0.0

• In the Material list, select Gold_Au_Lorentz_Drude_Model
• Click Add.

• To save the channel profile, click Store.
ChannelPro1 appears in the Channel folder.

4 Return to Initial Properties dialog box of Waveguide Layout Designer. 
Either minimize or close the Waveguide Profile Designer.

5 Type the following information in each corresponding area in Initial 
Properties dialog box
• Waveguide Properties:

Width ( ): 0.1
Profile: ChannelPro1

• Wafer Dimension
Length ( ): 0.6 (z-direction dimension)
Width ( ): 0.3 (x-direction dimension)

• 3D Wafer Properties
Cladding Material: Air
Cladding Thickness: 0.3(y-direction dimension)
Substrate Material: Air
Substrate Thickness: 0 (y-direction dimension)

6 Click OK in Initial Properties dialog box. OptiFDTD Designer-
[OptiFDTDigner1] window appears.

Note: 
• If not all Toolbars appear in the Layout Desinger window, you can change it 

from the “View-Toolbars” menu option.
• Click “+” (zoom) toolbar button to enlarge the layout window. 
•  Open “Wafer Properties” from the Edit menu to modify simulation domain 

properties.
• Select “Profiles and Materials” from the Edit menu to open the Profile 

Designer where you can add and modify materials and profiles.

7 Draw a nano-particle in the layout. 

• Select sphere under the 3D shapes of Draw menu.

• Click the mouse in the layout where the particle should be put. (Change 
the mouse drawing tool by selecting the arrow shortcut icon on the toolbar)

μm

μm
μm
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• To adjust the position and the shape of the waveguide, in the layout 
window,double-click the sphere. The Sphere  Waveguide Properties dialog 
box appears

• In the sphere waveguide properties dialog box, type the following values
Position x:  0
Position y: 0.15 (m)
Position z: 0.35 (m)
Radius:     0.05  (m)
Lable:       Sphere1
Material:  Gold_Au_Lorentz_Drude_Model
• Click OK to finished the sphere setting

Note: 

You can parameterize the waveguide by entering a user-defined variable (parameter) 
in the Expression field. The expression fields are marked with "fx". For example you 
can enter StartPosZ (or an expression like 2*StartPosZ), in the Expression field of 
Horizontal position definition. After that press the Evaluate button, to see the 
resulting Position value. If the specified parameter has not been defined, then the 
software will prompt you to define it.

8 Click 3D Layout Model tab under the layout window to observe the layout in 
3D mode (see Figure 1)

Figure 1 3D layout mode for sphere
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Define Input Wave
The Input Wave signal is defined within the Input Plane. To insert the Input Plane and 
set the excitation wave, follow the steps below:

Step Action 
1 From the Draw menu, select Vertical Input Plane, or select Vertical Input 

Plane shortcut toolbar (The Vertical Input Plane is in the x-y plane for 3D.)

2 Click in the layout window at the position where you want to insert the Input 
Plane. A red line that represents the input plane appears in the layout window.

3 To set up the Input Plane properties, double-click the red line (Input Plane) in 
the layout window. The Input Field Properties dialog box appears.

4 Set the time domain Input Plane basic information.

a. Select Gaussian Modulated Continuous Wave.

    The Gaussian Modulated CW tab appears.

b. Wavelength ( ): 0.55( )

Note: 
• Continuous Wave: Wavelength is a single wavelength that is used in 

simulations.
• Gaussian Modulated Continuous Wave:  Wavelength is the carrier 

wavelength (center wavelength) for the pulse simulations.

5 Click the Gaussian Modulated CW tab to set the time domain input 
waveform. The time domain pulse graphics appear. Type the following values 
for the time domain input plane

Time offset (sec.): 4.0e-15
Half width (sec.): 0.8e-15

Note: 
• Right Click on the graph and select the Zoom In tool to enlarge the selected 

graph region. You can observe the bandwidth in this way. 
• Adjust half width can adjust the bandwidth

6 To set up the general information (transverse field distribution) for the Input 
Plane, click the General tab
Input Field Transverse: Rectangular( windowed plane wave)
Z Position ( ): 0.2
Plane Geometry: Positive direction
Label: InputPlane1 (default)

7 Click 3D Transverse to setup the plane wave setting

• Center Position X: 0.0( );       Halfwidth X:   0.2( )

• Center Position Y: 0.15 ( );      Halfwidth Y:   0.2( )

• Effective index: Local
• Polarization: Linear Y

μm μm

μm

μm μm
μm μm
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• Amplitude:  1.0 (V/m2) 

To complete the Input plane setup, click OK.

Define Simulation Parameters

Step Action 
1 From the Simulation menu, select Simulate 3D Using 64-bit Simulator. 

The 3D Simulation Parameters dialog box appears.

2 In the mesh size region unselect “Auto” boxes, type the following values for 
the mesh size:

Mesh Delta X (m): 0.004
Mesh Delta Y (m): 0.004
Mesh Delta Z (m): 0.004

3 To set up the boundary condition parameters, click Advanced. The 
Boundary Conditions dialog box appears. 

• Set X and Y direction boundary condition as PBC

• Set Z direction boundary condition as APML

• Type the following values for the PML boundary condition:
Anisotropic PML layer number: 16
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameter: 60.0
Power of grading Polynomial: 3.5

4 Run for 4000 time steps

5 Time sampling interval: 2

Note: 
• Time steps size

The default value ensures stability and accuracy of FDTD simulations
• Time step number

The default value ensures that the wave completes propagation through the 
whole layout

• Time sampling interval

This sampling rate applies to observation areas. It determines how many time 
domain response sample points are used for the spectrum calculation.

6 Click the “Spectrum” button to set the spectrum range

• Set “Number of Samples” to 101,

• Uncheck the “Auto” checkbox,

• Check the “Use Wavelength” radio button

• Set Start wavelength as 0.4

• Set end wavelength as 0.9

• and press Ok button to accept changes

μm
μm
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ctangular( windowed plane wave)
Z Position ( ): 0.2
Plane Geometry: Positive direction

Setup the Observation Objects (result data-detector)
For the 32-Bit FDTD simulation, observation objects will record all the time domain 
response so that spectrum analysis can be performed in analyzer. For 64-Bit FDTD 
simulation, Observation points will still record all the time domain response in each 
single point, but Observation area will perform the spectral analysis in simulator and 
save the spectrum DFT results to the analyzer file. For 64bit FDTD simulation,

Observation Points or Observation Area must be present; otherwise simulations will 
not store any results for further analysis.
• Observation Point

Observes the time domain and frequency domain response. The transmission 
function can be obtained from the Observation Point analysis.
• Observation Area

It is used to compute power transmission ratio, and normalized power (power 
transmission /reflection) versus wavelength.

Step Action 
1 From the Draw menu (or the shortcut toolbar), select Observation XY Area.

2 Place the Observation XY Plane in the position after the sphere in the layout.

3 Double-click the observation XY Area. The “Observation Properties – X-Y 
Area” dialog box appears. Type the following values in the dialog box
General
Center Horizontal Offset (z-drection): 0.5( )
Center Vertical Offset(x-direction): 0.0( )
Center depth (y-direction): 0.15 ( )
X-Length  0.3 ( )
Y-Length  0.3 ( )
Label: ObservationArea1

Data Components
Ex, Ey, Hx, Hy

4 Click OK to close the dialog box

5 Repeat steps 1 to 4 to design another Observation area with center horizontal 
offset at z=0.1
General
Center Horizontal Offset (z-drection): 0.1( )
Center Vertical Offset(x-direction): 0.0 )
Center depth (y-direction): 0.15 (m)
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X-Length  0.3 (m)
Y-Length  0.3 (m)
Label: ObservationArea2

Data Components
Ex, Ey, Hx, Hy

Note: Observation1 will get the power spectral transmission function, 
Observation 2 is behind input plane and it will get the power spectral reflection 
function.

6 In the same manner we can put observation point in the layout.

Perform the 64Bit-FDTD Simulation

Step Action 
1 From the Simulation menu, select the “Simulate 3D using 64-Bit 

Simulator…” option. The 3D Simulation Parameters dialog box appears.

2 Click Run to start the simulation. The progress window appears, it displays 
the status of the simulations.  

3 Visualization of intermediate simulation results. configure the snapshot 
settings. In the calculation progress window, select “Simulation ->Take 
Snapshot” menu option. The “Set Snapshot” dialog box appears

• Click Browse to select the location of the output file

• Check the observation areas or observation points. The time domain 
response in the selected observation objects for the current time-step will be 
save to the file

• Click OK to close this dialog box

4 Click the “Take Snapshot” button in the simulation progress dialog box to 
save the time domain response in the current displayed time step

5 Go to the folder where the snapshot is saved and with 2D or 3D Viewer 
observe the time domain response for a certain time step

When the simulation is finished, you will be asked if you want to open the analyzer to 
view the results. Click yes to start the analyzer
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Post-Simulation Data Analysis

Step Action 
1 Select “Observation Area Analysis” under the “Tools” menu in the Analyzer. 

Select Observation area button to active observation area analysis, 
Observation Area dialog box appears

2 Select “ObservationArea1” in the observation area check list

3 Select Ey component.

4 Select wavelength 0.8 from the  list box

5 Click Update Graph (see Figure 2) 

6 Select Power Spectrum button, Power Spectrum dialog box appears, 
Select total Power “Pz”, Check “normalize with” checkbox and click 
Calculate button, PowerTransmission spectrum appears, (refer to 
Figure 3)

Figure 2 field pattern in observation area.

λ f⁄
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Figure 3 Power transmission  function

Note: Some researchers may check the extinction ratio from Mie theory for nano-
particle. Power transmission in this sample has the reverse properties compared 
with extinction ratio (see Figure 4)

Figure 4 Extinction ratio from Mie theory
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Example 2 Simulate Sub wavelenght holes in metallic film
It is generally accepted that the enhanced transmission is mediated by surface 
plasmon polaritons (SPPs) that exhibit resonances set up by the periodicity of the 
array. We will calculate the transmission through sub-wavelength holes in a gold film 
deposited in SiO2 substrate. Surface Plasmon wave that results from the periodic 
array of holes will enhance the transmission in a certain wavelength region.  The 
original layout is shown in figure 5.  It is periodic square-air-hole arrays that were 
created by ion milling in optically thick Au films (200 nm) deposited on glass. All arrays 
investigated have a period of 425 nm. The width of the square holes is varied (148nm, 
165nm, 187nm, 196nm, 231nm, 247nm, 286nm).  In this simulation the initial input 
plane wave will propagate to z-direction, so we can just pick up one unit cell for the 
simulation with x and y boundary set as PBC. This will save the simulation time.

The sample layout can be found in the 64bit sample folder, it is named as  
“X64_Sample53_HolesInGoldFilm_Pulse500nm_1000nm.FDT”

Figure 5 Original layout and single cell layout

The following will show: 
1) How to create the layout with variable.
2) How to setup variable to sweep the hole’s size. 
3) How to perform the variable sweep simulation. 

Layout Creation steps

Step Action 
1 Open OptiFDTD Waveguide layout Designer

From the Start menu, select Programs ->Optiwave Software -> OptiFDTD-
> Waveguide Layout Designer. OptiFDTD_Designer window opens.

2 Create a new project.
From the OptiFDTD_Designer File menu, select New. The Initial 
Properties dialog box appears.
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3 Define the material(s) and waveguide profile(s) that will be used in the 
project. 
Click the Profiles and Materials button in the Initial Properties dialog.The 
Profile Designer OptiFDTD opens.  

Note: At any time, you can open the Profile Designer from the “Edit->Profiles 
and Materials...” menu of the Layout Designer or from the Start menu. So you 
can make appropriate modifications to the defined materials and profiles 
whenever it is needed.

a. In the material folder of Master. Find build in gold material 
“Gold_Au_Lorentz_Drude_Model”, select this material and drag it to 
FDTD-Dispersive folder under Materials folder of current project 
OptiFDTD_Designer1, Click Store button in the 
Gold_Au_Lorentz_Drude_Model dialog box to save this material to the 
project. 

b. In the In the directory under OptiFDTD_Designer1 of Profile Designer 
OptiFDTD, under Materials folder, right-click the Dielectric folder. A 
context menu appears. Select New, the Dielectric dialog box appears. 
By default the constant refractive index (Const Ref. Idx) is selected. 
Type the following information 

Name: n=1.5
Constant refractive index (isotropic) (Re): 1.5
Click Store to save this material, Material n=1.5 will be listed under 
the FDTD-Dielectric folder

(the following sub-step c-d is to design the waveguide cross-section that will 
be used in the layout. )

c. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears. Select New. The 
Channel Profile dialog box appears. Type the following information:

• Profile name: Channel_Au
• Under 3D profile definition: Type the following information:
Layer name: Layer1
Width: 0.425
Thickness: 0.425
Offset: 0.0
• In the Material list, select Gold_Au_Lorentz_Drude_Model
• Click Add.
• To save the channel profile, click Store.
Channel_Au appears in the Channel folder.

d. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears. Select New. The 
Channel Profile dialog box appears. Type the following information:

• Profile name: Channel_Air
• Under 3D profile definition: Type the following information:
Layer name: Layer1
Width: 0.2
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Thickness: 0.2
Offset: 0.0
• In the Material list, select Air
• Click Add.
• To save the channel profile, click Store.
Channel_Air appears in the Channel folder.

e. In the directory under OptiFDTD_Designer1, under the Profiles folder, 
right click the Channel folder. A context menu appears. Select New. The 
Channel Profile dialog box appears. Type the following information:

• Profile name: Channel_SiO2
• Under 3D profile definition: Type the following information:
Layer name: Layer1
Width: 0.425
Thickness: 0.425
Offset: 0.0
• In the Material list, select n=1.5
• Click Add.
• To save the channel profile, click Store.
Channel_SiO2 appears in the Channel folder

4 Return to Initial Properties dialog box of Waveguide Layout Designer. 
Either minimize or close the Waveguide Profile Designer.

5 Type the following information in each corresponding area in Initial 
Properties dialog box

• Waveguide Properties:
Width ( ): 0.2
Profile: Channel_SiO2

• Wafer Dimension
Length ( ): 1.0 (z-direction dimension)
Width ( ): 0.425 (x-direction dimension)

• 3D Wafer Properties
Cladding Material: Air
Cladding Thickness: 0.425(y-direction dimension)
Substrate Material: Air
Substrate Thickness: 0 (y-direction dimension)

6 Click OK in Initial Properties dialog box. OptiFDTD Designer-
[OptiFDTDigner1] window appears.

Note: 
• If not all Toolbars appear in the Layout Desinger window, you can change it 

from the “View-Toolbars” menu option.
• You can click “+” (zoom) toolbar button to enlarge the layout window. 
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• You can open “Wafer Properties” from the Edit menu to modify simulation 
domain properties.

• Select “Profiles and Materials” from the Edit menu to open the Profile 
Designer where you can add and modify materials and profiles.

7 Define an variable that will be used as the hole’s width

• Select Edit Parameters under Simulation menu. Variable and Function 
dialog box appears

• Click User Variable tab,  define a variable Name as holewidth,  
expression as 0.247.

• Click Verify button to check the expression value, click Add/Apply button 
to add this variable in the list

• Click OK to finish the variable definition 

8 Draw the substrate 

• Select Linear Waveguide shape under Draw menu or form the shortcut 
toolbar

• In the layout window, drag the linear waveguide from the start point to the 
end point A linear waveguide appears in the layout window. 

• Release the Linear Waveguide selection tool by clicking the Select tool 
after the Linear Waveguide is drawn in the layout.

• To adjust the position and the shape of this linear waveguide, double-click 
on the drawn waveguide. The Linear Waveguide Properties dialog box 
appears

• In the Linear Waveguide Properties dialog box, type the following 
values

Start horizontal offset: 0.6 (z-direction start)
Start vertical offset : 0 (x-direction start)
End horizontal offset: 1.0 (z-direction start)
End vertical offset : 0 (x-direction start)

Channel thickness tapering (waveguide thickness in y-direction)
Unselect use default
Select taper type as linear 
Start:  0.425
End:    0.425

Width: 0.425  ( x-direction waveguide thickness)
Depth: 0         (waveguide button to the y-direction original point)
Label: Linear1
Profile: Channel_SiO2

• Click OK to close the substrate waveguide setting.

9 Draw the gold film layer

Add a linear waveguide using the previous steps outlined in step 8 and set it’s 
properties using the properties listed below: 
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Start horizontal offset: 0.4 (z-direction start)
Start vertical offset : 0 (x-direction start)
End horizontal offset: 0.6 (z-direction start)
End vertical offset : 0 (x-direction start)

Channel thickness tapering (waveguide thickness in y-direction)
Unselect use default
Select taper type as linear 
Start:  0.425
End:    0.425

Width: 0.425  ( x-direction waveguide thickness)
Depth: 0         (waveguide button to the y-direction original point)
Label: Linear2
Profile: Channel_Au

10 Draw the square Air hole. 

Follow the same manner in step 8 to design the Square Air hole with the 
following information 

Start horizontal offset: 0.399 (z-direction start)
Start vertical offset : 0 (x-direction start)
End horizontal offset: 0.6 (z-direction start)
End vertical offset : 0 (x-direction start)

Channel thickness tapering (waveguide thickness in y-direction)
Unselect use default
Select taper type as linear 
Start:  holewidth
End:    holewidth

Width: holewidth  ( x-direction waveguide thickness)
Depth: 0.425/2-holewidth/2  (waveguide button to the y-direction 
original point)
Label: Linear3
Profile: Channel_Air

Note: 
• You can parameterize the waveguide by entering a user-defined variable 

(parameter) in the Expression field. The expression fields are marked with "fx". 
For example you can enter StartPosZ (or an expression like 2*StartPosZ), in the 
Expression field of Horizontal position definition. Press the Evaluate button, to 
see the resulting Position value. If the specified parameter has not been defined, 
the software will prompt you to define it.
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11 Click 3D Layout Model button under the layout window to observe the layout 
in 3d Mode

• Right click and move the mouse will move the graph center

• Right click and move the mouse will change the will angle

• Roll the mouse will zoom in and zoom out the graph.

Design VB script code to Scan the hole width
In the above step 10 we connected the Air hole dimension with the defined variable 
“holewidth”, In this section we will use a simple VB code to scan this variable.

1 Click Scripting Button under the Layout window. VB scripting page appears

2 Copy the following VB code to this page.
dim dWit
For i=1 to 6
    select case i
       case 1
            dWit=0.148
       case 2
            dWit=0.165
       case 3
            dWit=0.187
       case 4
            dWit=0.196
       case 5
            dWit=0.231
       case 6
            dWit=0.247
       case 7
            dWit=0.266          
    end select       
    ParamMgr.SetParam "holewidth", dWIt
    WGMgr.Sleep 500
    ParamMgr.Simulate
Next

Note: The above code has six iterations, each iteration set a defined variable 
“holewidth” with a new value  “dWit”

3 Click Layout button under the layout window to observe the layout.

4 Click “Test Script” under Simulation Menu or click Play shortcut toolbar. This 
will run the VB code. A changing hole size will be observed in the layout 
window,
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Note: 
• VB Script in OptiFDTD is a powerful tool for designing layout, scanning 

parameters, or even post-data analysis. For more details about VB script, 
please have a look on VB script reference or tutorial lesson15-16.

Define Input Wave
The Input Wave signal is defined within the Input Plane. To insert the Input Plane and 
set the excitation wave, follow the steps below:

Step Action 
1 From the Draw menu, select Vertical Input Plane, or select Vertical Input 

Plane shortcut toolbar (The Vertical Input Plane is in the x-y plane for 3D.)

2 Click in the layout window at the position where you want to insert the Input 
Plane. A red line that represents the input plane appears in the layout window.

3 To set up the Input Plane properties, double-click the red line (Input Plane) in 
the layout window. The Input Field Properties dialog box appears.

4 Set the time domain Input Plane basic information.

a. a. Select Gaussian Modulated Continuous Wave.

    The Gaussian Modulated CW tab appears.

b. b. Wavelength ( ): 0.68( )

5 Click the Gaussian Modulated CW tab to set the time domain input 
waveform. The time domain pulse graphics appear. Type the following values 
for the time domain input plane

Time offset (sec.): 0.8e-14
Half width (sec.): 0.1e-14

Note: 
• Right Click on the graph and select the Zoom In tool to enlarge the selected 

graph region. You can observe the bandwidth in this way. 
• Adjust half width can adjust the bandwidth

6 To set up the general information (transverse field distribution) for the Input 
Plane, click the General tab

Input Field Transverse: Rectangular( windowed plane wave)
Z Position ( ): 0.2
Plane Geometry: Positive direction
Label: InputPlane1 (default)

7 Click 3D Transverse to setup the plane wave setting

• Center Position X: 0.0  ( );       Halfwidth X:   0.5( )

• Center Position Y: 0.4125 ( );      Halfwidth Y:   0.5( )

• Effective index: Local
• Polarization: Linear Y
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• Amplitude:  1.0 (V/m2) 

8 To complete the Input plane setup, click OK.

Define Simulation Parameters

Step Action 
1 From the Simulation menu, select Simulate 3D Using 64-bit Simulator. 

The 3D Simulation Parameters dialog box appears.

2 Type the following values for the mesh size:
Mesh Delta X (m): 0.005
Mesh Delta Y (m): 0.005
Mesh Delta Z (m): 0.005

3 To set up the boundary condition parameters, click Advanced. The 
Boundary Conditions dialog box appears. 

• Set X and Y direction boundary condition as PBC

• Set z direction boundary condition as APML

• Type the following values for the PML boundary condition:
Anisotropic PML layer number: 20
Theoretical Reflection Coefficient: 1.0e-12
Real Anisotropic PML Tensor Parameter: 70.0
Power of grading Polynomial: 3.5

• Click OK to save changes

4 Run for 12000 time steps

5 Time sampling interval: 2

response sample points are used for the spectrum calculation.

6 Click the “Spectrum” button to set the spectrum range

• Set “Number of Samples” to 101,

• Uncheck the “Auto” checkbox,

• Check the “Use Wavelength” radio button

• Set Start wavelength as 0.5um

• Set end wavelength as 1.0um

• and press Ok button to accept changes

7 Click Ok button to accept the specified simulation parameters

Setup the Observation Objects (result data-detector)
For the 32-Bit FDTD simulation, observation objects will record all the time domain 
response so that spectrum analysis can be performed in analyzer. For 64-Bit FDTD 
simulation, Observation points will still record all the time domain response in each 
single point, but Observation area will perform the spectral analysis in simulator and 
save the spectrum DFT results to the analyzer file. For 64bit FDTD simulation,
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Observation Points or Observation Area must be present; otherwise simulations will 
not store any results for further analysis.

Step Action 
1 From the Draw menu (or the shortcut toolbar), select Observation xy plane.

2 Place the Observation XY Area in the position after the sphere in the layout.

3 Double-click the observation XY Area. The “Observation Properties – X-Y 
Area” dialog box appears. Type the following values in the dialog box

General

Center Horizontal Offset (z-drection): 0.1( )
Center Vertical Offset(x-direction): 0.0 )
Center depth (y-direction): 0.2125 ( )
X-Length  0.425 ( )
Y-Length  0.425 ( )
Label: ObservationArea1

Data Components
Ex, Ey, Hx, Hy

4 Click OK to close the dialog box

5 Repeat step 1 to step 4 to designer another Observation area at z=0.1um

General

Center Horizontal Offset (z-drection): 0.8( )
Center Vertical Offset(x-direction): 0.0( )
Center depth (y-direction): 0.2125 ( )
X-Length  0.425 ( )
Y-Length  0.425 ( )
Label: ObservationArea2

Data Components
Ex, Ey, Hx, Hy

6 In the same manner we can put observation point in the layout.
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Perform the VB scripting Scanning 64Bit-FDTD Simulation

Step Action 
1 From the Simulation menu, select the “Simulate 3D using 64-Bit 

Simulator…” option. The 3D Simulation Parameters dialog box appears.

2 Select “Simulate Using VB script. This will do the VB script scanning 
simulation 

3 Click Run to start the simulation. The progress window appears, it displays 
status of the simulations. 

4 Visualization of intermediate simulation results. configure the snapshot 
settings. In the simulation progress window, select “Simulation ->Take 
Snapshot” menu option. The “Set Snapshot” dialog box appears

• Click Browse button to select the location of the output file

• Check the observation areas or observation points. The time domain 
response in the selected observation objects for the current time-step will be 
save to the file

• Click OK to close this dialog box

5 Click the “Take Snapshot” button in the simulation progress dialog box to 
save the time domain response in the current displayed time step

6 Go to the folder where the snapshot is saved and with 2D or 3D Viewer 
observe the time domain response for a certain time step

Note: the simulation may need some time to finish. Simulation is suggested in the 
off-work time such as in the night so that you can get the results when you come 
back to work.

  

Post-Simulation Data Analysis
The simulation will generate 6 result files with the extension name as FDA. Open one 
result file can observe the field patterns and power transmission/reflection function:

Step Action 
1 Select “Observation Area Analysis” under the “Tools” menu in the 

Analyzer. Select Observation area button to active observation area analysis, 
Observation Area dialog box appears

2 Select “ObservationArea2” in the observation area check list

3 Select wavelength 0.68  from the list box

4 Click Update Graph to observe the field pattern for this wavelength.

5 Select Power Spectrum button, Power Spectrum dialog box appears, 
Select total Power “Pz”, Check “Normalize With” checkbox and click 

λ f⁄
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Calculate button, PowerTransmission spectrum appears. Click Save As 
button will save the transmission spectrum to a file

6 Repeat step 6 for each result file, save the transmission spectrum the 
different file name

7 Use OptiFDTD graph tool “Opti 2D viewer” to plot the power transmission 
spectrum in the same graph

• Select “Opti 2D viewer” under Start/All Programs/Optiwave 
software/OptiFDTD/opti 2D viewer

• Select “Add” under file menu to load each exported transmission 
spectrum file (refer to Figure 6)

Figure 6 Power transmission spectrum
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Lesson 22 - Simulation 3D layout using non-
uniform mesh

Since FDTD requires that the entire computational domain be meshed, and the mesh 
spatial discretization must be sufficiently fine to resolve both the smallest 
electromagnetic wavelength and the smallest geometrical feature in the model, very 
large computational domains can be developed, which results in very long CPU times 
and huge memory usage.  For normal dielectric material, numerical dispersion 
analysis shows that to get accurate results, the mesh size should be at least 10% of 
the simulated smallest wavelength in medium; for  surface plasma layout where 
metallic material is usually needed, the mesh size should be even smaller to catch the 
wave attenuation within the skin depth. 

The strength for non-uniform FDTD is to save the memory usage and consequently 
to save the CPU time, for high refractive index region, the fine mesh should be sued, 
while in the low index region, the coarse mesh can be applied.  Before we learn the 
non-uniform mesh simulation in OptiFDTD, we should also discuss several 
benchmarks for this feature: 
• FDTD accuracy refers to the time and space mesh size. Non-uniform mesh FDTD 

accuracy refers to the largest mesh in the simulation. When numerical dispersion 
are not in the same level that refers to the mesh size, the largest error that comes 
from the largest mesh size will be affected and accumulated the whole simulation

• The Courant-Friedrichs-Lewy condition (CFL condition) in FDTD method ask  
the time step must be less than a certain otherwise the simulation will not be 
stable. The CFL condition for non-uniform mesh FDTD should refers to the 
smallest mesh size.   From this point of viewer the time iteration number does not 
saved. 

• Non-uniform mesh sometimes introduces errors of the geometry representation 
that is due to a staircase approximation of curved structure surface.

• Boundary condition in each direction for non-uniform mesh will also affect the 
simulation accuracy. 

• When input wave is put in the non-uniform mesh region, it will introduce additional 
interpolation errors. 

The following explains the non-uniform simulation with OptiFDTD.  User is supposed 
already know OptiFDTD design environment and uniform mesh simulations. 

Please use OptiFDTD layout designer open sample file named 
“X64_Sample58_SilverParticle_Non_Uniform_Mesh.FDT".   This is a 100nm 
diameter silver particle putting in a 0.7  *0.7 *0.8  simulation space.  
Double click on each object in the layout to check the layout setting.  
• Click "3D Layout Model" button  under the layout window to observe the layout 

in 3D mode.

μm μm μm
443



 LESSON 22 - SIMULATION 3D LAYOUT USING NON-UNIFORM MESH
• The silver particle center is put at domain center (x=0 , y=0.35 , 
z=0.4 ), so the particle edge is from -0.05  to +0.05  in x-direction, 
0.3  to 0.4  in y-direction, 0.35  to 0.45  in z-direction. 

• The time domain input wave is "Gaussian Modulated Continuous Wave" with 
center wavelength as 0.5 , bandwidth covers from 0.35  to 0.65 . 
(Right click on the spectrum graph and select the zoom in tool to enlarge the 
selected graph area, this can read the bandwidth)

• Transverse input field pattern is a truncate plane wave (rectangular wave).
• An observation area is put after the sphere, it will detect the transmission 

spectrum.

Check the memory requirement

Step Action 
1 Select "Simulation 3D Using 64bit Simulator..." under the Simulation 

menu, 3D Simulation Parameters dialog box appears. 

2 Click advanced button to check the boundary condition setting. 

3 Click Spectrum button to check the spectral information setting.

4 Unselect Use Non uniform Mesh checkbox in the Nonuniform Mesh 
Parameters region. Click OK button to close the simulation parameters 
dialog box.

5 Repeat step 1 to open the 3D Simulation Parameters dialog box again.  The 
current setting is for uniform mesh simulation, the mesh size is 0.005 . 
Under the mesh setting region, read the minimum memory requirement is: 
175.75M bytes.

6 Select Use Nonuniform Mesh checkbox in the Nonuniform Mesh 
Parameters region. Click OK button to close the simulation parameters 
dialog box.

7 Open the 3D Simulation Parameters dialog box. The current setting uses 
the non-uniform mesh. Read the memory usage is 54.28M bytes. 
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Non-uniform mesh setting

Step Action 
1 Click Parameters in the Nonuniform Mesh Parameters region of the 3D 

Simulation Parameters dialog box.  Nonuniform Mesh Parameters dialog 
box appears. (refer to Figure 1)

Figure 1 Nonuniform Mesh Parameters

Maximum Mesh Size:  The maximum mesh size value (unit in ?m) for low refractive 
index region.

Minimum Mesh Size:  The minimum mesh size value (unit in ?m) for high refractive 
index region.

Maximum Increase Rate:  The mesh increase rate between two neighbor 
mesh is suggested between 0.01 to 
0.5. 

A larger mesh increase rate will make the mesh discontinuity 
too big, which will results in larger simulation errors.

Generated by scanning the layout:  When this default mesh generation method is 
selected, the software will automatically scan the refractive 
index distribution in one direction. The Minimum Mesh Size 
value will be set to the highest refractive index region, while 
Minimum Mesh Size will be set to the lower index region. 
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Maximum Increase Rate will be used to smooth the mesh 
between the maximum and minimum mesh. 

Load From a File:  OptiFDTD allows the user to generate the mesh. The user can 
define the mesh grid coordinator value in a text file then load 
it into OptiFDTD to do the discretization. 

Based On the Predefined Sections of Minimum Mesh Size: This discretization 
method allows the user to define the minimum mesh size 
region by inputting Start Position, End Position, then click 
Add/Apply button to make it function in the software.  The 
Remove and Remove All buttons can remove selected 
defined regions.

Export Mesh: The mesh grid coordinator can be exported to a text file. 

Mesh Graph: Mesh in one direction can be observed in a 2D graph. 

2 Click X-Direction tab to set the x-direction mesh, set the following 
parameters
• Maximum Mesh Size:  0.0175
• Minimum Mesh Size:  0.005
• Maximum Increase Rate: 0.08
• Select Based On the Predefined Sections of minimum mesh size, 

Start position: -0.08 , End Position: 0.08 . Click Add/Apply 
button. This makes the silver particle in x-direction region use the 
minimum mesh

• Click Export Mesh button to export the mesh grid coordinator into a file. 
Use any text editor to open the file and check the mesh grid coordinator 
values.  

• Click Mesh Graph button to observe the x-direction mesh. (Refer to 
Figure 2).  Click Cancel button in mesh graph to return the mesh setting 
page.
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Figure 2 x-direction mesh graph

3 Click Y-Direction tab to set the y-direction mesh.
• Maximum Mesh Size:  0.0175
• Minimum Mesh Size:  0.005
• Maximum Increase Rate: 0.08
• Select Based On the Predefined Sections of minimum mesh size, 

Start position: 0.27 , End Position: 0.43 . Click Add/Apply 
button. This makes the silver particle in y-direction region use the 
minimum mesh.

4 Click Z-Direction tab to set the Z-direction mesh.
• Maximum Mesh Size:  0.0175
• Minimum Mesh Size:  0.005
• Maximum Increase Rate: 0.08
• Select Based On the Predefined Sections of minimum mesh size, 

Start position: 0.325 , End Position: 0.475 . Click Add/Apply 
button. This makes the silver particle in z-direction region use the 
minimum mesh.

5 Click OK  in Nonuniform Mesh Parameters dialog box to accept all the 
settings.

6 Click advanced button in the 3D Simulation Parameters dialog box, 
Boundary Condition dialog box appear.
• X and Y direction boundary set as PBC
• Z direction boundary set as AMPL
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• Number of PML Layer: 16
• Theoretical Reflection Coefficient: 1.0e-12
• Power of Grading Polynomial: 3.5
• Real AMPL Tensor Parameters: 10

Note: The above mesh setting makes the mesh close to the boundary is 
0.0175 .  So the APML tensor value can be around 5-10, in case of very small 
mesh around 0.005 , the AMPL tensor value should be around 60-90.

7 Save the new layout setting by clicking save in the file menu.

Perform the 64bit simulation and post data analysis

Step Action 
1 Click Run button in the Simulate 3D Using 64bit Simulator dialog box. 64bit 

simulation will start. 

Note: non-uniform mesh does not support 32bit simulation. 

2 After the simulation, open the results in OptiFDTD analyzer. 

3 Select Observation Area Analysis under Tools menu of OptiFDTD 
analyzer. Observation area analysis dialog box appears.

4 Select Observation Area tab, then Click Power Spectrum button. Power 
Spectrum dialog box appears.

5 Select Normalize with InputPlane1, and select total power Pz. 

6 Click Calculate, Power transmission spectrum appears (refer to Figure 3)

Figure 3 Power transmission spectrum
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Using the user defined non-uniform mesh 

Step Action 
1 Open the layout we just designed or open the layout named 

"X64_Sample59_SilverParticle_User_Uniform_Mesh.FDT" in the simple 
folder.  

2 Open the Nonuniform Mesh Parameters dialog box.

3 Click X-Direction tab, and select Load From a File. 

4 Click Browse to locate the x-direction mesh file named 
"Sample59_x_direction_ mesh.txt" in the 64 bit sample folder.  You can also 
open this file by any text editor to check the grid coordinator value. 

5 Click Y-Direction tab, and select Load From a File, Click Browse to locate 
the y-direction mesh file named "Sample59_y_direction_ mesh.txt" in the 64 
bit sample folder.  

6 Click OK button in nonuniform dialog box and 3D simulation parameters 
dialog box to make the settings function. 

7 Open the simulation dialog box again, the minimum memory requirement is 
listed as 38.34M bytes. 

8 Run the 64bit simulation. 

9 After the simulation the power transmission spectrum can be obtained.  (refer 
to Figure 4)

Figure 4 Power transmission spectrum
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